crop_rec on steroids: 3K, 4K, 1080p48, full-resolution LiveView

Started by a1ex, April 01, 2017, 11:15:41 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


My 3K continuous video record settings.
HDMI Output is check focusing preview monitor (real time fps), and DSLR monitor is check frame position preview monitor (only 7 fps slow, but no crop fully size preview)

DMStorage DM38 128GB CF Card (exFAT)

HDMI output monitor will help you.



Here are a couple quick edits I did last night. First one no real color work I was chasing my dogs around testing my 3d printed electronic follow focus I made for my Movi.

And one I shot yesterday at Red Bull Hart Lines in Detroit yesterday. No press pass so it was hard to get where I needed to be.

Thanks so much to the ML team! The raw advancements made me fall in love with my camera again. Everything was shot near 3k in 5x centered crop mode as this is the best for shooting with an external monitor on my Movi m10.


Quote from: Danne on May 12, 2017, 08:09:28 PM
Not working
- Compression of 10bit12bit files. DNG output comes out all black but compressed and with metadata present.

when using windows tools for preview, or lightroom i also get black images.
but when using dcraw to convert to TIF, i get a valid image.

a1ex said that adobes tool do currently not support all types of DNG images properly, so this might be due to their libraries.
Help us with datasheets - Help us with register dumps
magic lantern: 1Magic9991E1eWbGvrsx186GovYCXFbppY, server expenses: [email protected]
ONLY donate for things we have done, not for things you expect!


Hm, dcraw outputs a valid one. Thought I tried that before. Will test on my mac soon.
Fyi if compress a 10bit file(--dng -c) and export it with bit_depth = 10; I get a crisp, compressed and fully valid 10bit dng file. Makes me speculate if upres to 14bit could be applied later after compression? Of course I do not know fully how those bits behave going up and down.


Read a number of posts, and saw a 700D reference but no real explanation for any aps-c port.
I am a 70D user, and was wondering what the difference is here? to get to 4k?
The 70D even at 3X zoom mode, would be hard pressed to get 2k for any length of time.
Is there something I am missing, and what would be a 70D (card write is still 40 MB/s) max?

T3i+ML & 70D.112+ML, Tokina 11-16 2.8, Sigma 18-35 1.8, 50-150 II 2.8, 50 1.4, Canon 28 1.8, 35 2, 85 1.8 "Shoot Wide and Prosper"


Quote from: ShootMeAlready on May 15, 2017, 03:11:09 AM
saw a 700D reference

Yeah, that was me. It seems that all cameras can do the ProcessTwoInTwoOut thing. Basically the CR2 files are run through that lossless compression process. Then it is another thing to figure out how to tweak the sensor using adtg_gui in order to squeeze every pixel you can out of the camera. I looked into it a while ago but was in way over my head. Some guys are still trying and eventually someone should come up with something that works on the aps-c cameras.

You're right though--that maximum SD card write speed is going to keep these cameras from reaching 4K, except maybe the 7D because it has a faster CF card?



Hello everyone, someone could guide me about the workflow with crop_rec under Windows, thank you very much.  8)
Photographer, Videographer, RawVideo Lover.
Canon 7D / Canon 5DMKIII



Does crop mode have snd module available? Or impossible?

5D3 [size=6pt](OLPF removed)[/size] :: 1.1.3 :: Canon FD L Serie


@hjfilmspeed Awesome video.. This will help the Newbies big time. 


Hello guys.

Since I've tried April crop mode module, my shutter-release button has been acting up - it has reset itself twice to AE lock, instead of AFing. Plus microadjustment has switched itself once to a diff value as well. It has never happened to me before and at the time of malfunction the standard ML was installed. No warnings of any kind were shown upong booting with any of the April versions of the ML.



The half-shutter function is changed by ML and can be modified without notice if you take the battery out in the middle of taking a picture initiated from ML, for example. This is documented.

If it's not that, find a way to reproduce. I'd expect some similar behavior to happen after an assertion, a crash (e.g. err70) or after taking the battery out - in these cases, ML actively prevents Canon code from saving their settings at shutdown. This is a safeguard to prevent invalid settings (that could be related to the crash) from being saved into ROM (more info).

Note: I've reviewed the calls related to changing half-shutter functionality (cfn_set_af_button and its wrappers) and could not find any instance where the original setting is not restored as soon as it's no longer required. So, unless you (have to) take the battery out in the middle of some photo operation (e.g. bracketing sequence), I don't see how it would happen. Nothing on the video side changes this setting.


Thanks, much appreciated. I'll look into provided docs.




I suppose it has been covered, but I haven't been able to find a direct answer to my issue, so don't hit me too hard :)
In short - the dng files that have lossless compression aren't supported natively in the latest version of  Adobe premiere (at least on my PC). I wouldn't even bother with that because Resolve does a great job, but with the latest version of Premiere i found that it handles canon raw quite good (it can be absolutely my feeling, as didn't find anything in the release notes)

Is there any way to import the dngs directly into premiere? The simple uncompressed dng files work just fine.
Canon 5DIII| Sigma 35/1.4|T 24-70/2.8 VC| Tamron 70-200/2.8 VC USD


If on mac you get compatiblity with a mlv_dump version used in (ml-dng branch + several addons)


Thx Danne, I'm on PC and using the latest availabe mlv_dump from the experiments download section.
Canon 5DIII| Sigma 35/1.4|T 24-70/2.8 VC| Tamron 70-200/2.8 VC USD


@Danne, thx for the input. But i have zero knowledge in coding and compiling stuff :) For now it will be easier for me to install a hackintosh.
Canon 5DIII| Sigma 35/1.4|T 24-70/2.8 VC| Tamron 70-200/2.8 VC USD


Or someone with a windows setup could help you compile a version.


I've been messing around with the 1.5x Iscorama shooting 4K scope 24p anamorphic (2304x1382 with a 25% upscale). With a 24mm Leica-r it's equal to 40mm full frame. Shot at 3200 ISO with ACR chroma noise reduction. Filmconvert Fuji 8553 LUT.


I have 16 MLV files that fail to decompress. They almost 1GB average, each.
I was shooting with 5d mk3, 1.1.3. 1920x1080/50/60 2.35:1, 14bit lossless.
I use latest mlv_dump.
I get a message

LJ92 : failed (-1)

The mlv files were random among 70 files and their order do not satisfy any logic.
The last 10 shots were faulty. I assume the problem rested there.

I can upload a mlv file on my GoogleDrive for public access.
Any clue ?
Thanks in advance


Please upload a sample file. If you dig round mlv_dump code it says following.
Error related to int ret. Frame size?

    /* this block will load an image from a MLV file, so use its reported frame size for future use */
        printf("Loading subtract (dark) frame '%s'\n", subtract_filename);
        int ret = load_frame(subtract_filename, &frame_sub_buffer, &subtract_frame_buffer_size);

Your whole error code snippet from mlv_dump.c
                           int ret = lj92_open(&handle, (uint8_t *)frame_buffer, frame_buffer_size, &lj92_width, &lj92_height, &lj92_bitdepth, &lj92_components);

                            /* this is the raw data size with 16 bit words. it's just temporary */

                            size_t out_size = lj92_width * lj92_height * sizeof(uint16_t) * lj92_components;

                            if(ret == LJ92_ERROR_NONE)
                                    print_msg(MSG_INFO, "    LJ92: Decompressing\n");
                                    print_msg(MSG_INFO, "    LJ92: %dx%dx%d %d bpp (%d bytes buffer)\n", lj92_width, lj92_height, lj92_components, lj92_bitdepth, out_size);
                                print_msg(MSG_ERROR, "    LJ92: Failed (%d)\n", ret);
                                goto abort;