Author Topic: Error building ML unified - loader_gen.rb: Permission denied  (Read 3056 times)

jplxpto

  • Developer
  • Hero Member
  • *****
  • Posts: 506
Error building ML unified - loader_gen.rb: Permission denied
« on: August 01, 2012, 11:28:39 PM »

I could not compile the project, the following error occurred:


Code: [Select]
make -C lua/; make -C testplug/;
make[2]: Entering directory `/mnt/canon/canon/magic-lantern/plugins/lua'
~/arm-toolchain462/bin/arm-elf-gcc-4.6.2 -E -Wp,-MMD,/mnt/canon/canon/magic-lantern/plugins/lua/../.plugin.lds.d -Wp,-MT,/mnt/canon/canon/magic-lantern/plugins/lua/../plugin.lds -nostdlib -fomit-frame-pointer -fno-strict-aliasing -DCONFIG_MAGICLANTERN=1 -DCONFIG_=1 -DRESTARTSTART= -DROMBASEADDR= -DVERSION=\"\" -DCONFIG_DEBUGMSG=0  -Os -Wall -W -r -mstructure-size-boundary=32 -Wno-unused-parameter -Wno-implicit-function-declaration -Wno-unused-function -Wno-format -std=gnu99 -D__ARM__ -I/mnt/canon/canon/magic-lantern/plugins/lua -I/mnt/canon/canon/magic-lantern/plugins/lua/.. -I/mnt/canon/canon/magic-lantern/plugins/lua/../../src -mlong-calls -fpic -nostartfiles -ffreestanding /mnt/canon/canon/magic-lantern/plugins/lua/../plugin.lds.S | grep -v ^# > /mnt/canon/canon/magic-lantern/plugins/lua/../plugin.lds
~/arm-toolchain462/bin/arm-elf-gcc-4.6.2  -c -o /mnt/canon/canon/magic-lantern/plugins/lua/../entry.o /mnt/canon/canon/magic-lantern/plugins/lua/../entry.S
/mnt/canon/canon/magic-lantern/plugins/lua/../loader_gen.rb
/bin/sh: /mnt/canon/canon/magic-lantern/plugins/lua/../loader_gen.rb: Permission denied
make[2]: *** [/mnt/canon/canon/magic-lantern/plugins/lua/../loader.c] Error 126
make[2]: Leaving directory `/mnt/canon/canon/magic-lantern/plugins/lua'
make[2]: Entering directory `/mnt/canon/canon/magic-lantern/plugins/testplug'
/mnt/canon/canon/magic-lantern/plugins/testplug/../loader_gen.rb
/bin/sh: /mnt/canon/canon/magic-lantern/plugins/testplug/../loader_gen.rb: Permission denied
make[2]: *** [/mnt/canon/canon/magic-lantern/plugins/testplug/../loader.c] Error 126
make[2]: Leaving directory `/mnt/canon/canon/magic-lantern/plugins/testplug'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/mnt/canon/canon/magic-lantern/plugins'
make: *** [all] Error 2


Someone can help me?
Thank you.

BR

scrax

  • Contributor
  • Hero Member
  • *****
  • Posts: 1543
  • Code monkey
Re: Error building ML unified - loader_gen.rb: Permission denied
« Reply #1 on: August 04, 2012, 04:31:34 PM »
Code: [Select]
/bin/sh: /mnt/canon/canon/magic-lantern/plugins/lua/../loader_gen.rb: Permission denied

try to make executable loader_gen.rb

Code: [Select]
sudo chmod +x path/to/loader_gen.rb
I'm using ML2.3 for photography with:
EOS 600DML | EOS 400Dplus | EOS 5D MLbeta5- EF 100mm f/2.8 USM Macro  - EF-S 17-85mm f4-5.6 IS USM - EF 70-200mm f/4 L USM - 580EXII - OsX, PS, LR, RawTherapee, LightZone -no video experience-

ludenus

  • New to the forum
  • *
  • Posts: 3
Re: Error building ML unified - loader_gen.rb: Permission denied
« Reply #2 on: August 11, 2012, 08:48:29 PM »
you will have to make all ruby scripts executable:
Code: [Select]
~/magic-lantern$ find . -name *.rb | xargs chmod +x

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: Error building ML unified - loader_gen.rb: Permission denied
« Reply #3 on: August 12, 2012, 04:54:02 AM »
You know this happened to me but the unified still built, just plugins failed. Then again I don't make zips/docs/etc. Good  to see a fix.