Author Topic: Issues with ML DNG (from dual iso) files in Lightroom?  (Read 6072 times)

LexLuxor

  • New to the forum
  • *
  • Posts: 5
Issues with ML DNG (from dual iso) files in Lightroom?
« on: March 02, 2016, 11:38:22 AM »
So, I've been playing around with both ML and Lightroom for about 8 months periodically and haven't had any issues all is well. About a week a go I noticed an issue with the DNG files generated from cr2dng converter. Seems like this issue has always been there and might not be the fault of the files generated, but thought I'd ask you all if you've encountered anything like this yourself and if you possibly have a solution for it.

The problem is that in LR the DNG files loses a lot of detail which can't be recovered. See attachments below.

How it looks in the Windows preview:


How it looks in LR by default after import:


How it looks if I drag down the exposure in LR, showing where LR somehow has lost details by clipping the highlights:


Any ideas or suggestions? Is this due to the import in LR or is there something wrong with the DNG files generated from the dual iso converter?

Didn't really preview the photos before after the conversion and imported directly in LR. Just assumed that it was very difficult do well adjusted photos with dual iso...

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8339
Re: Issues with ML DNG (from dual iso) files in Lightroom?
« Reply #1 on: March 02, 2016, 11:45:54 AM »
Cr2dng?

Please describe your workflow in detail and version info for all tools involved. Download option for samples before/after showing the problem will be fine, too.

LexLuxor

  • New to the forum
  • *
  • Posts: 5
Re: Issues with ML DNG (from dual iso) files in Lightroom?
« Reply #2 on: March 02, 2016, 12:32:05 PM »
Ah, my bad, cr2hdr.exe

Version info:
cr2hdr: Only version info I have there is "0c08758, updated 2015-05-09 19:25:05"
exiftool.exe 9.9.5.0
dcraw.exe: no version info
LightRoom: 6.1.1

Work flow:
Drag and drop dualiso .CR2 files into cr2hdr.exe to do the conversion.
Simple import resulting DNG files into lightroom from native folder; find the files, select what to import, and then click the import button.

Files used:
Original .CR2 file:   See post below for links
The converted DNG file: See post below for links

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8339
Re: Issues with ML DNG (from dual iso) files in Lightroom?
« Reply #3 on: March 02, 2016, 12:48:05 PM »
Sorry but the download site you are using will force me to download an exe and I won't do that.

LexLuxor

  • New to the forum
  • *
  • Posts: 5
Re: Issues with ML DNG (from dual iso) files in Lightroom?
« Reply #4 on: March 02, 2016, 01:26:14 PM »
Damn it...... Really sorry about that.
Didn't think about it before but I'll use my google drive instead:
Original CR2 file: https://drive.google.com/file/d/0B54-HXOZVpbIM2RXTGp5YzBsaTg/view?usp=sharing

Converted DNG file: https://drive.google.com/file/d/0B54-HXOZVpbIY1hQNFlWNFZ3TW8/view?usp=sharing

Thanks for your help.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8339
Re: Issues with ML DNG (from dual iso) files in Lightroom?
« Reply #5 on: March 02, 2016, 02:13:34 PM »
Yes, LR mistreats this DNG again.
I imported your CR2 into LR, used kichetof's Dual-ISO plug-in to generate DNG -> Same mess as yours.
Then I used RAWTherapee to open DNG and exported as TIFF and imported TIFF into LR. And that's just fine = showing details where LR's DNG rendering fails miserably.

O Adobe, where art thou?

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7297
Re: Issues with ML DNG (from dual iso) files in Lightroom?
« Reply #6 on: March 02, 2016, 02:22:10 PM »
Canon 70D. Try changing the Camera Model Name tag to Canon EOS 6D. I,m pretty sure it,s a mix up between the camera model name and the color matrices which are the same for both cameras(Adobe bug).

By the way. If you change the DNG file it,s the unique camera model tag that needs to be changed.

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1197
Re: Issues with ML DNG (from dual iso) files in Lightroom?
« Reply #7 on: March 02, 2016, 03:55:08 PM »
 :o Now what? Didn't try myself but always thought it's fixed since end of January? Also remembering Adobe's changelog stated something like this:

http://magiclantern.fm/forum/index.php?topic=14309.msg161243#msg161243

70D.112 & 100D.101

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7297
Re: Issues with ML DNG (from dual iso) files in Lightroom?
« Reply #8 on: March 02, 2016, 04:13:36 PM »
Tried changing to the 6D tag and then it opens up fine in acr. Otherwise it stops halfway there. Don,t know how the latest acr versions handle this file.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8339
Re: Issues with ML DNG (from dual iso) files in Lightroom?
« Reply #9 on: March 02, 2016, 04:46:52 PM »
Well, it looks like we have to verify Hydra is back.
I'm not sure my own environments (cr2hdr.exe, dcraw.exe, exiftool.exe) are clean and most recent versions are installed.
DNG (straight out of cr2hdr) opens in LR and PS/CR 9.4.0.548 (Windows 8.1). Rendered crappy but opens.
Danne, which CR are you using?




Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7297
Re: Issues with ML DNG (from dual iso) files in Lightroom?
« Reply #10 on: March 02, 2016, 05:03:17 PM »
Adobe cs 6, Camera Raw version 8.8
Will check how MLP reacts to the file.
*Same results with MLP.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8339
Re: Issues with ML DNG (from dual iso) files in Lightroom?
« Reply #11 on: March 02, 2016, 06:53:57 PM »
Thanks, Danne!
I checked DNG's exif tags ColorMatrix2 and CalibrationIlluminant2 (Issue 2343) but that's not our problem: Both tags not there which *should* be good.
I sent a PM to camslide about his post in 70D thread and the problem at hand.



Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7297
Re: Issues with ML DNG (from dual iso) files in Lightroom?
« Reply #12 on: March 02, 2016, 07:08:45 PM »
Cool. It seems this issue only occurs with the 70D. Or else it should have been the same problems with eos M, 650D, 100D, and the 700D which shares the same matrices as well. Adobe had a bad day or something when working the 70D.

LexLuxor

  • New to the forum
  • *
  • Posts: 5
Re: Issues with ML DNG (from dual iso) files in Lightroom?
« Reply #13 on: March 05, 2016, 06:02:16 PM »
Thank for all your involvement in this. Wouldn't know where to start at all..

But as I've understood it from you all is that there is no solution to this problem other than waiting for Adobe?

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8339
Re: Issues with ML DNG (from dual iso) files in Lightroom?
« Reply #14 on: March 18, 2016, 10:59:22 AM »
Anyone evaluated Adobe Camera RAW 9.5.0.585/Lightroom 2015.5 [ 1067055 ]?
First attempt: Looks like Adobe failed again to fix this one. Anyone willing to bump this issue in Adobe's support site? Again?

elenhil

  • New to the forum
  • *
  • Posts: 44
Re: Issues with ML DNG (from dual iso) files in Lightroom?
« Reply #15 on: October 09, 2021, 02:16:03 PM »
I seem to have fallen prey to this very issue with my 70D Dual ISO DNGs 'mistreated' when imported into Lightroom Classic v10.3. Is spoofing a different UniqueCameraModel still the only workaround?