Author Topic: Canon 100D / SL1  (Read 519170 times)

sebi2k4

  • New to the forum
  • *
  • Posts: 7
Re: Canon 100D / SL1
« Reply #1475 on: July 22, 2018, 01:15:49 AM »
thank you for this hint. The 5x crop mode worked exactly one time after setting from AF to MF. After returning to the ML menu i have the same issues again with pressing the magnifier button and nothing happens. Live Preview says something like "processing... please wait" (<-- sorry for not being accurate here but my menu language is german :D )

Could you or someone here please post the correct settings which has to be done?

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8052
Re: Canon 100D / SL1
« Reply #1476 on: July 22, 2018, 01:35:27 AM »
Das Menü kann man auch schnell auf Englisch umstellen ...

Aber noch mal zum Problem: Du bist im Movie-Modus, drückst 2-mal auf die Lupe, bist dann im Crop-Modus, gehst dann über den Papierkorb ins ML-Menü. Was passiert, wenn Du direkt nach dem Sprung zum ML-Menü nochmal die Papierkorb-Taste drückst?
Bei mir (allerdings mit dem Fast-Nightly aus der hiesigen Download-Seite) bin ich dann wieder im Video-Modus mit Crop.
Setz doch mal ML auf Default zurück und probiere es ohne geladene Module.

sebi2k4

  • New to the forum
  • *
  • Posts: 7
Re: Canon 100D / SL1
« Reply #1477 on: July 22, 2018, 04:37:07 PM »
@Walter Schulz: Vielen Dank für den Tipp. Es lag tatsächlich an einer Einstellung im Movie Menü: "Movie Crop Mode" war aktiviert - damit ging das mit der Lupe nicht mehr. Kommst du auch aus Deutschland?

@all: Walter resolved my problem with the magnifier button. I had a wrong setting in Movie menu: 'Movie Crop Mode' has been activated and autofocus was on. Now at least pressing the button twice and getting a 5x magnification works fine.

But I'm still not able to get some RAW video recording with higher resolutions by sd overclocking. At least with low fps.
Could you Walter or somebody around here please explain the steps which have to be done with this build from Danne?
https://bitbucket.org/Dannephoto/magic-lantern/downloads/magiclantern-Nightly.2018Jun30.100D101_2K-3K-4K.zip

Thanks in advance.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7182
Re: Canon 100D / SL1
« Reply #1478 on: July 22, 2018, 04:40:40 PM »
Enabled crop_rec.mo? All higher res modes are in crop_rec menu. Enable one of those and then enable sd_uhs...

sebi2k4

  • New to the forum
  • *
  • Posts: 7
Re: Canon 100D / SL1
« Reply #1479 on: July 22, 2018, 04:54:24 PM »
Enabled crop_rec.mo? All higher res modes are in crop_rec menu. Enable one of those and then enable sd_uhs...

Hi Danne,
nope didn't activate that module. Now I did and I can choose one of the higher resolution modes in movie menu. Do I still need the RAW video setting in movie menu activated? Cause if I do activate it I don't get the higher resolutions there.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7182
Re: Canon 100D / SL1
« Reply #1480 on: July 22, 2018, 05:20:34 PM »
activate RAW video module
activate crop_rec module
restart and enter a crop_rec menu setting
Enable RAW video
enter x5 mode

If not highest resolution:
Change Resolution to higher one in RAW video menu
Maybe also change Aspect ratio for higher vertical resolution in RAW video

sebi2k4

  • New to the forum
  • *
  • Posts: 7
Re: Canon 100D / SL1
« Reply #1481 on: July 23, 2018, 12:22:33 AM »
Ahhh thanks Danne for this listing. I just added 'activate and run sd overclocking' after activating the other modules and now I'm able to use the RAW video feature with high resolutions.
I need to test a few shots during the next days to get a bit familiar with it. And then I guess I will need a faster sd card  :D

I'll keep you updated in case of any bugs.

Again, thank you all for this achievement.  ;)

IDA_ML

  • Hero Member
  • *****
  • Posts: 959
Re: Canon 100D / SL1
« Reply #1482 on: July 26, 2018, 01:41:45 PM »
Hello all,

I have now performed first tests on the latest build for the 100D provided by Danne yesterday:

https://bitbucket.org/Dannephoto/magic-lantern/downloads/magiclantern-Nightly.2018Jul25.100D101_2K-3K-4K_10bit_patch_g3gg0.zip

I think, this build is an important step forward since it provides reasonably long recording times at 2,5K resolution (2520x1304@24 fps) using 10-bit lossless compression.  Here are my first impressions from tests at the "2.5K 10bit 2520x1304" and the "4K 4056x2552" resolutions.  Did not have time to test the other ones.

1) This build is much more stable than the previous ones.  I rarerly observed crashes and if I did it was because I did not wait long enough for the camera to complete operation before changing modes.

2) The most interesting mode called "2.5K 10bit 2520x1304" can now provide up to 7 sec. recording time but this is rarely the case.  Most of the time, the camera stops after 2 to 4 sec.  even after the INFO button has been pressed and the Frozen LV preview activated.  I performed the following experiment:  Put the camera on a tripod, composed, focussed and metered the scene (evenly lit) by paying close attention to not overexposing the highlights (no pink areas in the frame !!!).  Then I performed 10 consecutive recordings without touching anything or changing light conditions.  I had only one recording of about 600 frames (speed indicator showing 58-59 MB/s write speed), all the rest were between 60 and 90 frames long.  There must be somewhere an instability bug causing the early camera stop.  Danne, could you try to reproduce this and see if it can be fixed?  It does not seem to have anything to do with the compression algorithm since I did not move camera or change light conditions at all between shots.

3) Working with the "2.5K 10bit 2520x1304" is quite tricky.  Preview is very dark, you don't see anything on the screen and this makes composing and focusing very hard.  I usually use a ND filter opened up for composition and focusing and then I close it by several stops to darken the screen before I hit the record button.  The most annoying thing is that the histogram reading is unreliable.  It indicates extreme underexposure all the time.  I usually increase the exposure until pink highlights start getting visible on the screen and then dial exposure down by a stop or so.  For now, you can use this mode only for static shots from a tripod without moving the camera.  I hope, this dark preview problem will be fixed soon - it works quite well with the 5D3, as far as I remember.  Haven't tried the picture style method yet.

4)  As long as you don't blow up the highlights, the MLV files coming out of the "2.5K 10bit 2520x1304" mode are really nice and compact.  Processing them with MLVApp works very well.   When opened they are quite dark but increasing the exposure and adjusting the dark and white strength fixes them easily.  I did not notice any quality degradation compared to 14-bit files but didn't pixel peep too hard.

5)  I especially liked the "4K 4056x2552" mode which is perfectly suited for smooth 4K timelapse videos.  Quality at 14-bit lossless is stunning and motion smootness is excellent - no dead time between frames!  Unfortunately, as expected, focus pixels are all over the frame in this mode.  We will need new maps once it is finalized.

Further testing is on the way but I have to find time for that.  If other 100D users jump in and share their findings this will help our developers a lot!  I would like to thank them all for their invaluable work.

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7182
Re: Canon 100D / SL1
« Reply #1483 on: July 26, 2018, 04:06:54 PM »
Thanks for reporting and testing. Appreciated and needed. Nice to hear that g3gg0 mlv_snd version is performing stable results.
Regarding 2) and instability issues there's really nothing new here. Since your card is operating on the edge it won't deliver consistent results. Lossless compression in this case isn't performing consistent bitrate. Is there a way for static bitrates?
3) preview darkness is white level lowered so just leave "framing" preview and you'll get back brightness.
I guess this is more a proof of concept at this stage and to go further would require some further sd_uhs vodoo :)

Edit:
Checking in raw.c you´ll see:
Code: [Select]
#define WHITE_LEVEL 16200Change it to #define WHITE_LEVEL 3500 and you get brighter liveview and 11bit reported in Mlv App

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1699
  • 6d - Nightly build user
Re: Canon 100D / SL1
« Reply #1484 on: July 26, 2018, 06:33:56 PM »
@Danne, about how to automatically get right white level in raw.c:

I'm not good in programming in C.
Only did some Microsoft Quickbasic, back in the 90s  :P
But I do have an idea how to approach this.
White level only needs fixing when analog gain registers are overriden.
So you need to read out one gain register in raw.c and check it's value, when it's overriden, change white level.
So we need something like this in raw.c:

If register 8882 = 0x46 then white_level = 3500 else white_level = 16200
 
But then in C language   ;D

Anybody here with some C knowledge ?

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7182
Re: Canon 100D / SL1
« Reply #1485 on: July 26, 2018, 06:38:37 PM »
Cool, will try it. Tested redefining 16200 to 3500 and it would affect previewing so definitely the right place to do exceptions.

OlRivrRat

  • Hero Member
  • *****
  • Posts: 538
Re: Canon 100D / SL1
« Reply #1486 on: July 26, 2018, 11:16:55 PM »
                 @Kouglov

" When I open the battery door, the card reader led does not blink.

Do you have any ideas why the card reader led does not blink ? "

       I do not know why this happens but My SL1 acts the same & always has.

                                                                  ORR~ DeanB
ORR~DeanB  ~~  80D-ML  &  SL1+ML  &  5D2+ML  &  5DC+ML  &  70D+ML(AliveAgain)

OlRivrRat

  • Hero Member
  • *****
  • Posts: 538
Re: Canon 100D / SL1
« Reply #1487 on: July 26, 2018, 11:46:53 PM »
           @Danne

What do You mean by >

"just leave "framing" preview"
ORR~DeanB  ~~  80D-ML  &  SL1+ML  &  5D2+ML  &  5DC+ML  &  70D+ML(AliveAgain)

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7182
Re: Canon 100D / SL1
« Reply #1488 on: July 27, 2018, 01:35:29 AM »
Go into real-time preview. Will get bright screen back.

IDA_ML

  • Hero Member
  • *****
  • Posts: 959
Re: Canon 100D / SL1
« Reply #1489 on: July 28, 2018, 05:47:41 PM »
Here is some more feedback on the latest July 25-th build for the 100D concerning the other croped modes.  All tests were performed in the "Framing" preview mode with the 95 MB/s SanDisk Extreme Pro SD-card (64 GB).

1)  "2.5K 2520x1304" and  "3K 3096x1320"

     (*) 14-bit lossless works just fine, with bright screen and WySiWyG preview, no corrupt frames;
     (*) 10 and 12-bit lossless modes provide corrupt footage;
     (*) 10, 12 and 14-bits uncompressed work too but there is no in-camera playback for 10 and 12 bits uncompressed (black screen);
     (*) as expected, the 3K mode needs new focus pixel maps.

PROBLEM:
--------------


The WySiWyG preview works fine only when the camera is cool.  As soon as the indicated temperature exceeds 50 deg. C, the preview becomes scrambled and this makes framing and focusing impossible.  Camera needs to cool down before the preview becomes normal.  This is not the case with the  "2.5K 10bit 2520x1304" mode in which 5x-preview continues to work even when camera temperature reaches 61 deg. C.  This is probably due to the fact that the screen stays pretty dark in that 10-bit mode.

2) "2K 2520x1080p"

This is the best working and most stable mode, with bright screen, WySiWyG preview and no corrupt frames in all compressed and uncompressed modes.  At 8 ... 11-bits and 12-bits LL compressed and proper exposure it provides continuous recording at 24 fps.  In this condition, the write speed is between 52 and 58 MB/s meaning that a 128 GB card can accommodate about 35 minutes of footage.  If the scene is exposed to the right, the exposure slider can be pushed down by one to two stops in MLVApp which provides very clean shadows, beautiful colors and superb overall image quality.  This mode is very good news for those who like shooting at 2,35:1 aspect ratio.

3)  "3x3 720p"

This mode is not working properly which is seen also in the preview screen.  A horizontal line splits the frame into two parts with different exposures and some greenish/bluish color cast on the upper part.  The same behavior is observed also when the footage is opened in MLVApp. The good news is that at the maximum resolution (2520x1078)@24 fps, this mode provides stable WySiWyG preview, continuous recording at 8 ... 11-bits and 12-bits lossless and in-camera playback.  All that needs to be done for it to work properly is to fix this split image.

4) "4K 4056x2552" (14-bit lossless)

In this mode, I also noticed some instability.  Although the write speed indicator was green, indicating about 45 MB/s write speed or less - well below the 59 MB/s limit, I was unable to get continuous recording at more than 3 fps.  Even at this FPS rate, recording was continuous only after I pushed the INFO button which kills the framing preview and provides a scrambled screen.  With the framing preview active I was able to get only 1 frame recorded, no matter what I did.   

-----------------------------------------------------------------

5)  I also would like to mention that the Normal uncroped mode at 1736x976 resolution as well as the Movie Crop Mode at 1800x1012 resolution also work very well at all compressed and uncompressed bit rates.  No surprises here.  At the 8 ... 11-bit lossless, 1736x976 resolution and 24 fps, the Normal mode writes at less than 32 MB/s when filming a normally lit and properly exposed scene.  This provides about 1 hour record time on a 128GB SD-card.  Therefore, with appropriate power supply (a fully charged quality battery or external power supply), the 100D is appropriate for filming even events.  I tested this with a 64 GB card and let the 100D film until card was full.  I did not observe camera overheating (temperature did not exceed 50 deg. C) and recording with sound was perfectly OK.  Another wonderful feature of the Normal mode which makes it usable for Slow motion shots, is that one can increase the frame rate to 42 fps and still get stable recording at the maximum 1736x976 resolution with the 8 ... 11-bit LL setting.  This is possible due to the SD-overclocking feature (thanks A1ex and Danne !!!).  Record time at the 42 fps rate is about 8 sec. You can go up to 44 fps but this is the edge and recording is not very stable.  At 45 fps, you get corrupt frames.  In the 2520x1080 mode (5x-magnification), FPS rate can be increased to 36,7 fps.

-----------------------------------------------------

PLEASE NOTE: Although this build is quite stable, random crashes in the high-resolution crop modes still occur now and then and they are impossible to reproduce.  Mostly they happen after changing modes, preview or FPS settings.  It is advisable, after these settings have been changed, to turn camera OFF and On again and then start recording.

I hope, this helps the developers continue their work on this most capable build.  If they manage to fix the dark screen and WySiWyG preview without reducing record time too much in the "2.5K 10bit 2520x1304" mode, the 100D will be ready to shoot 2,5K RAW video under real-life filming conditions.     




IDA_ML

  • Hero Member
  • *****
  • Posts: 959
Re: Canon 100D / SL1
« Reply #1490 on: August 16, 2018, 08:37:33 PM »
Yesterday, I shot a short video with the 100D at 2320x1304 (16:9) resolution and 24 fps using Danne's build called:

magiclantern-Nightly.2018Aug13.100D101_10bit_2K_only.zip

This build has some limitations - it works at 2,5K 10-bit lossless only but it provides WySiWyG preview and this makes it possible to get proper framing when the camera moves.  Unfortunately, it is quite buggy - most of the time, the camera stays in 5x-preview, also AF is quite sluggish and a pain to work with but the video quality is so good that it is well worth the effort.  See for yourself:


Thanks Danne!

Please note, that the video may have not finished converting yet.  I have just uploaded it.  You may need to wait a little.

If A1ex or some of the other developers could help Danne fix the WySiWyG preview and the other bugs, our 100D will become a hell of a camera!  Not quite Arri Alexa but close ...

 

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7182
Re: Canon 100D / SL1
« Reply #1491 on: August 16, 2018, 10:12:18 PM »
100D can't get enough love :)

OlRivrRat

  • Hero Member
  • *****
  • Posts: 538
Re: Canon 100D / SL1
« Reply #1492 on: August 17, 2018, 07:12:28 PM »
           @IDA_ML

       Mighty Fine ~
ORR~DeanB  ~~  80D-ML  &  SL1+ML  &  5D2+ML  &  5DC+ML  &  70D+ML(AliveAgain)

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Canon 100D / SL1
« Reply #1493 on: August 24, 2018, 10:42:57 AM »
Following this discussion from the EOS M thread, this tweak (in platform/100D.101/consts.h) should enable scrollwheel controls in ML menu while recording H.264:

Code: [Select]
#define GUIMODE_ML_MENU (lv ? 100 : 2)

That's just a minor nitpick; the previous definition looks otherwise fine to me. I've tested this tweak on a 700D with 97 instead of 100. On EOS M, one would use 99 to achieve the same behavior.

IDA_ML

  • Hero Member
  • *****
  • Posts: 959
Re: Canon 100D / SL1
« Reply #1494 on: August 28, 2018, 02:46:03 PM »
Another 100D video shot at 2320x1304 resolution but at 18 fps for continuous recording.  Details here:

https://www.magiclantern.fm/forum/index.php?topic=20025.msg205513;topicseen#msg205513

Enjoy!

Scubadude

  • New to the forum
  • *
  • Posts: 2
Re: Canon 100D / SL1
« Reply #1495 on: August 30, 2018, 10:17:52 AM »
Are there any limitations in Lossless vs regular RAW? If they really are identical, why use one over the other?

ebrc

  • New to the forum
  • *
  • Posts: 3
Re: Canon 100D / SL1
« Reply #1496 on: September 05, 2018, 08:13:30 AM »
Hello guys, it's my first post ... Sry if I'm posting on wrong topic. (I searched a lot about this problem)

I'm getting this weird stripe, recording h.264 in "Movie crop mode" when I use ML Digital ISO at -0.2 or 0.3

In RAW recording I have no problem... Can you help me?

Stripe



ML Version


Edgley

  • New to the forum
  • *
  • Posts: 12
Re: Canon 100D / SL1
« Reply #1497 on: September 18, 2018, 12:11:51 PM »
Hi,

I have spent ages trying to fully understand the options for getting the highest quality, and have these settings so far, that seem to give continuous recording.

The first thing is that the Sandisk Extreme card I have gives around 49mb write speed when I test it with Blackmagic Speed Disk, however, in the camera is only giving around 23mb.

I am running the 4k experimental build, with the following modules loaded:
crop_rec
mlv_lite
mlv_snd
raw_twk

As for settings, as follows:
FPS Overide 23.976, optimised for exact FPS
movie crop mode OFF
crop mode OFF
Raw Video 1568x882 @11/14bit Lossless

If I want to zoom in, I turn on the Movie Crop Mode and also the Crop Mode.
I have the display set to the 3 info setting, as I use manual focus with green lines to show where the focus is.

There are some problems, when stopping recording sometimes the camera seems to hang and I have to turn off and on again.
The resolution was found by trial and error, as to which gave the highest value. I also tested whether recording the sound or not, allowed a higher capture res, but it didn't.

I then process the files with Switch, using the default settings and then use Resolve to edit/ colour / grade.

Is it possible to get some advice/pointers on my setup please, and whether anything I am doing is wrong.

thanks,
Simon.

EDIT:
Just installed the firmware linked a few pages back.
Now I can record at 1712x964 @23.976

The problem is that I have to be on the first of the info screens, to get a green record.
If I go to the one I want to use, the 3rd as it shows focus lines, the speed drops and I am unable to record.
100D + 50mm 1.8 / Mac / Resolve

Cipolippo

  • New to the forum
  • *
  • Posts: 12
Re: Canon 100D / SL1
« Reply #1498 on: September 18, 2018, 01:06:19 PM »

Audionut

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3657
  • Blunt and to the point
Re: Canon 100D / SL1
« Reply #1499 on: September 18, 2018, 05:08:25 PM »
Hi
How can enable 1x3 Binning mode in canon 100d?

There's a bunch of links in the post that you linked to.  Happy reading.