Author Topic: Canon 60D  (Read 136129 times)

Avenger 2.0

  • New to the forum
  • *
  • Posts: 23
Re: Canon 60D
« Reply #75 on: January 10, 2017, 07:46:12 AM »
I need some help!! My camera keeps saying "Incorrect firmware version. Expecting firmware version 1.1.1" I have 1.1.2. Will it not work with 1.1.2? And if it does still work, can you give me help with how to install it properly as I'm not sure if I'm doing it correctly XD
You need 1.1.1. You can just put it on the SD card and run firmware update to downgrade to 1.1.1.
Found working 1.1.1 link on google: http://support-nz.canon.co.nz/contents/NZ/EN/0400055002.html

habo

  • New to the forum
  • *
  • Posts: 6
Re: Canon 60D
« Reply #76 on: March 30, 2017, 02:36:20 PM »
I have used ML for years, but to day I tried to update to the newest firmware  fc3ec35: marts 30 2017, but got a message on the camera update screen "Update not possible file 1.1.1. must be present" or something like this, update was not possible, firmware 1.1.1. was present, tried several times, finely I decided to update to an earlier version, no problem.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 11484
  • 5D Mark Free
Re: Canon 60D
« Reply #77 on: March 30, 2017, 02:56:29 PM »
Fixed, rebuilding the nightlies.

jeffjgale

  • New to the forum
  • *
  • Posts: 4
Re: Canon 60D
« Reply #78 on: July 26, 2017, 02:42:11 PM »
Can anyone be kind enough to tell me how [ step by step ] to go back to firmware 1.1.1 as my 60D is at 1.1.2 and I would like to run under ML. I have downloaded 1.1.1 from the net. Thanking you in advance. Jeff.

Walter Schulz

  • Hero Member
  • *****
  • Posts: 6157
Re: Canon 60D
« Reply #79 on: July 27, 2017, 05:22:45 AM »
Unzip file and follow instructions located in dir "update-procedure-pdf".

jeffjgale

  • New to the forum
  • *
  • Posts: 4
Re: Canon 60D
« Reply #80 on: July 27, 2017, 11:33:27 AM »
G'day Walter, Thank you for your prompt answer, May I ask where do I find this file, [dir/update-procedure-pdf] I have searched MF and the forum, but am unable to find it, Thank you. Jeff.

Walter Schulz

  • Hero Member
  • *****
  • Posts: 6157
Re: Canon 60D
« Reply #81 on: July 27, 2017, 02:05:49 PM »
Link to Canon's firmware file 1.1.1 is included in install instructions on Nightly Build download page for your cam. Or use http://pel.hu/eoscard
If you are on OS X/macOS: Just unzip.

Exo

  • New to the forum
  • *
  • Posts: 23
Re: Canon 60D
« Reply #82 on: November 20, 2017, 01:52:47 AM »
Here what i found on the web:

https://www.dropbox.com/s/gz50t04h4chxvhv/EOS%2060D%20Parts%20catalog.pdf?dl=0

60D part catalog! I got also for 7D, 5DII, 5DIII and 600D.

Might be some help for retroengineering?!

Cheers.

eduperez

  • Developer
  • Freshman
  • *****
  • Posts: 97
Re: Canon 60D
« Reply #83 on: November 20, 2017, 12:54:35 PM »
Here what i found on the web:

https://www.dropbox.com/s/gz50t04h4chxvhv/EOS%2060D%20Parts%20catalog.pdf?dl=0

60D part catalog! I got also for 7D, 5DII, 5DIII and 600D.

Might be some help for retroengineering?!

Cheers.

It just goes down to "printed circuit board" level, it does not even list the integrated circuits in that board... I do not think it can be used for reverse-engineering, unfortunately. However, service manuals do have that information (and more); those could be useful.

Exo

  • New to the forum
  • *
  • Posts: 23
Re: Canon 60D
« Reply #84 on: November 20, 2017, 11:48:09 PM »
Okay, this is the closest i got: 40D

http://cholla.mmto.org/photography/gear/repair/eos_40d_service_manual.pdf

Otherwise:

http://pdfwhiz.org/lp4/?title=canon%2060d%20service%20manual%20pdf

But don't count on me putting any credit card infos in that king of a website.

eduperez

  • Developer
  • Freshman
  • *****
  • Posts: 97
Re: Canon 60D
« Reply #85 on: November 21, 2017, 11:07:47 AM »
Okay, this is the closest i got: 40D

http://cholla.mmto.org/photography/gear/repair/eos_40d_service_manual.pdf

Otherwise:

http://pdfwhiz.org/lp4/?title=canon%2060d%20service%20manual%20pdf

But don't count on me putting any credit card infos in that king of a website.

Yes, the "2. BLOCK DIAGRAM > 2-1 GENERAL" on page 151 could be interesting, if there is something there that developers still do not know.

tt50080

  • New to the forum
  • *
  • Posts: 1
Re: Canon 60D
« Reply #86 on: November 24, 2017, 03:18:53 PM »
I have a Canon 60D which has 1.1.2 firmware installed. I would like to use Magic Lantern ...  I have looked for a 1.1.1 firmware and find that it has been removed from Canon's web site. I've searched elsewhere and it appears one can not just downgrade to an earlier firmware on this camera. Unless that is untrue, can you let me know the correct steps for getting back to version 1.1.1. I think once I have accomplished that, I should be able to install Magic Lantern.

Is there a link somewhere, -anywhere-, to get this?

Thank you!

sixb

  • New to the forum
  • *
  • Posts: 1
Re: Canon 60D
« Reply #87 on: November 29, 2017, 05:58:46 AM »
Hello Everyone,

I wanted to install Magic Lantern on my Canon EOS 60d, however, I can't find the Canon Firmware 1.1.1. They only have latest firmware 1.1.2. Would you be able to share the download link or dropbox link to canon 1.1.1 firmware for Canon 60d?

Thanks´╗┐
sixb

Echalotte

  • New to the forum
  • *
  • Posts: 1
Re: Canon 60D
« Reply #88 on: December 23, 2017, 01:04:43 PM »
Hello Everyone,

I wanted to install Magic Lantern on my Canon EOS 60d, however, I can't find the Canon Firmware 1.1.1. They only have latest firmware 1.1.2. Would you be able to share the download link or dropbox link to canon 1.1.1 firmware for Canon 60d?

Thanks´╗┐
sixb

In the thread I found this link:
http://pel.hu/eoscard

Walter Schulz

  • Hero Member
  • *****
  • Posts: 6157
Re: Canon 60D
« Reply #89 on: December 23, 2017, 03:58:04 PM »
Nice to know pelican's site is recovering.

timoadam

  • New to the forum
  • *
  • Posts: 2
Re: Canon 60D
« Reply #90 on: January 14, 2018, 07:51:43 PM »
Hello, I seem to have a problem with live audio playback. Using a mini-usb to 3.5mm jack adapter and the newest version of ML installed (2017-12-19) I get absolutely no audio through my headphones. Do I need the sescom cable or the cable that came with my camera instead? Or is it something with ML? Thanks in advance.

mike8712

  • New to the forum
  • *
  • Posts: 3
Re: Canon 60D
« Reply #91 on: January 30, 2018, 08:46:43 PM »
I was able to update my 60D with the ML firmware, I'm having 2 issues and I was hoping you guys might have some ideas.

1. When I am focusing to shoot video, there is plenty of light as it adjusts, but as it locks in focus, it becomes very dim.  It's odd.  I feel like there is some setting that is off - it was doing this before I downloaded ML, I was hoping this might affect or resolve.  Only for video.

2. When I start to record, it only lasts a few seconds, sometimes a little longer, and then stops recording automatically.  Empty card, plenty of storage, I cannot figure it out.  Again happened before ML install.

I am hoping there is some setting or something I have accidentally adjusted wrong.  Any tips or advice on how to troubleshoot is greatly appreciated.  Thanks!

Skyfox

  • New to the forum
  • *
  • Posts: 3
Canon 60D - best way to upgrade ML?
« Reply #92 on: February 24, 2018, 05:21:45 PM »
It's been many years since I installed Magic Lantern on my 60D.  The version I have is v2.3.60D.111 from July 2012.  The camera menu shows firmware version 1.1.1-ml-v2.3.  What's the best way to upgrade to the current version?  Can it just be directly upgraded by copying the files to the memory card and doing the firmware update in the camera?  Or is it best to uninstall the old version and then install the new version from scratch?

Walter Schulz

  • Hero Member
  • *****
  • Posts: 6157
Re: Canon 60D
« Reply #93 on: February 26, 2018, 04:41:58 PM »
Use a non-ML card (can be a small and slow one). Format card in cardreader, format card in cam.
Update cam with Canon firmware 1.1.6 using this card.

Now back to your ML card: Remove/rename *.fir, autoexec.bin and ML directory before copying nightly build files to card.
Insert ML card and enjoy.


Skyfox

  • New to the forum
  • *
  • Posts: 3
Re: Canon 60D
« Reply #94 on: February 28, 2018, 11:08:11 PM »
Thanks for the info.  Now, if I upgrade and it doesn't work right or I don't like it, is it equally straightforward to downgrade back to the old version I have?

Skyfox

  • New to the forum
  • *
  • Posts: 3
Re: Canon 60D
« Reply #95 on: March 08, 2018, 07:58:18 PM »
Ok, I'm confused here.  You said to update with Canon firmware 1.1.6.  If you mean firmware from the Canon website, the only firmware they offer is v11.2.
If you're talking about ML firmware, what's listed for the 60D is version 1.1.1.
If you did specifically mean ML firmware 1.1.6, the only one that shows that version number is for the Canon 6D (not the 60D).

Please advise, thanks!  (I'll admit, I'm stupid when it comes to figuring this stuff out.  I'm the kind of person that needs detailed step-by-step instructions.)

Use a non-ML card (can be a small and slow one). Format card in cardreader, format card in cam.
Update cam with Canon firmware 1.1.6 using this card.

Now back to your ML card: Remove/rename *.fir, autoexec.bin and ML directory before copying nightly build files to card.
Insert ML card and enjoy.

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3032
Re: Canon 60D
« Reply #96 on: April 13, 2018, 07:14:22 AM »
Looks like there's some confusion over firmware on the 60D. Current working Magic Lantern version is for 1.1.1 and latest Canon firmware is at 1.1.2. If anyone has a 60D.112 firmware dump please PM me. Thanks!
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 500D.112

jai554

  • New to the forum
  • *
  • Posts: 23
Re: Canon 60D
« Reply #97 on: April 13, 2018, 09:07:05 PM »
Looks like there's some confusion over firmware on the 60D. Current working Magic Lantern version is for 1.1.1 and latest Canon firmware is at 1.1.2. If anyone has a 60D.112 firmware dump please PM me. Thanks!

i can help you dump the 1.1.2 firmware but the method from CHDK doesnt seem to work
the portable rom dumper needs signed firmware right?

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3032
Re: Canon 60D
« Reply #98 on: April 14, 2018, 12:31:19 AM »
@jai554 - Great!

Steps:
  • Make sure you have ML working on your 60D, prepare a few cards with ML. Sometimes the card gets corrupted and usually smaller capacity cards cards work better than the large ones. The important part is that your camera and card bootflags are set. The ML installation does that.
  • Download the 60D Canon Firmware for Testers.zip from my downloads page: https://bitbucket.org/daniel_fort/magic-lantern/downloads/ in there you'll find the Canon firmware updaters to get you to 112 and back to 111.
  • Put both firmware updaters on either an SD card formatted without the bootflag set -or- on a ML prepared card with the bootflag set but remove the ML-SETUP.FIR file from the card.
  • Download the Portable firmware dumper from here: http://a1ex.magiclantern.fm/debug/portable-rom-dumper/autoexec.bin
  • Put the Portable firmware dumper (just an autoexec.bin file) on a card that has the bootflag set. It should dump the 1.1.2 firmware when you run it in camera. It might not work the first time or you might need to run it on a few different cards. You can read more about it here: http://www.magiclantern.fm/forum/index.php?topic=16534.0
  • Zip up the files and PM me. Don't share openly on the forum!
In case that doesn't work, try the blind dumper: https://a1ex.magiclantern.fm/bleeding-edge/blind-dumper/autoexec.bin
  • You'll need to have a valid image on your card so when you press the playback button it has something to playback.
  • Again, on a card with the bootflag set and a valid in the proper directory, put the blind dumper autoexec.bin file on the card and start the camera.
  • Press the Playback button.
  • You should get a new file in the root directory of your card, on the 500D it was named "As" and that should be the firmware dump.
If you're interested in how to port ML to a Canon firmware update you check out my tutorial.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 500D.112

jai554

  • New to the forum
  • *
  • Posts: 23
Re: Canon 60D
« Reply #99 on: April 14, 2018, 04:08:42 AM »
@jai554 - Great!

Steps:
  • Make sure you have ML working on your 60D, prepare a few cards with ML. Sometimes the card gets corrupted and usually smaller capacity cards cards work better than the large ones. The important part is that your camera and card bootflags are set. The ML installation does that.
  • Download the 60D Canon Firmware for Testers.zip from my downloads page: https://bitbucket.org/daniel_fort/magic-lantern/downloads/ in there you'll find the Canon firmware updaters to get you to 112 and back to 111.
  • Put both firmware updaters on either an SD card formatted without the bootflag set -or- on a ML prepared card with the bootflag set but remove the ML-SETUP.FIR file from the card.
  • Download the Portable firmware dumper from here: http://a1ex.magiclantern.fm/debug/portable-rom-dumper/autoexec.bin
  • Put the Portable firmware dumper (just an autoexec.bin file) on a card that has the bootflag set. It should dump the 1.1.2 firmware when you run it in camera. It might not work the first time or you might need to run it on a few different cards. You can read more about it here: http://www.magiclantern.fm/forum/index.php?topic=16534.0
  • Zip up the files and PM me. Don't share openly on the forum!
In case that doesn't work, try the blind dumper: https://a1ex.magiclantern.fm/bleeding-edge/blind-dumper/autoexec.bin
  • You'll need to have a valid image on your card so when you press the playback button it has something to playback.
  • Again, on a card with the bootflag set and a valid in the proper directory, put the blind dumper autoexec.bin file on the card and start the camera.
  • Press the Playback button.
  • You should get a new file in the root directory of your card, on the 500D it was named "As" and that should be the firmware dump.
If you're interested in how to port ML to a Canon firmware update you check out my tutorial.

Sorry i got a bit confused
i need to install firmware 1.1.2 first right?
then insert the card with ML working with the modified autoexec.bin?

Edit:
Nvm, i got it working now
dumping the rom :)
wish me luck haha XD