Author Topic: Back button issue  (Read 2105 times)

garry23

  • Contributor
  • Hero Member
  • *****
  • Posts: 2217
Back button issue
« on: September 04, 2014, 08:48:51 AM »
I buried a question in another post the other week, and got no reply.

Forgive me trying one more time.

It seems that if you use shutter half double press option to trigger AETTR, it also triggers off a double press of the back button focus. At least on my 50D and 5DIII.

Does anyone know if this can be switched off, ie just trigger off the shutter and not the back button.

Is this just a 'feature' of the code that could be tweaked to correct this effect?

Bottom line: I would have thought everyone using back button focus would wish this to be kept just for that, ie not triggering AETTR 

Cheers

Garry

ayshih

  • Contributor
  • Senior
  • *****
  • Posts: 266
Re: Back button issue
« Reply #1 on: September 04, 2014, 01:31:56 PM »
It's not currently possible in ML to discriminate between those two buttons (i.e., they send the same event).  See the following thread (it's about silent pictures, but the cause is the same):

http://www.magiclantern.fm/forum/index.php?topic=10740.0
Canon EOS 50D | 17–40mm f/4L & 70–300mm f/4.5–5.6 DO IS | Lexar 1066x

garry23

  • Contributor
  • Hero Member
  • *****
  • Posts: 2217
Re: Back button issue
« Reply #2 on: September 04, 2014, 06:05:48 PM »
Ayshih

Many thanks for the link and confirming what I thought was the issue.

Pity as it virtually wipes out half shutter as a trigger And, of course, SET clashes with other modules that use SET, eg the ND module.

Cheers

Garry