MLVFS - a FUSE based, "on the fly" MLV to CDNG converter

Started by dmilligan, August 31, 2014, 02:01:24 AM

Previous topic - Next topic

0 Members and 3 Guests are viewing this topic.


I've just compiled it ad now it works like a charm :)
Thanks !


I don't know what's wrong but I compiled it also with original code and it works...


Quote from: Ottoga on May 05, 2016, 04:52:19 AM

Re: the m22-1744 in your --mlv-dir path. Is this the actual mlv file or the directory where that mlv resides. The path should be to the directory where the mlv files reside.

Also, have you actually checked that dokan is loaded? See below for how to check (in a cmd window):

First of all thank you for your response!

I used the path where the mlv file is, so there is no subfolder left.

I tried the to check if dokan is loaded. When i type in the comments, there is is just a very short popup of another command prompt but i dont see what is written there. There is no further information in the prompt where i typed in the command. I tried to install the drivers but there was the same issue.

Would it help if i record my screen?
100D.100B ; Canon 18-55 STM ; Canon 50 1,8 II ; Canon 75-300 4,0 - 5,6 III ; Sigma 17-50 2,8



Some screen shots or a video clip taken with your smartphone would help.

Also, double check whether you have a 32 or 64 bit version of windows installed and that you are using the correct version for your operating system.
EOS 7D.203, EFS 55-250mm, EF 75-300 III, Tamron 16-300 DiII VC PZD Macro, SpeedLite 580EX II.


Im using the x64 bit version and i have a x64 Windows as you can see in the video below:
100D.100B ; Canon 18-55 STM ; Canon 50 1,8 II ; Canon 75-300 4,0 - 5,6 III ; Sigma 17-50 2,8


Been a bit since I've used MLVFS but when I select it from the right-click menu I'm just getting a spinning gear with a 0% complete message in the menu bar. This is on Mac. What am I doing wrong?


Did you choose the mount folder?Sometimes the dialog comes up behind other windows.


Wasn't prompted for a mount folder. Checked if it was hidden. That's kind of what's got me scratching my head.


That's the very first thing it does, so you probably missed it. Close all open windows and try again.



Thanks for the video clip. A couple of points:

  • The instructions below should be done in a cmd window with admin rights. My bad, I didn't clarify this in my earlier response to you. This should see the results of each command just being displayed within the cmd window.
  • There is no need to include the actual driver path to achieve what we are trying to do here.
  • The little window that flashed up when you entered 'dokanctl /I d' actually confirmed that the service was installed and started. If you are quick with the pause button you can see it.

From what I've seen, I think that the dokan service is installed and running. to convince yourself just try the commands (exactly as per below again in a cmd window with Admin rights). :

C:\Program Files\Dokan\Dokan Library-1.0.0>cd /d C:\Program Files\Dokan\Dokan Library-1.0.0

C:\Program Files\Dokan\Dokan Library-1.0.0>dokanctl

Driver path: 'C:\WINDOWS\system32\drivers\dokan1.sys'
dokanctl /u MountPoint (/f)
dokanctl /m
dokanctl /i [d||n]
dokanctl /r [d||n]
dokanctl /v

  /u M                : Unmount M: drive
  /u C:\mount\dokan : Unmount mount point C:\mount\dokan
  /u 1                : Unmount mount point 1
  /u M /f             : Force unmount M: drive
  /i d                : Install driver
  /i n                : Install network provider
  /r d                : Remove driver
  /r n                : Remove network provider
  /d [0-9]            : Enable Kernel Debug output
  /v                  : Print Dokan version

C:\Program Files\Dokan\Dokan Library-1.0.0>dokanctl /v
Driver path: 'C:\WINDOWS\system32\drivers\dokan1.sys'
dokanctl : Mar  8 2016 13:07:15
Dokan version : 100
Dokan driver version : 0x190

C:\Program Files\Dokan\Dokan Library-1.0.0>

As I said, I think that the dokan service is up and running on your PC. Can you do a similar clip of what happens when you launch MLVFS. remember it also needs to be in a cmd window with admin rights. Please include the launch process, what you see in file manager and the localhost browser details.

EOS 7D.203, EFS 55-250mm, EF 75-300 III, Tamron 16-300 DiII VC PZD Macro, SpeedLite 580EX II.


Ah okay, now dokan works/ shows information. But still MLVFS does not work right. I made another video:

Thank you so much for your help! :)
100D.100B ; Canon 18-55 STM ; Canon 50 1,8 II ; Canon 75-300 4,0 - 5,6 III ; Sigma 17-50 2,8


@canneloni , MLVFS is very simple to use you are making it more complicated then it really is .
I made a video for PC user's on how to install & execute the program , It is base on Win7 pro
but it still applies to win 10 as it basically has all the some commands .
Video Tutorial-->
Now the only difference is win 10 uses the x64 Dokan file version where as win 7 uses x86 that's it.

The Command are the same except navigation to the MLVFSx86 in your case MLVFSx64.
The command stuff starts around the 4:40 mark I do believe .
If you are still having troubles , let me know and I do a quick Win10 Video Tutorial and post it here .



Hmmm,  you appear to be doing everything correctly now. The only thing that I can think of that may be causing it not to work for you is the virtual drive letter that you are using ('X') when launching mlvfs. This virtual drive letter must be unique.

In you clip I noticed that you had three network drives assigned. The first was active but I didn't see what drive letter was assigned to it. The other two were inactive with drive letters "Y' and 'Z' assigned respectively. I am thinking that maybe your first network drive has already been assigned to drive 'X'.

If this is the case, just pick a free (unused) drive letter for use with mlvfs.  e.g.: mlvfs64.exe M: --mlv-dir=c:\mlvs

Failing this, you could try reddeercitys' suggestion to use the 32 bit version of mlvfs.

EOS 7D.203, EFS 55-250mm, EF 75-300 III, Tamron 16-300 DiII VC PZD Macro, SpeedLite 580EX II.


Okay it works now. I removed everything from Dokan i had installed and cleaned the regestry of every entry with the word "Dokan" in it. I then reinstalled the newest version of Dokan and used mlvfsx64.

Thank you guys so so so much for your work and time! Im so glad i can finally use mlfvs. I have to figure out wich workflow works best for me and my 100D but im pretty sure there is a good way ;)
100D.100B ; Canon 18-55 STM ; Canon 50 1,8 II ; Canon 75-300 4,0 - 5,6 III ; Sigma 17-50 2,8



I installed Dokan and MLVFS_x86 from the first page (running windows 7 64bits).
At first everything seemed to work fine, I can mount the dng files and open them in After Effects. But when I apply settings in ACR inside After Effects, they are only applied to the first frame, not to the whole sequence. It works fine if I put dng files in a regular folder without using MLVFS.
I then realized that I cannot copy a file onto the drive that is mounted, which probably explains that AE can not copy metadata files or write inside the dng files, therefore the settings are applied only to the first frame of the sequence.
I noticed other people here had the same problem, but could not find a clear solution in this thread. Should I use newer versions that are not released yet? If so where do I find them and how do I proceed?




Hello. Why capture DualISO band . When they disappear - the picture becomes darker ? On your video in the second case they were . English I do not know ( ( ( ( . I use a translator .


THANK YOU! I just wanted to make sure you understand how much I appreciate this software.
SL1 100D.100A - 5D - 7D2 - 5D3 1.2.3


hey.. for some reason.. i dont seem to get git fetch the source code..
can somebody kindly send me the commandline syntax ?



Hi there,

After some hours of test and post reading, here is some feedback.

3 different windows test :

- Windows 10 pro upgrade from a windows 7 pro :

  • dokan 0.8 + mlvfs_x86 > not working, as we already know it.  *edit* > working. Mounting and navigating super fast. Resolve workflow seems to be ok. Accessing dngs in resolve seems to be a bit longer than with win 7
  • dokan 1.0 + mlvfs_x64 > working but windows crash after few seconds each time. I don't know where i can find logs :/

- Windows 10 home upgrade from windows 8 home ( laptop ) :

  • dokan 0.8 + mlvfs_x86 > working, surprisingly. Resolve import ok. Playback laggy but laptop are not made for raw
  • dokan 1.0 setup failed. 0x80091007 - La valeur de hachage n'est pas correct.
Error 0x80091007: Hash mismatch for path: C:\ProgramData\Package Cache\.unverified\vcredist_2015_x64.exe, expected: 9A19A51D1F40CD5CD5ECB6E4E4F978F18DA8212A, actual: 3155CB0F146B927FCC30647C1A904CD162548C8C

-Windows 7 pro :

  • dokan 0.8 + mlvfs_x86 > working. Full Resolve workflow > all ok. Just a bit of cdng loading time at project opening. Don't know why. Does this loading time increase with project size ?

I wish i could give more log info, specially for the win 10 pro crashes. Maybe some tips to where i can find dokan/mlvfs logs please ?
Thanks for this great tool.

A little batch command with prompt to find your mlvs location. Place the .cmd file within MLVFS_X86 or MLVFS_X64 folder and feel free to place a short cut anywhere you want :
@if (@a==@b) @end /*

:: fchooser2.bat
:: batch portion

@echo off

for /f "delims=" %%I in ('cscript /nologo /e:jscript "%~f0"') do (
    echo You chose %%I
    C:\MLVFS_x86\mlvfs.exe z: --mlv-dir=%%I

goto :EOF

:: JScript portion */

var shl = new ActiveXObject("Shell.Application");
var folder = shl.BrowseForFolder(0, "Please choose a folder.", 0, 0x00);
WSH.Echo(folder ? folder.self.path : '');


Hey all. I've installed FUSE and MLVFS. I see the command file is in the Services folder, but MLVFS doesn't show up as a service when I right click on MLV files. No services show up. I tried re-installing. No help. Any suggestions?


@lostfeliz - You should be right clicking on a Folder (not the MLV file) and here's how I do it below...
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109



This might be a noobie question but I use MLVFS and Smart importer 2 in AE. In my mounted folder I have footage with different frame rates and now I wonder what the easiest way to process the footage in AE is, without messing around with the differnet framerates!


@ _OLLE_

So, in AE under edit preferences, under import, you can set the default sequence frame rate. Set that to whatever is your most common frame rate (or change it as needed).

In Smart Import 2, there is a field for the comp frame rate. If you leave it blank, the comp frame rates will be set at the default value you set in AE as mentioned above. If you put a value in there, it should override the default AE value.

Using these two settings, you should be able to deal with different frame rates. However, you might need to run Smart Import 2 script separately for each frame rate.