50D Frame Rate - An idiot's guide required

Started by SB50D, August 22, 2014, 03:43:52 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Hi all,

I'm new here but have searched through the forum and tried the user guide but I can't for the life of me work out how to change the video frame rate in my 50D.

I can tell from the menu that it defaults to 30fps but I want 24fps.

I know it's something to do with fps override but I have no idea what to set all the parameters to in the submenu and what each of them do. I'm none the wiser after having read the user guide.

Any help would be much appreciated!


If you're on the August 8th nightly this is easier, so I'd recommend installing that.

- First, enable movie recording (you know where and how to do that).
- Farther down the page is the FPS override. Enter the Q menu for FPS override by pressing the FUNC button.
- There should be a variable called "Desired FPS". If you have live view on it'll say "X (from 30)", where X is the default; if you don't have live view on it'll say "X (from 0)".
- Adjust the desired framerate to either 23.976 or 24.
- Set the "Optimize for" variable to "Exact FPS".

And that should do it. You're now recording video at a framerate of 23.976, which is a version of 24FPS that is compatible with NTSC/ASTC 59.94Hz displays.

NOTE: If you play an H.264 file made on your 50D with these settings, it will look like it was sped up. This is normal. Find a way to conform these files to 23.976 in your NLE of choice and it will work exactly like regular old 23.976 footage.


Brilliant, thanks very much for the help. I will give it a go and see if I can make more sense of it!


Righto, that worked very nicely indeed. Thanks! The nightly build looks much better too  :)

Next problem though - even if my camera is in manual mode and I fix the ISO, shutter speed and aperture. It seems to adjust all of those things automatically when I turn on live view and try and take a video. I've tried setting them in the ML menus as well but that doesn't seem to stop it changing either.

Anyone got any tips?


Turn on exposure override under the exposure tab
Canon EOS 50D | 17–40mm f/4L & 70–300mm f/4.5–5.6 DO IS | Lexar 1066x