Want to help with the latest development but don't know how to compile?

Started by Audionut, July 10, 2014, 04:28:51 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


 I have been using the 5D3 2014 Sep 26 FIX version. Granted I have not used it much but some tests of full res silent picture (with or without intervalometer) worked  fine. So no errors to report.

I only wished i had access to speeds as low as 25 sec (instead of 15sec) for milkyway timelapses though.

But I owe a big thank you to all you ML developers anyway...


Quote from: tron on January 06, 2015, 11:56:04 PM
I only wished i had access to speeds as low as 25 sec (instead of 15sec) for milkyway timelapses though.

This code (Thanks Alex ;)) increase the limit to the 35 sec.
The maximum time is 30 seconds as silent full res pic does not work with the bulb.

if (cam_500d)
cache_fake(0xff08afb8, 35000, TYPE_DCACHE);

So if you need 30 seconds, you have to find a register and create your own compilation. If 5D3 is similarly...


Then an updated  5D3-123 build would be welcome  :)

Right now I use 2014 Sep 26 (FIX) Mercurial changeset: bf22c22b62f6 (5D3-123)

The intervalometer tests were made using shoot like crazy

I have tried to time it. I have measured about 5 seconds delay between shots (Tv set to 15sec). I guess selecting 25 sec instead of 15 sec will make the 5 sec gap less important.


I got to the point where I couldn't stand the fact that I can't compile this code into the FRSP module (anxious to use the 25-30 sec shutter speed) that I decided to take a deep dive into ML wiki ( http://magiclantern.wikia.com/wiki/Magic_Lantern_Development_on_Mac) and followed the step by step to get myself ready to compile with the that code posted by @Greg whom he got it from @A1ex (Thanks for that) but since I'm not quite sure how to start on editing the Module within MacHGg application.

Can I just dive into that module and just copy the code and replace it?

Can't be easy as it sounds...

or am I wrong?

5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109


I am interested in focus stacking and full resolution silent mode. I have been using both ML focus stacking for AF lenses and a homemade automated focusing rail with remote triggering of the camera. I would like to test the full res silent for this purpose with and without external flash. My camera is 6D. Can anyone help with a compilation of the latest FRSP module for this camera, please?


*** Testers needed ***

Help write test scripts for the new lua scripting engine: http://www.magiclantern.fm/forum/index.php?topic=14828.0

I will provide the lua.mo and keep it up to date with development, but a full build for the particular camera is needed for the module to load.


Custom test build from branch LUA scripting (ffcf212) for 550D:

Compiled with Codio:
1. hg clone -r ffcf212 https://bitbucket.org/hudson/magic-lantern
2. "Makefile.modules.default" changes in folder modules:
MODULE_CFLAGS += -I../../src/
ML_MODULES_DYNAMIC ?= file_man pic_view ettr silent deflick mlv_play mlv_rec mlv_snd lua

3. cd magic-lantern/platform/550D.109
4. make clean && make zip

Additional changes after compiling and downloading the zip:
- all files deleted in scripts folder
- added "forced_delay.lua" script file in the scripts folder (thanks dmilligan!):
menu =
parent = "Intervalometer",
name = "Force Delay",
help = "Add an extra delay to each interval",
min = 0,
max = 300,
unit = UNIT.TIME,

events =
intervalometer = function() msleep(menu.value * 1000) return true end

- custom cropmarks: hd.bmp + cinema.bmp
- copied "dual_iso.mo" from latest nightly build (because gcc 32bit isn't working on Codio cloud service and it couldn't be compiled, it's a 64bit system)
- so modules folder: adv_int.mo, deflick.mo, dual_iso.mo, ettr.mo, file_man.mo, lua.mo, mlv_play.mo, mlv_rec.mo, mlv_snd.mo, pic_view.mo, silent.mo

!!!Read the OP here!!!

// Outdated build removed.  Audionut.
550D + nightly ML


Here is one for the 7D.

I used hg clone -b lua https://bitbucket.org/hudson/magic-lantern
instead of -r that surami used. Also added lua to ML_MODULES_DYNAMIC.

Added the dual_iso.mo from the latest nightly, the  "forced_delay.lua" and "stop_thief.lua" from the original post.

Off to learn lua.

// Outdated build removed.  Audionut.
7D, AE-1P, 4x5 and GAS



I would like to run some lua script on my camera.
Is it possible to have a build for the 600D and the corresponding lua.mo?



Lua branch build for 600D.

I had to disable the whole 'movie menu' featureset to shrink it down to <500k - might take a closer look at what to remove another time.

Also moved some of the sample scripts to a new folder called scripts-disabled because they were eating up all of the available memory on this model.

Enjoy! Thanks for your work @dmilligan

//  Outdated build removed.  Audionut.


can someone compile for me the latest version of ML with Lua scripts feature?
My camera is the 700D.
Thanks a lot,


Here you go.

I don't have a 700D so there's no QC on this build. Please post when you downloaded it so I can delete it.

//  Outdated build removed.  Audionut.


thank you very much!
I downloaded it, you can delete the file.
If someone has the Canon 700D and wants ML with Lua:


//  Outdated build removed.  Audionut.


Here is a build for the 600D that includes the benchmarks and selftest as modules for fixing nightly builds.

Please test it and report at the pull request link above, to push this to the nightly builds and fix the 600D nightly.

Build removed.  This branch has been merged with unified.


Knock knock--Hello, any 60D users out there?

I've been working with a 60D user in the UK on an issue with mv640crop mode video but I haven't heard from him for a while. Is there any 60D user willing to test out a fix for it? I had a solution but a1ex provided a better one and would like to have someone test and report back.

Here's the pull request:

And here's a build with the new fix for testing:

Build removed as this has been merged with unified.  // Audionut



I'll have a play with this. I tried your zip link but it was 404. Do you still need someone to test?