Author Topic: Full-resolution silent pictures (silent.mo)  (Read 639980 times)

swinxx

  • Hero Member
  • *****
  • Posts: 602
Re: Full-resolution silent pictures
« Reply #300 on: September 27, 2014, 11:29:38 AM »
after 1 month of wait i downloaded a version from yesterday 26.09.2014 and i have to report that it is very unstable (fullres silent pic) with my canon 5d mk3 1.2.3 - got some err70 freezes while shooting (never got them before) .. will post the log today. thank you.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Full-resolution silent pictures
« Reply #301 on: September 27, 2014, 11:58:16 AM »
Now you understand why it's not yet in the nightly?

Jockerl

  • New to the forum
  • *
  • Posts: 26
Re: Full-resolution silent pictures
« Reply #302 on: September 27, 2014, 12:30:28 PM »
@swinxx
http://www.magiclantern.fm/forum/index.php?topic=12608.msg129663#msg129663
mk11174  uploaded a new version for 1.2.3 which may work better

swinxx

  • Hero Member
  • *****
  • Posts: 602
Re: Full-resolution silent pictures
« Reply #303 on: September 27, 2014, 04:08:09 PM »
thx. the updated version works, but i got too many err70 freezes, so i probably have to wait a little longer. greets.

mk11174

  • Contributor
  • Hero Member
  • *****
  • Posts: 809
Re: Full-resolution silent pictures
« Reply #304 on: September 27, 2014, 05:10:42 PM »
Correct; it only shows until file saving is done. I could look at image review settings in Canon menu and use that - useful?
It is nice to know about the battery for sure, but since I guess most people will use the MLV option, they won't have time to read the battery info because at least on the 700D it is just a flash, so if it was able to be adjusted say as long as the Canon image review, then that would be good idea for sure so it can be useful in MLV saving mode.
500D/T1i  550D/T2i  600D/T3i  700D/T5i

mk11174

  • Contributor
  • Hero Member
  • *****
  • Posts: 809
Re: Full-resolution silent pictures
« Reply #305 on: September 27, 2014, 05:23:55 PM »
Any user getting the black Raw Error screen, please double check you have your picture quality set to RAW.
500D/T1i  550D/T2i  600D/T3i  700D/T5i

mk11174

  • Contributor
  • Hero Member
  • *****
  • Posts: 809
Re: Full-resolution silent pictures
« Reply #306 on: September 27, 2014, 05:58:51 PM »
One thing I notice on the 550D because the LED tells me things is if you load FullRes and take a fullres silent picture, then turn off FullRes then turn off cam, it looks like task is looping, because after maybe 10 seconds the led starts blinking 1 flash every few seconds.

If you just load FullRes and don't take a picture and just turn it off, it does not loop any task, it is only if you take at least 1 fullres silent picture and then turn it off.

And of course after you try to load camera again it says it crashed so it cant load modules and then you have to restart.

So, at least on the 550D, if you use Fullres you will need to take battery out after your done using it and turn off camera to shut the loop off.

And to confirm, this does not happen on the 700D, no lights blinking and no errors loading camera on next boot, so nothing looping on this camera.

UPDATE!, Also on 550D as far as the task looping, I notice this only happens in PHOTO MODE, even though it is only really meant for PHOTO MODE, I tried it in MOVIE MODE and no looping happens after taking a silent picture and turning cam off. You have no control of shutter of course in movie mode for FullRes, but at least it might be useful to note that this looping only happens in photo mode.

UPDATE 2! Just to note, none of your new tweaks is causing this issue with the looping task for the 550D, it also does it before your tweak updates, so its not from any new changes you made.
500D/T1i  550D/T2i  600D/T3i  700D/T5i

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7137
Re: Full-resolution silent pictures
« Reply #307 on: September 27, 2014, 06:21:07 PM »
I got a black screen and a resulting error 70 code when I held down the shutter button longer than needed taking a picture. Had to remove battery. 5D mark 3 firmware 1.1.3

mk11174

  • Contributor
  • Hero Member
  • *****
  • Posts: 809
Re: Full-resolution silent pictures
« Reply #308 on: September 27, 2014, 06:31:57 PM »
With all these results, I def see why this is not in the nightly, it works really well on the 700D, but it is clear there are many issues with other cameras for sure, so this is good all these tests can be made with these other cameras, maybe it will help to get things fixed so one day it will be stable enough for the nightly, but I am sure the DEVS need more feedback from all users and cameras that test this and good details on what happens and what they do during an error, so anyone that has errors, please post as much info as possible, not just that it crashed or something.  :)
500D/T1i  550D/T2i  600D/T3i  700D/T5i

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7137
Re: Full-resolution silent pictures
« Reply #309 on: September 27, 2014, 06:56:28 PM »
Yes, sorry. I, ll post the crash log when back home

mk11174

  • Contributor
  • Hero Member
  • *****
  • Posts: 809
Re: Full-resolution silent pictures
« Reply #310 on: September 27, 2014, 07:00:54 PM »
Yes, sorry. I, ll post the crash log when back home
Oh, no problem, I was not referring to you or anything, it was just for everyone.

You let us know that you held button down to long, so that is some detail at least, so def not directed toward you or anyone else, just want to make a note for any users testing it to help speed up the debugging process.
500D/T1i  550D/T2i  600D/T3i  700D/T5i

Danne

  • Developer
  • Hero Member
  • *****
  • Posts: 7137
Re: Full-resolution silent pictures
« Reply #311 on: September 27, 2014, 08:24:26 PM »
Do I put log messages here or at bitbucket somewhere?

Anyway.
5d mark 3 firmware 1.1.3 gave a black screen and a error 70 and a crash log after I tried to press and hold shutter button a while longer than needed. Was thinking maybe I get some longer shutter speeds  :P

Crash log

ASSERT: GetMemoryAddressOfMemoryChunk( GetFirstMemChunk( pMem1AllocateListItem->hMemSuite ) ) == pMessage->pAddress
at SrmActionMemory.c:1505, task RscMgr
lv:0 mode:3

Magic Lantern version : Nightly.2014Sep26.5D3113
Mercurial changeset   : 81a2fd653497+ (fullres-silent-pics) tip
Built on 2014-09-26 19:53:38 UTC by mathew@mathewubuntu64.
Free Memory  : 149K + 3789K

mk11174

  • Contributor
  • Hero Member
  • *****
  • Posts: 809
Re: Full-resolution silent pictures
« Reply #312 on: September 27, 2014, 08:37:53 PM »
Do I put log messages here or at bitbucket somewhere?
I would think here is good.
500D/T1i  550D/T2i  600D/T3i  700D/T5i

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Full-resolution silent pictures
« Reply #313 on: September 28, 2014, 06:43:29 PM »
One thing I notice on the 550D because the LED tells me things is if you load FullRes and take a fullres silent picture, then turn off FullRes then turn off cam, it looks like task is looping, because after maybe 10 seconds the led starts blinking 1 flash every few seconds.

Can you record a video to show the issue, and paste your settings directory? I'm trying to reproduce, without success.

Meanwhile I've fixed most half-shutter-related errors, as reported by Danne. Maybe it was related.

mk11174

  • Contributor
  • Hero Member
  • *****
  • Posts: 809
Re: Full-resolution silent pictures
« Reply #314 on: September 28, 2014, 07:40:38 PM »
Can you record a video to show the issue, and paste your settings directory? I'm trying to reproduce, without success.
Ok, in video you will see me reset ML config first so its all defaults since non of that changes the outcome.

I will then take a fullres silent pic and then shut off cam, and wait for led to flash and then turn back on, but for this video, the bug is not letting me enter live view again, until I take bat out and then you will see the not loading modules warning message.

Then I will load module without taking a picture and do same process of restarting without issue.

Then I will do first step once more with same error results.

500D/T1i  550D/T2i  600D/T3i  700D/T5i

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Full-resolution silent pictures
« Reply #315 on: September 28, 2014, 07:51:40 PM »
Reproduced.

At 1 second exposure time, it fails. At 0.8 seconds it's fine.

Minimal code for reproducing (no need to enter LiveView):
Code: [Select]
    void* job = (void*) call("FA_CreateTestImage");
    call("FA_CaptureTestImage", job);
    call("FA_DeleteTestImage", job);

mk11174

  • Contributor
  • Hero Member
  • *****
  • Posts: 809
Re: Full-resolution silent pictures
« Reply #316 on: September 28, 2014, 08:06:16 PM »
I just do that by habit with turning off module.  :)

And I guess the long exposure might make sense since in movie mode it does not do it and you have no control of exposure in that mode because you can't go lower than the video frame rate.

Double checked on my 700D with longer exposures, no issue still for that cam at least.
500D/T1i  550D/T2i  600D/T3i  700D/T5i

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Full-resolution silent pictures
« Reply #317 on: September 28, 2014, 09:41:35 PM »
If you trigger these long exposures with the intervalometer, it should be fine (cameras affected so far: 550D and 500D).

It seems to conflict with Canon meter. If I wait 5 seconds after last half-shutter press, before taking the silent picture, it's fine. If I wait only 3 seconds, it fails.

mk11174

  • Contributor
  • Hero Member
  • *****
  • Posts: 809
Re: Full-resolution silent pictures
« Reply #318 on: September 28, 2014, 10:00:10 PM »
It seems to conflict with Canon meter. If I wait 5 seconds after last half-shutter press, before taking the silent picture, it's fine. If I wait only 3 seconds, it fails.
Nice catch,  good to keep in mind.
500D/T1i  550D/T2i  600D/T3i  700D/T5i

mk11174

  • Contributor
  • Hero Member
  • *****
  • Posts: 809
Re: Full-resolution silent pictures
« Reply #319 on: September 28, 2014, 11:50:06 PM »
Using intervolmeter,  even setting start and delay between each picture to as high as 15seconds for 1sec exposures still causes issue to happen,,  but have not tried with your latest tweak to half shutter yet
500D/T1i  550D/T2i  600D/T3i  700D/T5i

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Full-resolution silent pictures
« Reply #320 on: October 03, 2014, 09:01:12 AM »
Indeed, in LiveView it always fails, regardless of the time since the last half-shutter press. My previous test was outside LiveView, and there it appeared to work if the test code was ran at least 5 seconds after pressing half-shutter.

Some more progress: the problem is triggered by DarkCurrentCorrection, which is only executed for 1-second or longer exposures. I've tried to patch the code so it doesn't do this noise reduction step, with partial success: camera shuts down correctly, but you can no longer take regular pictures (bottom bar says BUSY).

Code: [Select]
    patch_instruction(0xff07f6d0, 0x8b07fd32, 0xeb07fd32, "silent NR off");
    patch_instruction(0xff07f754, 0x8a0000b1, 0xea0000b1, "silent NR off");
    call("FA_CaptureTestImage", job);
    unpatch_memory(0xff07f6d0);
    unpatch_memory(0xff07f754);

(to run this, you need to merge with the patchmgr branch and include "patch.h")

I think I'll limit the exposure times to 1 second for the affected cameras (550D and 500D so far) for now (unless I'll find a better solution over the weekend).

vstrglv

  • Member
  • ***
  • Posts: 245
Re: Full-resolution silent pictures
« Reply #321 on: October 03, 2014, 05:46:00 PM »
I have tried to compile silent.mo from silent.c https://bitbucket.org/hudson/magic-lantern/src/8ad793b88c3050ed443c64f01741e566d76f316c/modules/silent/?at=fullres-silent-pics  but got an error
Code: [Select]
magiclantern@magiclantern-VirtualBox:~/magic-lantern/modules/silent$ make clean
[ RM ]  silent.o silent.mo silent.sym silent.dep module_strings.h *.o *.d *.dep *.sym hgstamp
magiclantern@magiclantern-VirtualBox:~/magic-lantern/modules/silent$ make
Updated HGVERSION
[ README   ]   module_strings.h
[ CC       ]   silent.o
silent.c: In function 'silent_pic_take_fullres':
silent.c:1005:12: error: invalid use of void expression
silent.c:1067:9: error: invalid use of void expression
silent.c:1068:9: error: invalid use of void expression
make: *** [silent.o] Error 1
magiclantern@magiclantern-VirtualBox:~/magic-lantern/modules/silent$
Please help
Canon 5D3,1.1.3; Canon EOS M,202,  CF-SanDisk Extreme PRO,160MB/s, 256GB, SD-SanDisk Extreme Pro, 170MB/s, 128GB.

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1186
Re: Full-resolution silent pictures
« Reply #322 on: October 03, 2014, 06:48:04 PM »
Please use the full branch to compile:
https://bitbucket.org/hudson/magic-lantern/commits/branch/fullres-silent-pics

Don't simply compile the module. Fully compile to get your nightly zip and try it out.
70D.112 & 100D.101

vstrglv

  • Member
  • ***
  • Posts: 245
Re: Full-resolution silent pictures
« Reply #323 on: October 03, 2014, 07:24:01 PM »
Thank you! But I do not know how to compile full branch...
Canon 5D3,1.1.3; Canon EOS M,202,  CF-SanDisk Extreme PRO,160MB/s, 256GB, SD-SanDisk Extreme Pro, 170MB/s, 128GB.

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1186
Re: Full-resolution silent pictures
« Reply #324 on: October 03, 2014, 07:47:52 PM »
e.g.
Code: [Select]
mkdir fullresvst
cd fullresvst
hg clone -r fullres-silent-pics https://bitbucket.org/hudson/magic-lantern
cd magic-lantern
make -j2
cd platform
cd 6D.113 (if you wanna compile for 6D)
make zip

Please also read this:
http://magiclantern.fm/forum/index.php?topic=7579.0

You might have to adjust makefile.user.default if you don't have gcc 4.8.3
70D.112 & 100D.101