Author Topic: Full-resolution silent pictures (silent.mo)  (Read 741750 times)

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1741
  • 6d - Nightly build user
Re: Full-resolution silent pictures
« Reply #175 on: July 31, 2014, 02:47:59 PM »
@NikFreak, Thanks for helping :D

Downloaded the build in the link, but the modules folder only contains one file (6D_113.sym) for the rest it is empty...that's not good is it ?
I expected at least a silentpics module and raw_diag module.

Can you take a look at it ?

Happened before, a build with no modules, audionut said this about it:


@nitfreak, for future reference, run make in the source directory, then browse to the required platform directory (6D.113 in this case), and run make zip.
This will compile the modules and produce a nightly type zip in the platform directory.



nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1197
Re: Full-resolution silent pictures
« Reply #176 on: July 31, 2014, 03:08:05 PM »
Yeah I did it like Audionut instructed. But you are right about missing modules. They don't get added cause of some missing rst2html:

Code: [Select]
Building module silent...
REBUILDING
[ README   ]   module_strings.h
cat README.rst | grep -v -E "^:([^:])+:.+$" | rst2html --no-xml-declaration | python ../html2text.py -b 700



/bin/sh: 1: rst2html: not found

(<type 'exceptions.SystemExit'>, SystemExit(1,), <traceback object at 0x2ad947187368>)
make[4]: *** [module_strings.h] Error 1
70D.112 & 100D.101

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1741
  • 6d - Nightly build user
Re: Full-resolution silent pictures
« Reply #177 on: July 31, 2014, 03:10:13 PM »
Do you know how to solve this ?

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1197
Re: Full-resolution silent pictures
« Reply #178 on: July 31, 2014, 03:13:59 PM »
Done! had to fix my docutils:

Here you go http://www59.zippyshare.com/v/38767089/file.html

Sorry again.
70D.112 & 100D.101

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1741
  • 6d - Nightly build user
Re: Full-resolution silent pictures
« Reply #179 on: July 31, 2014, 03:32:46 PM »
Downloaded your build, it has indeed modules now  :D

RAW_DIAG module is not in it, downloaded RAW_DIAG module from the first page of this thread and put in the module folder.
Unfortunately the RAW_DIAG is not loaded at startup, it says, "OldAPI" instead of "OK",
And displays, "Wrong version, (v5.0, expected v6.0)" 
So at this moment I can't do the test Alex asks for...

Is this message for RAW_DIAG module "Wrong version, (v5.0, expected v6.0)" , something you can fix, Nikfreak ?
Or do we need Alex to ask what's going on (Alex is probably working on a newer RAW_DIAG, V6.0, but it's not yet online ?)


nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1197
Re: Full-resolution silent pictures
« Reply #180 on: July 31, 2014, 03:46:36 PM »
I have really no clue. I compiled "fullres-silent-pics" branch and what's that about v5.0 / 6.0 I don't know cause I didn't try myself. If a1ex tells what to do I will do and we can do the requested test for 6D. Sorry still freshman over here....
Btw that raw_diag module from 1st page is prebuilt. I have no idea where the sources are so that I could increase a version number in source and compile myself

@a1ex: This is what I did: http://magiclantern.fm/forum/index.php?topic=12523.msg124160#msg124160

Where did I wrong? Can you teach plz?
70D.112 & 100D.101

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1741
  • 6d - Nightly build user
Re: Full-resolution silent pictures
« Reply #181 on: July 31, 2014, 03:51:23 PM »
No problem, already glad you could help this far  :D

@A1ex, Can you help us out here ?

The RAW_DIAG module on page one of this thread does not work with currently compiled builds.
The module won't load at startup, OldAPI.
It shows the message "Wrong version, (v5.0, expected v6.0)" 




ayshih

  • Contributor
  • Senior
  • *****
  • Posts: 266
Re: Full-resolution silent pictures
« Reply #182 on: July 31, 2014, 04:26:00 PM »
The version of the module API was bumped up a few days ago (this commit) due to the expectation of bugs resulting from changes in FIO return values.  That's why previously-built modules will no longer run.

You should be able to build a new raw_diag.mo yourselves from the iso-research branch, after first locally merging it with the current unified.  If merging is difficult, you might be able to just copy over the raw_diag source files from that branch to the current unified and build it that way.
Canon EOS 50D | 17–40mm f/4L & 70–300mm f/4.5–5.6 DO IS | Lexar 1066x

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1197
Re: Full-resolution silent pictures
« Reply #183 on: July 31, 2014, 04:41:06 PM »
Thx for your response. Merging gets me headache. i am still uncomfortable with hg mercurial compared to using git / github. I tried copying raw_diag into unified and tried compiling as you suggested but that gave me compile errors. Dunno at least me and Levas tried. Hopefully this is honored and 6D won't be thrown out. Maybe ayshih you can instuct me or upload a raw_diag.mo for us so we can use my built zip from "fullres-silent-pics" branch from today which I compiled for 6D??
70D.112 & 100D.101

ayshih

  • Contributor
  • Senior
  • *****
  • Posts: 266
Re: Full-resolution silent pictures
« Reply #184 on: July 31, 2014, 05:21:23 PM »
Yeah, I'm much better at Git than Mercurial too.

I won't be back at my ML build environment for many many hours, so hopefully someone else can figure out how to get raw_diag.mo to build in the meantime.  If you'd like, you can PM me the compile errors you're getting, but I may not be able to diagnose them from remote.
Canon EOS 50D | 17–40mm f/4L & 70–300mm f/4.5–5.6 DO IS | Lexar 1066x

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Full-resolution silent pictures
« Reply #185 on: July 31, 2014, 05:29:27 PM »
Updated the link, should be OK now.

You can simply compile from iso-research branch and take the .mo file; the branch is up to date.

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1741
  • 6d - Nightly build user
Re: Full-resolution silent pictures
« Reply #186 on: July 31, 2014, 05:51:51 PM »
Thanks, Nikfreak, Ayshih and A1ex!
It works finally  :D

The Cyan box fits perfectly inside the noisy borders (for 6d that is)
.
See "OB-Zones-6d-31Juli2014.png" on my google drive
https://drive.google.com/folderview?id=0B1BxGc3dfMDaazVGRF9JOTF2VzQ&usp=sharing

Although, I don't get the bright noise on the bottom left in the white box, what's that A1ex ?

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Full-resolution silent pictures
« Reply #187 on: July 31, 2014, 05:57:24 PM »
Looks alright. Can you also take a screenshot showing some overexposed raw zebras?

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1741
  • 6d - Nightly build user
Re: Full-resolution silent pictures
« Reply #188 on: July 31, 2014, 06:11:10 PM »
How do I take a Screenshot of the zebra's ?

I Did try to use the "screenshot -10s" option in the Debug menu, but the zebra's don't show up on the screenshot written on the memory card...

The zebra's do show up on my camera LCD screen, but their not visible in the screenshot ?

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1741
  • 6d - Nightly build user
Re: Full-resolution silent pictures
« Reply #189 on: July 31, 2014, 06:26:34 PM »
Wait, problem solved.
Zebra's were on Luma, now they're on RGB and they show up in the screenshot.

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1741
  • 6d - Nightly build user
Re: Full-resolution silent pictures
« Reply #190 on: July 31, 2014, 06:31:23 PM »
For Raw zebra's screenshot from the 6d:
Check my google drive for "Raw-Zebras-6d.png"
https://drive.google.com/folderview?id=0B1BxGc3dfMDaazVGRF9JOTF2VzQ&usp=sharing


Edit, wrong screenshot

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Full-resolution silent pictures
« Reply #191 on: July 31, 2014, 06:32:01 PM »
Zebras must be RAW, not YUV.

Also, they must be in photo mode, not LiveView. Either the silent full-res or the regular photo mode, they are the same.

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1741
  • 6d - Nightly build user
Re: Full-resolution silent pictures
« Reply #192 on: July 31, 2014, 06:44:33 PM »
Took 2 pictures the normal way and with picture review it makes a colored overlay of the overexposed areas.

See "Raw-Zebras-6d.png" and "Raw-Zebras-6d-.png"
https://drive.google.com/folderview?id=0B1BxGc3dfMDaazVGRF9JOTF2VzQ&usp=sharing

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Full-resolution silent pictures
« Reply #193 on: July 31, 2014, 06:48:01 PM »
Alright, it's correct then :D

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1741
  • 6d - Nightly build user
Re: Full-resolution silent pictures
« Reply #194 on: July 31, 2014, 07:01:03 PM »
Whoehoe!

So we're done (for) now  8)

Full-res-silent pics will be introduced in the nightly builds soon and Canon 6d will be in those nightly builds  :D

Thanks everyone who helped

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Full-resolution silent pictures
« Reply #195 on: July 31, 2014, 08:22:25 PM »
Now you're gonna kill me: I've deleted a bunch of code, is it still working?

https://bitbucket.org/hudson/magic-lantern/commits/5925e186ed67

You no longer need to check any offsets; if there are problems with the new method, silent pictures and zebras would be totally broken (easy to notice, unlike the possible problems caused by wrong offsets).

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1197
Re: Full-resolution silent pictures
« Reply #196 on: July 31, 2014, 08:59:02 PM »
Still the skip offsets were worth it plus I learned to correct some mistakes
70D.112 & 100D.101

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1741
  • 6d - Nightly build user
Re: Full-resolution silent pictures
« Reply #197 on: July 31, 2014, 09:04:55 PM »
I've deleted a bunch of code, is it still working?

If it ain't broken, don't fix it! 
  >:(
No kidding  ;D , you probably had a good reason for it, like cleaner code...

Do I have to test some stuff or are you asking Nikfreak to look at the code ?

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1197
Re: Full-resolution silent pictures
« Reply #198 on: July 31, 2014, 09:08:39 PM »
Same game. Fullres-silent-pics branch needs to be compiled and retested. we do this tomorrow ok?
70D.112 & 100D.101

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Full-resolution silent pictures
« Reply #199 on: July 31, 2014, 09:09:15 PM »
Yeah, but this time there's nothing special to test - just see if it works.