Author Topic: switched off Canon 5D2, ML v2.3 keeps battery draining  (Read 4789 times)

hajes

  • Just arrived
  • *
  • Posts: 1
switched off Canon 5D2, ML v2.3 keeps battery draining
« on: June 21, 2014, 09:42:47 AM »
Hi,

first I want to thank you guys for developing this piece of SW.

About a month ago I've installed latest ML v2.3 on my Canon 5D2 for some testing since I was disappointed by internal mic (what a surprise ;-).

All works well except one minor and major bug, which will most likely ends the testing and uninstall of ML.

1. when ML is on and I shoot just pictures, which is main reason I use my camera. Zoom function in PLAY mode doesn't work properly. Lets say I shot a picture and I want to evaluate my picture. If I zoom in/out it goes haywire. It starts to zoom itself in/out. Not big deal. I learn to switch off ML during the photo session.

2. Major problem for me, which cost me already few missing pictures is battery depletion even when my camera is off. I came from a photo session and I had 3/4 of battery capacity. One week later...battery dead. even two days later. Just to avoid confusion and arguments about broken batteries. No, I have one new battery and two with 80% health and before they last a month without using the camera.

My question is. Does anyone has this issue, please?

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: switched off Canon 5D2, ML v2.3 keeps battery draining
« Reply #1 on: June 21, 2014, 10:20:30 AM »
2. Do not remove the card before the final LED blink.

(it's printed in bold in the install guide, and answered many times on the forum)

1. see the user guide.

dcw1979

  • New to the forum
  • *
  • Posts: 39
Re: switched off Canon 5D2, ML v2.3 keeps battery draining
« Reply #2 on: June 25, 2014, 11:01:31 AM »
I have the same problem. Even without taking out the card. Ive just been taking out the battery when Im not using the camera.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: switched off Canon 5D2, ML v2.3 keeps battery draining
« Reply #3 on: June 25, 2014, 01:01:58 PM »
Can you isolate the setting that's causing the battery drain?

I always keep the battery inside the camera, and had no problems yet (except for the documented issue - removing the card too fast).

SpcCb

  • Member
  • ***
  • Posts: 207
Re: switched off Canon 5D2, ML v2.3 keeps battery draining
« Reply #4 on: June 25, 2014, 04:07:01 PM »
Seems to be an old issue, I reported it last year: -> http://www.magiclantern.fm/forum/index.php?topic=4791.msg28383#msg28383

In fact, even when the camera is on 'off' some electronics are still active; you can make the test by removing/attaching an EF lens -> the red LED will blink.
So maybe _in certain conditions even with waiting the 'shutdown' red LED blinking_ ML drains the battery on 'off' position.
Note: I even had this issue without removing the CF card, just by switch off the camera after use it.

For people who have this issue: do you use the 'standard' ML v2.3 or a nightly build?

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: switched off Canon 5D2, ML v2.3 keeps battery draining
« Reply #5 on: June 25, 2014, 04:17:51 PM »
The LED blinking is just Canon bootloader waking up.

Explained here: http://magiclantern.fm/forum/index.php?topic=1455.msg3943#msg3943