Author Topic: Cannot get SD cards over 8gb to work with Canon Rebel T3I. HELP!  (Read 15847 times)

BunkyJack

  • New to the forum
  • *
  • Posts: 12
I've scoured the internet and keep finding answers CLOSE to what I need, but not quite.

Here's my equipment: Toshiba Satellite Laptop with Windows 7 Home Premium (works like a charm)
Various different brands of 32gb and 64gb SD cards (Lexar, Samsung, etc.)
And most importantly, I have a brand new Canon Rebel T3I.

I've already had instant success installing and loading ML onto a 2gb card into my Canon T3i, and... BAM! Magic Lantern boots fine when I put the card in! Great options, even an intervalometer and tons of other things! But I can't save diddly squat of video on a 2, 4, or 8gb card.  :-\  So......

My problem: I'm properly installing ML, including the autoexec bin file, etc. to my 32 and 64gb SD cards. I put the SD card in the camera, turn it on, and... NOTHING. I push the trashcan button till the sun goes down, but NO Magic Lantern. I can, however, easily hit MENU and make use of the pre-installed Canon options. My T3i does recognize the SD card, and I can take pics, video, to save on the card, etc. BUT... it does not, will not, cannot seem to boot or load ML from any SD card over 8 gigs in size. I have tried BootCF which doesn't work on my computer, by the way, and I have tried the EOS Boot Loader, which doesn't help it work either. I have also tried to re-update my Canon Rebel T3i firmware from it's stock 1.0.2 to (you've guessed it) 1.0.2. I've done this just for good measure when all else failed (re-installed firmware update 1.0.2). Camera works fine, but my Rebel T3i WILL NOT RECOGNIZE ML unless I use an 8gb or smaller SD card. What is the problem here??? I'm formatting within the camera, copying files to the SD card from my computer -- in effect, every single thing I did to make the 2gb 4gb, and 8gb cards work, but when I put the card into the camera, the cute little trash can mocks me by not loading the ML menu. Anyone think they have an answer for this conundrum? Help would be truly appreciated.  ::)

nachordez

  • New to the forum
  • *
  • Posts: 31
  • EOS 600D
Re: Cannot get SD cards over 8gb to work with Canon Rebel T3I. HELP!
« Reply #1 on: May 20, 2014, 08:06:30 AM »
Are you doing then bootable through EOS utility? It's clearly explained in manual that this has to be done on each card you use...
EOS 600D  /  OpenSuse 13.1

BunkyJack

  • New to the forum
  • *
  • Posts: 12
Re: Cannot get SD cards over 8gb to work with Canon Rebel T3I. HELP!
« Reply #2 on: May 21, 2014, 11:38:00 PM »
I'm formatting all cards in the T3i with the low level format option, then I'm trying two different options: 1. Removing the card from the camera, inserting it to my PC, then copying all ML files onto the card. 2. I've used the EOS utility for cards, too. I've tried both methods. I even tried a 16gb SDHC class 10 card, but ML doesn't does boot at all when I press the trashcan button the the camera. But the card is able to record video and takes pictures, no problem.

Is there a different utility besides the EOS utility that works? For some reason, I'm having a HELL of a time getting ML to boot on anything over an 8gb card. And as you know, not much video is gonna fit on small SD cards.

Thanks in advance for the reply.

nachordez

  • New to the forum
  • *
  • Posts: 31
  • EOS 600D
Re: Cannot get SD cards over 8gb to work with Canon Rebel T3I. HELP!
« Reply #3 on: May 22, 2014, 12:42:51 AM »
It's strange, I can use all size cards, in FAT, or exFAT, with no problem.

If I don't mistake, your option 1 is not enough. The card has to be made bootable through EOS utility. Or (if not in exFAT), do again the software update (with the ML file, of course), and sdcard will be made bootable automatically.

Not if exFAT, cause software update does not work from exFAT cards.

For me worked so always...
EOS 600D  /  OpenSuse 13.1

kihlbahkt

  • Member
  • ***
  • Posts: 176
Re: Cannot get SD cards over 8gb to work with Canon Rebel T3I. HELP!
« Reply #4 on: May 22, 2014, 01:06:24 AM »
I recommend that you start over from scratch following each step in the install guide. It does work for the card sizes you mentioned. Weird issue but you will likely fix it by starting from scratch. Re-update firmware and reset cam settings too.
600D x2

BunkyJack

  • New to the forum
  • *
  • Posts: 12
Re: Cannot get SD cards over 8gb to work with Canon Rebel T3I. HELP!
« Reply #5 on: May 22, 2014, 01:06:44 AM »
I'll try that. So, using exFAT can cause problems? I read that exFAT is the file system format for Canon Rebel T3i. But I will try to make a different file format such as NTFS. I cannot seem to figure out why I can't get my cards to work if they are over 8gb SD cards. It's like my ML does not want to work with Class 10 SDHC cards. I'm so confused...  :-\

BunkyJack

  • New to the forum
  • *
  • Posts: 12
Re: Cannot get SD cards over 8gb to work with Canon Rebel T3I. HELP!
« Reply #6 on: May 22, 2014, 01:11:23 AM »
I'll have to try that, because no cards over 8gb work. What's funny is that even my little old 2gb SD card boots ML like a charm. No problem. I think I'll try to install the firmware with a 32gb Class 10 Samsung SD card and see what happens. Sadly, I'll have to reset everything later. I had all the settings I wanted, and in perfect order, but that's for Canon firmware 1.0.2 though.

I'll reset the cameras settings back to default, re-install the Canon 1.0.2 Canon Rebel T3i firmware, then insert and format a 32gb SD card with the camera. After that, I'll use the EOS utility to try and make the 32gb SD card ML bootable. Sound about right?

nachordez

  • New to the forum
  • *
  • Posts: 31
  • EOS 600D
Re: Cannot get SD cards over 8gb to work with Canon Rebel T3I. HELP!
« Reply #7 on: May 22, 2014, 08:58:07 AM »
No problem with exFAT! More than that, is the only option to manage files over 4 GB if you use options for that... Just, you can't do the firmware upgrade (and so, the first ML install in your camera) from an exFAT-formatted card, must be FAT (and so, 32 GB or smaller), if not camera will not find the firmware upgrade. After that, you can use exFAT cards without problem (I always use exFAT with no problem att all).

When I told before EOSutility, I meant EOScard you'll find in http://www.magiclantern.fm/install.html, my fault....

Re-read install procedure, and go through it carefully, as you've been told.

I'll remember you all you have to do, but, even so, please, read instructions http://www.magiclantern.fm/install.html again to double check. I'm talking from memory...

1. Format your first card, low level in camera, and choose to eliminate ML (if you've not doing so yet) to return stock your camera (really, just to erase ML files from card, an erase the booting from sd flag from camera.

(1a. If you want to be even more sure, download and copy on card the original 600D 1.0.2 firmware from http://www.magiclantern.fm/install.html, and do firmware update on your camera. But not needed at all)

2. Format low level in camera your other cards intended to use with ML. (If you want any of them in exFAT, for sure for an 64 GB card, but can be alsosmaller, you'll have to do formatting in computer, usual way, choosing exFAT)

3.- Copy the files from the official stable 2.3 ML release into a FAT formatted card, specially including the EOS 600D firmware update file. If you want to use a more recent beta build (as I do), then, download it and overwrite the corresponding file/folders in you SD.

4.- Insert card, choose M mode, do restore default settings on your camera, and do firmware upgrade from Canon menu. You've yet enabled boot from sd in your camera, and this card is done bootable, so, you can use ML with it.

5.- For other cards:

      5a.- If they are in FAT (and 32 GB as maximum) you can just go through 3. an 4. again. Cards will be ready when firmware upgraded (even if it was yet upgraded)

     5b.- For any card (but compulsory for exFAT ones, or SDXC ones). Download EOScard (or the options for other OS... but the linux one didn't worked for me) from link in http://www.magiclantern.fm/install.html, and mark, as shown there, the card as bootable (check image there), and save changes. Copy ML files (autoexec.bin and ML folder) into the card (if using a new beta release, I'm nor sure if they are complete... I alwas copy at first files from the official 2.3, and then overwrite with the beta ones). Should be working.

All clearly stated in http://www.magiclantern.fm/install.html
EOS 600D  /  OpenSuse 13.1

BunkyJack

  • New to the forum
  • *
  • Posts: 12
Re: Cannot get SD cards over 8gb to work with Canon Rebel T3I. HELP!
« Reply #8 on: May 22, 2014, 10:14:26 PM »
Thank you so much, nachordez!  :) I've got my 32gb card working! But I'm still trying to figure out why my 64gb SD cards are still not working. My 16gb is not working either. I did the firmware update of ML with my 32gb card and now I can use it just fine. What I'm wondering, though, is why the EOS Utility won't allow me to try and change my 16gb from FAT32 to exFAT. I was thinking that my camera only wants exFAT because I installed the firmware with an exFAT 32gb SD card.  When I'm installing ML on different file system types like 16gb SD card with FAT32, ML is not working with those cards. I'm not sure, but I'm glad I can at least use a 32gb card now instead of the small storage 2, 4, or 8gb cards.

I see nothing on the instructions regarding this, but after installing with either FAT, FAT32, or exFAT, do I need to stay with that same format on all cards? For example, if I install ML with a FAT32 SD card, do I have to use all FAT32 SD cards in order to use ML? Is that what the issue is?  :-\

nachordez

  • New to the forum
  • *
  • Posts: 31
  • EOS 600D
Re: Cannot get SD cards over 8gb to work with Canon Rebel T3I. HELP!
« Reply #9 on: May 23, 2014, 12:31:58 AM »
Can't say much more than I did, I'm not dev... I use small cards with FAT and 64 GB with exFAT, changing whenever I want,  without problems...

Perhaps you can just try to format exFAT your 64 GB card in computer (not in camera). A proper formatting, not a fast one. Then make it bootable with EOScard (not EOSutility, that was my fault), copy files, and see if it boots ML.

Can't give more help, perhaps @A1ex can...
EOS 600D  /  OpenSuse 13.1

BunkyJack

  • New to the forum
  • *
  • Posts: 12
Re: Cannot get SD cards over 8gb to work with Canon Rebel T3I. HELP!
« Reply #10 on: May 23, 2014, 07:01:09 PM »
I've now got them all working! :) Here's what I did:

1. Quick format of SD card on my laptop first.
2. Another format (low level) on the SD card with my Canon T3i.
3. Then I placed the SD card back in my laptop and ran EOSCard.
4. I changed the allocation size option to "Default." (Note: it says nothing about what allocation size to use in the ML EOSCard instructions).
5. I ticked the top two boxes (leaving "Script" unchecked).
6. Clicked "Save."
7. Placed each card into the camera, testing each for ML. All worked great.

This is what I was doing before, but the difference is that the EOSCARD
auto-selects an allocation size in the drop-down menu. I had to change each card's allocation size to "Default" before it would make the cards bootable. Weird, huh? I would think that would make no difference, but it did for me. Crazy stuff.

Thank you, thank you, thank you for the help! Problem solved.

dmilligan

  • Developer
  • Hero Member
  • *****
  • Posts: 3218
  • 60Da / 1100D / EOSM
Re: Cannot get SD cards over 8gb to work with Canon Rebel T3I. HELP!
« Reply #11 on: May 23, 2014, 07:23:04 PM »
It is not called "EOS Utility". Please don't call it that, b/c that may confuse others. "EOS Utility" is the name of Canon's official software for downloading images and tethering to the camera. The program you're using is called "EOSCard". There is a huge difference.

BunkyJack

  • New to the forum
  • *
  • Posts: 12
Re: Cannot get SD cards over 8gb to work with Canon Rebel T3I. HELP!
« Reply #12 on: May 23, 2014, 11:29:35 PM »
Thanks for catching that! I didn't notice I was calling it EOS Utility. You're correct, it's the EOS Card utility by Pelican. EOS Utility is Canon's proprietary software. EOS Card is the one everyone should be using to create auto-boot SD cards with ML.

nachordez

  • New to the forum
  • *
  • Posts: 31
  • EOS 600D
Re: Cannot get SD cards over 8gb to work with Canon Rebel T3I. HELP!
« Reply #13 on: May 24, 2014, 12:52:55 AM »
I'm happy you solved it!
EOS 600D  /  OpenSuse 13.1