Author Topic: Canon 5D Mark II / 5D2  (Read 730558 times)

LJR

  • New to the forum
  • *
  • Posts: 4
Re: Canon 5D Mark II / 5D2
« Reply #425 on: May 16, 2015, 04:29:00 PM »
Hello.

Magic Lantern for 5DMii 2.1.2 not available for download - error message This Build Failed.

First time user, can anyone assist me please?

Thanks.

Erik Krause

  • Freshman
  • **
  • Posts: 59
Re: Canon 5D Mark II / 5D2
« Reply #426 on: May 18, 2015, 10:27:25 PM »
On https://builds.magiclantern.fm/#/ after choosing the correct camera click on "Show Older Builds" and choose the next one.

bci123

  • Just arrived
  • *
  • Posts: 1
Re: Canon 5D Mark II / 5D2
« Reply #427 on: May 27, 2015, 05:10:24 PM »
Guys, where can I find out what is the latest STABLE build for 5D MK II and where do I download it?  When I click downloads all I can find is nightly releases.  I don't want nightly releases, I want the latest most stable most recommended version?


Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8046
Re: Canon 5D Mark II / 5D2
« Reply #428 on: May 27, 2015, 05:23:02 PM »
Old stable version is not recommended by devs anymore.
So make up your mind about what you want because you contradict yourself.

jpk

  • New to the forum
  • *
  • Posts: 3
Re: Canon 5D Mark II / 5D2
« Reply #429 on: May 30, 2015, 10:10:24 PM »
I have activated ML on my 5D2. I can only access the ML program and menus when I have the card with ML firmware card in the camera. Once I remove it I lose all ML info. How do I retain ML in my 5D2 in order to use it? OR.....do I have to have ML on every CF I will be shooting with to utilize it while shooting? Thanks.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8046
Re: Canon 5D Mark II / 5D2
« Reply #430 on: May 30, 2015, 10:19:29 PM »
FAQ, Installation Guide, User Guide.

jpk

  • New to the forum
  • *
  • Posts: 3
Re: Canon 5D Mark II / 5D2
« Reply #431 on: May 31, 2015, 03:15:13 AM »
Gotcha...

Chimping

  • New to the forum
  • *
  • Posts: 5
Re: Canon 5D Mark II / 5D2
« Reply #432 on: June 03, 2015, 03:37:02 PM »

Guys, where can I find out what is the latest STABLE build for 5D MK II and where do I download it?  When I click downloads all I can find is nightly releases.  I don't want nightly releases, I want the latest most stable most recommended version?

This is the same question I have. Although the above author may not have made his question perfectly clear, it is my understanding the nightly releases are still betas with new tweaks on an ongoing basis. What I think both he and I are looking for is any release, nightly,  or any other that is confirmed to be the most recent and fully tested and stable release for the MK2.

What I want to avoid is installing a release that hasn't been fully stable and tested and I believe some of the nightly releases may not be fully stable until some time has gone by to test them.

So how can one choose a release and know if it is fully stable or not?

Can one simply choose a nightly release that is previous to the most recent release and assume that any older release is stable? Or is there another methodology for selecting the most recent stable release?

Cheers...

Frank7D

  • Senior
  • ****
  • Posts: 456
Re: Canon 5D Mark II / 5D2
« Reply #433 on: June 03, 2015, 04:41:13 PM »
Chimping,

The nightlies are generally considered here to be the preferred builds. As with any new software, there may be surprises. There is no designated QA crew; that would be you and I and whoever else. You can look for bugs people are reporting. My recommendation would be to download a nightly and test it thoroughly. You know better than anyone else what your requirements are.

Chimping

  • New to the forum
  • *
  • Posts: 5
Re: Canon 5D Mark II / 5D2
« Reply #434 on: June 04, 2015, 09:03:22 PM »
Thank you Frank. I had actually downloaded a nightly a few weeks ago and I am running the 2015 May 03 nightly. I have not discovered any problems with it as far as I am aware and it seems stable to me. But the issue is if there was a bug I might not even recognize it since I am completely new to ML. So I would not make a good beta tester for QA assurance purposes. So that is why I was hoping for an experienced and advanced MKII user to say which one they know to be quite stable. That would be perhaps more helpful than downloading a build and trying to guess if it is working correctly or not since I don't have a point of measure or reference to say whether the build is good or not at this point.

Also, going from memory it seems there were some overlays for sound levels and histogram that I think were present when I first started using it, but they don't appear to be present now any longer. Again, I am not experienced to really say what's happening. It is likely an operator error on my part and not an error with the build. But I tried resetting everything back to original ML settings and I still can't seem to bring back the original overlays I recall seeing when I first installed. Perhaps they weren't the standard overlays I saw which  I had inadvertently enabled at one point and then perhaps removed again them without realizing it and that's why I think they have gone missing.

In this case is there also perhaps a detailed ML setup or configuration guide somewhere for the MKII which includes screenshots by any chance?

I watched a good video on Vimeo by a young film maker named David Kong, but he was shooting with a different Canon body (the 550 I think) so I assume his overlays are going to be different and perhaps camera specific.

Cheers...

Chimping

  • New to the forum
  • *
  • Posts: 5
Re: Canon 5D Mark II / 5D2
« Reply #435 on: June 04, 2015, 09:27:40 PM »
Regarding the overlays, I figured out the issue. I had pressed the info button which reduced the overlays to nearly nothing in live view mode. Now that I pressed the info button again all the overlays are back for histogram, sound levels, etc.


simon.pl

  • New to the forum
  • *
  • Posts: 2
Re: Canon 5D Mark II / 5D2
« Reply #436 on: June 06, 2015, 03:37:43 PM »
Hi All
New to the forum although been using ML for some time. Mostly for TimeLapse work. Thanks for awesome work.

Just installed the magiclantern-Nightly.2015Apr28.5D2212 - wanted to check the settings in Deflicker module and can't find XMP to choose. Just UFRaw. As I work with LR I need XMP. Any idea? Is it a bug or just something went wrong during installation?  :o

Cheers  ;)

simon.pl

  • New to the forum
  • *
  • Posts: 2
Re: Canon 5D Mark II / 5D2
« Reply #437 on: June 07, 2015, 01:34:27 PM »
Downloaded and reinstalled again. Everything works.  :)

dckiteboards

  • Just arrived
  • *
  • Posts: 1
Re: Canon 5D Mark II / 5D2
« Reply #438 on: June 09, 2015, 11:18:26 PM »
new to magic lantern and installation went great yesterday and today I went to use it with the new 1000x card and ML was gone from the computer so I did a reinstall and now I cant seem to activate the RAW function. I followed the exact directions on this forum and when i go into modules and click ok will load, and then i reboot , it still says ok will load?

Thanks
C

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8046
Re: Canon 5D Mark II / 5D2
« Reply #439 on: June 09, 2015, 11:51:51 PM »
This will happen if you're not giving ML enough time to shut down properly.
Shut down, wait for 5 seconds.
Power on cam.
Status?

pixelriffic

  • Just arrived
  • *
  • Posts: 1
Re: Canon 5D Mark II / 5D2
« Reply #440 on: June 10, 2015, 05:51:02 PM »
Hi all,

I own a 5D2 and a EOS-M.  The EOS-M ML firmware allows recording in crop mode but with standard recording.  It looks great in crop mode, and is an easy way to extend the effective length of the lens. 

I know the current 5DII supports 3X crop in raw, but is there any way to get it to work in standard H.264 mode? 

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Canon 5D Mark II / 5D2
« Reply #441 on: June 10, 2015, 07:27:55 PM »
Currently no, but there are some promising findings here: http://www.magiclantern.fm/forum/index.php?topic=10111.msg145036#msg145036

It's likely to be similar to 500D.

ae2

  • New to the forum
  • *
  • Posts: 4
Re: Canon 5D Mark II / 5D2
« Reply #442 on: June 17, 2015, 09:07:38 PM »
I am trying to install the newest NB on my 5D2 following the instructions, accurately. After preparing the card with the ML files I press the install new firmware version button as required. Then, the install new firmware message appears very shortly and the red LED blinks quickly for around 3 seconds and the process hangs up indefinitely. Complete black out. The camera is not responsive. Removing the battery the camera boots up normally and the Canon 2.1.2 seems untouched. Any idea what can be the problem?

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8046
Re: Canon 5D Mark II / 5D2
« Reply #443 on: June 17, 2015, 09:09:32 PM »
Top of page -> User Guide -> Install Guide

ae2

  • New to the forum
  • *
  • Posts: 4
Re: Canon 5D Mark II / 5D2
« Reply #444 on: June 17, 2015, 09:46:35 PM »
Thank you, I read the guide thoroughly and made everything recommended. No result, ML does not want to boot in my camera. Lost my hope.

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8046
Re: Canon 5D Mark II / 5D2
« Reply #445 on: June 17, 2015, 09:52:02 PM »
Everything included installing Canon's firmware v2.1.2 downloaded using given link?

ae2

  • New to the forum
  • *
  • Posts: 4
Re: Canon 5D Mark II / 5D2
« Reply #446 on: June 18, 2015, 12:10:38 AM »
Yes, I reinstalled the native 2.1.2 again for sure (fresh download). The camera and the installation process behave quite probabilistically. Sometimes the whole firmware installation hangs up (with red LED on) before the sensor cleaning in the boot process could start and the camera becomes unresponsive, only battery reset helps. Sometimes the ML installation process seems to finish normally, red LED is off and the sensor cleaning cycle starts ... then nada. In this case the camera is responsive, and when I bring up the Canon menu it says that current firmware is "2.1.2-ml". The ML menu, however, cannot be actuated by the trash button. When resetting (off-on cycle) the firmware reverts to the original 2.1.2. No idea.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Canon 5D Mark II / 5D2
« Reply #447 on: June 18, 2015, 07:24:06 AM »
Can you try the new installer from here? (replace the FIR)
https://bitbucket.org/hudson/magic-lantern/pull-request/631/new-installers

If it still doesn't work, can you record a video of the install process?

ae2

  • New to the forum
  • *
  • Posts: 4
Re: Canon 5D Mark II / 5D2
« Reply #448 on: June 18, 2015, 10:28:58 AM »
Thank you guys. I will document the case on video, however, I have a planned tour for the next week (I was happy to try ML in the first time, I am a HDR shooter). When I come back I will allocate more time for the resolution. In the meantime I will be stuck with the hated 3 frames bracketing. Shame yourself Canon.
THX for your help.

Chimping

  • New to the forum
  • *
  • Posts: 5
Re: Canon 5D Mark II / 5D2
« Reply #449 on: June 22, 2015, 05:13:45 AM »
^ Have you tried using it with another CF card? Perhaps there is an issue with the CF card you are using.