Author Topic: Playback Dual ISO Images  (Read 3193 times)

brapodam

  • Member
  • ***
  • Posts: 121
Playback Dual ISO Images
« on: January 23, 2014, 11:59:46 AM »
Hi,

I'm not sure if this is a bug or if it's caused by a certain setting, but whenever I view a dual ISO image in playback mode, the image is just a blurry mess. It goes back to normal if I zoom in, but at the normal playback size, the image will first appear normal for about half a second (apart from the bars of alternate ISOs), then become a blurry mess (a small black box with containing either "dark" or "bright" shows up as well, and I assume it's showing which parts would be used from the dark and bright areas respectively - or something like that). Sometimes I am able to see the dual ISO images normally (without the blurring effect), but I cannot reproduce that outcome.

How do I view the dual ISO images "normally"? I don't mind having the bars of alternate ISOs, but having the blurry images makes previewing the images almost useless. Since I do see the non-blurry preview for half a second + the image isn't blurry if I zoom in, there has to be a way that the preview can stay non-blurry, right?

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Playback Dual ISO Images
« Reply #1 on: January 23, 2014, 12:14:33 PM »
I found it helpful to dial picture style sharpness down to 0.

At some zoom levels, the downsampling factor hits the sweet spot and you can get a fairly good image (so just try them all).

brapodam

  • Member
  • ***
  • Posts: 121
Re: Playback Dual ISO Images
« Reply #2 on: January 23, 2014, 12:18:53 PM »
My picture style sharpness is already 0 though.

As I said before, the issue is not there when I zoom in (or out, for that matter). But at the default image preview/playback size (fullscreen image), the image will display perfectly for about half a second before becoming blurry. That happens when the box at the top left corner of the screen pops out, showing either "dark" or "bright"

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Playback Dual ISO Images
« Reply #3 on: January 23, 2014, 12:24:25 PM »
It means the heuristic in dual_iso.c (isoless_playback_fix) is broken (you can delete it and see if it improves anything, or think at something more robust).

engardeknave

  • Senior
  • ****
  • Posts: 339
Re: Playback Dual ISO Images
« Reply #4 on: January 23, 2014, 12:27:11 PM »
nm

brapodam

  • Member
  • ***
  • Posts: 121
Re: Playback Dual ISO Images
« Reply #5 on: January 23, 2014, 04:00:30 PM »
I'll just wait till it gets fixed in the official nightlies; I'm a bit lazy to go and compile myself now. Unless dual_iso.c is supposed to be found on my camera, in which case I don't have it.

I'm more interested in keeping up with the developments with the current investigation on ISO, even though I don't understand most of the technical parts of it.

Marsu42

  • Contributor
  • Hero Member
  • *****
  • Posts: 1557
  • 66d + flashes
Re: Playback Dual ISO Images
« Reply #6 on: January 23, 2014, 04:04:27 PM »