Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - clanlee

Pages: [1]
Thank you to the developers for all their great work on this application.

Would it be possible to see more than just one of Histogram, Waveform, Vector scope and Parade?  Would it be possible to adjust the size to make it larger?

Thank you.

I experienced the same issue but then used the mlvfs.exe located here:

Along with the latest Dokan, I have no problem opening raw video files.  Do not use the x64 exe.

I figured out the problem with the web gui not working.  I looked thru a bunch of post and saw this one:

Don't know about resolve issue but for correctly display settings web page you absolutly have to change dir (cd) to MLVFS folder when running it from the command line. Otherwise mlvfs can not find needed files to display page corectly. Also it can not find focus pixel maps.

I'll leave the post of just in case someone else needs the information.  You must change directory to the mlvfs.exe or mlvfs_x64.exe directory to get the web gui working.

---Original post starts here---

I realized that my setup works great and I can access the dng files via windows explorer but the web interface isn't working. 

Code: [Select]
C:\mlvfs_x64\mlvfs_x64.exe Z:\ --mlv-dir=C:\Videos\Files

I wasn't getting any error messages or able to stop the drive.  Instead, I added -f and I was able to get error messages and by pressing CTRL + C, it would umount the drive:
Code: [Select]
C:\mlvfs_x64\mlvfs_x64.exe -f Z:\ --mlv-dir=C:\Videos\Files

I'm getting the following message when attempting to access the web gui (localhost:8000):
Code: [Select]
webgui: scanning C:\Videos\Files/...
load_resource: fopen error
webgui: scanning C:\Videos\Files/favicon.ico...
load_resource: fopen error

Any thoughts as to why web gui stopped working?

Yes, it needs to be in the sd.img or cf.img depending on which (virtual) camera you are using. I had some problems on the EOSM and it turned out there was a problem with the SFDATA.BIN file I was using.

Did you follow these instructions?

If you have a problem with the user guide or suggestions, a1ex is looking for feedback -- post it on the How to run Magic Lantern into QEMU?!... topic.

Yes, I was following those instructions but as a linux newbie, I ran into a road block when trying to mount the sd.img file.  I'm trying to setup the environment for the 5D3.123.  I wasn't sure where to post the question since this is specific to the Windows 10 running Ubuntu so I thought this might be a good place.

This is where I ran into the problem.  According to the instructions:
mount the card image (sd.img or cf.img) as /whatever/EOS_DIGITAL, then run make install from your platform directory:

# from the magic-lantern directory
cd platform/60D.111
make clean; make
# make sure your virtual card is mounted (this step is operating system specific)
make install
# make sure your virtual card is no longer mounted

I ran make clean; make command in the platform/5D3.123 folder.

When I attempted to mount the sd.img file, it's failing due to my lack of knowledge in linux commands.  I tried the following command:
sudo mount -t ~/qemu-eos/sd.img ~/magic-lantern/platform/5D3.123/EOS_DIGITAL -o loop

But received a message that it can't find the path in /etc/fstab.  When I listed the contents of fstab, it's nothing like the suggestions I found when searching for answer.  It's probably due to the fact that it's a virtual environment in Windows. Any help would be appreciated.

I need some assistance.  I followed the instructions and got to the point where I can call up the QEMU window but I can't do anything from there.  It looks like Magic Lantern is not loaded so I have nothing but the QEMU window.  I tried pressing M for menu and all other combinations of buttons but nothing happens.

How do I load Magic Lantern within the Ubuntu environment?  Do I have to copy the contents of the nightly build somewhere?  Thank you.

I've run test with 15-45 seconds of RAW video clips.  With those small clips, MLVFS and Dokan ( does not seem to have delay.

Which version are you running that allows large files to mount immediately?

Part of the reason that I posted instructions was to help write updated information.  This is the first one that I was successfully able to figure out.

MLVFS Installation on Windows 10 x64

Install latest version of Dokany:

Reboot if necessary.


Delete the following files from the extracted folder:

Using MLVFS:
Note the path of the extracted MLVFS_x64.exe
Open Command Prompt

Run program from within directory into the executable:
The web gui interface only works if you call the executable from the same directory
cd mlvfs_x64
mlvfs_x64.exe Z:\ --mlv-dir=C:\Videos\Files

Run from any location by typing full path to executable:
If you run this from a remote directory, the web gui will not work
C:\mlvfs_x64\mlvfs_x64.exe Z:\ --mlv-dir=C:\Videos\Files

If your folder name contains spaces, use quotation marks for path:
"C:\Extracted files\mlvfs_x64\mlvfs_x64.exe" Z:\ --mlv-dir="C:\Videos from Camera\Files"

C:\mlvfs_x64\mlvfs_x64.exe Z:\ --mlv-dir="C:\Videos from Camera\Files"

"C:\Extracted files\mlvfs_x64\mlvfs_x64.exe" Z:\ --mlv-dir=C:\Videos\Files

The Z:\ option is setting a mount point.  You'll have to use an unused drive letter in your computer.  When you open Windows Explorer, you'll see a list of all the drives in your computer.  Use a drive letter that is not used.

@Canon eos m:

please uninstall dokan from your control panel
install dokan v1.0.0-rc1
unpack mlvfs_x64 into your folder f:\mlvfs_x64\
open a commandline
Code: [Select]
cd \mlvfs_x64
mlvfs_x64.exe Z:\ --mlv-dir=F:\

did you do a chmod +x FILENAME ?

Camera-specific Development / Re: Canon 5D Mark II / 5D2
« on: March 27, 2018, 09:13:10 PM »
I think I just have a bad 5D2 copy, at least for video.  Photo is great but the very few times I've tried video in the past, aliasing was very bad.  This was when I tried shooting video on the Canon firmware, without Magic Lantern. 

Camera-specific Development / Re: Canon 5D Mark II / 5D2
« on: March 24, 2018, 06:07:26 PM »

I'm using the Cinestyle profile with Sharpness set at 0, Contrast at -4 and Saturation and Color Tone set to 0.  I also tried the Flaat and Neutral and got similar results in regards to aliasing.

Here's the footage with the Prolost Flat profile shot at 35mm @ f/2.8:

I tried shooting crop mode in H.264 and it looked worse than the non cropped mode.  Just to be sure I did it correct, I pressed the zoom button once (5x) and started recording.  Sound wasn't recorded and when I pulled the video, aliasing was worse than non cropped mode.  The VAF filter is an option if I could find one used.  I would love to continue using my 5D2 but based on my test, I don't think I want to.  A software solution would be ideal.

If I can't get this working, I might try to get a used 5D3.

Camera-specific Development / Re: Canon 5D Mark II / 5D2
« on: March 24, 2018, 06:16:00 AM »
Hello.  Long time lurker, first time poster.

First, thank you to everyone for the amazing work that's been done on Magic Lantern.  It's breathing new life into older hardware.

I'm using Magic Lantern (latest nightly build) on my EOS M for non RAW video and it's amazing.  I'm not looking to use RAW anytime soon due to various reasons and am happy with H.264.  The only issue I have with the EOS M is poor ISO performance so I was looking to use my 5D2.  I installed the latest nightly build and everything seems to be working correctly.  The only issue I am running into is the Aliasing on the 5D2.  Compared to the EOS M, it's terrible.  Here's a comparison video shot at f/2.8:

I also shot video at f/8.0 and it's a similar result.

When I shoot RAW on the 5D2, it's amazing but I can't use it due to the crop and file size.  Do I have any hope with my 5D2?

Thank you.

Pages: [1]