Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - John Kesl

Pages: 1 2 [3] 4
51
Raw Video / Re: Canon 7D RAW Video News.
« on: August 05, 2013, 07:10:32 PM »
funny, i just bought a refurb 7d because i believe very much in the ML team of developers. I was gonna get a 50d instead, but the potential of the 7d is just too tempting, and formidable.

52
Raw Video / Re: 60D RAW video - it's working !!!
« on: August 05, 2013, 07:05:37 PM »
Hi,
About the pink frame phenomenon that I was experiencing. What I did is, I took a fresh copy of ML2.3 Unified Stable release. added Next ML from nanomod but I keep original PDFs and all. then I add update 11. I do this on a fresh 3x format card. 1x in camera remove ML. then format in disk utility to mac os extended, then put it back in the camera and format low level once more. Then I put the new ML files. I am not getting any pink frames. I am shooting 12 fps exact, 1600@ 2.35:1. Camera is 60D , nikon lens, Extreme pro 95Mb/s card, S2 jpeg. 1920x1080 24fps is camera settings. @ 400 iso and 800 iso. I roll for 1.4gb. Before I wold get pink frame within 40 frames and then every 100 or so. Now I don't see it. So, try, make a new card with the ML 2.3, Next 60D and Update 11. remember to remove ML and reinstall with the new fresh stuff on your card. ( I know I am lazy and I wasn't updating NEXT and NIghtly 60d or Updates from the front of the post, probably loose bits messing around on a fragmented card, remember, copying your files from drive to drive is the same as defrag.)

Marekk mluvite cesky? Ste cech? ja taky.

53
Raw Video / Re: 60D RAW video - it's working !!!
« on: August 04, 2013, 11:34:08 AM »
I've been doing some tests and such regarding the random corrupt frames with pink errors. I don't know if anyone else is experiencing the phenomenon but, what I've discovered is that the june 27, nightly build doesn't have this behavior. I've been keeping a pretty consistent catalog of raw nightly builds for 60d for the last 2 months or so and have noticed these corrupt frames come up every now and again in previous builds and not at all in others. In the latest builds, including update 11 and nightly builds of late the pink frames are pretty persistent. In the june 27 nightly build. 
https://www.dropbox.com/sh/1kitzbmanifb6sf/Tr-k0D5_Oq/ML-RAW-60D-hourly_2013-06-27_18-30.zip doesn't exhibit the phenomena.
I am no programmer nor do I know anything but to follow directions and do research when it comes to this stuff. But, If someone can take this info and do what you do to determine what's changed. As for the hot pixels, if you use Lightroom or PS to process your DNG's to tiff files ACR will remove them. But, as with the pink frames, even the amount of dead pixels has increased with the latest builds.
As for the frame rate issue. I might suggest making yourself a new ML card. Start with the stable release and build up.
I usually use http://nanomad.magiclantern.fm/nightly/ to get the latest goods and then put the appropriate raw auto exec.bin and modules folder from the raw nightly build.

Update: I took my own advice and rebuilt myself a fresh ML and put the 11th update files: 60d_111.sym and raw_rec.mo into the modules folder along with that autoexec.bin from update 11 onto the card and ran a test. and. no pinky frames hooray.
 

54
Raw Video / Re: 60D RAW video - it's working !!!
« on: August 03, 2013, 08:08:57 AM »
hi Marekk,
is it possible to integrate the changes from update 11 into the unified tree, because I like the black frame and lv_af switch in the raw menu but it doesn't exist in the unified ML Nightly 60D builds.
Thank you,
JK

55
Raw Video / Re: 60D RAW video - it's working !!!
« on: August 03, 2013, 01:33:07 AM »
I asked here cause i saw someone commenting about bad behavior of sandisk with the 60d raw footage. i know the limitation of the 60d but it doesn't change the fact that some cards behave better than others, thus my request for some indication in a good direction specifically for this model.

Well that's a different question isn't it? To answer that I'd say. From my experience the Sandisk 95Mb/s pro cards do give consistent 21.3 Mb/s on the 60D where as the Sandisk 45Mb/s top out at 20.9Mb/s I know it's not much but every little bit counts. As far as any other manufacturer, I don't have any experience with hence, I don't know.

56
Raw Video / Re: 60D RAW video - it's working !!!
« on: August 03, 2013, 12:47:14 AM »
can someone help me to choose a good sdcard for raw recording?

You can do it yourself by reading the information available to you in this forum.
http://www.magiclantern.fm/forum/index.php?board=40.0

And you'll also find, once you do some more research that the 60D is limited by it's own buffer to 21.3mb/s , therefore a fast card isn't needed.

57
Raw Video / Re: 60D RAW video - it's working !!!
« on: August 03, 2013, 12:27:28 AM »
hi Marekk,
is it possible to integrate the changes from update 11 into the unified tree, because I like the black frame and lv_af switch in the raw menu but it doesn't exist in the unified ML Nightly 60D builds.
Thank you,
JK

58
Raw Video / Re: 60D RAW video - it's working !!!
« on: July 17, 2013, 09:15:08 PM »
hi tool.
yeah i shoot @ 11.986 fps. FPS override. Peruse the forums and you'll discover that the 60d is limited by it's buffer, so you must do some juggling to get the resolution you want. namely juggle resolution, aspect ratio and FPS. have fun. also your 60D will likely top out @ 21.3Mb/s, so if you'll notice on the bottom of your camera display in yellow it tells you what you can expect in terms of pipeline.
Have fun.

59
Raw Video / Re: 60D RAW video - it's working !!!
« on: July 17, 2013, 08:12:26 PM »
Now it should be ok:

raw_rec.mo
https://docs.google.com/file/d/0B-HdscXfsKpgOU5ueFdHTjRIYTQ/edit?usp=sharing

LV_AF_RAW is a tempoary solution. We should to find memory address where raw type is stored. Then we can set correct raw type like on 5dmkIII, 600D etc.. Unfortunately disassembling is to difficult for me.
I don't even know what you said just then, disassembling memory address raw type? bro  :-\ , but, I'm testing the module now....And it works. Siiiiick. And my 60D is rolling @ 21.3Mb/s. 2948 frames @ 1600 @ 2.35 @ 11.986. That's not bad at all. Awesome. Thank you

60
Raw Video / Re: 60D RAW video - it's working !!!
« on: July 17, 2013, 07:29:21 PM »
Hey John can't see the screenshot.

I can. the black box with the white rectangle is the screenshot.

61
Raw Video / Re: 60D RAW video - it's working !!!
« on: July 17, 2013, 05:17:38 PM »
What it looks like:


62
Raw Video / Re: 60D RAW video - it's working !!!
« on: July 17, 2013, 04:52:27 PM »
Ok, So I checked with the external monitor, set force VGA over HDMI and recorded 1600 @ 2.35 @ 11.986 and works great. (except of the flicker of the meter for the frames and size). I'll put up a screen shot in a few minutes.

63
Raw Video / Re: 60D RAW video - it's working !!!
« on: July 17, 2013, 04:35:12 PM »
Hi Marekk,
So as the other user said, the only issue is the meter flickers, and the frames and size info are cut off at the border with the frame.  Otherwise it's awesome, I like very much the lv_af on/off, it's good, nice touch. I recorded at my usual 1600 @ 2.35:1 @ 11.986 and ran the result through rawmagic 0.7b and looks good, really good. especially with lv_af on, as you know. also, i will test with my monitor and see what happens, because I checked with my friends 5dmk2 and used the monitor with this function and force VGA and it worked, i had acurate preview on the monitor and no corruption so i'll see what is results. Otherwise, this is fantastic, makes framing very nice and it looks nice when you shoot to have all black around the frame. Maybe it's also good for battery life?
Any way. Thank you.

64
Raw Video / Re: 60D RAW video - it's working !!!
« on: July 17, 2013, 02:23:52 PM »
here is a raw_rec code for 5DMKII builds.
https://bitbucket.org/pravdomil/magic-lantern-hack/src/4c786d285287d28e4c7cc9ab72a82753f2fc7a2f/modules/raw_rec/raw_rec.c?at=unified

I'm going do add black borders and automatic disabling of global draw during recording to 60D build (till the end of this week).

Wow. Awesome. Thank you.

65
Raw Video / Re: 60D RAW video - it's working !!!
« on: July 17, 2013, 01:31:37 AM »
Here's the screenshots:





Thank you for all the work you've done here. And A1ex and nanomad and everyone else I have no Idea who you are but thank you, all of you

66
Raw Video / Re: 60D RAW video - it's working !!!
« on: July 17, 2013, 12:34:57 AM »
I think global draw should be ON to do it..

With the 5dmk2 the option to have black border is only available when global draw is off, it's in the RAW rec submenu. I recently shot a short film with my friends mk2 saw the feature and think it's fantastic. I know maybe you don't have the mk2 I'll post some screen grab in an hour or so.

67
Raw Video / Re: 60D RAW video - it's working !!!
« on: July 16, 2013, 10:52:52 PM »
Hi Marekk.  Was wondering if it's possible to make black box like 5d mkII when recording raw. What I mean is, instead of just a white  rectangle to show recording area, the 5D blocks out the rest of the non recorded area in black and also no GlobalDraw. It's like the black and white preview only it's color, is it possible with the 60D or is outside of the cameras ability? Thanks.

68
Raw Video / Re: 60D RAW video - it's working !!!
« on: July 16, 2013, 03:13:14 PM »
Go to Raw2Dng Forum and read it. There all your answers will be revealed. do a search for raw2dng and READ THE STUFF.
Furthermore, this forum is not concerned with Raw2DNG app it's concerned with 60D, Hence.

Does anybody know what the .mov file is after a dng extraction?

69
Raw Video / Re: 60D RAW video - it's working !!!
« on: July 14, 2013, 02:43:01 AM »
Hi Marekk. Fantastic stuff this RAW. I Usually shoot 2.35:1 @ 1600 @ 11.986 and can shoot for 3000 frames. amazing.
Anyway. Was wondering if it's possible to make black box like 5d mkII when recording raw. Thanks.

70
Raw Video / Re: 60D RAW video - it's working !!!
« on: July 13, 2013, 08:26:32 PM »
Hi Marekk. Fantastic stuff this RAW. I Usually shoot 2.35:1 @ 1600 @ 11.986 and can shoot for 3000 frames. amazing.
Anyway. Was wondering if it's possible to make black box like 5d mkII when recording raw. Thanks.

71
The MVR resets are a bit hard to spot. The overlay blanks and then the bit rate goes back to "normalish" settings. When the buffer gets full it does something similar but can stop.

I've already seen 176 (and above, messing with D sizes). Actually written peaks? 267Mb/s on one of audio nut's graphs. Realistic average rates will probably stay around 100 until SD cards get faster.

Bit rate doesn't really "set" the rate... its just scaling I rate, P rate and the gop options. So you can get 17mbps at 3.0x depending on settings/scene/etc. We also need to get more out of the bit rate we already have.

Yup. It is very scene dependent. it seems the lower the light the higher the bit rate. I've been using Sandisk Extreme Pro SDHC 95Mb/s cards. And for me it seems that the highest, non buffer full reset is 1.8x without audio. Which when I analyze this in bits per sec I am getting 85-90 pretty steady and honestly for me that's plenty. 600mb per minute is quite a bit.

72

[/quote]
What is your sustained write speed? Regular mode. I have no problems with 2.0x even at high ISO. My write is 15-18MB/s

[/quote]

Hi, yeah. but. setting the camera to 2.0x doesn't mean it does that. according to my testing the highest I can set the camera and it actually means something bit rate wise is 1.8 on a good day. usually I leave it at 1.5x and let it ride. When I set my camera to 2.0 or more all it does is revert back to default, it 's not as if the camera stops recording, it just records at 1.0 default.

73
I assume it does, or the ML team wouldn't include it?  ???

I can't say that I've noticed any difference, but in the meantime I leave it on 1.8x just in case there's something good going on I can't see, but that has an influence further down the pipeline. I do a lot of manipulating in post and anything that increases quality is welcome.

Anyone able to comment?  :)

What camera you use, the ISO and the card in it are important. If you use lower ISO, bitrate will not increase as much as high ISO. Also, on my 60D with 95Mb/s card I can pull 1.5 -1.6 up to 1.7 but any higher and the gains are minimal. If you set it to 1.8 you may or may not be getting 1.8. I would do the minute test. roll 1 minute on the same scene whilst adjusting the ISO and bitrate to see which combination of what yields the largest file size, write down those settings and then test them at different CBR to see how much file size you get. The most I've got so far on my 60D is 521MB for 1 minute of footage. And I can see a diff in AE doing color and look. The gradation is smoother.

74
Is this true? You loose the audio? Maybe you should record the audio external...

I think this is a bug! Increasing the bitrate in order to loose the audio?!?!?!?

Seriously bro, you need to do some reading of the users manual and the forum before you post. The Bitrate goes up and the sound drops out, does that not make sense to you? It's no bug, it's a by product of overclocking the processor.

75
For the 60D i had to run the pearl app so that i could have them compressed cause the 60d won't recognize the photoshop rle compression and for the 60d they need to be small. like 33kb or so.
jk

Pages: 1 2 [3] 4