Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - 47Crows

Pages: [1] 2 3 4
1
Camera-specific Development / Re: Canon 1100D / T3
« on: July 18, 2015, 09:29:54 PM »
Preventing things like exploding cameras.

Wouldn't it have been easier just to remove the "Don't touch this" feature?

2
Camera-specific Development / RAW zebras and histograms
« on: May 25, 2015, 05:43:10 PM »
(currently on the magiclantern-Nightly.2015May03.1100D105 build)
Has anyone tried RAW zebras/histograms lately?

I'm fairly sure I've seen them work on the 1100, but they seem to have stopped working at some point, since all I see are normal zebras(fast Luma-style over and underexposure red-blue patterns)/histograms (no ETTR hint, no EV bars), both in LiveView and image review. I am positive they are set to their RAW mode.

Also, screenshots might not be saving properly, since not IrfanView, nor GIMP can open .PPMs generated by the camera anymore. The header seems to be missing; here's the screenshot, anyway.


Edit: According to dmilligan, we'll just wait for round 2 of RAW testing when the time's right.

3
Camera-specific Development / Re: Canon 1100D / T3
« on: March 14, 2015, 06:40:27 PM »
Are these problems known or is it something new?
Thanks!

This is definitely new.

4
Camera-specific Development / Re: Canon 1100D / T3
« on: February 06, 2015, 06:08:52 PM »
Not really well.
Sometimes the ML menu flash anc you can see the camera menu or display.

Don't worry, it's been occasionally doing that since at least 2013 with no ill effects.

5
Camera-specific Development / Re: Canon 1100D / T3
« on: November 05, 2014, 03:49:22 PM »
I'm using the "magiclantern-Nightly.2014Oct07.1100D105" build. It's quite stable.

6
Camera-specific Development / Re: Canon 1100D / T3
« on: October 07, 2014, 04:32:35 PM »
Can we get someone to flash a per-page, flashing-red sticky that says "READ THE FAQ, THEN THE WHOLE THREAD"?

Ontopic: read the instructions that flash on the camera when you install ML. Or, you know, the faq/manual.

7
Camera-specific Development / Re: Canon 1100D / T3
« on: August 09, 2014, 02:52:30 PM »
The 1100D does not have any way to input audio through an external microphone. What are you refering to?

From what I understand, he spliced it. My guess is that instead of using the embedded microphone, he rewired the circuitry (2 wires, one cold, one hot) into a mono input, in which he can plug a microphone.

8
Camera-specific Development / Re: Canon 1100D / T3
« on: August 03, 2014, 11:52:04 PM »
Need help guys.. can you point me in right direction :)

I need to uninstall magic lantern from my camera [...]

Here you go.

Quote
"[...] Uninstalling Magic Lantern

Don't just delete the Magic Lantern files from the card! If you do, the camera will freeze at startup and you'll have to take the battery out.

Uninstalling ML from one card

    Format that card from the camera (select this option: Format card, remove Magic Lantern) and reboot. Your camera will load the original firmware when you use that card.

Uninstalling ML from the camera

    With a Magic Lantern card, launch the Firmware Update process and follow the instructions on-screen.
    Re-installing Canon firmware will not remove Magic Lantern."

9
Camera-specific Development / Re: Canon 1100D / T3
« on: July 11, 2014, 11:35:32 PM »
Did somebody try full res silent pics?

Currently using #1257's Experimental_build_1100D.zip (https://mega.co.nz/#!294TkDZK!cPxupx6zZ_1gc_t-iXemeAVj0e4UWAXap1ffRgRXizM) , which was posted June 27th.

  • Silent pics of ANY resolution result in a blank (0 bytes) DNG for each session (i.e.: the time between power up and power down of the camera); a message is printed briefly each time I "take" a silent pic, with the location at which the DNG was supposed to be
  • RAW video works like a charm, except for when you zoom in (Canon's zoom, not magic zoom): the LV picture freezes, but the recording continues normally (action following the freeze is recorded seamlessly)
  • this one is a bit tricky: in LV, while having silent pics enabled (with half shutter press as trigger), if I snap a picture (full shutter press), the image gets written to the file, but the camera beeps; a second time this is attempted, the shutter can be heard doing its job, the mirror comes down, but it never comes up. The camera then prints out a Canon message "BUSY" on the screen, the LED stays lit. When trying to power down the camera, the Canon image saving screen appears (blue circle thingy stating how many images it has to save) and it stays there indefinitely. When opening the card/battery door, the camera prints out a Canon message among the lines of "Close the door. Do not remove the battery." No image is saved this time.
Hope I've been of some help.


tl;dr: there are plenty of bugs, but the camera is very much alive, with no sign of being bricked; AETTR works like a charm and I quite dig the RAW histogram and zebras(which are more like false colours)

10
Camera-specific Development / Re: Canon 1100D / T3
« on: July 11, 2014, 07:23:25 PM »
I'll get the newer regular IS II (non stm) version tomorrow so we'll see how it does with that one.

I have the IS II version and it doesn't work. It's the lens specs themselves.

dmilligan (at least) once explained what's the deal with it and why it won't work with this focal length range and aperture range setup. It simply had something to do with ML's values not syncing with the minimum F-numbers at each end of the focal length range.

11
Camera-specific Development / Re: Canon 1100D / T3
« on: July 10, 2014, 11:13:04 PM »
Apperture size doesn't change in video mode during Exposure override when the value is changed, it's adjusting itself when it's changed from the lowest F number. Am I doing anything wrong or it's a bug ?

It's a bug available only while using zoom lenses[citation needed]. It will work fine on a fixed-focal length lens.

EDIT: as corrected below, the problem is with the 18-55mm f/3.5-5.6 III and with the 18-55mm f/3.5-5.6 IS II so far.

12
Camera-specific Development / Re: Canon 1100D / T3
« on: June 22, 2014, 08:59:28 PM »
Is there anybody still using this camera [...]?

Yes, just doing bimonthly updates since there's no activity on the forum, thus having no new features with which to experiment.

13
Camera-specific Development / Re: Canon 1100D / T3
« on: May 06, 2014, 05:54:23 PM »
Hi. I have two questions. Is possible to find change log for night builds just for 1100D and is there some list with all change not just for one day? Because I don’t want check change log every day. I try find, but I didn’t. Thank you :-)

I believe this is the closest thing to your request.

Also, https://groups.google.com/forum/#!msg/ml-devel/hgaMKPUYctI/LZnOzMVgVcoJ ; https://bitbucket.org/hudson/magic-lantern/src/tip/platform/1100D.105/ to check what's happening with development.

14
Completely off-topic, but I figure someone might want to look up this info, let it be found on a 1100D forum:
I opened up my focusing screen ensemble. Just a heads-up for anyone who ventures there, IT (the focusing screen) WAS NEVER MEANT TO BE REPLACED, so make sure you understand the risks.
  • Put the camera on its back. (preferably, tilted at a 45° angle toward the top side)
  • Open the outer frame (3) by pushing inside on its tab. Try to avoid touching the mirror at all times.
  • Pick up the screen (2) by any of the north "ears" (those facing you). Try to avoid touching the central part of the screen. Don't worry, there is only one way of putting in the screen (check the south ear that should fit in the bottom slot to the right). If all goes wrong, try to install the screen as the number 20 (seen on the east ear) is facing you.
  • If done correctly, you shouldn't even deal with the other frame (1). If you do, however, dislodge it, don't worry, like the screen, it can only be put in one way (check the cutaways in the frame and compare them to their counterparts on the camera). At the time of writing I am wondering why this frame even exists since it's completely flat and very thin.

I hope someone finds it helpful.

15
Camera-specific Development / Re: Canon 1100D / T3
« on: April 21, 2014, 12:19:16 PM »
when is someone going to work on a released version of ml for the rebel t3?

I think he means a Unified/"Official" version, like with the 5D and all those that are fully supported. I'm no developer, but I doubt that will happen anytime soon, mainly because of the limitations this camera has and the bugs that are caused by said limitations/differences.

Offtopic, but it's been driving me insane: whenever I shoot in LiveView, I hear a short, mechanical, friction-ridden sound at the beginning of the exposure, from within the camera (which is not the mirror going up, obviously). Up until now I thought it was the shutter, resetting the sensor or something, but I took the lens out and repeated the experiment. The shutter does not come down, but the sound is present. It is not produced by the speaker. Can anybody please tell me what it is? It's keeping me up at night since I can't explain its existence. Thanks.

EDIT: apparently, the shutter "resets" the sensor, which means the shutter travels right at the beginning of the exposure.

16
Camera-specific Development / Re: Canon 1100D / T3
« on: April 10, 2014, 12:41:01 PM »
if anyone has tested it, please post a video or something

You can either trust us or not. You don't see some angry guy spamming the forum with multiple accounts after having his camera bricked, so I'd say it's safe to run it.
Speaking of which, try force yourself into going through the entire thread before running ML, to get an idea of what happened with our build. Also, reading the rules and FAQ should help clear some stuff up.

17
Camera-specific Development / Re: Canon 1100D / T3
« on: April 02, 2014, 08:00:33 AM »
Is the release for ML a nightly build then?
Yes.
Is it safe to use for the auto reset for video recording?
Yes.

18
Camera-specific Development / Re: Canon 1100D / T3
« on: March 19, 2014, 09:33:08 AM »
Found a bug while testing Trap Focus: when the focus indicators light up, the camera takes 3 pictures. I've tried both modes, with the C-Fn AF button configuration at default and otherwise.
HDR bracketing is off (even tried to set the number of frames to 2, just in case), the drive mode is single.

I'm using the 18Feb2014 build, but I haven't used this feature in a long time, so I don't know when the bug appeared.

edit: once in a while, it just takes 2 pictures.
:-X

Forgot I had set Pics at once to exactly 3 (Shoot tab, Shoot preferences).

19
Camera-specific Development / Re: Canon 1100D / T3
« on: March 14, 2014, 10:10:10 AM »
So you don't think the 1100D will record raw video continously?
And what exactly is silent pictures, does this mean raw video without audio?

http://magiclantern.wikia.com/wiki/Unified/UserGuide#silent-pictures

As for actual RAW video, I don't think it generally records sound. Someone correct me if I'm wrong, but as far as I know, it's a series of DNG files, written very quickly on the camera, right up to the moment when the buffer gets full. Recording sound as well will fill up the buffer prematurely, so it's probably disabled.

20
Camera-specific Development / Re: Canon 1100D / T3
« on: March 05, 2014, 06:06:47 PM »
Do you have some images to show it?


To what I can observe, it seems only the green channel is affected by these changes. If you mix equal parts of brightness and contrast adjustment, the image tends to balance itself out, color-wise.

EDIT: I tried taking a screenshot, but it crashed (apparently this happens in LV) and the PPM that resulted didn't have any changes in color/contrast/brightness, like the screenshot was taken pre-effect.

21
Camera-specific Development / Re: Canon 1100D / T3
« on: March 05, 2014, 05:39:50 PM »
Ok, then, I've had this bug since around october 2012, when I got my first nightly.

Everything is when using LiveView, as suggested by the name of each feature:

  • LV DIGIC peaking set to anything other than "off" or "slightly sharper" will result in a crisp, greener image.
  • LV brightness results in a green tint.
  • LV contrast results in a purple tint.
... but at least LV saturation and display gain work as expected.

22
Camera-specific Development / Re: Canon 1100D / T3
« on: March 05, 2014, 10:09:32 AM »
...my liveview screen is now green.
Is there any option i clicked by mistake?

That usually happens when you tamper with brightness/contrast in the Display tab.

23
Camera-specific Development / Re: Canon 1100D / T3
« on: March 02, 2014, 10:15:48 PM »
Hi! Does anyone else experience the following bug with AETTR? Whenever i try to take a picture with AETTR the Shutter Speed decreases to the point when the picture is almost black and then it says " Expo limits reached". I tried different scenarios..some with low, high dynamic range, some in dark rooms or bright daylight.
What is it i'm doing wrong?

So far, autoETTR is NOT yet supported in LiveView, because we're still lacking LV RAW support. However, you can do just that by using either of the first 2 modes (always and autosnap, NOT during LiveView): take a RAW pic and then the exposure will be automatically set as far as it should be to the right, after an "offline" analysis is done on the previously-taken image.

(Am I doing it right, guys?)

24
Camera-specific Development / Re: Canon 1100D / T3
« on: February 23, 2014, 09:49:48 AM »
Feb23rd works great for me.
Just noticed the QuickReview overlays and I have to ask, are they really RAW in the review stage?

Maybe offtopic, but I thought I should let you know, yesterday's build hung while entering stand-by and the LED turned on and remained that way. All because of one "if()" regarding memory?

25
Camera-specific Development / Re: Canon 1100D / T3
« on: February 22, 2014, 11:01:01 PM »
Here you go, took quite a lot to make it have a memory error. For some reason, while trying to take a snap of it, everything ran smooth. But I managed to break it, don't worry.
It seems almost random to me.



EDIT: left at the original resolution, for your viewing pleasure

Pages: [1] 2 3 4