Author Topic: Using wrong versions of module error  (Read 6665 times)

maxpervij

  • New to the forum
  • *
  • Posts: 4
Using wrong versions of module error
« on: January 12, 2014, 01:05:14 PM »
MLV RAW with audio on Canon 5D markII.

It's greate news about sound with RAW, but after update of firmware I have an error on my 5dm2

> tcc: error: undefined symbol 'mlv_set_type'
> tcc: error: undefined symbol 'mlv_rec_set_rel_timestamp'
> [E] failed to link modules

Can somebody help me with this error ? :)

Malcolm Debono

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 707
  • Cinematographer
Re: Using wrong versions of module error
« Reply #1 on: January 12, 2014, 01:48:40 PM »
It's greate news about sound with RAW, but after update of firmware I have an error on my 5dm2

> tcc: error: undefined symbol 'mlv_set_type'
> tcc: error: undefined symbol 'mlv_rec_set_rel_timestamp'
> [E] failed to link modules

Can somebody help me with this error ? :)

Most probably you enabled the mlv_snd module without enabling the mlv_rec module. Make sure that both are enabled
Wedding & event cinematographer
C100 & 6D shooter
New here?  Check out the FAQs here!

Francis Frenkel

  • Member
  • ***
  • Posts: 190
  • documentarist - filmmaker - DOP
Re: Using wrong versions of module error
« Reply #2 on: January 12, 2014, 02:50:02 PM »
Cause you have to find another version of your original Ml firmware.
It happends to me, on my first installation test, same error message = I just change the autoexec.bin and the Canon5d.fir, and did a new firmware update !
And voilĂ .

Tell me if it works.

Francis
Francis Frenkel
www.ffrenkel.com

g3gg0

  • Developer
  • Hero Member
  • *****
  • Posts: 3182
Re: Using wrong versions of module error
« Reply #3 on: January 12, 2014, 03:59:21 PM »
It's greate news about sound with RAW, but after update of firmware I have an error on my 5dm2

> tcc: error: undefined symbol 'mlv_set_type'
> tcc: error: undefined symbol 'mlv_rec_set_rel_timestamp'
> [E] failed to link modules

Can somebody help me with this error ? :)

its just an old/missing mlv_rec. update it and it will work
Help us with datasheets - Help us with register dumps
magic lantern: 1Magic9991E1eWbGvrsx186GovYCXFbppY, server expenses: paypal@g3gg0.de
ONLY donate for things we have done, not for things you expect!

maxpervij

  • New to the forum
  • *
  • Posts: 4
Re: Using wrong versions of module error
« Reply #4 on: January 12, 2014, 06:53:31 PM »
its just an old/missing mlv_rec. update it and it will work

O_o It works  8) thanks

maxpervij

  • New to the forum
  • *
  • Posts: 4
Re: Using wrong versions of module error
« Reply #5 on: January 12, 2014, 07:03:38 PM »
mmm... have one more little problem... "Tag: Text" isn't working, is not active...

g3gg0

  • Developer
  • Hero Member
  • *****
  • Posts: 3182
Re: Using wrong versions of module error
« Reply #6 on: January 12, 2014, 08:45:05 PM »
what do you mean with that? "it is not active"
Help us with datasheets - Help us with register dumps
magic lantern: 1Magic9991E1eWbGvrsx186GovYCXFbppY, server expenses: paypal@g3gg0.de
ONLY donate for things we have done, not for things you expect!

maxpervij

  • New to the forum
  • *
  • Posts: 4
Re: Using wrong versions of module error
« Reply #7 on: January 13, 2014, 07:23:19 AM »
what do you mean with that? "it is not active"
I try to choose this item and change tag but the new window is not opening...

g3gg0

  • Developer
  • Hero Member
  • *****
  • Posts: 3182
Re: Using wrong versions of module error
« Reply #8 on: January 13, 2014, 10:49:43 PM »
aaah. you need ime modules being installed
(dl there: http://www.magiclantern.fm/forum/index.php?topic=6899.0)
Help us with datasheets - Help us with register dumps
magic lantern: 1Magic9991E1eWbGvrsx186GovYCXFbppY, server expenses: paypal@g3gg0.de
ONLY donate for things we have done, not for things you expect!