Author Topic: Canon 7D Mark I  (Read 945355 times)

blackjack102

  • New to the forum
  • *
  • Posts: 26
Re: Magic Lantern for 7D 2.0.3
« Reply #375 on: June 20, 2014, 05:23:04 AM »
Just tried FPS Override... i extracted the MLV file and frames doesnt hold the data.. all i received is vertical lines in those DNG files.

https://drive.google.com/file/d/0B3HtquGOmHVmRG1xTVlsTEkteTQ/edit?usp=sharing

Anyone else tested??


Never mind, I tried another test and found it works. I think I screwed some setting last night.

Danialdaneshmand

  • Freshman
  • **
  • Posts: 73
Re: Magic Lantern for 7D 2.0.3
« Reply #376 on: June 20, 2014, 03:42:21 PM »
Finally got my hands on the Magical lantern last night (last nightly build)
One word , Wonderful.
a big thank to whoever worked on this project it's absolutely brilliant.
Anyway , one of the things that got me into buying a 7D for magic lantern was the "Audio trigger shutter" , i couldn't find it in menus or subs and modules.
Is this feature missing for 7D or its name has changed?

BushanBengaluru

  • New to the forum
  • *
  • Posts: 25
Re: Magic Lantern for 7D 2.0.3
« Reply #377 on: June 20, 2014, 03:46:36 PM »
Never mind, I tried another test and found it works. I think I screwed some setting last night.
sorry guys,  Yes it worked for mine too..  just tried with 1frame per 24fps.. worked well..

will try for slower  fps soon..

thank you

vyskocil

  • Freshman
  • **
  • Posts: 53
Re: Magic Lantern for 7D 2.0.3
« Reply #378 on: June 20, 2014, 10:54:00 PM »
Finally got my hands on the Magical lantern last night (last nightly build)
One word , Wonderful.
a big thank to whoever worked on this project it's absolutely brilliant.
Anyway , one of the things that got me into buying a 7D for magic lantern was the "Audio trigger shutter" , i couldn't find it in menus or subs and modules.
Is this feature missing for 7D or its name has changed?

FEATURE_AUDIO_REMOTE_SHOT seems to defined only for 650 & 700 build...
I just defined it in 7D features.h, compile it and give it a try : seems to works very well !
I don't know why this is not included by default ?

[Update] in fact this feature depends on CONFIG_AUDIO_CONTROLS and this had been disabled recently for 7D because some features were untested/or perhaps not working (?)

I don't understand (in all_features.h) :
Code: [Select]
#ifdef CONFIG_AUDIO_CONTROLS
    #define FEATURE_AUDIO_REMOTE_SHOT   /* requires audio controls, otherwise there's no sound in photo mode */
#endif

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Magic Lantern for 7D 2.0.3
« Reply #379 on: June 20, 2014, 11:05:16 PM »
It doesn't really depend on CONFIG_AUDIO_CONTROLS, but it's enabled by default if you have ML audio controls (because ML implementation simply keeps the sound chip on all the time, while Canon's implementation turns it off in photo mode, for example).

Without audio controls, ML has to use some tricks to enable audio. These tricks were implemented for 7D, 6D, 650D and 700D, so these cameras should have CONFIG_AUDIO_CONTROLS in features.h. It's not defined because I didnt't notice it's missing.

edit: enabled and did a small cleanup; can you try? (can't test it right now, but looks OK)

vyskocil

  • Freshman
  • **
  • Posts: 53
Re: Magic Lantern for 7D 2.0.3
« Reply #380 on: June 21, 2014, 12:19:26 AM »
It doesn't really depend on CONFIG_AUDIO_CONTROLS, but it's enabled by default if you have ML audio controls (because ML implementation simply keeps the sound chip on all the time, while Canon's implementation turns it off in photo mode, for example).

Without audio controls, ML has to use some tricks to enable audio. These tricks were implemented for 7D, 6D, 650D and 700D, so these cameras should have CONFIG_AUDIO_CONTROLS in features.h. It's not defined because I didnt't notice it's missing.

edit: enabled and did a small cleanup; can you try? (can't test it right now, but looks OK)
I quickly tried it and it seems to works ok.

But at the end why CONFIG_AUDIO_CONTROLS had been disabled on the 7D ?
It seems also all right when I enable it on my 7D...

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: Magic Lantern for 7D 2.0.3
« Reply #381 on: June 21, 2014, 12:23:37 AM »
Do you get audio menus up and running? I don't remember seeing them, but will double-check.

vyskocil

  • Freshman
  • **
  • Posts: 53
Re: Magic Lantern for 7D 2.0.3
« Reply #382 on: June 21, 2014, 12:26:25 AM »
Do you get audio menus up and running? I don't remember seeing them, but will double-check.
Yes and live audio meters even when not recording (very useful :)

Rainmanwalking

  • New to the forum
  • *
  • Posts: 13
Re: Magic Lantern for 7D 2.0.3
« Reply #383 on: June 21, 2014, 03:13:29 AM »
Alex,  Thanks for all the recent work on the 7d.  It's really added a lot to my old camera.  :) 

Danialdaneshmand

  • Freshman
  • **
  • Posts: 73
Re: Magic Lantern for 7D 2.0.3
« Reply #384 on: June 21, 2014, 05:19:27 PM »
I don't get it is there an Audio Trigger option somewhere in number 140 nightly then?

jyc128

  • New to the forum
  • *
  • Posts: 4
Re: Magic Lantern for 7D 2.0.3
« Reply #385 on: June 24, 2014, 06:09:21 AM »
Hello , I just upgraded from a t3i to a 7D , I had ML on my t3i and liked some of the features, I read that the  7D doesn't have a stable version , can someone please tell me if it would be safe for me to install the nightly build version? , or is a stable version for the 7d in the way?  , I literally had to borrow money to buy this camera, so I can't really afford to break it ..

Where would I get the latest version of the software?,In case I decide to test it out.
I appreciate everyone's time thank you  :)

ansius

  • Member
  • ***
  • Posts: 177
Re: Magic Lantern for 7D 2.0.3
« Reply #386 on: June 24, 2014, 11:24:54 AM »
have been using ML on 7D for some time, I had to restart it by force once in a while, but if you do use the basic features most of them work without hiccup, raw is not that stable, and I've had some problems with ETTR / dual_iso, but have not been able to find what I have to do to repeat the problem (either ETTR strops adjusting or dual_iso is not triggered). Fut for most, really, it's fine
Canon EOS 7D & 40D, EF-S 17-85mm IS USM, EF 28-300mm IS USM, Mir-20, Mir-1, Helios 44-5, Zenitar ME1, Industar 50-2, Industar 61L/Z-MC, Jupiter 37A, TAIR-3
http://www.ansius.lv http://ansius.500px.com

jyc128

  • New to the forum
  • *
  • Posts: 4
Re: Magic Lantern for 7D 2.0.3
« Reply #387 on: June 24, 2014, 04:26:49 PM »
Thank you for sharing your own experiences !
So I should just download the last nightly build version from the website?
Thanks again .

dpjpandone

  • Senior
  • ****
  • Posts: 284
Re: Magic Lantern for 7D 2.0.3
« Reply #388 on: June 24, 2014, 06:28:10 PM »
Yes and live audio meters even when not recording (very useful :)

This is VERY useful indeed! It's a pain to not be able to monitor audio in standby, since this is when you would want to trim your levels! Thank you again for helping to get 7D current Vyskocil!

Danialdaneshmand

  • Freshman
  • **
  • Posts: 73
Re: Magic Lantern for 7D 2.0.3
« Reply #389 on: June 25, 2014, 08:29:37 PM »
Speaking of audio meters I'm having the same issue , is there a way to have them when not recording?
Anyone tested the Audio remote shot yet , I don't if i should get the nightly #149 or #145 if tested?

arrinkiiii

  • Hero Member
  • *****
  • Posts: 1101
  • ML ADDICTED 7D
Re: Magic Lantern for 7D 2.0.3
« Reply #390 on: June 25, 2014, 08:39:34 PM »
Speaking of audio meters I'm having the same issue , is there a way to have them when not recording?
Anyone tested the Audio remote shot yet , I don't if i should get the nightly #149 or #145 if tested?

You talking in RAW mode or in normal video mode (h.264) ?   In raw mode you need to enable the sound module.

Danialdaneshmand

  • Freshman
  • **
  • Posts: 73
Re: Magic Lantern for 7D 2.0.3
« Reply #391 on: June 26, 2014, 08:25:54 AM »
You talking in RAW mode or in normal video mode (h.264) ?   In raw mode you need to enable the sound module.
Normal mode , since i'm not recording what could be different?

Jbowdach

  • Freshman
  • **
  • Posts: 74
  • Editor\Colorist for Cinetic Studios
Re: Magic Lantern for 7D 2.0.3
« Reply #392 on: June 26, 2014, 06:24:19 PM »
Do we actually know why there is tearing \ pink frames occasionally when using an HDMI monitor attached? Sorry if this has already been discussed, trying to catch up\follow along the development.

dpjpandone

  • Senior
  • ****
  • Posts: 284
Re: Magic Lantern for 7D 2.0.3
« Reply #393 on: June 26, 2014, 08:53:23 PM »
Using an external display adds overhead to the overall processing load, I get less of these artifacts when i record at a lower resolution or frame rate. Until this is investigated further, the best performance can be obtained by setting global draw to "don't allow"  in the mlv menu, then using a monitor that has a cropmark feature to frame your shot accurately.

Danialdaneshmand

  • Freshman
  • **
  • Posts: 73
Re: Magic Lantern for 7D 2.0.3
« Reply #394 on: June 26, 2014, 10:34:30 PM »
Using an external display adds overhead to the overall processing load, I get less of these artifacts when i record at a lower resolution or frame rate. Until this is investigated further, the best performance can be obtained by setting global draw to "don't allow"  in the mlv menu, then using a monitor that has a cropmark feature to frame your shot accurately.
I'm not a monitor user but doesn't ML transfer files like you see it back in the screen itself so we can use the cropmarks internally?

dpjpandone

  • Senior
  • ****
  • Posts: 284
Re: Magic Lantern for 7D 2.0.3
« Reply #395 on: June 27, 2014, 11:07:11 PM »
Yes, the external monitor will display cropmarks (at the cost of more performance overhead, which causes tearing) this is why I suggest disabling all ML overlays and using the cropmarks on external monitor. Does that make sense?

jyc128

  • New to the forum
  • *
  • Posts: 4
Re: Magic Lantern for 7D 2.0.3
« Reply #396 on: June 27, 2014, 11:20:59 PM »
I just got my 7d it has the firmware 2.0.5 , can I install ML , is there a tutorial anywhere ? Please help !

walter_schulz

  • Contributor
  • Senior
  • *****
  • Posts: 396
Re: Magic Lantern for 7D 2.0.3
« Reply #397 on: June 27, 2014, 11:30:08 PM »
Downgrade to firmware 2.0.3 and follow instructions on page one of this thread.
You will find links to older firmware here and other infos, too.

najor

  • New to the forum
  • *
  • Posts: 4
Re: Magic Lantern for 7D 2.0.3
« Reply #398 on: June 28, 2014, 04:04:14 PM »
Hi! Could someone please help me. I installed latest Nightly build on Canon 7d without having Magic Lantern installed on camera.
Now it gives me a bunch of errors about missing everything. Is there a way to uninstall nightly build or I should install Magic Lantern over it?

walter_schulz

  • Contributor
  • Senior
  • *****
  • Posts: 396
Re: Magic Lantern for 7D 2.0.3
« Reply #399 on: June 28, 2014, 04:38:53 PM »
Format card using a cardreader. Insert card into cam and format again. Download latest nightly and expand contents. Copy contents to card (cardreader again). Insert card into cam, run firmware update procedure.