Author Topic: Canon 7D Mark I  (Read 829222 times)

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6744
Re: Canon 7D Mark I
« Reply #1275 on: November 30, 2016, 11:39:55 AM »
What branch are you working from Nikfreak? Latest unified merged with raw_video_10bit_12bit branch works with raw_twk and then preview works with 10/12/14-bit more or less realtime.
raw_twk download here.
http://www.magiclantern.fm/forum/index.php?topic=13163.msg174991#msg174991

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1171
Re: Canon 7D Mark I
« Reply #1276 on: November 30, 2016, 12:50:29 PM »
Release I posted is based upon plain "raw_video_10bit_12bit" branch.
70D.112 & 100D.101

Brawl

  • Member
  • ***
  • Posts: 206
Re: Canon 7D Mark I
« Reply #1277 on: December 01, 2016, 02:08:26 AM »
@flofifull which software did you used to transcode mlv 10 bit into dng to pc? thx a lot

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6744
Re: Canon 7D Mark I
« Reply #1278 on: December 01, 2016, 11:08:43 AM »
Quote
Release I posted is based upon plain "raw_video_10bit_12bit" branch.
I tried compiling from your repository at bitbucket but seems you have done some changes. Your published compiled build works good while compiling from official raw_video_10bit_12bit and also from your repo all you get is some shaking corrupted earthquake sequences.

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1171
Re: Canon 7D Mark I
« Reply #1279 on: December 01, 2016, 11:45:37 AM »
*deleted to avoid confusions*
70D.112 & 100D.101

flofifull

  • New to the forum
  • *
  • Posts: 18
Re: Canon 7D Mark I
« Reply #1280 on: December 01, 2016, 01:13:51 PM »
@flofifull which software did you used to transcode mlv 10 bit into dng to pc? thx a lot

MLV Mystic  ;)

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6744
Re: Canon 7D Mark I
« Reply #1281 on: December 01, 2016, 01:56:08 PM »
Thanks Nikfreak.
Quote
Let me know your result. I might take a look in my VM later in hopes I didn't already delete my working dir  :P
Checked and no cegar on this one. Might wanna check your VM for the magic lines again.
Ok so what happens when I add this line:
Code: [Select]
uint32_t edmac_write_chan = 16; /* Write 0x5 0x6 0x4 (LV) */When stopping recording a series of beep tones comes to live and it writes something about slots and memory. Exiting liveview also exits the beeps.

When specifying only this output still scrambled unfortunately.
Code: [Select]
uint32_t dmaFlags = 0x40001000; //Enhanced
When specifying both lines above the beep tones and error memory/slot message, recorded file like a nice little earthquake ;).

*Deafeyejedis builds are also not working.

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1171
Re: Canon 7D Mark I
« Reply #1282 on: December 01, 2016, 02:12:34 PM »
Sorry Danne,

My build is quite old - dated 25th November - but I will have a look into my VM when I return @home to check what has changed (if the working dir from 25th still exists). Meanwhile I just suggest using my build from 25th as provided until the mystery solves (maybe I used another branch!? don't know for the moment...)
70D.112 & 100D.101

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6744
Re: Canon 7D Mark I
« Reply #1283 on: December 01, 2016, 02:19:39 PM »
No problem. Main quirk is to get the raw_twk to work with that build.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12423
Re: Canon 7D Mark I
« Reply #1284 on: December 01, 2016, 03:10:23 PM »
From metadata, nikfreak's build is 48bb172, without any changes. Simply open autoexec.bin with a hex editor ;)

For modules, all the uncommitted source code changes are included in the .mo file. To see them:
Code: [Select]
/path/to/magic-lantern/modules/module_hginfo_dump.sh file.mo

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6744
Re: Canon 7D Mark I
« Reply #1285 on: December 01, 2016, 04:43:33 PM »
Nice trick with the module_hginfo_dump.sh. Tested on raw_rec and it said all was in order. Tested against later magic-lantern repo.
Still have to find changeset 48bb172. So this is unmodified by viewing autoexec.bin?  I checked but didn,t compare since I don,t know where to find this this changeset. Somewhere in the raw_video_10bit_12_bit branch I suppose.

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3751
Re: Canon 7D Mark I
« Reply #1286 on: December 01, 2016, 05:19:01 PM »
Still have to find changeset 48bb172.

Click on "Commits" on the left panel of the web page then enter 48bb172 in the search box and presto:

https://bitbucket.org/hudson/magic-lantern/commits/all?search=48bb172
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1171
Re: Canon 7D Mark I
« Reply #1287 on: December 01, 2016, 08:50:30 PM »
I can confirm it is plain 48bb172 w/o any further modifications. Scratched my old post as that rather was experimental stuff.
70D.112 & 100D.101

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6744
Re: Canon 7D Mark I
« Reply #1288 on: December 01, 2016, 09:27:33 PM »
Great to know. Will get my hands on a 7D on monday first and things moves fast...

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3394
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Re: Canon 7D Mark I
« Reply #1289 on: December 02, 2016, 01:21:11 AM »
Thanks for confirming this @nikfreak and @a1ex for sharing the trick re: module_hginfo_dump.sh from changeset 48bb172.
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

kamranjon

  • New to the forum
  • *
  • Posts: 37
Re: Canon 7D Mark I
« Reply #1290 on: December 07, 2016, 10:10:44 PM »
I tried the firmware hack from nikfreak but was unable to increase the resolution past 1735x976 even though my bit depth is set to 10 and my preview is set to canon. Anyone know why that might be? Thanks!

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1171
Re: Canon 7D Mark I
« Reply #1291 on: December 07, 2016, 10:37:02 PM »
please switch to X5 zoom.
2400x1200px has been reported to record continuously in 10bit. You mightwant to set fps to 24 as X5 is 30fps by default.
70D.112 & 100D.101

kamranjon

  • New to the forum
  • *
  • Posts: 37
Re: Canon 7D Mark I
« Reply #1292 on: December 07, 2016, 10:38:15 PM »
I think I figured it out, I am able to record at higher resolutions when I zoom in with cropped mode at 5x. I am unable to see what is being recorded, the image just freezes, but it appears to be recording without issues at 1080p in cropped mode. The next highest resoluton 2240x1200 goes for about 25 seconds before stopping.

kamranjon

  • New to the forum
  • *
  • Posts: 37
Re: Canon 7D Mark I
« Reply #1293 on: December 07, 2016, 11:01:28 PM »
By turning off Auto Lighting Optimizer in the Canon menu I was able to record at 2240x1200 continuously but still unable to view what is being recorded.

nikfreak

  • Developer
  • Hero Member
  • *****
  • Posts: 1171
Re: Canon 7D Mark I
« Reply #1294 on: December 07, 2016, 11:31:33 PM »
preview on your lcd, right? That's ok for the moment and same for everyone. Your camera lcd freezes but records.
Viewing on your computer what has been recorded for you in 10bit is best done with MLVFS.
70D.112 & 100D.101

kamranjon

  • New to the forum
  • *
  • Posts: 37
Re: Canon 7D Mark I
« Reply #1295 on: December 07, 2016, 11:51:07 PM »
Yes I was able to confirm that it was recording properly and without issues on my mac using mlvfs and davinci. Beside continuous at 2240x1200 was able to get around 1m40s of recording at 2520x1200. This is really awesome, I hope it will continue to be developed!

williamsts

  • Just arrived
  • *
  • Posts: 1
Re: Canon 7D Mark I
« Reply #1296 on: December 11, 2016, 07:00:52 PM »
Hi everyone, I have been using the Magic Latern on my Canon T3i for some time, now I recently bought a Canon 7D, but I did the firmware update for a version 2.0.6, which Magic Lantern is not compatible, is there any method to go back to Factory or Do I downgrade to a firmware version 2.0.3 so that I can install Magic Lantern on my Canon 7D?

Lokman

  • Just arrived
  • *
  • Posts: 1
Re: Canon 7D Mark I
« Reply #1297 on: December 12, 2016, 09:13:00 PM »
First of all thank you nikfreak for the update
on my 7d  14 and 12 bit works fine but 10 bit still has corrupt frames and good ones (I mean one by one )
settings : Global draw off
                Preview Canon
                FPS overidde 23.967
is there any advise ?
Magic "Canon 7D" Lantern

Roberto Mena

  • Freshman
  • **
  • Posts: 69
Re: Canon 7D Mark I
« Reply #1298 on: December 16, 2016, 06:52:41 PM »
There are only a handful of Canon models that can take almost full advantage of ML's features and the 7D is one of them, the others are the 5DII and III but the 7D is 1/4 the cost of a 5DIII but its almost as good as the 5D's though the 5D's have a full frame sensor as apposed to the 7D's smaller APC-S sensor. But, the 7D's APS-C sensor is close to the size of a Super-35mm digital cinema sensor! The rest of the cameras like the 700D/T5i for example can only record RAW video for about 10-15 seconds and not close to the maximum resolution of 1080p. The 7D can record RAW video til the CF card is full and close to 1080p resolution. But RAW video is so sharp and your taking better advantage of the camera's dynamic range that when you scale it to 1080p it still looks sharper and better than the 7D's native video h.264 codec. 

Check out this ML camera chart:

https://docs.google.com/spreadsheets/d/16cgnRivbUv7nA9PUlCLmLdir3gXdIN3pqzCNAAybepc/edit#gid=5

Bolik

  • Just arrived
  • *
  • Posts: 1
Re: Canon 7D Mark I
« Reply #1299 on: December 21, 2016, 08:53:55 AM »
Hi guys! I have latest build (2016-12-18 23:30), i see "mlv_rec/mlv_play: add variable bit depth support." in discription. But i don`t understand how i can get this functional on my 7D :(