Author Topic: Canon EOS M  (Read 990900 times)

uEOSM

  • New to the forum
  • *
  • Posts: 5
Re: Canon EOS M
« Reply #3350 on: September 02, 2019, 10:58:45 PM »
Please tell me what version is causing you corrupted frames. Also what preset are you using getting corrupted frames.
crop_rec_4k_mlv_snd_raw_only_2019Sep01.EOSM202 and previous from this series
there were no such problems on crop_rec_4k_mlv_snd_isogain_1x3_presets_*** series



dnr

  • New to the forum
  • *
  • Posts: 3
Re: Canon EOS M
« Reply #3351 on: September 02, 2019, 11:07:31 PM »
Sorry, if I'm too blind or too stupid to find it, but is there any way to use half-shutter to start/stop recording in Aug30, as in the previous builds?
I found "Rec trigger" in the raw video settings, but that seems to be only for start/pause within a clip.
I did turn off focus aid within the customized buttons, so I think it doesn't interfer with that.
The reason why I need that function is quite simple; my REC button doesn't work.
Sorry to bring this up again, but i feel like it went unnoticed. I play around with Sep02, but I didn't get it to work either.
Any workaround for my problem?

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6574
Re: Canon EOS M
« Reply #3352 on: September 03, 2019, 01:13:02 AM »
For that set up I would recommend switch over to 4k anamorphic rewired preset. i never had much luck with the 5k anamorphic mode set to 16:9.

henricusmaria

  • Freshman
  • **
  • Posts: 70
Re: Canon EOS M
« Reply #3353 on: September 03, 2019, 11:53:06 AM »
The latest build is working great!
Well done guys!

mix_vfx

  • New to the forum
  • *
  • Posts: 20
Re: Canon EOS M
« Reply #3354 on: September 03, 2019, 03:06:56 PM »
Hi!

Did some testing with Sept03 build, however, with a HDMI monitor hooked up.

Default, first start up with 1080p rewired works flawless, records well, no pink frames, etc.

2.5K: preview is live and framing is not correct, (its on the Canon 5x zoom view), ill link images in a bit. Right half of the screen is basically the last refreshed pixel in the middle tiled till the edge if it makes sense.
Recording OK, with whole images, but plenty of pink frames(50-70%), playback works.

4K ANA Rewired: preview is live, and framing is not squeezed (its on the Canon 5x zoom view), Preview is with full images, no bug like 2.5K.
Recording OK, with whole images, but plenty of pink frames (10-20%), playback works, but shows black screen (see the LED blinking, reading accordingly), both on internal and external screen.

I'll test w/o a monitor, just wanted to see how much funcionality has progressed with it since I'm very keen to use only External monitors with it. Love 1080p already, and occasionally do use without to get nice 4, and 2,5K results. Thanks a lot for your hard work, beautiful to see the M becoming a cine camera even with its brutally slow cpu : )

Cheers
Miki

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6574
Re: Canon EOS M
« Reply #3355 on: September 03, 2019, 03:42:09 PM »
4K ANA Rewired: preview is live, and framing is not squeezed (its on the Canon 5x zoom view), Preview is with full images, no bug like 2.5K.
Recording OK, with whole images, but plenty of pink frames (10-20%), playback works, but shows black screen (see the LED blinking, reading accordingly), both on internal and external screen.
Could you do a screenrecording of what your monitor gives when using it with 4k anamorphic modes?

henricusmaria

  • Freshman
  • **
  • Posts: 70
Re: Canon EOS M
« Reply #3356 on: September 03, 2019, 04:50:18 PM »
I've tested the 4k an rewired and mv1080p mcmrewire modes. Works smoothly. The build feels very intuitive now. Also when changing between the two modes.
With mv1080p mcmrewire I see some flickering in the footage. But that's maybe because of the higher iso (400)?

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6574
Re: Canon EOS M
« Reply #3357 on: September 03, 2019, 04:59:03 PM »
Can´t see any flicker?

henricusmaria

  • Freshman
  • **
  • Posts: 70
Re: Canon EOS M
« Reply #3358 on: September 03, 2019, 05:27:31 PM »
It is visible in the reds. Maybe it’s just noise? Although I don’t see it in the 4K an rewired footage.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6574
Re: Canon EOS M
« Reply #3359 on: September 03, 2019, 06:17:27 PM »
Now I see. Seems some codec export issue. Did you shoot in 10bit? Could be that too. Or post production steps.
Thanks for sharing.

mix_vfx

  • New to the forum
  • *
  • Posts: 20
Re: Canon EOS M
« Reply #3360 on: September 03, 2019, 07:34:04 PM »
Test ReDone!


Could you do a screenrecording of what your monitor gives when using it with 4k anamorphic modes?

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6574
Re: Canon EOS M
« Reply #3361 on: September 03, 2019, 08:42:57 PM »
Thanks.
Hard to say what we see here. But the main question is if you real time preview with the full image resolution or is only showing part of the image(aka cropped preview)?

mix_vfx

  • New to the forum
  • *
  • Posts: 20
Re: Canon EOS M
« Reply #3362 on: September 03, 2019, 09:19:10 PM »
I'd say its cropped, and looks stretched too. I've redone, and reuploaded in a bit better quality:


Pause for preview frame at 0:11
Pause for playback frame at 0:50

Hope its more recognizable. Had to switch back to 1080p rewire to have playback working as well, but you know : )

henricusmaria

  • Freshman
  • **
  • Posts: 70
Re: Canon EOS M
« Reply #3363 on: September 04, 2019, 03:53:38 AM »
Now I see. Seems some codec export issue. Did you shoot in 10bit? Could be that too. Or post production steps.
Thanks for sharing.

It was shot in 14 bit, 16:9, 24p 1/48 fps.
When I open the file in mlv app the flickering is visible.
The 4K an rewired is shot in 10 bit, 16:9, 24p 1/48 and has no flickering.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6574
Re: Canon EOS M
« Reply #3364 on: September 04, 2019, 04:10:09 AM »
Could you upload  the mlv file?

henricusmaria

  • Freshman
  • **
  • Posts: 70

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6574
Re: Canon EOS M
« Reply #3366 on: September 04, 2019, 07:18:52 AM »
I´d say it´s light flicker.

henricusmaria

  • Freshman
  • **
  • Posts: 70
Re: Canon EOS M
« Reply #3367 on: September 04, 2019, 07:27:51 AM »
I´d say it´s light flicker.

Could be. Maybe because I shot in 1/48 fps? But the 4K ana rewired didn’t exhibit the flicker with the same settings.
Anyway, I just left on a journey through China. And the Eosm will do a big part of the video capturing!

ZEEK

  • Senior
  • ****
  • Posts: 258
Re: Canon EOS M
« Reply #3368 on: September 04, 2019, 01:40:19 PM »
The flicker is 100% caused by fine-tuning to 1/48fps. 1/50 is always fine. I believe there is flickering in 1/48 perhaps becuase if you go into the Canon Menu, Movie Mode FPS is automatically set to 25fps.
EOS M - EOS M2 - 5D2

henricusmaria

  • Freshman
  • **
  • Posts: 70
Re: Canon EOS M
« Reply #3369 on: September 04, 2019, 02:36:10 PM »
The flicker is 100% caused by fine-tuning to 1/48fps. 1/50 is always fine. I believe there is flickering in 1/48 perhaps becuase if you go into the Canon Menu, Movie Mode FPS is automatically set to 25fps.

Thanks Zeek, I came to the same conclusion. Should have known better..

liuk718

  • New to the forum
  • *
  • Posts: 6
Re: Canon EOS M
« Reply #3370 on: September 04, 2019, 02:38:35 PM »
I´d say it´s light flicker.

Hi Danne,i was tested new build 02/09 today,please add 2.5k 1x1 centered mode back,so i can shot 2.5k 2.35:1 in 32FPS

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6574
Re: Canon EOS M
« Reply #3371 on: September 04, 2019, 03:19:10 PM »
New build:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

- x5 zoom centered added back. Only reachable from regular preset menu, not from the startoff preset list(tap display)
- Added a focus aid option called "sticky push". It´s under customized buttons. Works as follows:
Push halfshutter until x10 zoom is reached. Release button and x10 zoom is still on. Push halfshutter again and it goes back to normal preview.
On a sidenote I also added a function so that if tapping display while in x10 mode you will be able to reach three different presets here. Or you can be in x10 zoom and push SET button and this will let you reach different 3k, 4k presets.

rinski

  • New to the forum
  • *
  • Posts: 33
Re: Canon EOS M
« Reply #3372 on: September 04, 2019, 08:50:56 PM »
Good, please know if you can record more than 47 mbs with the sd .
Thank you

mix_vfx

  • New to the forum
  • *
  • Posts: 20
Re: Canon EOS M
« Reply #3373 on: September 04, 2019, 10:46:29 PM »
Ok, this is great : )

Sept 04 build.

Still with External monitor, with Preview set to Frozen LV, 4K Anamorphic Rewired works very good. Preview is still cropped, like mentioned earlier, but live, and gives no corrupt frame (yet). Playback works as well.

All bit modes work, only thing is 12, and 10 bits give quite dark preview, with greenish tint.

AF-OFF

  • Member
  • ***
  • Posts: 109
  • 50Dc EOSM
Re: Canon EOS M
« Reply #3374 on: September 05, 2019, 01:54:00 AM »
Great Work Danne, keep it up

I've an issue with Dual Iso in viedo mode
file here - link will expire after one week from now, also notice the X
httpx://we.tl/t-pDRW1htNPh
it consist of a mlv-dualiso video and the corresponding MLV APP receipt, version 1.7
 
August 30 version

as Zeek mentioned, there are changes going on in reported framerates from canon menu. in my case, on NTSC preset have without card the canon setting at 24FPS, but with Danne's build it it's changed to 30fps. Maybe Zeek is Pal and did set from there 24FPS (which by the way seems strange in it self to me)

best