Author Topic: Canon EOS M  (Read 1317946 times)

Bobe

  • New to the forum
  • *
  • Posts: 8
Re: Canon EOS M
« Reply #900 on: January 10, 2016, 08:35:21 AM »
https://mega.nz/#!YlAHGTjI!5htKdhxVOGZdV088WwQcWZ5vkstCo1l1NFt5OZ5crB8
same bad lines whit other ML vers magiclantern-Nightly.2015Apr19.EOSM202.zip

Licaon_Kter

  • Hero Member
  • *****
  • Posts: 519
  • M
Re: Canon EOS M
« Reply #901 on: January 10, 2016, 10:34:49 AM »
@bobe: Bad frames, I guess the card can't keep up or other hardware issue.

Lexar 32Gb 633x 95/MB/s u3 - advertised speeds don't matter in general, true speeds matter, now the EOS-M can't do more than 40Mb/s anyway, no matter the card.

Try to benchmark the card: Start H.264 ( normal) video recording an then go to ML menu -> Debug -> Benchmark -> Card R/W, wait for it to finish and take a pic of the results.


Although that resolution should be low enough to not pose transfer issue, hmmmm.

musicmanx

  • New to the forum
  • *
  • Posts: 9
Re: Canon EOS M
« Reply #902 on: January 10, 2016, 12:04:59 PM »
hi,
i'm new in eos m  ( i am a user of magic lantern in mark 3 )
i have a problem whit the RAW File

there ara many many pink noise.
can you help me ??

https://www.dropbox.com/s/v1y69wzz2cxv1o2/M10-1135_C0000_00008.jpg?dl=0

Bobe

  • New to the forum
  • *
  • Posts: 8
Re: Canon EOS M
« Reply #903 on: January 10, 2016, 12:46:04 PM »
FIX i change the frame rate in canon menu 1920x1080 30fps to24fps  and fps overwrite 24fps the issue gone :) i rec mlv 411.4 sec. clean.
who want try this issue put camera in 1920x1080 30fps and record in mlv 1280x432 @ 30fps.
the issue not fix in 20-31 fps range overwrite in ml menu, she gone afther i change the video setings in canon menu 30fps top 24fps.

Sry for Bad ENG.

Licaon_Kter

  • Hero Member
  • *****
  • Posts: 519
  • M
Re: Canon EOS M
« Reply #904 on: January 10, 2016, 01:48:01 PM »

i have a problem whit the RAW File
there ara many many pink noise.
Look around here: http://www.magiclantern.fm/forum/index.php?board=54.0 for the word pink.


Also, your RAW program (which one do you use?) should have something that handles that.

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3751
Re: Canon EOS M
« Reply #905 on: January 10, 2016, 02:36:29 PM »
i'm new in eos m  ( i am a user of magic lantern in mark 3 )
...
there ara many many pink noise.

I'm a new 5D3 user but have been using the EOS-M for a while.

What you are seeing are the dreaded "Pink Dots" though they show up in other colors too but mainly green and magenta. They are most likely caused by the focusing system used by certain cameras like the 100D, 650D, 700D and EOSM.

You can either try chroma smoothing or if the program you are using has it, Focus Dots suppression--MLV Producer for Windows has it.

Here's more than you will ever want to know about that "pink noise": http://www.magiclantern.fm/forum/index.php?topic=16054.0
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

musicmanx

  • New to the forum
  • *
  • Posts: 9
Re: Canon EOS M
« Reply #906 on: January 10, 2016, 03:04:54 PM »
Quote
Also, your RAW program (which one do you use?) should have something that handles that

thanks for your answer

i' susing RAW MAGIC but there isn't a fixed problem.
a program for mac thet fix the problem ??

Licaon_Kter

  • Hero Member
  • *****
  • Posts: 519
  • M
Re: Canon EOS M
« Reply #907 on: January 10, 2016, 03:20:51 PM »

a program for mac thet fix the problem ??
RawMagic can not discussed here: http://www.magiclantern.fm/forum/index.php?topic=13335.0

See here for other apps that you can use: http://www.magiclantern.fm/forum/index.php?board=54.0
MLVFS for Mac/Linux
MLP for Mac


Also MlRawViewer is kinda old, if it works ok if not the developer did not update it in a while.

musicmanx

  • New to the forum
  • *
  • Posts: 9
Re: Canon EOS M
« Reply #908 on: January 10, 2016, 03:25:42 PM »
Thank you  ;)

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3751
Re: Canon EOS M
« Reply #909 on: January 14, 2016, 02:26:10 PM »
Strange, I just checked the Nightly Builds and it looks like the only platform that hasn't been updated is the EOSM. Ironically, the latest changeset fixes an exposure compensation limits issue on the EOSM.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8046
Re: Canon EOS M
« Reply #910 on: January 14, 2016, 03:06:08 PM »
For overview ask Jenkins: https://builds.magiclantern.fm/jenkins/
And you are right. Don't know why.

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3751
Re: Canon EOS M
« Reply #911 on: January 14, 2016, 05:06:58 PM »
Thanks for verifying Walter. Looks like there are some other platforms that either didn't get built or are broken but we're only interested in the EOSM here.  8)
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

Licaon_Kter

  • Hero Member
  • *****
  • Posts: 519
  • M
Re: Canon EOS M
« Reply #912 on: January 14, 2016, 07:25:38 PM »
EOSM is not broken, it builds fine, Jenkins did not even try to build it yet.

dmilligan

  • Developer
  • Hero Member
  • *****
  • Posts: 3218
  • 60Da / 1100D / EOSM
Re: Canon EOS M
« Reply #913 on: January 14, 2016, 07:48:06 PM »
Looks like something didn't quite get pushed to the repo in time last night (some cameras got it, some didn't, I guess the EOSM ran first):

EOSM Build:
Code: [Select]
Started on Jan 14, 2016 12:07:49 AM
Polling SCM changes on master
[workspace] $ hg pull --rev unified
pulling from https://bitbucket.org/hudson/magic-lantern/
no changes found
[workspace] $ hg log --rev unified --template {node}
[workspace] $ hg log --rev unified --template {rev}
Done. Took 2.7 sec
No changes

60D Build:
Code: [Select]
Started on Jan 14, 2016 12:14:49 AM
Polling SCM changes on master
[workspace] $ hg pull --rev unified
pulling from https://bitbucket.org/hudson/magic-lantern/
searching for changes
adding changesets
adding manifests
adding file changes
added 2 changesets with 2 changes to 2 files
(run 'hg update' to get a working copy)
[workspace] $ hg log --rev unified --template {node}
[workspace] $ hg log --rev unified --template {rev}
[workspace] $ hg status --rev f87b7594be9cd50b31226819f646c596f2e05348 --rev ca5315a3b586931c1b58b9e72fbed6b96d558d6f
Dependent changes detected
Done. Took 2.9 sec
Changes found


Should get updated tonight though, so just be patient ;)

1100D and 600D are disabled because: http://www.magiclantern.fm/forum/index.php?topic=15360.msg160341#msg160341
5D3.123 has to be merged (it's in a separate branch).

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3751
Re: Canon EOS M
« Reply #914 on: January 15, 2016, 06:39:11 PM »
New EOSM nightly is ready.

https://builds.magiclantern.fm/#/

The update includes an exposure compensation limits fix for the EOSM and it also fixes a bug in mlv_rec.mo that is key to automating focus pixel removal. There's still lots to do with focus pixels but the research is being carried out on the EOSM.

By the way, I took down the custom EOSM build from my bitbucket download area because all my pull requests have been merged except for the EZ White Balance which I can't get working yet. I also took out Video Hacks which I never figured out. I'm currently using the standard unified branch which is available from the nightly downloads page.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

mshirani

  • New to the forum
  • *
  • Posts: 3
  • 5D3M
Re: Canon EOS M
« Reply #915 on: January 18, 2016, 11:03:11 PM »

I tried to shoot time lapse in 3x crop mode. But the files are posterized. I don't know if the dng files are corrupted or another issue.
 Settings: Basic silent picture in Video crop mode. FPS override. Shooting interval : 30 Seconds. Magiclantern-Nightly.2016Jan15.EOSM202
Sample DNG file :https://drive.google.com/file/d/0B5vPhFcWMEVic1l4SmJ1ZW9VWEk/view?pref=2&pli=1

Also sometimes intervalometer stops after the first picture in Full Silent Picture mode. The only fix that I know is to remove the battery and try again

Licaon_Kter

  • Hero Member
  • *****
  • Posts: 519
  • M
Re: Canon EOS M
« Reply #916 on: January 19, 2016, 12:18:33 AM »
Also sometimes intervalometer stops after the first picture in Full Silent Picture mode. The only fix that I know is to remove the battery and try again
Use "leave menu" as trigger.

You need a "Picture review" time (not off) in Canon menu set up.

The camera is/might not be stopped, it just waits for your input (buttons?) since, I believe, you did not set up a review time.

What are your power saving settings? Be aware of this bug: https://bitbucket.org/hudson/magic-lantern/issues/2265/turn-off-lcd-enabled-stops-intervalometer

Do upload the (a shorter) MLV with your issue.

Does it happen when saving as DNG (instead of MLV) in camera?

Tried any other program for MLV ? ( MLVFS? MLP for Mac? MLVProducer? )

mshirani

  • New to the forum
  • *
  • Posts: 3
  • 5D3M
Re: Canon EOS M
« Reply #917 on: January 19, 2016, 07:26:25 AM »
Thanks for the reply.
The problem was the bug since I used the settings that you mentioned.

About the video, it was MLV. I tried recording again it was working without a problem. I think the file somehow corrupted.

Justinliv5

  • Just arrived
  • *
  • Posts: 1
Re: Canon EOS M
« Reply #918 on: January 25, 2016, 09:59:41 PM »
Why is there no audio tab in the newer builds?

Licaon_Kter

  • Hero Member
  • *****
  • Posts: 519
  • M
Re: Canon EOS M
« Reply #919 on: January 25, 2016, 10:20:30 PM »

Why is there no audio tab in the newer builds?
There was never one in the first place. See:  http://builds.magiclantern.fm/#/features ?
Be careful not to confuse it with the MLV_SND module option.

mapline

  • New to the forum
  • *
  • Posts: 18
Re: Canon EOS M
« Reply #920 on: January 26, 2016, 05:11:53 PM »
Hi
Tried  magic lantern and getting along well. Thanks so much for all the hard work.
Just a query if I may?
Like the use Prefs>Powersave in LiveView>Use shortcut key>INFO = Blank LCD screen.
However this stops the menu to change to AV/ TV/M etc unless it is changed back. Am I correct or is there another way?
Would be great INFO key could be like TRASH key short click one action hold ML menu. Don’t know if the INFO key could be like that ie click blank screen/hold choice of camera setting?
Many thanks Michael

Licaon_Kter

  • Hero Member
  • *****
  • Posts: 519
  • M
Re: Canon EOS M
« Reply #921 on: January 26, 2016, 06:36:15 PM »
Not so many buttons on the M unfortunately.


Use a lower timer in Turn LCD off maybe?

mapline

  • New to the forum
  • *
  • Posts: 18
Re: Canon EOS M
« Reply #922 on: January 26, 2016, 11:44:05 PM »
Hi Licaon_Kter
Thanks for reply which I take it is NO to all possible amendments.

donmarkon

  • New to the forum
  • *
  • Posts: 4
Re: Canon EOS M
« Reply #923 on: February 06, 2016, 11:05:43 PM »
Hello! Im new here and i have problem. Got EOS M and i did try to install ML but ... install goes fine, it says restart camera and back up ... i do that and then when i turn on camera there is nothing ... everythign is normal. I did try to flash Canon FW 2.0.2 again just in case and then ML and still nothing ... And help would be good. Thanks
EDIT
I figured it out :D

StopGap

  • New to the forum
  • *
  • Posts: 2
Re: Canon EOS M
« Reply #924 on: February 12, 2016, 05:24:43 AM »
I've got a similar problem to what donmarkon describes.

I've been thru the process about 4 times now and the result is the same - everything goes fine, but when I touch the screen with 2 fingers, I can a message screen, which has something like "Magic Lantern - Development version for test purposes". It remains on screen for a few seconds, flickers a little, then nothing - ie back to normal screen.

Any help appreciated.

Thanks.