Author Topic: Canon EOS M  (Read 1069945 times)

yokashin

  • Freshman
  • **
  • Posts: 96
Re: Canon EOS M
« Reply #4300 on: July 30, 2020, 07:08:27 AM »
Hi everyone!
Was trying to get some photos of the neowise comet with the EOS M and its working perfectly, if i zoom on the moon 10x and take a photo i don't get the zoomed version, is there a way/hack for this? i remember people talking here about using one of the croped video modes to take a photo and simulate the zoon effect? i tried but i might be missing something because it doesnt work.

Can anyone help?

It all comes down to enlarging the basic image ... It will be much better to take a few or a dozen photos of a given section of the sky. In the appropriate program, the stars and the comet will overlap and noise will be removed.
https://nightskypix.com/astrophotography-stacking-software/
Or you can use Topaz A.I. Gigapixel for enlargements.
https://www.magiclantern.fm/forum/index.php?topic=22869.msg212747#msg212747

In 70d, when I want to zoom in on something I use digital zoom (x3-x10) in video (canon menu). Unfortunately, the final material is sometimes not suitable for anything ...

clubsoda

  • New to the forum
  • *
  • Posts: 26
Re: Canon EOS M
« Reply #4301 on: July 30, 2020, 12:51:07 PM »
Ok so i am on the new (not the latest but the one before) sd overclock build and set the sd card hack to 192 and i get random very spontanious aborts on one of my eos m cameras (in mcm1080 with and without 3x crop max resolution with 25fps). All have the exact same build and settings installed (all cameras have the sandisk extrem pro 128gb 170mb card)
The camera setups only differ in lenses. It works perfect on every camera but not on this one. The abort happens very suddenly without the indicator indicating an abort before, so no orange or red sign it crashes while it's green and  immortal and the exposure has no influence i think) I could eliminate the problem by setting the sdcard hack to 160. Anyone had a similar experience or is there anything i can do? I will test another one of the same type of sdcard...

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6861
Re: Canon EOS M
« Reply #4302 on: July 30, 2020, 01:15:18 PM »
Test the latest build and do tests with the setup not working.

clubsoda

  • New to the forum
  • *
  • Posts: 26
Re: Canon EOS M
« Reply #4303 on: July 31, 2020, 10:18:19 AM »
So i put the sd card with the failure into another camera and now it's randomly crashing there so i think it has to do with that exact sd card although it is exactly the same model as the other ones. I put a new sd card in the camera where the crashes happen the first time and set it to 192 and it works without problems. There is still an orange indicator if i shoot bright or clippead areas (and i may risk a crash if i push it too far) but that happens on every camera so it's normal and has nothing to do with the hard crash problem. Maybe this exact sd card has some sort of failure or damage. I will test further and report back if i make any new discoveries. If i find the time i will also tested the latest build... was there anything changed that has to do with this problem? :)

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6861
Re: Canon EOS M
« Reply #4304 on: July 31, 2020, 10:29:42 AM »
Sounds like the card is working different. There´s some way to to deeper formatting on cards, check the sd_uhs thread. Some mention of formatting apps. Did you try doing a low level format in cam?

clubsoda

  • New to the forum
  • *
  • Posts: 26
Re: Canon EOS M
« Reply #4305 on: July 31, 2020, 01:39:25 PM »
Interesting. So i remember doing a deep format with every card in camera but i will test later today and will report back

clubsoda

  • New to the forum
  • *
  • Posts: 26
Re: Canon EOS M
« Reply #4306 on: July 31, 2020, 02:12:37 PM »
Danne you are awesome! I did a deep format (in camera) with that problematic card and now the problem is gone! Maybe something was wrong, it could be that i formatted it with the canon 6d long time ago i can't remember. Running 1800x1012 14 bit raw 25fps in 3x crop or normal mcmrewire continues (most of the time green and no orange indicator until i fiddled with iso or overexposed like you would never do in reality but no crash or stop so far) with 192mhz card setting. Damn awesome :)

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6861
Re: Canon EOS M
« Reply #4307 on: July 31, 2020, 02:46:50 PM »
Nice.
Also. Should be no trace of the name mcm rewire so maybe you are using an older build?

clubsoda

  • New to the forum
  • *
  • Posts: 26
Re: Canon EOS M
« Reply #4308 on: July 31, 2020, 08:01:53 PM »
Ah no i just called it like that sry using new build :)

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6861
Re: Canon EOS M
« Reply #4309 on: July 31, 2020, 09:18:53 PM »
No worries, have a club soda  8).

SoFloCineFile

  • New to the forum
  • *
  • Posts: 13
Re: Canon EOS M
« Reply #4310 on: August 02, 2020, 06:37:11 AM »
Hello everyone! I just purchased a refurbished EOS-M a few days ago and did my first video using Danne's new 7/29 build. Amazing work btw Danne  8)!
It was super hot here in Florida (camera reached 50 Celsius) and I just shot handheld in the 14-bit, 1736 by 976 RAW mode:



I wanted to also test Anamorphic Live View mode, but for some reason it was stuck in "framing" mode and wouldn't let me switch to live-view. I didn't want to record in framing mode because it was really tough to figure out if the focus was right or not.
Is anyone else having this issue (of not being able to switch to live-view in anamorphic mode)?

clubsoda

  • New to the forum
  • *
  • Posts: 26
Re: Canon EOS M
« Reply #4311 on: August 02, 2020, 11:48:50 AM »
Cheers  ;)

berechiah

  • Freshman
  • **
  • Posts: 79
Re: Canon EOS M
« Reply #4312 on: August 04, 2020, 05:47:45 AM »
Hey guys
No sound when recording mp4

I tried go play around with the settings but I csnt figure it out

There is no sound when recording if I disable raw video

Any clues

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6861
Re: Canon EOS M
« Reply #4313 on: August 04, 2020, 06:01:33 AM »
Mp4? You mean MOV or can it record with both formats?
If on my build select h264 from the tap screen menu. What does it say in canon menu when you check for audio settings?
If still not solved do a screen recording of what's in your menus.

2blackbar

  • Senior
  • ****
  • Posts: 413
Re: Canon EOS M
« Reply #4314 on: August 04, 2020, 07:39:15 AM »
turn off fps override

berechiah

  • Freshman
  • **
  • Posts: 79
Re: Canon EOS M
« Reply #4315 on: August 04, 2020, 10:18:00 PM »
Mp4? You mean MOV or can it record with both formats?
If on my build select h264 from the tap screen menu. What does it say in canon menu when you check for audio settings?
If still not solved do a screen recording of what's in your menus.

Yes sorry .mov
yes its your latest build
the canon audio menu it is enabled
ill try that now

thanks again

berechiah

  • Freshman
  • **
  • Posts: 79
Re: Canon EOS M
« Reply #4316 on: August 04, 2020, 10:19:11 PM »
turn off fps override

ill try it now ty

HiphopMoment

  • New to the forum
  • *
  • Posts: 2
Re: Canon EOS M
« Reply #4317 on: August 05, 2020, 03:11:44 AM »
I'm sorry, my English is not very good.
I like eosm  It is very cheap, second-hand price in China is about 60-70 dollars, I have two.
Eosm if you use a new lens, its single touch focus is useful, as long as you don't use AF-s. So I think excuse me, how to cancel the touch screen out the menu。
So many people in China use the Magic Lantern, they would like to donate, but Bitcoin cannot be used in China。
eos m eosm2 6d 5d3

amitkattal

  • New to the forum
  • *
  • Posts: 8
Re: Canon EOS M
« Reply #4318 on: August 05, 2020, 12:37:52 PM »
Is it possible to have some sort of level indicator in eos m?. like to see if the camera is tilted or straight?

m300

  • New to the forum
  • *
  • Posts: 3
Re: Canon EOS M
« Reply #4319 on: August 06, 2020, 07:30:24 PM »
I seem to have lost HDMI output in Movie Mode only. I tried resetting the ML settings as well as the Canon settings and custom functions but still nothing. Any ideas?

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6861
Re: Canon EOS M
« Reply #4320 on: August 10, 2020, 10:30:01 PM »
New version:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

- Cropped real time preview with 3k and 4k modes

Quite epicly theBilalFakhouri gave us real time preview in higher resolutions. Have fun.

eXodus

  • Just arrived
  • *
  • Posts: 1
Re: Canon EOS M
« Reply #4321 on: August 11, 2020, 12:17:34 PM »
I really hope that someone knows a fix for this issue I'm having. I think it started happening ever since 2.5k got viable, so.. somewhere around fall of last year, I think? Whenever I try to record, my EOS M has to go through 3-6 failed attempts until it actually keeps going - then I can record for minutes without any issues, but this happens every time I boot up the camera and it gets really damn annoying. It also doesn't seem to matter which mode I'm in, but I usually record in 2.5k. I've been using several different builds (currently on 'Jul19') and my SD card is a Lexar Prof. 1667x SDXC-II v60, which is obv fast enough to handle the amount of data.

Things I've tried: Making sure that fps override and similar stuff is turned off / using the SD card warm-up feature (all the way up to the highest setting) / trying out a different SD card (some random Transcend v30) / turning off all the liveview features like zebras etc / using different fps settings / using those new SD card hacks / reinstalling ML

Nothing worked so far. Is this just plain and simple SD card incompatibility? Because the EOS M can't work with SDXC-II cards or something? I could try out one of those SanDisk Extreme Pro that people like to use~ But I wanna make sure that this is the exact problem before I throw my money out of the window if this doesn't fix anything, haha. Could it be that my camera is just faulty itself? Looking forward to any possible solution here~

Another minor question -- is it possible to automatically apply audio settings after startup? They always seem to default back to the standard values whenever I boot up the camera and I usually have to enter the canon menu, go into the audio settings and back out again for it to actually set the levels correctly. It's just a minor inconvenience compared to my main issue, but it would be neat.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6861
Re: Canon EOS M
« Reply #4322 on: August 11, 2020, 02:34:40 PM »
New version:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

- 2.8K preset added(only 2.39:1 and 2.35:1 but continuous). Also works with 25fps.

Thanks to real time preview in higher resolutions I decided to add a 2.8k preset. Pixel map files also updated.

Reachable here:


and here:



Possie

  • Just arrived
  • *
  • Posts: 1
Re: Canon EOS M
« Reply #4323 on: August 11, 2020, 05:41:15 PM »
Thank you !

Zeek was on it like a hawk


Emyoss

  • Just arrived
  • *
  • Posts: 1
Re: Canon EOS M
« Reply #4324 on: August 12, 2020, 04:56:31 AM »
Hi everyone, I'm a beginner in the world of photography and I'm having problems with the ML installed on my EOS-M. First of all :

I have installed and reinstalled several versions of ML but each time, it's impossible for me to shoot more than in "1080p" ( 1736x976 & 1736x738 ) in fact, when I shoot in 2k 3k 4k etc. the screen becomes weird full of glitch, well as I want to film in RAW ; it's a problem, but not the worst!

The real problm is : when I want to do the auto-focus by pressing the main button, the camera thinks I want to take a picture (even when I don't press it, half press) what happens then is the worst bug: the screen goes crazy, and it even happened that it doesn't want to restart before I remove the battery ...

Any help would be appreciated, if other people have had this kind of experience don't hesitate to tell me how you managed to fix it.


Specs :

My hardware: Canon EOS-M + Pancake Ef-M 22mm, SD card: SDXC SanDisk Extreme PRO 64 GB, 170 MB/s, Class 10, U3, V30.

My current version of ML: Last Danne's version