Author Topic: Canon EOS M  (Read 973345 times)

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6486
Re: Canon EOS M
« Reply #3175 on: July 25, 2019, 09:29:49 PM »
New version:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

- Pushed a few x5 zoom fixes when using x10 focus aid.

IkerKovach

  • Just arrived
  • *
  • Posts: 1
Re: Canon EOS M
« Reply #3176 on: July 25, 2019, 10:05:11 PM »
hi everyone! i am new here, sorry for language, i'm from russia.
i'm using Danne's magic lantern configuration from 23th of July on my eos m, and when i'm recording 24fps mv1080 2.35:1 12bit raw, loading this to mlvapp in order to get cDNG, after this i am loading this to after effects to make "detail preserving upscale" and colorgrade, after this i'am using final render to h.264 for youtube and i am getting video track and audio track the same lenght, but audio isn't synchronized with picture. I need to make video track with 80% speed and move my audio track a little bit. Its very annoying. Of course, i'am not using this audio in final video, but i need it to synchronize with my other micro and a few other cameras. In every step i'am using in settings 24 fps (from mlvapp to AE, from AE cDNG to h.264).
what should i change? what's my misstake?

Apxub

  • New to the forum
  • *
  • Posts: 4
Re: Canon EOS M
« Reply #3177 on: July 26, 2019, 03:26:09 AM »
New version:
Danne, please make fast on/off waveform with a button push (up/left/right)

ngemu

  • Freshman
  • **
  • Posts: 83
Re: Canon EOS M
« Reply #3178 on: July 26, 2019, 04:24:38 AM »
New version:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

- Pushed a few x5 zoom fixes when using x10 focus aid.


Hi Danne, just played around with the latest build and wow, lines are still there but greatly improved.  :)


before
https://imgur.com/ednpgDP

after
https://imgur.com/Z4HYsiT

MLV
https://drive.google.com/file/d/1Ly6kXM9noiQNhdSSoCvL_BK0asHhlMwy/view?usp=sharing

ZEEK

  • Senior
  • ****
  • Posts: 251
Re: Canon EOS M
« Reply #3179 on: July 26, 2019, 08:03:29 AM »
A few people are mentioning line streaks across the live view during 2.5k. I haven't experienced it myself. Maybe menu is to be double pressed each time before recording to set configuration.
EOS M - EOS M2 - 5D2

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6486
Re: Canon EOS M
« Reply #3180 on: July 26, 2019, 08:41:40 AM »

Hi Danne, just played around with the latest build and wow, lines are still there but greatly improved.  :)


before
https://imgur.com/ednpgDP

after
https://imgur.com/Z4HYsiT

MLV
https://drive.google.com/file/d/1Ly6kXM9noiQNhdSSoCvL_BK0asHhlMwy/view?usp=sharing

Did you try this suggestion? I really can´t say what´s causing your issue.
Interesting. Is it happening on every recording with this set up? If so you could test to find what is causing this. Maybe the villtrox, fps or something else.

Uploaded a new build with a few small changes.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6486
Re: Canon EOS M
« Reply #3181 on: July 26, 2019, 09:30:19 AM »
The sample was recorded with the following video settings:
PS override: 16 fps
Crop mode 3k, 3032x1436 (Is this 3k preset?)
RAW video: ON, 2736x1244

I tested a bit more with lower resolutions in both 2.5k modes with fps override on and off and it looked both clean. In 3k mode fps override off, didn't even showed a preview (only white screen). With fps override I get a frame preview.

Problem is fps override with no ratio set under crop med sub menu.
Expect unexpected results when using fps override and messing with reolutions in RAW video menu along with my presets in crop rec. I did not account for these conflicts but choose to keep fixed presets in crop rec.c.
In KlausH case building a fixed preset would be better.

KlausH

  • New to the forum
  • *
  • Posts: 4
Re: Canon EOS M
« Reply #3182 on: July 26, 2019, 09:34:08 AM »
Yes, 10x focus aid works fine now in 3.k mode  :D

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6486
Re: Canon EOS M
« Reply #3183 on: July 26, 2019, 09:56:40 AM »
but i need it to synchronize with my other micro and a few other cameras.
Filming with a micro?

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6486
Re: Canon EOS M
« Reply #3184 on: July 26, 2019, 10:52:21 AM »
Yes, 10x focus aid works fine now in 3.k mode  :D
Fixed now. New upload.

lightspeed

  • New to the forum
  • *
  • Posts: 36
Re: Canon EOS M
« Reply #3185 on: July 27, 2019, 11:44:58 PM »
anyone experience dark bands across the image. Only noticeable in dark areas.

DarkCAL

  • New to the forum
  • *
  • Posts: 9
Re: Canon EOS M
« Reply #3186 on: July 28, 2019, 05:21:07 AM »
@lightspeed Not here using ML build July26
Downloaded it yesterday without testing
Shot some footage today
I'll post some test footage

DarkCAL

  • New to the forum
  • *
  • Posts: 9
Re: Canon EOS M
« Reply #3187 on: July 28, 2019, 07:02:57 AM »
Test footage shot earlier today with my EOS-M anamorphic run & gun rig
New to ML, motion and anamorphic
But slowly getting there
Have to say that the EOS-M is an impressive performer
And thanks @Danne for all the effort
Impressive what you are doing !
This was shot using ML Build July26 in mv1080p rewire and upscaled to 4K
Plain RAW footage
Just added some sharpness



ricardopt

  • Member
  • ***
  • Posts: 110
Re: Canon EOS M
« Reply #3188 on: July 28, 2019, 11:24:32 PM »
Hi everyone, running the latest version here as of today, im having issues with 4.5k rewired or not, i followed some suggestions by Danne but i still cant have 16:9 or 2.39 clean footage without pink frames, can anyone share any "trick", some users said to use 2.35 aspect ratio, to me 2.35 is more of a "cinematic aspect ratio" not a "daily aspect ratio"

Thanks for any help with this

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6486
Re: Canon EOS M
« Reply #3189 on: July 28, 2019, 11:40:03 PM »
Use 5k anamorphic preset and set it to 2.39:1 ratio.
Also a fast sandisk card freshly formatted. Extreme pro or similar.

DarkCAL

  • New to the forum
  • *
  • Posts: 9
Re: Canon EOS M
« Reply #3190 on: July 29, 2019, 05:32:55 AM »
Problem of red dots solved !

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1561
Re: Canon EOS M
« Reply #3191 on: July 29, 2019, 07:51:25 AM »
The rest has the red dots
Never had problems with those before
Without a short sample (MLV) nobody can tell something about your red dots.
5D2.212 | EOSM.202

ctfire

  • New to the forum
  • *
  • Posts: 41
Re: Canon EOS M
« Reply #3192 on: July 29, 2019, 09:34:14 AM »
Test footage shot earlier today with my EOS-M anamorphic run & gun rig
New to ML, motion and anamorphic
But slowly getting there
Have to say that the EOS-M is an impressive performer
And thanks @Danne for all the effort
Impressive what you are doing !
This was shot using ML Build July26 in mv1080p rewire and upscaled to 4K
Plain RAW footage
Just added some sharpness








Hey, and what lens do you on this shot

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6486
Re: Canon EOS M
« Reply #3193 on: July 29, 2019, 10:43:12 AM »
New build:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

- startoff preset function to get fast into a working recording state(thanks Jip-Hop for feedback)

todo: Need help to assign a shortcut button into the preset menu. For instance select menu and open up the startoff menu by pushing INFO button. Any help here would be welcome.

Also: When assigning a startoff preset a few Crop mode menu items are modified. Exactly which check the Crop mode section before and after selecting or check in crop_rec.c code.





DarkCAL

  • New to the forum
  • *
  • Posts: 9
Re: Canon EOS M
« Reply #3194 on: July 29, 2019, 07:29:24 PM »
Hey, and what lens do you on this shot
EOS-M
Helios 44
Schneider Cinelux ES 2x
SLR Magic Rangefinder

Rookie in motion and ML
But we need to get going anyway
Steep learning curve

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6486
Re: Canon EOS M
« Reply #3195 on: July 31, 2019, 04:55:48 PM »
New build:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

- Enabling kill global draw when pushing halfshutter and using framing preview while recording. Hopefully helps a little when it comes to corrupted frames

This feature is automated and will be used whenever framing preview mode is enabled. @ricardopt might wanna try anamorphic modes with this version.

OlRivrRat

  • Hero Member
  • *****
  • Posts: 538
Re: Canon EOS M
« Reply #3196 on: July 31, 2019, 06:20:15 PM »
                     @ DarkCAL

"Helios 44
Schneider Cinelux ES 2x
SLR Magic Rangefinder"

           So which of these Pieces were used in this Vid example ?
ORR~DeanB  ~~  80D-ML  &  SL1+ML  &  5D2+ML  &  5DC+ML  &  70D+ML(AliveAgain)

guerchi

  • New to the forum
  • *
  • Posts: 13
Re: Canon EOS M
« Reply #3197 on: July 31, 2019, 09:45:54 PM »
Quote
New build:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

- Enabling kill global draw when pushing halfshutter and using framing preview while recording. Hopefully helps a little when it comes to corrupted frames

This feature is automated and will be used whenever framing preview mode is enabled. @ricardopt might wanna try anamorphic modes with this version.

If I understood correctly, with this version, can I, even with kill global draw on, see the framing preview by pressing halfshutter while recording? That sounds really good.
I was still using the Nightly.2019.Jul05.EOSM202 version
Because I use the 4k Anamorphic Rewired mode a lot and with the halfshutter I can have a Framing preview. And when shooting with kill global draw, I avoid the pink frames and I have real time preview to be able to focus, although I have to imagine the bottom part of the frame. In addition, that firmware version gave me a lot of stability with those modes.
Here is a video testing the modes and their versatility:
Amazing how it handles noise at ISO 800. No noise reduction was applied.
All tested modes are the most stable I have found.
The best in my opinion considering: crop factor, resolution, alaising, stability, is by far 4k ANAMORPHICS REWIRED

mv1080p 1736x976 46 / 48fps MODE is the only one that gave me 2 pink frames between all the shots.

The vignette is caused by the Crop lens added to the Viltrox speedbooster: Tamron 17-50mm F / 2.8

ricardopt

  • Member
  • ***
  • Posts: 110
Re: Canon EOS M
« Reply #3198 on: July 31, 2019, 10:11:23 PM »
Hi everyone, using the latest version as of today, selected the cinema 2.39:1 script, after the script finished i went on the the crop mode menu and recorded several videos using 2.35, 2.39 and 16:9 videos and all ofthem were pink frames free, i only previewed them om mlvapp but so far in over 20 videos none had pink frames.

i only changed the aspect ratio setting everything, all teh other settings were left as they were by default.

TOP QUALITY STUFF DANNE!!

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6486
Re: Canon EOS M
« Reply #3199 on: July 31, 2019, 10:11:58 PM »
@guerchi. It actually works as before but while pressing halfshutter it enables kill global draw. I just wanted to know if it gives some more headroom.
Also automated is kill global draw in high speed modes. 48fps really need kill global draw on.

@ricardopt
Good to hear :) They probably comes back when least expecting it ;)