Author Topic: Canon EOS M  (Read 1091904 times)

AF-OFF

  • Member
  • ***
  • Posts: 109
  • 50Dc EOSM
Re: Canon EOS M
« Reply #2425 on: March 15, 2019, 08:39:45 PM »
For 46fps preset, switch GlobalDraw=OFF. Otherwise you'll get much more corrupted frames.
For removing focus pixels use the latest focus pixel maps from dfort.

thank You masc
did turn on the new raw video submenu kill GD. did record several longer clips withous problems and almost without corruption (only 2 bad frames in several 1000 frames)
also  used with x3crop
I have installed the focus pixel maps from dfort

later I tested the 2.5k preset. at 2112x1188, 10bit lossless and 23,976 fps, without problems & after disabling the ratio of 16:9 in crop mode submenu, I increased the res in raw video submenu to 2520x1418 and did set fps override to 18fps, was able to record continuous, without any corrupted frames.

great Work Danne

 

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6924
Re: Canon EOS M
« Reply #2426 on: March 15, 2019, 08:47:24 PM »
Great, thanks for feedback. I might set 16:9 to 45 fps for better  takes and maybe corruption free. 1 fps decrease probably would go unnoticed anyway.
Af-off. If you could increase reg_6014 so you get 45fps and test for corruption it would be nice.

gravitatemediagroup

  • Member
  • ***
  • Posts: 242
Re: Canon EOS M
« Reply #2427 on: March 15, 2019, 10:03:32 PM »
@masc  was probably a couple different light sources, natural from a window, tungsten overhead, but no fluorescent.  I've tested all other builds from the past couple months in the same environment, with same shutter, but this is the first I've noticed this in the past couple builds.   

AF-OFF

  • Member
  • ***
  • Posts: 109
  • 50Dc EOSM
Re: Canon EOS M
« Reply #2428 on: March 15, 2019, 10:04:09 PM »
Af-off. If you could increase reg_6014 so you get 45fps and test for corruption it would be nice.

Yes Danne, I 've increased the reg_6014 to 1 and 4 but the recordings did have a bad frame each. then I increased to 15 and did a 1 min. recording at 44,457fps and everything is fine!

Is this normal, that after powering cam off and later back on these reg_ value is again 0 ?
Anyway, I will try this reg_ in 2.5k preset too, instead of using fps override.

Thanks much Danne
will report later

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6924
Re: Canon EOS M
« Reply #2429 on: March 15, 2019, 10:07:58 PM »
Yes. Turning off will reset regs. They are only for testing. Anyway. Are you sure finetuning to 45 fps isn't working?
By the way. If you set sd_uhs from crop mode sub menu and restart cam there's no longer need for sd_uhs.mo enabled.

AF-OFF

  • Member
  • ***
  • Posts: 109
  • 50Dc EOSM
Re: Canon EOS M
« Reply #2430 on: March 15, 2019, 11:17:13 PM »
@Danne - Disabled sd_uhs.mo
did test the 2.5k preset 2520x1412 10bit and adjusted the value of reg_6014 to 615 which gave me continuous at 18,028fps. value of 619 gave me 17,999fps, which was the closest to 18 I could get

all recordings where ok!

the value of 15 just worked for the mv1080p 46fps preset. isn't it better to have no bad images than an odd value of fps? will check this soon anyway, playing with this reg_6014 is fun somehow
 

AF-OFF

  • Member
  • ***
  • Posts: 109
  • 50Dc EOSM
Re: Canon EOS M
« Reply #2431 on: March 16, 2019, 12:29:49 AM »
Are you sure finetuning to 45 fps isn't working?

in mv1080p 46fps preset- with biggest res.
10bit, sd_uhs enabled, reg_6014 = 28 &
1736x976, 1:1, preview Real-time, crop rec preview = automode, kill GD ON, sound off
reg_6014 = 28 is 45.026 fps
reg_6014 = 29 is 44,993 fps -  250 frames with max res. , with resolution of 1600x900 up to 15 sec.two bad frames, with 1536x864 about 30 sec. everything good

so I did decrease the res. to record continuous to 1504x846 at 44,993 fps & formatted card
could record easily 2 mins. (5,79GB) took some time to watch it with playback speed in mlv app of 14.15 fps, no corrupted images.



Noticed cam gets much hotter in these high speed mode




Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6924
Re: Canon EOS M
« Reply #2432 on: March 16, 2019, 07:23:49 AM »
Ok, I see. You manually set ratio. Good to know it works. There is a fixed preset ratio 16:9 among the 46fps presets. I thought you were testing that. Is that one also working out of the box?
Sidenote. reg_6008 is also related to fps together with reg_6014.

AF-OFF

  • Member
  • ***
  • Posts: 109
  • 50Dc EOSM
Re: Canon EOS M
« Reply #2433 on: March 16, 2019, 03:22:48 PM »
yes, was working first with Your presets. then tried using own settings
as You have suggested.
If the ratio is set in crop rec submenu, either 16:9 or 2.35:1, the mlv resolutions are limited. as we know, some resolutions work only at ratios like 1:2 or 1:1, right?
I like the new x3crop for the mv 1080p modes. This is because I like to use some c-mount glass sometimes. Therefore I like also the most the 2.5k preset. in the max possible res, I get a nice fov with the 12,5mm one.
the MCM mode is also very nice if using non c- mount glass.

will do some more testing and comparing the footage.

thank You very much for this good work Danne

AF-OFF

  • Member
  • ***
  • Posts: 109
  • 50Dc EOSM
Re: Canon EOS M
« Reply #2434 on: March 16, 2019, 03:25:04 PM »
I thought you were testing that. Is that one also working out of the box?
Sidenote. reg_6008 is also related to fps together with reg_6014.

Yes, out of box, but as macs mentioned, disabling GD is essential to ged rid of corruption in frames.
Will take the other register into account, thanks!

AF-OFF

  • Member
  • ***
  • Posts: 109
  • 50Dc EOSM
Re: Canon EOS M
« Reply #2435 on: March 16, 2019, 05:07:02 PM »
further testing, Danne's march14 build
->scripts - eos cinema 2.35:1, activates 5k preset
res is now 1504x1390, preview changed to real time, kill GD on, soundrec. off
->canon menu, format card
crop mode menu - 10bit, 2.35:1, sd_uhs enabled, reg_6014 =19, reg_6008 =20,reg_6800_height =950 <-----this centers the realtime preview
can't get continuous, so ->prefs,config options, ->restore ML defaults
after restart, in modules activated crop-rec,lua,mlv lite, mlv sound, sd-uhs, silent
-> Overlay,magic zoom to off
after restart, formated card again from canon menu
raw video menu, sound off, Kill GD ON
crop mode menu - 12bit, 16:9, disable 25fps, sd_uhs ON, restart
checking - ->Debug , Memory Patches - 4rom 2ram, crop_rec & sd uhs, sdr104
recording MCM video, continuous at 42MB, 20% idle, recording OK
changing preset to 5k , and restarting cam
unchanged entries in crop mode menu
raw video menu - 1184x2000, 1:2, real-time, kill GD
recording (shows now 3.5k anamorphic) continuous, 47MB, 32% idle, recording OK
changing crop rec reg_6800 to 950 again
now somehow the res did change, to 1184x1050 - don't know why, clips ok, did use ca. 37MB write speed at 37% idle

so far, will do some more testing later
thanks to Danne and all others






AF-OFF

  • Member
  • ***
  • Posts: 109
  • 50Dc EOSM
Re: Canon EOS M
« Reply #2436 on: March 16, 2019, 10:19:53 PM »
interestingly, still using Danne's march14build, I found something interesting in 5k preset.
crop mode changes: bitdepth 10bit, ratios OFF, x3crop enabled, sd_uhs still enabled
raw video changes : Preview Framing, crop rec preview - automode, Resolution 1664x2126 , unchanged also kill GD & aspect ratio of 1:2 & sound OFF

tried recording, the liveview got scrambled, but recording went on, tried with Preview-Frozen LV, nothing, restarting cam (have also to change the battery which shows the red sighn since 15 minutes....

after power up, 12bit, thought to have changed it to 10bpp, will check , but now the indicator inLV reads 5k anamorphic instead of 3.5k before res change. did change the bpp to 10 and the reported res is still 1668x2126

after restart tried another recording, which got everythime scrambled while recording some frames and then restored back the Framing preview
so decided to go down as much as 11 fps for the next shot
activated fps override and set the framerate to 11 and optimized for Exact fps. Then most importantly I switched ->Overlay - GD to off. this gave me the scrambled LV (back)
the recording kicked in at 39.5MB, so recorded a minute and then did change following : crop mode - bitdepth to off (was 10bpp)
so now this was 14bit lossless as its default in raw video, preview still scrambled, did another recording, which on second attempt jumped from the start in continuous at 51,2MB and recorded almost 2mins (i've stopped it, green light all time)

now time to check the files in mlv app
and yes, all clips are fine, but the best is the one with 14bpp lossless. if anyhow, You don't rely on fps, this is very nice image at 4992x2126 - maybe I missed the boat, but this is the biggest resolution I've ever seen on the old eosM.

any suggestions





Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6924
Re: Canon EOS M
« Reply #2437 on: March 16, 2019, 11:03:52 PM »
A lot of stuff going on here  :P
You are right about biggest resolution for eosm. I works with framing mode so global draw needs to be on. While recording.
Easiest access is to run the cinema script then turn off the ratios in crop mode sub menu. RAW video always 14bit lossless. Set to 10bit in crop mode sub menu.

AF-OFF

  • Member
  • ***
  • Posts: 109
  • 50Dc EOSM
Re: Canon EOS M
« Reply #2438 on: March 17, 2019, 08:17:58 PM »
A lot of stuff going on here  :P
You are right about biggest resolution for eosm. I works with framing mode so global draw needs to be on. While recording.
Easiest access is to run the cinema script then turn off the ratios in crop mode sub menu. RAW video always 14bit lossless. Set to 10bit in crop mode sub menu.

nice thanks Danne,
it works!
I've noticed, its usefull to format card before beginning a new session with each card. just deleting the file on pc isn't enough. cards seem to perform worst without.
so first deleted all configs (restore ML defaults), then formatted card in canon menu
activated crop rec, lua, mlv lire and sound, sd uhs and silent
disabled magic zoom and restarted cam
->Scripts-eosm cinema
now I have in LV 12bit 4.5k anam. framed preview
in crop rec enable x3crop and sd_uhs
in raw video cannot change res any higher than 1624x1160, sound recording to off,
restart the cam
ok now LV tells me 10bit, 5k anamorphic, Framing
but just before the framing preview kicks in, there is the familiar white magenta black scrambled LV for short time
going to ML menu (again shorttime scrambled)
first checking the debug menu, 4rom 2 ram patches executed
in movie menu
raw video shows now res of 1624x2126
able to increase manually to 1664x2126, so now I dont use the kill GD
wow, now the preview gets Framing and B/W while recording
it records 5 and 7 seconds.
now I want to test something
in raw video menu I change the resolution to 1280x2126, where the info text at bottom changes to green, leaving menu
can record continuously for 1min.
now because I'm using a c-mount glass and thus seeing the crop isn't centred, I go to the crop rec menu and trying to change the reg_6800 to 800 and this breaks the preview and limits the vertical res to 1326 , so I set the reg_6800 back to 0 and restart cam
so now everything is back again

reducing image width makes in some resolutions the preview jump, so there would be probably corrupted frame(s).

let's look at clips so far in mlv app
at 1184x2126 there are some bad frames
at 1168x2126 the images are somewhat jumping to the left, as it was in LV be seen
at 1232x2126 bingo! please test this one, no corrution
at 1200x2126 as notived while recording, jumping around
at 896x2126 (which makes it almost rectangular, the same as with 1168 and 1200 previously
at 960x2126 bingo, please test this one (looks similar to 4:3 aspect ratio, like this somehow)
at 1008x2126 bingo again, this looks more 3:2 isch
at 1280x2126 only 4 bad frames out of 1511, this looks like 16:9, although for a c-mount glas, this is much to high res, see pic below
at 1664x2126 bingo

somehow the center alignment isn't right. and reg_6800 doesn't on it alone do the job
anyway, this build is great for further experimentation with


thanks to Danne and others 








AF-OFF

  • Member
  • ***
  • Posts: 109
  • 50Dc EOSM
Re: Canon EOS M
« Reply #2439 on: March 18, 2019, 02:56:49 AM »
did test all resolutions with the 5k preset, all recordings at 10bit lossless, 23,976 fps
each recording if not stated otherwise around 500 Frames, 50GB total

resolution - behavior during recording - playing in mlv app (OK means no damaged frames)

640x2126 - LV jumps during recording, ML console comes up, restarted, jumps
656x2126 - LV seems undisrupted during rec. , 2 bad images at beginning
672x2126 - LV seems undisrupted during rec. , 1 bad image
688x2126 - LV seems undisrupted during rec. , 1 bad image
704x2126 - LV jumps once after starting recording, jumps
720x2126 - LV jumps once after starting recording, some bad frames
736x2126 - LV jumps once after starting recording, 3 bad frames at beginning
752x2126 - LV seems undisrupted during rec. , some bad images , jumps
768x2126 - LV jumps during recording, ML console comes up, restarted, jumps
784x2126 - LV jumps several times after starting recording, jumps
800x2126 - LV seems undisrupted during rec. , 4 bad frames
816x2126 - LV two bad frames then seems undisrupted during rec. , some bad images
832x2126 - LV seems undisrupted during rec. , OK
848x2126 - LV two bad frames then seems undisrupted during rec., 3 bad fr. at start
864x2126 - LV one bad frame then seems undisrupted during rec. ,  1 bad fr. at start
880x2126 - LV jumps once after starting recording, OK
896x2126 - LV jumps during recording, many bad trames
912x2126 - LV seems undisrupted during rec. , OK
928x2126 - LV seems undisrupted during rec. , OK
944x2126 - LV two bad frames then seems undisrupted during rec. , 2 bad frames
960x2126 - LV two bad frames then seems undisrupted during rec. , jumping frames
976x2126 - LV two bad frames then seems undisrupted during rec. , 2 bad frames
992x2126 - LV two bad frames then seems undisrupted during rec. , jumping frames
1008x2126 - LV jumps during recording, 2 bad frames
1024x2126 - LV seems undisrupted during rec. , OK
1040x2126 - LV seems undisrupted during rec. , OK

battery is hot, make a small break

1056x2126 - LV jumps during recording, some bad frames
1072x2126 - LV jumps 4x after starting recording, jumps at beginning
1088x2126 - LV jumps during recording,  jumps
1104x2126 - LV seems undisrupted during rec., OK
1120x2126 - LV seems undisrupted during rec. , OK
1136x2126 - LV jumps 1x after starting recording , jumps once then ok
1152x2126 - LV jumps during recording, jumps
1168x2126 - LV seems undisrupted during rec. , 2 bad fr. at end
1184x2126 - LV seems undisrupted during rec., OK
12oox2126 - LV seems undisrupted during rec., OK
1216x2126 after switching to this res, LV broken, restarting cam,
everything works again but recording jumps around, jumping all over
1232x2126 - LV jumps during recording, jumps around
1248x2126 - LV jumps 1x after starting recording, one jump at beginning
1264x2126 - LV seems undisrupted during rec. , OK
1280x2126 - LV jumps once during recording, one bad frame
1296x2126 - LV seems undisrupted during rec. , one bad frame
1312x2126 - LV seems undisrupted during rec. , OK
1328x2126 - LV jumps heavily during recording, strong jumping
1344x2126 - LV seems undisrupted during rec. OK
1360x2126 - LV jumps 1x after starting recording, one bad frame
1376x2126 - LV seems undisrupted during rec., OK
1392x2126 - LV jumps heavily during recording, jumps
1408x2126 - LV jumps heavily at beginning recording, jumps heavy at first third
1424x2126 - LV jumps twice laggy after starting recording, jumps
1440x2126 - LV seems undisrupted during rec. , one bad frame

cam temp reaches 50°C, making a break, batt. hot

1456x2126 - (first rec stop), then   LV seems undisrupted during rec., OK
1472x2126 - LV seems undisrupted during rec. , OK
1488x2126 - LV seems undisrupted during rec. , OK
1504x2126 - LV seems undisrupted during rec. , continuos for 26sec., OK
1520x2126 - LV seems undisrupted during rec. , continuos for 21sec., OK
1536x2126 - LV seems undisrupted during rec. , continuos for 15sec. OK
1552x2126 - LV seems undisrupted during rec. , continuos for 14sec. OK
1568x2126 - LV seems undisrupted during rec. , continuos for 14sec. OK
1584x2126 - LV seems undisrupted during rec. , continuos for 12sec., one bad fr.
1600x2126 - LV seems undisrupted during rec. , continuos for 11sec. one bad fr.
1616x2126 - LV seems undisrupted during rec. , continuos for 9 sec.OK
1632x2126 - LV seems undisrupted during rec. , continuos for 7 sec. jumping
1648x2126 - LV seems undisrupted during rec. , continuos for 8 sec one bad fr.
1664x2126 - LV seems undisrupted during rec. , continuos for 6 sec.., jumping




Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6924
Re: Canon EOS M
« Reply #2440 on: March 18, 2019, 09:37:05 AM »
Are you testing by using raw video ratios? The first 5k option is really just a proof of concept and unlike the other two ratios real time preview is not working while recording.
There are four skip regs to play with as well in crop mode sub menu. Maybe works too. (Called skip_left, skip_right etc)

SGrim

  • Just arrived
  • *
  • Posts: 1
Re: Canon EOS M
« Reply #2441 on: March 18, 2019, 01:48:58 PM »
Been researching n days about RAW on EOS M, and the more info had found the more questions had raised. Some of them (maybe) can be solved by buying camera and trying out ML myself, but because i’m a little bit poor, i need to know before buying that it’s worth it. So a few questions/thoughts about RAW on EOS M, and if i misunderstood something – feel free to correct me.

1) 2.5k RAW (in which i'm interested most) can be recorded in 3.33x “crop mode” which makes lenses focal length three times more (for example, 10 mm lens =~33 mm in 35mm equivalent).
2) LiveView is working fine most of the time.
3) Crop factor of LiveView is only 5x due to some unavoidable restrictions (it cannot be 3, for example).
4) EOS M itself seem to have no limitations to SD card capacity, so any card up to 2 TB (SDXC format limit, but in terms of money saving i would probably buy 256 GB) can be used.
5) Could it be a better thing to use V60/V90-alike cards so sustain write speed would be closer to ~70 MB/s ML RAW than SanDisk Extreme Pro (which is V30 class)?
6) My main question. Is EOS M config is reliable for real continuous shooting for more than hour or two in any weather conditions (lets say up to +35 degrees Celsius in terms of possibility of overheating)?

I understand that 5D or 7D is most obvious choice for stability, but they cost half of my car - going over 200ish$ for body is not an option at all.

Thanks in advance.

(probably should have created a separate topic in RAW "subforum" but general thread seems to be more or less right for what kind of answers i'm looking for)

AF-OFF

  • Member
  • ***
  • Posts: 109
  • 50Dc EOSM
Re: Canon EOS M
« Reply #2442 on: March 18, 2019, 02:08:39 PM »
I have shut ratios to OFF in crop menu, otherwise all the resolutions shouldn't be possible.
reg_skip_top destroys the colors, reg_skip_bottom cuts portions of the image.

my idea was to use the 5k preset as supplement to 2.5k preset - in the latter max res is 2520x1418, which is 16:9 but cannot roll at 23,976 fps, but with the 5k preset set to 1264x2126, which is the closest to 16:9 can record with 23,976 fps.

2126 x 1,77 = 3763,02 / 3 = 1254,34 and the closest I've found stable would be then 1264x2126




 

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6924
Re: Canon EOS M
« Reply #2443 on: March 18, 2019, 02:29:25 PM »
I see. Well keep on testing  8)

AF-OFF

  • Member
  • ***
  • Posts: 109
  • 50Dc EOSM
Re: Canon EOS M
« Reply #2444 on: March 18, 2019, 03:01:25 PM »
I see. Well keep on testing  8)

Yes will do! I've noticed and downloaded Your new build - march 18 - any news on the new version?

as ever thanks a lot for the great work !

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6924
Re: Canon EOS M
« Reply #2445 on: March 18, 2019, 03:13:02 PM »
You can check commits. I added some black level fixes for previewing while recording reduced bitdepths. Still a halfway solution...

AF-OFF

  • Member
  • ***
  • Posts: 109
  • 50Dc EOSM
Re: Canon EOS M
« Reply #2446 on: March 18, 2019, 03:29:38 PM »
5k preset
reg_skip_right   -70
reg_skip_top     -100 <---- when doing this, there is white border on top
raw video resolution 1264x2126
recording continuous for 30 sec. max....





in mlv app, the resolution is shown as 1264x2236 , seems the reg_skip_top had changed this somehow.... see picture

I've found a good res that works for me - 1024x1728, records a clean video continuous and suitable for mount-c glass





gravitatemediagroup

  • Member
  • ***
  • Posts: 242
Re: Canon EOS M
« Reply #2447 on: March 18, 2019, 08:44:19 PM »
The greenish tint in liveview while recording is gone! now it looks like a vintage 70's LUT, which is fine by me.  :P

marcelo.lippi

  • New to the forum
  • *
  • Posts: 15
Re: Canon EOS M
« Reply #2448 on: March 18, 2019, 11:13:06 PM »
I was able with the March 14 version to work very well with 4.5k at 24 and 25 fps, one minute without corrupt files. Now I have replaced with today's version and when I start recording the monitor turns white or pink. I can't understand the vertical definition that sometimes stands at 2120 and others at 1920. Maybe I should re-install the previous one.
Thank you for all

marcelo.lippi

  • New to the forum
  • *
  • Posts: 15
Re: Canon EOS M
« Reply #2449 on: March 18, 2019, 11:43:11 PM »
maybe i'm going crazy? in the bitbucket download area I can't find a March 14 version ... did I dream about it and am I awake now?