Author Topic: Canon EOS M  (Read 1095365 times)

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6933
Re: Canon EOS M
« Reply #2350 on: February 26, 2019, 08:11:05 AM »
This is what I do.
MLVApp searchs for fpm files first. If it doesn't find one, it uses internal code. If it finds a fpm file, it uses the file. So just copy your fpm next to the executable (.exe on Win, executable inside App package on OSX) and have fun. This will override internal code for this setting.
Bloody ace! Great to hear and have.

IDA_ML

  • Hero Member
  • *****
  • Posts: 864
Re: Canon EOS M
« Reply #2351 on: February 26, 2019, 12:49:17 PM »
The 100D tests are 100% at this point.

Dfort,

I did test quite extensively your FP maps from February 20-th on the 100D and also performed several stress tests in all modes as you requested.  Did not find any problems with them.  They all seem to work quite well with MLVFS. 

I will do more tests with the latest reworked FP maps that you posted yesterday.  But this will take some time.  Please be patient.

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3751
Re: Canon EOS M
« Reply #2352 on: February 26, 2019, 05:38:24 PM »
Ok--all sample MLV's are working with the latest map files. Feel free to continue testing focus pixel free. Well, at least until you come up with yet another setting that needs attention.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

uy scuti

  • New to the forum
  • *
  • Posts: 2
Re: Canon EOS M
« Reply #2353 on: February 26, 2019, 07:15:05 PM »
Friends, tell me who knows, I can not set a long exposure at 25 fps, 1/60, it can be done but only at 25,002 fps, what am I doing wrong?
shooting mode:mv1080p 1736x1158
Sorry for my English

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6933
Re: Canon EOS M
« Reply #2354 on: February 26, 2019, 09:29:32 PM »
 Ah, handcrafted map files. Appreciated. Will run tests soon. Thanks.
Here are test files if anyone wants to have a look:
https://bitbucket.org/Dannephoto/magic-lantern/downloads/focus_pixel_MLV_all_presets_eosm.zip

There could be one or three files not working since I changed offsets a few times. Most files should work.

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3751
Re: Canon EOS M
« Reply #2355 on: February 27, 2019, 01:13:41 AM »
The only one that still has a problem is 01_anamorphic. Strange, worked on that one and thought I had it. The map file fits perfectly so something weird is going on.



[EDIT] Just tried it with with dcraw and the map file is working perfectly. Anyone care to try it out? From Danne's samples in the focus_pixel_MLV_all_presets_eosm.zip package located on his Bitbucket downloads page look in the first_batch folder and run this on the 01_anamorphic.MLV file:

Code: [Select]
mlv_dump --dng --no-fixfp 01_anamorphic.MLV file
./mlv2badpixels.sh -v 01_anamorphic.MLV
dcraw -T -P EOSM_anamorphic_1664x2126.txt 01_anamorphic_000000.dng

The mlv2badpixels.sh script is located in the ML Focus Pixels repository in the scripts_archive directory. It takes the full raw buffer map file and trims it to the same size as the image so it can be run through dcraw. Note that I modified that old script to recognize the new crop_rec settings as best as possible using what we know about raw buffer dimensions.

In any case, why isn't this map file working in MLVFS and MLV App?

[EDIT 2] Oops -- my mistake. I must have not updated the focus pixel map file in the apps before testing. All good, all settings are now focus pixel free. You can still try the dcraw exercise, interesting how different apps can use these map files.

BTW--Kudos for the MLV App developers for supporting .fpm files and properly handling 1x3 sampling.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3751
Re: Canon EOS M
« Reply #2356 on: February 27, 2019, 02:58:51 AM »
Going through all these new crop_rec settings for the EOSM there is one really interesting setting @theBilalFakhouri put into his 700D version that uses the entire sensor area as the full raw buffer. I made a fpm file for this setting though I haven't seen a sample on the EOSM yet. This post just jogged my memory about that setting.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

MADagain

  • New to the forum
  • *
  • Posts: 2
Re: Canon EOS M
« Reply #2357 on: February 27, 2019, 04:27:50 AM »

Why don't you just give a try at least with today's build from @Danne's bitbucket page?  :P

Link... please?

I tried the current nightly and for what I need like magic focus or the overlays... don't seem to work at all.

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3397
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Canon EOS M
« Reply #2358 on: February 27, 2019, 06:56:36 AM »
Link... please?

Perhaps try scrolling up two post above yours.

and please bookmark his Bitbucket downloads page while you’re at it.
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6933
Re: Canon EOS M
« Reply #2359 on: February 27, 2019, 07:50:10 AM »
@dfort
Very nice work dfort. Tested my files regarding focus pixels and all seemingly worked. Next up some real life testing.

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1691
Re: Canon EOS M
« Reply #2360 on: February 27, 2019, 08:04:25 AM »
Link... please?

I tried the current nightly and for what I need like magic focus or the overlays... don't seem to work at all.
In version from Danne magic focus and overlays work fine. I use them every day.
5D3.113 | EOSM.202

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 7584
Re: Canon EOS M
« Reply #2361 on: February 28, 2019, 05:11:25 PM »
Friends, tell me who knows, I can not set a long exposure at 25 fps, 1/60, it can be done but only at 25,002 fps, what am I doing wrong?
shooting mode:mv1080p 1736x1158
Sorry for my English

Build used?

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6933
Re: Canon EOS M
« Reply #2362 on: February 28, 2019, 06:21:37 PM »
New build:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

Managed to eliminate a few stubborn hot/cold pixels on my screen by tweaking cmos 4.
Code: [Select]
/* all presets */
if (is_EOSM)
{
/* hot/cold pixels. Usually 0x2. 0x34 to be tested */
        cmos_new[4] = 0x34;
}

Not sure how this will affect other eosm cameras but please test and see. The change is applied to all presets. If you have hot/cold pixels on your screen they might dissappear now. If you don´t have them check so nothing breaks the recording(should be safe).

cmos 4 0x2


My three hot friends.


Not easy to see but looks like this:


After the change to cmos4 was applied:
cmos 4 0x34



uy scuti

  • New to the forum
  • *
  • Posts: 2
Re: Canon EOS M
« Reply #2363 on: February 28, 2019, 06:36:56 PM »
Build used?
Used build Danne:
EOS M ML Build 4K Crop Rec 1x3 12th Feb

Larouso

  • New to the forum
  • *
  • Posts: 12
Re: Canon EOS M
« Reply #2364 on: February 28, 2019, 09:37:43 PM »
Not directly. Download 80000331_1872x1190.fpm from dfort's repos and copy it next to executable (.exe on Win, on OSX executable inside app package). MLVApp will recognize this file and use it.

Hi everyone,
just received the eos M last weekend - and spent already countless hours here reading through the stuff :) You are doing such great work. Thanks a hundred times to everybody contributing so far!

My question is:
I downloaded the 80000331_1872x1190.fpm from dforts bitbucked, placed the file next to the exe. Now whenever I open up a 1080p MCM rewire clip, the video in MLV app stays black, as soon as I hit play it crashes.
Other crop modes are not affected - so it seems to me map file is recognized, but something is going wrong then. Am  doing something ovious wrong?  Used Dannes latest build, but it`s the same with the other ones that I already tried.

Thanks for any hints.



Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 6933
Re: Canon EOS M
« Reply #2365 on: March 01, 2019, 12:21:14 AM »
Could you upload a sample MLV that you can confirm is crashing also after you shorten it?

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3751
Re: Canon EOS M
« Reply #2366 on: March 01, 2019, 02:24:58 AM »
This reminds me, a few (or is it just one) of the samples will trigger a segfault on mlv_dump when creating dng files with or without the --no-fixfp option. Same file works fine on MLV App and MLVFS. Got to dig through the files to find the trouble file.

[EDIT] Here are the problem files:

Code: [Select]
MLV Dumper
-----------------

Mode of operation:
   - Input MLV file: '013_4K 4038x2558.MLV'
   - Using output path '013_4K 4038x2558_' for DNGs
   - Convert to DNG frames
   - Output into '013_4K 4038x2558_'
File 013_4K 4038x2558.MLV opened
File 013_4K 4038x2558.M00 not existing.
Processing...
Segmentation fault: 11

 MLV Dumper
-----------------

Mode of operation:
   - Input MLV file: '015_4K 4038x2558_169.MLV'
   - Using output path '015_4K 4038x2558_169_' for DNGs
   - Convert to DNG frames
   - Output into '015_4K 4038x2558_169_'
File 015_4K 4038x2558_169.MLV opened
File 015_4K 4038x2558_169.M00 not existing.
Processing...
Segmentation fault: 11

I also wrote a post on how to get rid of your hot pixel "friends" in post -- by modifying the focus pixel map file.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1691
Re: Canon EOS M
« Reply #2367 on: March 01, 2019, 08:08:45 AM »
@Larouso: I tried to reproduce, also on windows. But here it works fine for my MCM rewire testclip and this fpm file. So I need your MLV file (maybe shortend is enough, please try) to debug. Maybe some more info would be nice to have too (which windows, which MLVApp version (32bit, 64bit, v?.?).
5D3.113 | EOSM.202

Larouso

  • New to the forum
  • *
  • Posts: 12
Re: Canon EOS M
« Reply #2368 on: March 01, 2019, 06:49:16 PM »
I uploaded short MLV file that does not work on my site as long as I have the map file placed in the same folder as the exe. If I relocate the map file the mlv is opened up just fine.
https://ln.sync.com/dl/6f7dff240/wf93hqtf-xde3ktj4-p8enfdfb-4737m5qh
(hope sharing the mlv in that way is all right) - 12.4 MB

I`m using win 10, MLV 1.5; 64 bit version (MLV.App.v1.5.Win64.static.zip)
Let me know if I can provide any further info.

Thanks a lot for looking into it.

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3751
Re: Canon EOS M
« Reply #2369 on: March 01, 2019, 08:55:49 PM »
@Larouso - Your file works fine over here and the focus pixel map file is also working. MLV.App.v1.5.OSX.zip on macOS Mojave 10.14.3.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1691
Re: Canon EOS M
« Reply #2370 on: March 02, 2019, 10:24:42 AM »
@Larouso: thanks for the file. No problem on OSX here (10.9). Have to wait some days until I can test on a windows system. Have you tried 32bit build? Does it crash too, if you do the same? I tried with one of my files on 32bit windows version yesterday and it worked fine.
5D3.113 | EOSM.202

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3397
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Re: Canon EOS M
« Reply #2371 on: March 02, 2019, 10:53:54 AM »
MLV App 1.5 vs MLV App compiled (Mojave 10.14.3) on 3/2/2019 shows @dfort's magic w his latest focus pixel map files FTWAC...


5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

Larouso

  • New to the forum
  • *
  • Posts: 12
Re: Canon EOS M
« Reply #2372 on: March 02, 2019, 02:00:08 PM »
@Larouso: thanks for the file. No problem on OSX here (10.9). Have to wait some days until I can test on a windows system. Have you tried 32bit build? Does it crash too, if you do the same? I tried with one of my files on 32bit windows version yesterday and it worked fine.

@masc/dfort:
Alright, then it seems the problem is on my PC - or in front of the PC :) ... thanks for looking into it anyway!
I will also check out the 32 BIt Version as well and give feedback.

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1691
Re: Canon EOS M
« Reply #2373 on: March 02, 2019, 03:43:38 PM »
@masc/dfort:
Alright, then it seems the problem is on my PC - or in front of the PC :) ...
:) Don't think so. No matter what you do - MLVApp should not crash. Especially on Windows we have the biggest problem. For every smallest bug in MLVApp, on Windows it crashs, on OSX it is more tolerant.
5D3.113 | EOSM.202

Larouso

  • New to the forum
  • *
  • Posts: 12
Re: Canon EOS M
« Reply #2374 on: March 02, 2019, 09:59:20 PM »
:) Don't think so. No matter what you do - MLVApp should not crash. Especially on Windows we have the biggest problem. For every smallest bug in MLVApp, on Windows it crashs, on OSX it is more tolerant.

In fact it works under the latest (v1.5) 32bit version of MLV App. I can load the file, edit it, export it, go frame by frame... how ever occasionally also MLV 32 bit crashes if I hit play.