Author Topic: Canon EOS M  (Read 847328 times)

Jonit

  • New to the forum
  • *
  • Posts: 38
  • EOS M | 700D
Re: Canon EOS M
« Reply #2175 on: February 13, 2019, 08:07:45 AM »
there is also another issue with dual iso. i couldn't end up with a video that doesn't flicker when dual iso is on. i tried various iso combinations with still shots and moving camera and it always flickers without any color adjustments. tested 1x3 mode and mv1080 (in which i'm well aware of having smooth videos before). i'll try again tomorrow though.
I'm also having problem with flickering DualISO shots. It flickers ocasionaly on some shots through out the entire clip. But I noticed that on many clips there is flickering in the last second of video or so..

I will upload the file later.

Jonit

  • New to the forum
  • *
  • Posts: 38
  • EOS M | 700D
Re: Canon EOS M
« Reply #2176 on: February 13, 2019, 06:44:48 PM »
@Danne - here is the MLV DualISO file that is flickering - https://mega.nz/#!6ZtH2YiD!qf_-i6sM8Mc9Lp88x80-U_g_m9chrmriQEmMAZq95wA

zabenoid

  • New to the forum
  • *
  • Posts: 3
Re: Canon EOS M
« Reply #2177 on: February 13, 2019, 07:35:26 PM »
Hi! I have a problem: I'm trying to do silent-film style fps pitch, in music video. Electricity is 50hz so i need to shoot 25fps. So i need to pitch backing music and i maybe need 37 or 38 fps for that and slow it to 25, then play slowed down music to get lip sync, then pitch up the footage back to 37 or 38. (or use led lamps and shoot 16 and pitch to 24). So: i need working FPS override AND some ML version to get my camera to record faster in SD card, am i correct? I can only get to a bit over 31 fps with regular build.
Which build i need to use?
Help!

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5902
Re: Canon EOS M
« Reply #2178 on: February 13, 2019, 07:47:57 PM »
You can start reading from here @zabenoid:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

You can get fps up to 45 in mv1080p 16:9. This means you will be able to decrease from 45 to 37 fps which makes it even better for continuous shooting. 25 fps is also working.


@Jonit
What were your settings when exporting this file? What program was used to process? Mlv App? Did you compile it yourself? Official download? You could also try sharing the file in the Mlv App thread since I suspect there is something with conversion which can cause this. Lastly. Did you try exportingthe MLV into dng files instead of exportting to mov file? If the dng files are processed ok then we could suspect either post processing sliders or something in dual iso/Mlv App code.

Edit: I exported the file and can confirm small flicker. Try exporting to dng and see if that works better...Still some micro flicker. I think if anyone can draw a good conclusion here it would be bouncyball.

optical-work

  • New to the forum
  • *
  • Posts: 17
Re: Canon EOS M
« Reply #2179 on: February 13, 2019, 08:38:13 PM »
i think x3zoom has no effect on anamorphic mode but distance parameter is placed, just gone when dual iso is on. sorry, i missed that. @Danne.

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5902
Re: Canon EOS M
« Reply #2180 on: February 13, 2019, 08:49:14 PM »
Correct. x3 is applied to the mv1080p presets. Not really useful for anamorphic and the mv720p 50fps mode.

zabenoid

  • New to the forum
  • *
  • Posts: 3
Re: Canon EOS M
« Reply #2181 on: February 13, 2019, 09:38:27 PM »
Ok, thanks @Danne!
Now, about shutter speed, i'm confused... let's say i shoot 18 fps, so how do i get to set it to about 36, to follow 180 rule? Looks very complicated!

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5902
Re: Canon EOS M
« Reply #2182 on: February 13, 2019, 09:42:27 PM »
I have no idea. I think though, using fps override decreasing fps is working better than increasing from my presets. Or you could increase or decrease reg_614 to adjust fps.
Maybe someone else can help further. Good luck.

liuk718

  • New to the forum
  • *
  • Posts: 6
Re: Canon EOS M
« Reply #2183 on: February 14, 2019, 06:54:27 PM »
being comparison 2.5k 30fps and 5k anamorphic 24fps(2:35:1 on),i choosed 5k anamorphic mode fianlly,it's low noise and very nice quality that i need.thanks danne!

optical-work

  • New to the forum
  • *
  • Posts: 17
Re: Canon EOS M
« Reply #2184 on: February 14, 2019, 07:56:27 PM »
here, two consecutive 5 seconds shots of a wall, frame is fixed, dual iso is on. i tried them with mlv app and mlvfs, both flickers.

400/800 iso: https://we.tl/t-BYPZmQ9bqC

200/800 iso: https://we.tl/t-ZSFpZKR5Bk

there is also one without dual iso if needed: https://we.tl/t-iNi04I5DFY


Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5902
Re: Canon EOS M
« Reply #2185 on: February 14, 2019, 08:29:29 PM »
Any conclusions? Is it also happening when using base iso 100?
I´ve seen slight variations in colr/white balance causing flicker. Cannot find the post about it but I´m sure a1ex knows what´s going on.

the_real_bill_jones

  • New to the forum
  • *
  • Posts: 4
Re: Canon EOS M
« Reply #2186 on: February 15, 2019, 04:50:37 AM »
I've been trying to shoot with the mv1080 preset in x3 crop mode, but the framing in the preview is all wrong. It's squished and doesn't show the whole frame that's being recorded. When I view the file on my computer, it's fine. Just the preview that's messed up. Is this just how it is, or am I doing something wrong? Thanks

Edit: Seems the framing in regular movie crop mode is off too. Also I'm getting focus pixels in mv1080 crop, but not in movie crop.

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3736
Re: Canon EOS M
« Reply #2187 on: February 15, 2019, 07:02:05 AM »
Also I'm getting focus pixels in mv1080 crop, but not in movie crop.

Which build are you using? Focus pixel fixing for Danne's bleeding edge builds is still a work in progress. Check on the Dealing with Focus Pixels in raw video for updates. If you are using a build from the official ML downloads pages then we have a problem. Which application are you using for your MLV files?
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

the_real_bill_jones

  • New to the forum
  • *
  • Posts: 4
Re: Canon EOS M
« Reply #2188 on: February 15, 2019, 07:12:10 AM »
I'm Using MLV APP 1.5 and the Feb 13th build

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5902
Re: Canon EOS M
« Reply #2189 on: February 15, 2019, 03:06:08 PM »
New build:
https://www.magiclantern.fm/forum/index.php?topic=9741.msg208959#msg208959

"mv1080p correct real time preview"

I´m experimenting with reconfiguring Movie crop mode back to mv1080p and it seems to be working. The positive side effect here is that we get 16:9 real time preview with correct ratio just like when filming 1080p H.264.

Select Movie crop mode:


Then select mv1080p MCM rewire 16:9:


At first you should get the x3 zoom but when the rewire preset is chosen it should get you back into mv1080p 23.980 fps. There should be a black border to the right to indicate you are in the right place. The border won´t affect the recording.
You can always push canon MENU button once or twice to refresh registry if things gets stuck. Restart camera if needed.

This kind of proofs the idea from dfort about Movie crop mode working properly and that it could be reconfigured back to mv1080p. Next step would be to find out what registers could be added without going through Movie crop mode to get straight into this mode without roundtrips. Creating logs with adtg_gui would be a good start.

This preset works with regular bits 14/12/10 lossless and uncompressed but will not work with bitrate changes from the Crop mode sub menu. Only 16:9 for now. Might work changing 24 or 25 fps straight in canon menu. Or even better seems to be using FPS override.

MLV file:
https://bitbucket.org/Dannephoto/magic-lantern/downloads/cat_rewired.MLV


Do not forget. These builds are bleeding edge. Test with caution and report back what´s working and not.

norek

  • New to the forum
  • *
  • Posts: 8
Re: Canon EOS M
« Reply #2190 on: February 15, 2019, 06:18:44 PM »
Danne!

No words... incredible...  :o testing all weekend...

henricusmaria

  • Freshman
  • **
  • Posts: 70
Re: Canon EOS M
« Reply #2191 on: February 15, 2019, 06:45:24 PM »
Nice!

Does this also mean less aliasing and moiré?

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5902
Re: Canon EOS M
« Reply #2192 on: February 15, 2019, 07:00:59 PM »
Please do tests, compare and post your results.

kayman1021

  • New to the forum
  • *
  • Posts: 14
Re: Canon EOS M
« Reply #2193 on: February 15, 2019, 08:28:29 PM »
Apart from the center focus pixels in red and blue, i have noticed some repetetive pattern in both greens as well. Under the cat's head. Very faintly i see it in red and blue as well.


EOS 100D, Xiaomi A1

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1358
Re: Canon EOS M
« Reply #2194 on: February 15, 2019, 09:16:31 PM »
Hi Danne, something is strange here when trying your todays build: using mv1080p MCM rewire preset I get a resolution of 1672x564 for 16:9... is that expected? Do I have to stretch it in height like the mv720p files? And I only get 29.973fps, not 23.x.

Edit... no... nothing to stretch. it is 1672x564 and needs no stretch. But ratio in liveview is not correct here too.
5D2.212 | EOSM.202

Danne

  • Contributor
  • Hero Member
  • *****
  • Posts: 5902
Re: Canon EOS M
« Reply #2195 on: February 15, 2019, 09:26:29 PM »
You should get 1736x976 mv1080p. Try canon menu button a few times if nothing works. Also set resolution to max under Raw video menu.

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1358
Re: Canon EOS M
« Reply #2196 on: February 15, 2019, 09:36:45 PM »
Hm... max resolution is set to 5xxx pixels, pressed Menu button so often now, but nothing changes. I get only this:


Edit... AAHHH! Movie Crop Mode has to be switched ON? (see it in your screenshot now)
5D2.212 | EOSM.202

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1358
Re: Canon EOS M
« Reply #2197 on: February 15, 2019, 09:47:34 PM »
Japp... that's it. Forgot to switch on Crop Mode! Looks fantastic now! ;) Great work Danne!
5D2.212 | EOSM.202

dfort

  • Developer
  • Hero Member
  • *****
  • Posts: 3736
Re: Canon EOS M
« Reply #2198 on: February 16, 2019, 06:14:14 AM »
Made a pass at creating a focus pixel map file for this but it looks like those subtle focus pixels are stubborn.
5D3.* 7D.206 700D.115 EOSM.203 EOSM2.103 M50.102

masc

  • Contributor
  • Hero Member
  • *****
  • Posts: 1358
Re: Canon EOS M
« Reply #2199 on: February 16, 2019, 12:06:50 PM »
The sun is shining, so I was outside with the new reworked mv1080p mode. Handling is fantastic - I can focus fine now! Yay. In the green grass I saw that the bottom line is red. Maybe you know which register has to be get a little hit to make it the right color :)
5D2.212 | EOSM.202