Author Topic: Ok... so this is not clear!  (Read 4484 times)

tonymuffin

  • New to the forum
  • *
  • Posts: 9
Ok... so this is not clear!
« on: December 22, 2013, 07:10:58 PM »
Couple things are not quite clear.

1.  The main page on the site, http://www.magiclantern.fm/ says that the Magic Lanter is compatible with the 7D and 5D Mark iii however, from the download page, http://www.magiclantern.fm/downloads.html it states the cameras supported are:  5D Marik ii 2.1.1, 50D 1.0.9., 60D 1.1.1., 500D 1.1.1., 550D 1.0.9., 600D 1.0.2.

I have a 50D with the 1.0.9 firmware, but I also have a 7D and a 5D Mark iii.  So is it compatible with the 7D and 5D Mark iii or not?

2.  Movie Mode:  On the User Guide page, http://wiki.magiclantern.fm/userguide it says to put the 50D in movie mode: For Canon 50D: in LiveView, with movie recording enabled from ML menu.

How do you enable Movie recording from the ML menu?

walter_schulz

  • Contributor
  • Senior
  • *****
  • Posts: 396
Re: Ok... so this is not clear!
« Reply #1 on: December 22, 2013, 08:27:27 PM »
1: Please read with more care.
On the download page you will find some cams listed  under "Stable Release v2.3". Others are not because their status is not yet considered "stable". You will find their builds (if any) tagged "Nightly" or "Alpha".

tonymuffin

  • New to the forum
  • *
  • Posts: 9
Re: Ok... so this is not clear!
« Reply #2 on: December 22, 2013, 09:24:40 PM »
Actually... I did read that and with all due respect..it is not clear.  As mentioned, the main page on the site, http://www.magiclantern.fm/ says that Magic Lanter Supports:
Supported Cameras:
 
5Dc, 5D2, 5D3, 6D, 7D, 40D, 50D, 60D, 500D (T1i), 550D (T2i), 600D (T3i), 650D (T4i), 700D (T5i), 1100D (T3), EOS M, 100D (SL1)

While on the download page it states: Cameras supported:
  5D Mark ii 2.1.2
  50D 1.0.9
  60D 1.1.1
  500D 1.1.1
  550D 1.0.9
  600D 1.0.2

There is nothing that I see that would indicate that one would need to use a different build in order to support the cameras that are not listed except at the bottom of the page.  Perhaps it should be more visable.

escho

  • Contributor
  • Hero Member
  • *****
  • Posts: 562
Re: Ok... so this is not clear!
« Reply #3 on: December 22, 2013, 09:45:48 PM »
Actually... I did read that and with all due respect..it is not clear.  As mentioned, the main page on the site, http://www.magiclantern.fm/ says that Magic Lanter Supports:
Supported Cameras:
 
5Dc, 5D2, 5D3, 6D, 7D, 40D, 50D, 60D, 500D (T1i), 550D (T2i), 600D (T3i), 650D (T4i), 700D (T5i), 1100D (T3), EOS M, 100D (SL1)

Yes, that´s not very clear. I guess, it would be better to write:

Supported cameras: see download page

Edgar
https://sternenkarten.com/
600D, 6D, openSUSE Tumbleweed

tonymuffin

  • New to the forum
  • *
  • Posts: 9
Re: Ok... so this is not clear!
« Reply #4 on: December 23, 2013, 01:48:58 AM »
Indeed.

Now for my #2 question.  How does one start Movie Mode on the 50D once Magic Lantern is installed.  The reference to that is also not clear.

engardeknave

  • Senior
  • ****
  • Posts: 339
Re: Ok... so this is not clear!
« Reply #5 on: December 23, 2013, 01:52:49 AM »
If you would like to track the constant progression of this completely free software and update all relevant pages as needed, I'm sure A1ex would be glad to hear from you.

Audionut

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3605
  • Blunt and to the point
Re: Ok... so this is not clear!
« Reply #6 on: December 23, 2013, 07:21:09 AM »
Now for my #2 question.  How does one start Movie Mode on the 50D once Magic Lantern is installed.  The reference to that is also not clear.

http://wiki.magiclantern.fm/userguide#movie_record_50d

tonymuffin

  • New to the forum
  • *
  • Posts: 9
Re: Ok... so this is not clear!
« Reply #7 on: December 24, 2013, 03:01:38 AM »
Well... this has been quite the learning experience!  Never did get the video functionality to work on my 50D after installing Magic Lantern.  However, ML sure spanked the pooch with my camera.  With ML installed it causes the battery to drain instantly.  Charge the battery and one only has partial functionality ... then the camera stops responding completely. Finally, after re-charging the batter 3 times I inserted a different memory card and the camera functioned normally.  I formatted the previous card in the computer which finally allowed me to format it in the camera to completely remove ML

Thank goodness I experimented with this on my 50D instead of also trying on my 7D and 5D Mark III. 

Needless to say... USE THIS AT YOUR OWN RISK!!! 

ilguercio

  • Hero Member
  • *****
  • Posts: 843
Re: Ok... so this is not clear!
« Reply #8 on: December 24, 2013, 03:40:23 AM »
Especially if you can't bother reading the manual, i'd say.
;)
Canon EOS 6D, 60D, 50D.
Sigma 70-200 EX OS HSM, Sigma 70-200 Apo EX HSM, Samyang 14 2.8, Samyang 35 1.4, Samyang 85 1.4.
Proud supporter of Magic Lantern.

Stedda

  • Hero Member
  • *****
  • Posts: 504
Re: Ok... so this is not clear!
« Reply #9 on: December 24, 2013, 09:33:19 AM »
Runs fine on my 7D and 5D III along with hundreds if not thousands of others... but I also read up on it.

Theres no battery drain issue if you pay attention to clearly marked warnings.
5D Mark III -- 7D   SOLD -- EOS M 22mm 18-55mm STM -- Fuji X-T1 18-55 F2.8-F4 & 35 F1.4
Canon Glass   100L F2.8 IS -- 70-200L F4 -- 135L F2 -- 85 F1.8 -- 17-40L --  40 F2.8 -- 35 F2 IS  Sigma Glass  120-300 F2.8 OS -- 50 F1.4 -- 85 F1.4  Tamron Glass   24-70 2.8 VC   600EX-RT X3

Frank209

  • New to the forum
  • *
  • Posts: 17
Re: Ok... so this is not clear!
« Reply #10 on: December 24, 2013, 11:08:24 AM »
Especially if you can't bother reading the manual, i'd say.
;)

 ;D

Mine works like a charm. But i can read.