Author Topic: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)  (Read 1228396 times)

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 7244
Re: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1450 on: February 08, 2015, 09:36:29 PM »
Have you tried to put your files somewhere nearer to the root and without blanks?
G:\TST_AREA
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3382
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Re: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1451 on: February 09, 2015, 08:24:18 PM »
*Few CRASH REPORTS*

As I've tried to export all with current setting (Press C) which starts the process and usually after about 3-4 .MOV's the MLRV just crashes and I get this report...

Crash Report #1

Crash Report #2

However, it somehow vanished from my mind... is the latest stable version 1.3.3 or 1.3.4? (I understand that latest 1.4.3 is somewhat Beta)

Thanks @Baldand for your contributions although you may be on a much deserved hiatus!  ;)
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

gnoklei

  • New to the forum
  • *
  • Posts: 2
Re: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1452 on: February 11, 2015, 01:12:17 PM »
Baldand:

Hi! I have been using MLViewer with success thus far but yesterday ran into what I hope is not a bug but easily fixed by some magic words of wisdom.

When I export MLVfiles to Prores it works as long as they are around 1,5-2 GB in size---

But, when I tried to film a bit longer and recorded a 4-5 minute shot, it would export it to a file not readable by either Quicktime, Quicktome Pro 7 och MKV player.

This is really making me scratch my head!

Have i missed something apparent? Why does the file size matter if it turns out a Prores file or not?

If anyone can help me in this I would be eternally grateful.


/Daniel

ric.pce

  • New to the forum
  • *
  • Posts: 2
Re: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1453 on: February 16, 2015, 07:36:20 AM »
How do we get rid of the pink and blue dots in MlRawViewer 1.3.3 on Mac? I'm shooting on a 700d and there are dots almost everywhere, specially under low light conditions.

Thank you.

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3382
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Re: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1454 on: February 16, 2015, 10:34:32 PM »
*FEEDBACKS*

MLRV 1.4.3 still crashes when pressing "C" on more large amount of files. more than 15-20 MLV/RAW's.

However, instead as I go file by file and press "E" after each RAW/MLV which seems to do the trick and has not crash as of now.

Strange?
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

N/A

  • Hero Member
  • *****
  • Posts: 576
  • Dreaming in 14 bit
Re: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1455 on: February 17, 2015, 09:47:50 PM »
Its due to processing newer mlv files, all my recent files export just fine but older ones cause it to hang up. One error I've found is from

AttributeError: 'MLRAW' object has no attribute 'bodySerialNumber'

7D. 600D. Rokinon 35 cine. Sigma 30 1.4
Audio and video recording/production, Random Photography
Want to help with the latest development but don't know how to compile?

sgofferj

  • Member
  • ***
  • Posts: 136
Re: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1456 on: February 25, 2015, 12:31:37 PM »
I have problems with MLRawViewer on kUbuntu 14.04. Opened an extra thread here. Should that have gone into this thread?
18+ years Linux user, wolf-fan, hobby photographer and -filmmaker
EOS 6D, EOS 7D

Tao

  • New to the forum
  • *
  • Posts: 30
  • Ficklegrapher
Re: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1457 on: March 14, 2015, 04:46:16 PM »
Hey,

I just tried to download MLrawviewer on my Macbook Air (Latest OS X, 1,3Ghz i5, HD Graphics 5000, 8Gb RAM, 256Gb SSD) but it doesn't even load, I'm forced to quit the app. Is this normal ?

Thanks!
5D Mark III w/ Sigma Art 50mm f/1.4 + Sigma Art 24mm f/1.4 + Canon L 70-200 f/4.0

LRF

  • New to the forum
  • *
  • Posts: 34
Re: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1458 on: March 14, 2015, 06:08:05 PM »
First of all, thanks for excellent program. Ability to see thumbnails is great.

I was trying to make some tests with v.1.4.3 on WIN7 64-bit and my results are quite random.
Three test files were located in folder G:\MLV. Two 24fps MLVs recorded in autumn, one 25fps RAW from newest ML build.

Can't find any repetitive pattern; sometimes converting MLV or RAWs to MOV hangs at 0.79%, sometimes at 0.23% or so, and 0:00:00s long mov file is created. While closing, program alerts that there's some conversion going on. Sometimes conversion is just fine. In last 10 attempts I had approx 30% success rate. All initial attempts failed. Recent ones worked fine. All within 10 minutes. Nothing has changed in the meantime.

Converting RAW to DNG doesn't work in my case. Empty folder is created, sometimes static progress information with 0:00:00 is displayed, (usually not) then disappears.
Converting MLV to DNG works fine.

Tried both "C" and "E" keys.
With "C", when exporting to DNG, only MLVs show up in progress list. When exporting to MOV, all the files are displayed. Sometimes RAW file hangs at 0.96% and prevents following files from being processed, sometimes all three convert fine. Once one of MLVs hanged at 99.7%.

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3382
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Re: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1459 on: March 15, 2015, 03:23:35 AM »
Try deleting all .MDX files and retry 1.4.3...

Post result.
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

LRF

  • New to the forum
  • *
  • Posts: 34
Re: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1460 on: March 15, 2015, 04:40:36 PM »
I read somewhere that those additional files that appear might have influence on results, so I was deleting them. Each attempt was made with only three source files in folder.
As far as I remember, 1.3.4 was working fine, when I gave it a short try some time ago.

Files were 650-750 MB each, recorded with 5D3.

Sane__

  • New to the forum
  • *
  • Posts: 31
Re: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1461 on: March 16, 2015, 04:45:44 AM »
Hello i got a lame question.Is it possible to upscale the raw file before export it in prores?I'm using 5d mark II and i find that i lose quality when i upscale the prores from 1856 to 1920 but not when i upscale the cndg files.

revast

  • New to the forum
  • *
  • Posts: 24
Re: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1462 on: March 18, 2015, 01:13:59 PM »
ok, looks like people have to jump over their shadow and try to use Linux ;-)



OR people are willing to setup / compile for their platform - which is not a big thing, but you have to jump through some hoops - if people devote some time to it, it should be no problem to make a nice tutorial with a partly-scripted workflow.

I understand baldand loosing interest - making such a cool app, and then hanging in mac and windows issues others should cope with -
let the master code, guys!!




How do you get MlRawViewer ? - Git 
So installing git is the first thing everyone should do.


What do you need to run MlRawViewer ?
- Python. 
I recommend to use virtualenv.


what do you need to compile a (part of a) program - a compiler.
On Win, that is either Visual Studio (Microsoft) or Mingw (basically all the tools from Linux ported to Windows), on Mac there is Xcode.


And what do you need for packaging?
on Windows there is py2exe, on the mac there is an equivalent to make an .app package




Now to make it a more streamlined process to get an up-and running MlRawViewer, one could make different things. You have to deal with the python part for shure, and eventually with the compiler part.


- for the Python part, one can use virtualenv - that is a self-contained python version which resides in one folder. With this, it's very easy to install all the python things which are needed - and all the things MlRawViewer needs are in one folder. One could ship a full virtualenv (remember, it;s just a folder) with everything in it to run MlRawViewer, and just have an accompanying launcher script to start it and automatically update it.

- one could provide precompiled binary versions of the C parts of MlRawViewer - If you really need that accelerated playback - that would be the easiest way I guess. just drop the newest .dll or .dylib into the Python folder and that's it. Or make the start script do that for you - plus searching for the newest version of the precompiled binary.

- compiling things on Mac/Win can be daunting, compared to Linux, but still, it's no rocket science. Making a quick tut for every platform should be no problem. Automating it neither. on Mac, you just have to install Xcode, then the compilation part should already work, on Win, MinGW.

- Having an alias (shortcut) to mlrawgui.py, place that  on Dsktop, into dock (taskbar), one which opens a terminal (cmd window) ready to use mlrawviewer.py - this should be enough for you guys! remember it's about testing a software which can have bugs and changes often! I can understand the everybody wants convenience - but magiclantern is DIY -  so people will have to deal with it.

- Another Idea is to have virtual machines of mac & windows which have everything put in place  - just click a button and newest mlrawviewer gets compiled and packed for your platform;  you will only have to learn how to start the virtual machine - which works on every platform  - and how to get the built file out of the vm. Further this could serve as a kind of virtual automated build server for the different platforms, which could be made reachable over the internet, e.g via vnc, teamviewer. (that would be real fun - and overkill!)


Someone willing to help (or help by donating?, if allowed?)


DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3382
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Re: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1463 on: March 18, 2015, 05:40:16 PM »
I'm more than willingly to help but can only speak for Mac's...
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

N/A

  • Hero Member
  • *****
  • Posts: 576
  • Dreaming in 14 bit
Re: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1464 on: March 18, 2015, 06:15:41 PM »
I downloaded the source a while back and did some messing around with the code but couldn't get it to compile (Mavericks 10.9.5), probably need to get virtualenv and my pkg builder configured correctly. Iirc there's a .sh script in the bitbucket repo that compiles the installer, just have to know where to point it for the tools.
I'd love to see development continue on MLRV, I honestly can't imagine shooting MLV without it. Soon as I have spare time I'll see if I can debug my compiler.
7D. 600D. Rokinon 35 cine. Sigma 30 1.4
Audio and video recording/production, Random Photography
Want to help with the latest development but don't know how to compile?

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3382
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1465 on: March 18, 2015, 08:34:10 PM »
I agree. Can't imagine shooting MLV without MLRV. It's too good of an app to let it be discontinued in developments (although I don't blame you @baldand for losing interest) but as confident I can tell that it will be back in action sooner rather than later.
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

revast

  • New to the forum
  • *
  • Posts: 24
Re: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1466 on: March 18, 2015, 10:11:22 PM »
First of all, as I explain more thoroughly some lines later, it's not necessary to compile anything - MlRawViewer will run as it is, as Python is an interpreted Language - As long as all necessary python libs are installed - and their dependencies - maybe there has to be compiled something..

I have made a basic tutorial how to make it happen in (Debian-based) Linux, which I find is a good start to find out what we will need-  Its not so straightforward as I thought (the program changed alot during last year) but its a start.



open a terminal , and enter:

Code: [Select]
sudo apt-get install build-essential python-opengl python-numpy python-dev python2.7-dev python-tk python-pyaudio gitThis will install nearly all dependencies. You will have to enter your user's password here.

python-pyaudio is optional, python-tk needed for GUI.

Now I found out that a recently added dependency is missing and not available in Debian/Ubuntu: scandir
I have made a package for that :

Code: [Select]
wget  http://openartisthq.org/magiclantern/python-scandir_0.9-1_amd64.deb
get it.

Code: [Select]
sudo dpkg -i python-scandir_0.9-1_amd64.deb
install it.

 
Code: [Select]
git clone https://bitbucket.org/baldand/mlrawviewer.git
This will make a mlrawviewer folder in your home directory, and puts the latest source-code in it.

with
Code: [Select]
git pull, (you don't have to run this now) you will be able to update your code to the newest version in git. So every time you want the newest version, just do a   git pull  , and you have the newest code.

 
Code: [Select]
cd mlrawviewer
Go into that folder.


Also, glfw3.1 is needed, which is not available in ubuntu 14.04, 14.10 nor 15.04  ( !!!!!!!!!!! )
but, no fear, you just need to get it from me:
Code: [Select]
wget http://openartisthq.org/magiclantern/libglfw.so.3
wget http://openartisthq.org/magiclantern/libglfw.so.3.1

I am doing this here so that these two already sit in the right directory...



Code: [Select]
python setup.py build
This optionally compiles the bitunpack module; Remember, Python is an interpreted language, no need to compile,
but playback will be faster if you do compile this module written in C.

Code: [Select]
cp build/lib.linux-*/bitunpack.so .
copy the bitunpack.so binary from the build/lib.linux-* subfolder to the same place where mlrawviewer.py is.
 
Code: [Select]
chmod +x mlrawviewer.py
Code: [Select]
chmod +x Viewer.py.py
make these executeable

Browser.py is mentioned at webpage and in README, but it's not found? strange...



Code: [Select]
./Viewer.py
run the GUI interface.

Code: [Select]
./mlrawviewer.py
run the commandline interface.

Code: [Select]
ln -s Viewer.py ~/Desktop
make a link to the Desktop to run it from there.



This are the basics of getting it run - no menu entry, no packaging. Maybe this is not good for convenience, but good for testing. As explained before, if you skip the part to build the bitunpack[.so/.dll/dylib], MlRawViewer is still fully functional.

Remember:
Code: [Select]
git pull will give you instantly the newest version of the code, and if you take this tutorial and make a script out of this (basically just writing everything into a text file), have a symlink / shortcut / alias to that script to run it from e.g. Desktop, you will always have the newest version available - and baldand can do what he's best in.




Now with Windows and Mac - its a bit more complicated to set up (that's why I love my Linux).


How do you get MlRawViewer ? - Git 
So installing git is the first thing everyone should do.


What do you need to run MlRawViewer ?
- Python. 
As I said, I recommend to use virtualenv.

                                                       
THE COMPILING PART IS OPTIONAL:
from https://bitbucket.org/baldand/mlrawviewer/overview
Quote
The playback will be faster if you build the included bitunpack module.

This means compiling the C part of MlRawViewer is only (please tell me if I am wrong) needed if you want to have faster playback - otherwise  run it like it is -

Mac also has package systems like apt: homebrew and port . so these could be used to install external dependencies needed by the virtualenv stuff.

Windows .. there are different ways, I do not know which libraries are available in which form (via pip in virtualenv, or via setup.exe... we have to check this out - it are not so many dependencies so I have hope that we find an elegant solution..



N/A

  • Hero Member
  • *****
  • Posts: 576
  • Dreaming in 14 bit
Re: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1467 on: March 18, 2015, 10:28:20 PM »
Cool thanks for the type up. I got the terminal bin to compile and run just fine, but I wanted to get the hang of building the complete package and try to see what may be causing the mlv's, and moreso the raw files, to hang when trying to export. One issue seemed to be with MLRV crashing when trying to convert files with insufficient exif data or no audio (I.e. Raw files) as well as OpenGL crashing when using gpu-based processing. But that takes a less busy mind than mine lol.
7D. 600D. Rokinon 35 cine. Sigma 30 1.4
Audio and video recording/production, Random Photography
Want to help with the latest development but don't know how to compile?

parxal

  • New to the forum
  • *
  • Posts: 2
Compile MlRawViewer for windows 8.1 64Bit
« Reply #1468 on: March 21, 2015, 02:22:38 PM »
I'm trying to compile MIRawViewer for windows 8.1 64bit, but i'mt not a python programmer:

Want i have installed :
Python Tools for Visual Studio (https://pytools.codeplex.com/)
Anaconda (http://continuum.io/downloads) which comes with python 2.7

Opened project

Ran:
python setup.py install to compile bitunpack.c, copy it from "build\lib.win-amd64-2.7" to project root

Ran:
pib install PyOpenGL==3.0.2
pib install PyOpenGL_accelerate==3.0.2
pib install glfw==1.1.1
pib install numpy==1.9.1
pib install scandir==0.9

Downloaded "PyAudio-0.2.8-cp27-none-win_amd64.whl" from "http://www.lfd.uci.edu/~gohlke/pythonlibs/" and
pib install PyAudio-0.2.8-cp27-none-win_amd64.whl

Error on compiling :

"File "C:\Users\user.DOMAINADMINS32\Documents\mlrawviewer\glfw.py", line 49, in <module>
    raise( RuntimeError, 'GLFW library not found' )"

_base_glutInit( ctypes.byref(count), holder ) TypeError: 'NoneType' object is not callable

As sugested here ("http://stackoverflow.com/questions/10188595/pyopengl-typeerror-nonetype-object-is-not-callable")
OpenGL\DLLS folder were empty.

1) Copied freeglut 3.0 dll (http://www.transmissionzero.co.uk/software/freeglut-devel/) to windows folders

Program runs, window opens but stays white and blocked. Error:

"
Using GLUT instead of GLFW. Some features may be disabled.
Traceback (most recent call last):
  File "C:\Users\user.DOMAINADMINS32\Documents\mlrawviewer\glfw.py", line 49, in <module>
    raise( RuntimeError, 'GLFW library not found' )
  File "C:\Users\user.DOMAINADMINS32\Anaconda\lib\site-packages\OpenGL\platform\baseplatform.py", line 379, in __call__
    return self( *args, **named )
WindowsError: exception: access violation writing 0xFFFFFFFFEA441D90
"

Any help?


revast

  • New to the forum
  • *
  • Posts: 24
Re: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1469 on: March 21, 2015, 11:05:44 PM »
yeah you need at least glfw 3.1.

legreve

  • New to the forum
  • *
  • Posts: 27
Re: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1470 on: March 22, 2015, 07:33:06 AM »
It might be buried in the 59 pages.... but can anyone tell me, why frames exported with MiRawviewer to DNG is 1.3mb pr. frame and rawmagic is 4mb pr. frame?

baldand

  • Contributor
  • Senior
  • *****
  • Posts: 408
  • 7D, Developer of MlRawViewer
Re: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1471 on: March 22, 2015, 10:21:17 AM »
It might be buried in the 59 pages.... but can anyone tell me, why frames exported with MiRawviewer to DNG is 1.3mb pr. frame and rawmagic is 4mb pr. frame?

MlRawViewer supports the "lossless compressed" mode of the DNG spec, which makes the files smaller without losing any information.

Licaon_Kter

  • Hero Member
  • *****
  • Posts: 519
  • M
Re: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1472 on: March 22, 2015, 11:30:14 AM »
MlRawViewer supports the "lossless compressed" mode of the DNG spec, which makes the files smaller without losing any information.
And you can force it to export uncompressed by editing ExportQueue.py at line 471 by changing ljpeg = “True” to “False” save, exit and delete ExportQueue.pyc.
I need them uncompressed since darktable (see comments) does not (yet?) support compression.

@baldand: Any chance to have compression option-able? I'm afraid that in the future it might not be this easy to disable it and the darktable devs did not say anything about supporting it in the future ( although as I point them out in the comments there this is in the standard at least since DNG v1.1 ).

komunakavra

  • New to the forum
  • *
  • Posts: 4
Re: MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1473 on: March 24, 2015, 02:44:25 AM »
Hi guys,....Im looking for someone to help me... :D

Lets see, I work with a macpro OSX 10.6.8 and canon 7D... and after read and read...and download and test, I have some questions:

1- There is any software that works on my machine to review or convert my MLV Clips?? :D :D :D because I've tested both MLRawViewer and raw2dng and I couldnt see any frame of any *.MLV that I tested. The exported clips appear as black ones, anything of the image.

2- I work with AE CS3 and I've seen that there are some plugins for it. Do you know if they work on my AE version??

Thanx!!


DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3382
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
MlRawViewer 1.3.3 (CDNG/MLV/RAW Viewer & Encoder, Linux/Mac/Win)
« Reply #1474 on: March 24, 2015, 03:04:01 AM »
Which MLRV version are you using?

Sounds like you didn't set the export folder yet -- Try pressing 'W' to set your destination spot prior to exporting.

Otherwise you can try other apps that work well on Mac's...

Try your footage with either @dmilligan's MLVFS or @Danne's cr2hdr-r and they both run well!
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109