Author Topic: New 5D Mark III user - firmware 1.2.3?  (Read 7169 times)

Aprime

  • New to the forum
  • *
  • Posts: 2
New 5D Mark III user - firmware 1.2.3?
« on: October 11, 2013, 12:03:35 AM »
I'm not quite sure what to make of this. My camera runs version 1.2.3, which isn't even available for download on Canon's US page at the moment. I'm attempting a downgrade to 1.1.3 but it's failing every time. Any assistance on the matter would be appreciated. Specifically, insight on my firmware version, after which I'll probably try to downgrade to 1.2.1 instead of going straight to 1.1.3.

Yes, I intend to run ML on this, hence I'm posting it in the ML Q&A section as going to version 1.1.3 (whether it's an upgrade or a downgrade) is part of the process.

Sean E

  • Just arrived
  • *
  • Posts: 1
Re: New 5D Mark III user - firmware 1.2.3?
« Reply #1 on: October 18, 2013, 12:42:04 PM »
I too have firmware version 1.2.3 on my recently purchased 5D M3. I contacted Canon Australia and sent them a photo of the rear screen (as requested by them) clearly showing the firmware version installed. Their response was to return the camera to their technicians for investigation, which at this stage I am not keen to do. The 6th digit on the serial number is '0'(if that is at all relevant). All menu screens are identical as per the Canon manual for cameras with firmware version 1.2.0 or later (printed 2013). The camera has operated flawlessly so far. I have been looking for answers for weeks and this is the only other case I have seen. I am curious to say the least.

Pelican

  • Contributor
  • Senior
  • *****
  • Posts: 406
Re: New 5D Mark III user - firmware 1.2.3?
« Reply #2 on: October 18, 2013, 02:18:18 PM »
Use EOS Utility to downgrade your firmware.
Follow the user's manual if you are not sure how to do it.
EOS 7D Mark II, EOS 7D, EOS 5, EOS 100 + lenses (10mm to 300mm), 600EX, 550EX, YN600EX x 3
EOScard, EOS DSLR firmwares, ARMu, NiControl, etc.: http://pel.hu/down

timetraveller

  • New to the forum
  • *
  • Posts: 20
Re: New 5D Mark III user - firmware 1.2.3?
« Reply #3 on: October 30, 2013, 01:21:17 AM »
Use EOS Utility to downgrade your firmware.
Follow the user's manual if you are not sure how to do it.


I have 1.2.3 too, I'll do the downgrade procedure and inform about the results.

thanks


EDIT: I have downgraded form 1.2.3 to 1.1.3 successfully. No problem at all.

Aprime

  • New to the forum
  • *
  • Posts: 2
Re: New 5D Mark III user - firmware 1.2.3?
« Reply #4 on: December 05, 2013, 11:05:45 PM »
As it turns out, an update officially came out at the end of October. Weird that 'we' got our hands on it before everyone else, must've been a supplier thing. Anyway, haven't read or found anything about successful downgrades before that one post, so figure I should bump.

Did it take many tries? Did you do it with a CF or SD card? Basically, if you've got any info or tips, please share them.