Author Topic: Compile Errors for latest Unified Clone 08/20/13  (Read 5396 times)

John Kesl

  • Freshman
  • **
  • Posts: 86
  • sudo apt-get install is your friend
Compile Errors for latest Unified Clone 08/20/13
« on: August 20, 2013, 03:34:23 PM »
Hello,
I am getting this error with the latest Unified whilst I try to compile.

Johns-Mac-Pro:magic-lantern johnkesl$ make 7D
make -C  /Users/johnkesl/Development_ML/magic-lantern/platform/7D.203
[ VERSION  ]   ../../platform/7D.203/version.bin
make[1]: truncate: Command not found
make[1]: *** [../../platform/7D.203/version.bin] Error 127
make: *** [7D] Error 2

I have tried compiling ML from Unified today, with a freshly cloned rep. And received the error.
 I tried compiling ML from an older Unified clone 08/11/13 and didn't receive the error. I have checked my make file and it looks in order was wondering where the truncate command comes from and also I see the version.bin which I've not seen before.
What am I missing?
please help.
Thank you

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: Compile Errors for latest Unified Clone 08/20/13
« Reply #1 on: August 20, 2013, 04:14:24 PM »
apparently the truncate command. try to type truncate in terminal.

http://linux.die.net/man/1/truncate

John Kesl

  • Freshman
  • **
  • Posts: 86
  • sudo apt-get install is your friend
Re: Compile Errors for latest Unified Clone 08/20/13
« Reply #2 on: August 20, 2013, 05:25:20 PM »
i typed man truncate in OSX terminal and get the proper man for BSD system calls ftruncate and truncate but I am still getting the compiler error, I just don't know where to start looking for the source of the error due to lack of some kind of other indicator.

Francis

  • Hero Member
  • *****
  • Posts: 818
Re: Compile Errors for latest Unified Clone 08/20/13
« Reply #3 on: August 20, 2013, 06:24:14 PM »
I had that error as well a few months back. I installed via MacPorts to get that command ('port install truncate'). I also had to edit makefile.src to remove the following option flag, I think it was 'truncate -r ....' which I replaced with 'truncate'

I've had a few other stumblings compiling on a mac. Let me know if you run into anything else.

John Kesl

  • Freshman
  • **
  • Posts: 86
  • sudo apt-get install is your friend
Re: Compile Errors for latest Unified Clone 08/20/13
« Reply #4 on: August 20, 2013, 08:46:41 PM »
I had that error as well a few months back. I installed via MacPorts to get that command ('port install truncate'). I also had to edit makefile.src to remove the following option flag, I think it was 'truncate -r ....' which I replaced with 'truncate'

I've had a few other stumblings compiling on a mac. Let me know if you run into anything else.

Yup, yup, yup, I see there is some new stuff in the makefile.src ( I forgot about that one.) There's a few more instances of truncate there then there used to be. I just updated my ports and sudo port install truncate also helped ( as I have truncate now). Also, sudo port install montage for make docq problem and all should be good.
 thank you.
I was also wondering about build_fir7.py which should be in the a dumper directory, I just am not understanding which Dump, is it an IDA dump of canon firmware or is it a dump via firmware from my 7D?

JK


nanomad

  • Administrator
  • Hero Member
  • *****
  • Posts: 2918
  • All your websites are belong to us
Re: Compile Errors for latest Unified Clone 08/20/13
« Reply #5 on: August 21, 2013, 10:59:25 AM »
You can't build a fir anyway since the signing tools are the only "undisclosed" thing of ML.
EOS 1100D | EOS 650 (No, I didn't forget the D) | Ye Olde Canon EF Lenses ('87): 50 f/1.8 - 28 f/2.8 - 70-210 f/4 | EF-S 18-55 f/3.5-5.6 | Metz 36 AF-5

John Kesl

  • Freshman
  • **
  • Posts: 86
  • sudo apt-get install is your friend
Re: Compile Errors for latest Unified Clone 08/20/13
« Reply #6 on: August 21, 2013, 11:41:52 PM »
You can't build a fir anyway since the signing tools are the only "undisclosed" thing of ML.

Aahha, so that's the Builder_Dir. ?
Gotcha. Thank you. i've been trying to figure this thing out. All I want to compile is an autoboot 7D alpha 2 with the video hacks active. The Raw_rec is great and all but from a production stand point the variable GOP and Bitrate is some of the trully most usefull to me. I know and see the modulariztion of ML and understand the beauty, I just don't have the chops to write my own Video_Hack.mo yet. Thank you for your input nanomad. (nice new website design, BTW)

bischofftep

  • New to the forum
  • *
  • Posts: 17
Re: Compile Errors for latest Unified Clone 08/20/13
« Reply #7 on: April 10, 2014, 08:35:19 PM »
So... if one were to want to work on the 7D_MASTER code, which appears to require a signed firmware, one is out of luck?
Douglas E. Bischoff
Audio/Video Production & Scoring