Author Topic: 7D Raw Thread  (Read 550515 times)

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8854
Re: 7D Raw Thread
« Reply #2275 on: January 10, 2014, 07:08:59 PM »
Follow http://www.magiclantern.fm/forum/index.php?topic=7464.msg63694#msg63694 to the letter. If you already did: Repeat it!
Post results.

Ciao
Walter

teemuvillikka

  • Just arrived
  • *
  • Posts: 1
Re: 7D Raw Thread
« Reply #2276 on: January 10, 2014, 07:48:39 PM »
Hi,

I'm having a bit weird problem with my raw footage. I was filming a three studio clips for a music video. Clips was more than 4gb so I joined the files together and then transformed them to dng files. After that I imported them to AE as a dng sequence, but the video plays much faster than the original song?

Calomile

  • New to the forum
  • *
  • Posts: 4
Re: 7D Raw Thread
« Reply #2277 on: January 10, 2014, 08:32:00 PM »
I tried to do use bspatch.exe and booton.bsdiff with the 7D203.fir file found in the latest Tragic Lantern release and I got a message that booton.bsdiff is not the right one.

Use the original firmware (7d000110.fir) with bspatch.exe to create your firmware.

arrinkiiii

  • Hero Member
  • *****
  • Posts: 1104
  • ML ADDICTED 7D & 5D III
Re: 7D Raw Thread
« Reply #2278 on: January 10, 2014, 09:01:18 PM »
Hi,

I'm having a bit weird problem with my raw footage. I was filming a three studio clips for a music video. Clips was more than 4gb so I joined the files together and then transformed them to dng files. After that I imported them to AE as a dng sequence, but the video plays much faster than the original song?

Did you record in Zoom mode (x5) or have the fps override? What version of ML you got?

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 7D Raw Thread
« Reply #2279 on: January 10, 2014, 09:12:37 PM »
AE defaults to 30FPS for image sequences. change it

Midphase

  • Hero Member
  • *****
  • Posts: 712
Re: 7D Raw Thread
« Reply #2280 on: January 11, 2014, 04:12:15 AM »
Guys, just wanted to check in. Shooting a short next week-end on a couple of 7D's. Right now they're both loaded with 12/03/13 TL and they work great for what I need to do.

I'm a bit hesitant to switch to the latest version before the shoot, but if it's rock solid then I have a week to test it out.

Is the latest TL working well for everyone? And if yes, I'm a bit confused as to which version I should grab, the one from the nightlies in 1%'s repository, or the one from the Nightly Builds section of the forum?

Many thanks!

africanmarty

  • New to the forum
  • *
  • Posts: 4
Re: 7D Raw Thread
« Reply #2281 on: January 11, 2014, 07:47:00 AM »
Try using the tools from g3gg0's thread on MLVBrowserSharp, I don't know if my mlv dumper is exactly right. I've always used the binaries from there with decent results.

thanks mate i'll try that.

javyelow

  • New to the forum
  • *
  • Posts: 33
Re: 7D Raw Thread
« Reply #2282 on: January 12, 2014, 01:26:04 PM »
Hi!

I have the latest tragic latern version (from yesterday) and it works very good,

now i can record hd raw in continous with the 7d, and i can put all the global draw settings on when i shoot in 1790 and get continous recording (23,97 fps)

one thing that make me sad for the begining of the 7d raw , why crop mode? any explanation that i could understand in the forum please? (i cant find it)

the diference from 1790 to 1920 is small but with crop mode this diference make 1920 useless for me

thanks for your time-!!

legi008

  • New to the forum
  • *
  • Posts: 3
Re: 7D Raw Thread
« Reply #2283 on: January 12, 2014, 02:33:03 PM »
The 18 MegaPixel sensor of the Canon 7D  has a definition of 5 184 × 3 456 pixel.

In normal video recording, it uses only 1 pixel every 3 pixels. So 5184/3 =  1728 pixels -> Produce Moire an Aliasing
In crop mode, it uses only the center of the sensor with exacly the choosen number (ex 1920) but it include a zoom magnification. -> no(or very low) moire and aliasing

javyelow

  • New to the forum
  • *
  • Posts: 33
Re: 7D Raw Thread
« Reply #2284 on: January 12, 2014, 03:04:54 PM »
thanks!! ok this is possible but the result looks bad? moare like h264 recording or more?


legi008

  • New to the forum
  • *
  • Posts: 3
Re: 7D Raw Thread
« Reply #2285 on: January 12, 2014, 03:42:31 PM »
no, in crop mode it is the best quality you can have but it zoom.
So you need to  be farther from the subject or shoot with a wilder ange to compensate the zoom.

Midphase

  • Hero Member
  • *****
  • Posts: 712
Re: 7D Raw Thread
« Reply #2286 on: January 12, 2014, 07:11:26 PM »
Thank you...so the new TL is a good version to use right? And I assume I should grab it from 1%'s Nightly and not from the general Nightly repository right?

Thanks...sorry, kinda being a bit paranoid since this entire shoot is relying on my decisions when it comes to this stuff.

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 7D Raw Thread
« Reply #2287 on: January 12, 2014, 08:04:58 PM »
http://tl.bot-fly.com/ is where it gets nightlied

Its working OK for me from what I shot. Recently the H264 and audio hooked me up in an emergency. Should be OK but please test what you're going to shoot for a decent period of time (i.e not just once).

Idir75

  • New to the forum
  • *
  • Posts: 4
Re: 7D Raw Thread
« Reply #2288 on: January 13, 2014, 05:30:38 PM »
Hello friends, I have a small problem on my 7d. Whether in the fomat RAW or MLV, I have a small purple point on all videos. This point does not appear in H264 or photos. Is there a solution?

I attached a picture.



Midphase

  • Hero Member
  • *****
  • Posts: 712
Re: 7D Raw Thread
« Reply #2289 on: January 13, 2014, 07:54:28 PM »
Hello friends, I have a small problem on my 7d. Whether in the fomat RAW or MLV, I have a small purple point on all videos.

Here's a whole thread about it for you to read:

http://www.magiclantern.fm/forum/index.php?topic=9700.0

Idir75

  • New to the forum
  • *
  • Posts: 4
Re: 7D Raw Thread
« Reply #2290 on: January 13, 2014, 09:34:23 PM »
This but me is bizarre .... I have the same dot and only one purple dot in raw or mlv video shot ... Helm me please... :)


Kiss from Paris  :o

Idir75

  • New to the forum
  • *
  • Posts: 4
Re: 7D Raw Thread
« Reply #2291 on: January 13, 2014, 10:15:07 PM »
I begin to answer. The purple dots appear when I am 2:35 format. There are no purple dots when 16:9 is selected.

weird ...

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 7D Raw Thread
« Reply #2292 on: January 14, 2014, 12:36:14 AM »
Cold/Hot pixels. They are marked for ACR only and not physically removed.

stanley

  • New to the forum
  • *
  • Posts: 4
Re: 7D Raw Thread
« Reply #2293 on: January 15, 2014, 03:12:10 PM »
First off thank you to the guys responsible for all the great developments on the 7D so far, I've been eagerly following from the start now updating with the nightlies and haven't run in to any huge noticeable problems, until now.

For some reason whenever the camera switches off I loose all my settings, iso, aperture and white balance etc, I've tried multiple cards with and without ML lantern on with no luck. This seemed to have started happening since the 08 Jan nightly build, has anyone else experienced this?

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 8854
Re: 7D Raw Thread
« Reply #2294 on: January 15, 2014, 03:15:18 PM »
Maybe you turned "autosave" off.

Prefs -> Config files -> Config Autosave

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: 7D Raw Thread
« Reply #2295 on: January 15, 2014, 04:04:05 PM »
I loose all my settings, iso, aperture and white balance etc

Are you in C mode?

(these settings are not handled by ML, but by Canon firmware)

Frank7D

  • Senior
  • ****
  • Posts: 457
Re: 7D Raw Thread
« Reply #2296 on: January 16, 2014, 08:38:26 AM »
First post, hi everyone.

I was using the 1/13/14 nightly build, shooting crop mode 1920x1080 23.976 fps when the filming stopped with beeps and "Early Stop 9 This is a bug please report it" so that is what I am doing. I have filmed a little since then and it hasn't happened again yet.

Also, I can't get the ml grayscale preview to appear. I set it to that and also tried "auto" but don't see it when shooting crop video.

stanley

  • New to the forum
  • *
  • Posts: 4
Re: 7D Raw Thread
« Reply #2297 on: January 16, 2014, 03:14:49 PM »
I feel very silly now, definitely slipped off manual in to C mode.

Thanks!

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 7D Raw Thread
« Reply #2298 on: January 16, 2014, 06:09:35 PM »
ML grayscale still working, have to add the fulltime color, the ML nightly is missing display filter code if you're using that. If someone wants to port it, its near 50D code and needs the state-object stuff for sync.

Deem

  • New to the forum
  • *
  • Posts: 19
Re: 7D Raw Thread
« Reply #2299 on: January 17, 2014, 01:42:58 PM »