Author Topic: 7D Raw Thread  (Read 368275 times)

DragonFlame

  • New to the forum
  • *
  • Posts: 27
  • Professional DOP
Re: 7D Raw Thread
« Reply #625 on: August 29, 2013, 10:10:46 AM »
FPS was the problem on 50D, you can only 30P the non zoomed size. If that is fixed here you should have 1080P.

That was the conclusion I jumped to also.

I'm sorry if I confused anyone earlier, as of right now 1080p is not available continuous but with the cameras specs it should be theoretically possible in the future when the 7D has had some tinkering and then ONLY with cards that can unlock the cameras true write speed.
Don't expect 1080p raw on your 60mb/s SanDisk as I know a lot of people here have them.

arrinkiiii

  • Hero Member
  • *****
  • Posts: 1101
  • ML ADDICTED 7D
Re: 7D Raw Thread
« Reply #626 on: August 29, 2013, 10:51:48 AM »
We are about to close the donations, just more a little bit for ending. If you can help us just send me a private message.

https://docs.google.com/spreadsheet/ccc?key=0AvJqzXLhtFjddERyZkRDQTYyOE93RXhNaHFEaUpYZEE#gid=0





Leave here something for you guys read while we wait for some Magic happen in ours 7D's

http://www.lensrentals.com/blog/2013/08/whats-all-this-raw-hack-business

dmk

  • Member
  • ***
  • Posts: 132
Re: 7D Raw Thread
« Reply #627 on: August 29, 2013, 11:19:36 AM »
Curious- is there going to be some sort of LZMA compression which will allow slower cards and/or more storage? Or is that already happening and compression of raw files is basically as good as it's going to get?

animotto

  • New to the forum
  • *
  • Posts: 2
Re: 7D Raw Thread
« Reply #628 on: August 29, 2013, 11:56:59 AM »
Nothing explains better the situation than this animated GIF!
Thanks Britom for this post with the latest builds.
Done some test shoots with my 7D as well:

Not a valid vimeo URL

Nice! Did you use the "Mosaic VAF-filter"? This is the first 7D raw-video I've seen without aliasing or moire (or maybe its in crop-mode?)

Mati

  • New to the forum
  • *
  • Posts: 9
Re: 7D Raw Thread
« Reply #629 on: August 29, 2013, 03:03:51 PM »

feureau

  • Hero Member
  • *****
  • Posts: 604
Re: 7D Raw Thread
« Reply #630 on: August 29, 2013, 03:29:20 PM »
I've been getting this hack error: http://i.imgur.com/nm5KIUd.jpg

Running Britom's latest build that builds .mlv at 1600x680

Also, a frame sometimes purples at the beginning of the clip, (before the first second) but that's been reported before, I guess.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: 7D Raw Thread
« Reply #631 on: August 29, 2013, 03:37:17 PM »
=> the safeguard is working well; all cache hack code should use this approach IMO

arrinkiiii

  • Hero Member
  • *****
  • Posts: 1101
  • ML ADDICTED 7D
Re: 7D Raw Thread
« Reply #632 on: August 29, 2013, 03:39:30 PM »
I've been getting this hack error: http://i.imgur.com/nm5KIUd.jpg

Running Britom's latest build that builds .mlv at 1600x680

Also, a frame sometimes purples at the beginning of the clip, (before the first second) but that's been reported before, I guess.

Hi feureau, long time no see you, we miss you  8)

For this version you need to disable the hack mode for not show up that warning. Not yet try but i think with britom and g3ggg0 version don't give you pink frame, you get more speed and more smooth on rec. Not yet make extensive tests.

If you have a warning about the small hack just turn it off. I've made some modification to make it work but it never went to the main repo, I think.
It's avilable in my repo (Pelican/raw)

ok, maybe different error warning

arrinkiiii

  • Hero Member
  • *****
  • Posts: 1101
  • ML ADDICTED 7D
Re: 7D Raw Thread
« Reply #633 on: August 29, 2013, 03:42:57 PM »
=> the safeguard is working well; all cache hack code should use this approach IMO

Is just to prevent that something bad happen to the card/camera? Wend the card don't have speed enough?

feureau

  • Hero Member
  • *****
  • Posts: 604
Re: 7D Raw Thread
« Reply #634 on: August 29, 2013, 03:51:22 PM »
Hi arrinkiii! Been out for a bit, and came back to this. Awesome development! :D Thanks for putting up that 7D + card thing for 1%

Disabled small hacks, and the hack error went away. I think it may be pelican's fix that didn't get in to the main repo. Someone might want to check that out.

Also, I enabled card warm up, and it seems the purple frame at the beginning of the clip error went away. Can anyone confirm this? (Mine's set at 256MB)

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: 7D Raw Thread
« Reply #635 on: August 29, 2013, 03:56:58 PM »
I've looked it up, but couldn't find it...

When you patch Canon code, you have to be sure you are patching the right thing. Otherwise, the side effects can be anywhere from not noticeable to camera exploding. That's why I've added that safeguard.

arrinkiiii

  • Hero Member
  • *****
  • Posts: 1101
  • ML ADDICTED 7D
Re: 7D Raw Thread
« Reply #636 on: August 29, 2013, 04:17:58 PM »
Hi arrinkiii! Been out for a bit, and came back to this. Awesome development! :D Thanks for putting up that 7D + card thing for 1%

Disabled small hacks, and the hack error went away. I think it may be pelican's fix that didn't get in to the main repo. Someone might want to check that out.

Also, I enabled card warm up, and it seems the purple frame at the beginning of the clip error went away. Can anyone confirm this? (Mine's set at 256MB)

It's nothing my friend,  just doing what i should do  :)  welcome back. Good to know that pink frame and warning have gone.

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 7D Raw Thread
« Reply #637 on: August 29, 2013, 04:19:42 PM »
Will have to fix the timers hack and see if disabling them completely helps any.

feureau

  • Hero Member
  • *****
  • Posts: 604
Re: 7D Raw Thread
« Reply #638 on: August 29, 2013, 04:46:36 PM »
It's nothing my friend,  just doing what i should do  :)  welcome back. Good to know that pink frame and warning have gone.

It's good to be back and testing new stuff. :D

Currently testing hot/dead/stuck pixel. Apparently I have some in my DNGs. Exporting via lightroom eliminates some but there's still hot pixel. Did the sensor cleaning thing to trigger the pixel mapping but it didn't seem to go away. I wonder if raw_rec ignores hot pixel mapping?

thoma

  • New to the forum
  • *
  • Posts: 9
Re: 7D Raw Thread
« Reply #639 on: August 29, 2013, 04:57:18 PM »
I was having the vertical lines issue but Hbr's advice fixed it ( disabling highlight tone priority, low iso noise reduction and long exposure noise reduction).  Now though I'm noticing the hot/dead/stuck pixel thing. 

Mainly hot single pixels evident once recovering shadow detail in ACR....is there something in camera that usually filters these out that's being bypassed?

jman

  • Freshman
  • **
  • Posts: 76
Re: 7D Raw Thread
« Reply #640 on: August 29, 2013, 05:04:23 PM »
Is anyone else getting this dropped pink frame in their raw video?? If so what is it. Used the 1152 X 648 resolution. Cheers ....John

jman

  • Freshman
  • **
  • Posts: 76
Re: 7D Raw Thread
« Reply #641 on: August 29, 2013, 05:10:15 PM »
Not sure if the video above will work. Here is the address.

brunonicko

  • New to the forum
  • *
  • Posts: 10
Re: 7D Raw Thread
« Reply #642 on: August 29, 2013, 07:11:46 PM »
Nice! Did you use the "Mosaic VAF-filter"? This is the first 7D raw-video I've seen without aliasing or moire (or maybe its in crop-mode?)

No, I did not use the filter. And it is not in crop mode  :)
I was able to remove some of the moire using the "remove chromatic aberration" options in adobe's raw loading interface, but I think that my lens being a little dirty helped too, hehehe

animotto

  • New to the forum
  • *
  • Posts: 2
Re: 7D Raw Thread
« Reply #643 on: August 29, 2013, 07:32:01 PM »
No, I did not use the filter. And it is not in crop mode  :)
I was able to remove some of the moire using the "remove chromatic aberration" options in adobe's raw loading interface, but I think that my lens being a little dirty helped too, hehehe

Ok :), When I've eventually switched my 60D for the 7D I will try those tricks before buying the filter.

Is it possible for audio being recorded simultaneously in future 7D-ML-versions? or is it the dual card-slots that make that possible on 5Dmark3?

kh3naz

  • Freshman
  • **
  • Posts: 52
Re: 7D Raw Thread
« Reply #644 on: August 29, 2013, 07:58:52 PM »
New test , watch in "Original" quality if possible


Pelican

  • Contributor
  • Senior
  • *****
  • Posts: 406
Re: 7D Raw Thread
« Reply #645 on: August 29, 2013, 08:09:29 PM »
If somebody want to play with enabling the small hack on 7D then I made a pull request to the main repo...
EOS 7D Mark II, EOS 7D, EOS 5, EOS 100 + lenses (10mm to 300mm), 600EX, 550EX, YN600EX x 3
EOScard, EOS DSLR firmwares, ARMu, NiControl, etc.: http://pel.hu/down

vnguyen972

  • Freshman
  • **
  • Posts: 72
Re: 7D Raw Thread
« Reply #646 on: August 29, 2013, 08:16:06 PM »
New test , watch in "Original" quality if possible


Very nice... what resolution spec and aspect ratio and fps did you use? crop mode? did you use any moire filter? love those bricks...
Love my EOS7D!

kh3naz

  • Freshman
  • **
  • Posts: 52
Re: 7D Raw Thread
« Reply #647 on: August 29, 2013, 08:24:37 PM »
Very nice... what resolution spec and aspect ratio and fps did you use? crop mode? did you use any moire filter? love those bricks...

I'm glad you liked , all crop mode , some shots with burst mode and some with the newest build with the raw module , all in 2520\2512 x 1200 , i did some really zoomed in handheld shots with my IS lens to see what it would look like

arrinkiiii

  • Hero Member
  • *****
  • Posts: 1101
  • ML ADDICTED 7D
Re: 7D Raw Thread
« Reply #648 on: August 29, 2013, 08:30:09 PM »
@kh3naz

Cool video, raw is amazing

@Pelican
@britom

Im ready, just need the compilation

dmk

  • Member
  • ***
  • Posts: 132
Re: 7D Raw Thread
« Reply #649 on: August 29, 2013, 08:31:42 PM »
kh3naz, really nice composition and color there. Looks excellent :)