600D ExFAT 4GB limit - what am I doing wrong?

Started by pipkato, August 05, 2013, 01:18:57 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


I posted this some time ago but did not find a solution so I hope someone can help.

I'm trying to install ML2.3 on a 16GB Sandisk Ultra card formatted in ExFAT but can't seem to get  it to work. My main objective is to get extended recording time, hopefully up to 16GB, on this card with my Canon 600d.  I'm not really concerned about audio or RAW, although extra functionality would be nice.  I already have ML2.3 working normally with my 600D on a different FAT32 SD card.

I think I'm following the instructions correctly, but when I put the card in my 600D and select 'Update Firmware' I get 'Cannot find the firmware update file' message.
Here's what I'm doing:

1.  Format the card in Disk Utiity to ExFAT

2.  Run Macboot in 'DSLR boot' mode and 'Prepare' the card.  Everything seems to run fine and I get a 'success' message.

3.  Using Finder copy the unzipped files from ML2.3 to the card.

4.  Put the card in the 600D, prepped for ML install, turn it on and select Firmware Update.  It can never find the update file.  So I remove the battery and start again. Always the same result.  I've also tried the suggestion of replacing the 'autoexec.bin' file to the one referred to below, but without success. I get the same error message.


Posts: 1416
Code monkey

Lengthen video recording time
« Reply #14 on: August 16, 2012, 05:23:19 AM »
exending file limit on 600D:
how to

          *                                                 *
          *                                                 *

1. Format card to EXFat
2. Make bootable
3. Copy ML 2.3 zip contents on card
4. overwrite autoexec.bin with the one from 1% fork
5. record more than 4GB.
6. fix the video file with g3gg0 tools on post

all link to what needed are here
« Last Edit: August 16, 2012, 09:53:56 AM by Malcolm Debono »

And, while I'm asking, is it also possible to achieve extended HD recording on the Canon 5D Mark II using ExFAT?



2.3 didn't have it. My builds did. No 5DII/50D, fat32 only.

You have to re-write the H264 files too.


Thanks very much 1% for that clarification. 

I had read that you did the work to get extended recording working, and thanks a lot for that.

I hope that explains the 'error messages' too.

I'm guessing you're referring to your builds as one of the nightly builds?  Does the latest nightly build contain your code?  If not, can you give me a link to the build that has the exFAT extended recording time option?

When I download it do I just follow the steps outlined in my first post, is there a step-by-step somewhere, or any 'must dos'?



Hello again 1%.

I think I found the download site for your work on Magic Lantern (https://bitbucket.org/OtherOnePercent/tragic-lantern-2.0/downloads), but I'm not sure which file to download, or exactly how to install it on a formatted exFAT SD card.

I've done a lot of googling but can't seem to find any step-by-step info anywhere.  As you've probably already gathered, I'm not a techie, but I am able to follow instructions.



I had the same problem with my Canon 600D a week ago. Today is your lucky day! You did everything right but the last part where you tried to go to Canon menu and update the firmware. To summarize, format your card to Exfat. Open Macboot and prepare card. Use the DSLR option. Unzip Magic Lantern 2.3 and copy it to main directory of the SD card. Download Tragic Lantern 2.0 and replace the autoexec.bin. That's it.


Thanks rikitik22.

That's really useful and I'll give it a try later.  It's really hard to find information about this 1% 'feature'.

So once I've copied ML2.3 to the exFAT card I just have to copy across the autoexec.bin from Tragic Lantern and  it should record HD beyond the 4GB limit?

Have you tried it for long recordings, and were you happy with the result?  Do you know where to find the latest version of the g3gg0 tool to fix the extended recording?  I'm on a Mac but I've a feeling that the 'fix' tool is for Windows.  Anyone know if  this is true or if there's a Mac version?