Canon 650D / T4i

Started by nanomad, August 03, 2013, 07:27:52 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


How to downgrade?
eos 1.05 - eos 1.04



Just found this forum, today.  Hope to obtain a solution to the 29:59 minute limitation when recording video.  Essential to an objective I have of recording our church services and making the videos available to our members who are at home and unable to get out.

I have a Canon ESO T4i.  It is about 2-3 years old.  I am attempting to install ML, but all my attempts result in failure at the 4% mark while the Firmware Update Program is running.  At that point, I receive the following message:

"Update file error

Please check the memory
card and reload the
battery and try again."

The camera was using firmware version 1.0.5.  I installed version 1.0.4 after reading here that the current version of ML requires 1.0.4 (please correct me if I am wrong).

Initially, I was using a 200-GB card, but after reading some past posts about possible problems with anything above 32-GB, I attempted to install ML from a 2-GB card.  Still not successful.

I performed a low level format of the card (using the camera) before copying the ML files to it.  During all this, I noticed the camera formats the card using FAT despite the manual saying exFAT is used.  As a result, I attempted installing ML using the card formatted as FAT, then exFAT.  Still no success with the same error message.

I also attempted to use the last three ML posted files.  I got as far as using the nightly build posted MAR 12, 2017.  Same unsuccessful results.

At this point, I am at a loss as to what to try next.  Any guidance would be greatly appreciated.

Thank you!


Walter Schulz

Use photo mode M, retry with 2 GB card. Retry.
If it fails, reset cam to factory defaults. Don't forget C.Fn settings. Retry.

Cam will format all cards < 64 GB with FAT16/FAT32. Doesn't matter for this part of the operation.


Hey guys,

after a long flawless life of Magic Lantern, I got some blue screens on April 1st, saying my camera is bricked. Thinking it was an April fool's joke, I re-entered the battery and got another one after a couple of hours. I updated to the latest nightly build, Mar30. Since then, no errors, just a random freeze yesterday.

Any ideas?


I wonder how many hours April Fools Day lasts?

24 maybe  ;)


Hi, everyone!  Where is the module in this firmware??? Where I can download this module?


Found this module in FW for 50D - may i copy this module to my FW?


Wanted to share my latest video using ML,  Bit rate increase to 1.7 H264


Quote from: NickGRava on April 18, 2017, 12:02:55 AM
Hi, everyone!  Where is the module in this firmware??? Where I can download this module?

Just a quick google search away....Quote from

"this module does not add AFMA support to camera bodies that did not contain this feature in Canon firmware."
650D | Canon 17-55 2.8 | Tamron 70-200 2.8 | Nifty 50 1.8


Current issues with Magic Lantern for 650D.

1. When you pop out the LCD to view yourself when shooting video VERY OFTEN the LCD will be a mirror image of its with all the text also the wrong way round.
You can some what fix this by rotating the LCD screen up/down/in/out, BUT most of the time the auto face detection / focus is then mirrored the wrong way round (So if you move your head to the left the focus square moves in the opposite direction).

(Auto mirroring does not fix this, but I'm not sure its even intended for this)

Ive tried the above WITHOUT Magic Lantern installed and it operates correctly so it must be ML causing this.

2. Flashing histogram layered on top of Magic Lantern main menu (When you hit TRASH). Sometimes you will also see some of the view from the lens too.

I assume this is where we report issues?

Thanks in advance for looking into this and fixing it.


Brand new to Magic Lantern and installed on my t4i. I don't see the ETTR on the Expo menu, but I've seen mentions of it, including a long post where somebody had it running on the t4i. Is it gone....coming back?


Modules tab.
See download page ->Features
for feature sets for all cams supported with nightly builds.


I have a  problem with the third Party Flash function...
I don't have the Feature.... Why?
Loaded the last latest Release ML


Picture Styles, when set to view in one style and record in another, does not record in another.
Sometimes yes, Most of the times not.


Hi, I have a question regarding fps override. I am targeting 1 fps (from 60). With ISO at 100 and aperture closed to highest f-stop I am overexposed by several EV. I also have a 600D and with the same settings, or even more open aperture, I am able to achieve correct exposure. I have the 2017Jul03 nightly installed. I am shooting daylight scenes such as clouds time lapse. I have ND filters that allow me to obtain correct exposure, but would love to do without them.  Any tips? Thank you.


Hi! Thank you for your work. One that's upset that Canon650D not able to see your audio settings. it is very important to monitor the level of sound, but unfortunately these features are not available on camera Canon 650D. please do complete the item "Audio" for 650D. may be the problem to quickly fix this by adding a module?


Hello, I was the original poster of this thread. WOW, who knew it would have been so useful. Thanks for being there. I have a new Canon EOS 650D T4i and am looking for a current installer package, updated instructions and an easily accessible link to update to the correct firmware. I've also notices there were issues with other installations and wish to avoid those. Is there any way to run ML's firmware from the SD card without doing an install. Thanks.


UPDATE ... Firmware has been updated 1.0.4 firmware and extracted current nightly build file to card an downloaded new .FIR. Camera said to restart but reverted back to original Canon menu, suggestion?

Walter Schulz

Top of page -> User Guide -> Install Guide -> Step 3.

Walter Schulz

Sure, why bother with ML's inofficial firmware repository linked in download page and hosted by user pelican?


Looking for 650D user input on a short test.

The audio meters were broken on the 700D and since the 650D is closely related I'd like to see if maybe it is also happening on the 650D.

The way to run the test is fairly simple. Turn on both the mlv_rec and mlv_snd modules and activate those modules. I prefer to reduce the frame to the smallest size because we're only checking for an audio issue. The first time you record an MLV clip the audio meters should work normally. What I'm interested in is what happens on the second through the forth clip. Make sure not to restart the camera between takes. Do the audio meters continue to operate normally? On the 700D the audio meters stopped working after recording the first clip. Of course more important is if sound is being recorded to the MLV file. In the case of the 700D the audio did get recorded even though the meters weren't working.

We're running an experiment with mlv_snd that might be affecting the 650D. Go to my Bitbucket download page and get both these files:

Run the same test as above and please report your results in the "Will the real SoundDevShutDownIn please stand up" topic. My theory is that these test builds should work the same as the current nightly but I don't have access to a 650D to test my theory.

For a quick explanation of what is going on, a few cameras have the same address for two different stubs, SoundDevShutDownIn and StopASIFDMAADC. We're running a test in the crop_rec_4k branch to put things in order but we want to make sure nothing breaks on the other ML supported cameras. The 650D_test_mlv_snd_fix uses the fix found for the 100D which calls both SoundDevShutDownIn and StopASIFDMAADC to stop the audio while the 650D_test_stubs_fix uses the fix found for the 700D which doesn't use either of those functions so they are commented out in the stubs.S file. Note that the 650D doesn't have the StopASIFDMAADC defined.


Oops--found that the 650D is missing StopASIFDMAADC in the stubs.S file yet the camera does have this stub. Let's see if this works. If you already downloaded this file please re-download it and run the test again. (There was only 1 download so you know who you are.)

Walter Schulz

"audio failed to stop, state 4" after stopping 2nd recording with new build.

Audio markers not moving in LV after 2nd recording for both builds. Always 0.
After starting record again (Global Draw off) you will see audio markers moving for short time before switching to record screen.
and with Global Draw On they are moving during recording, too.


Hi Walter - thanks for testing.

I'm a bit confused though.

Quote from: Walter Schulz on October 03, 2017, 07:35:37 AM
"audio failed to stop, state 4" after stopping 2nd recording with new build.

By new build do you mean the latest Nightly or the file I just posted in Reply #1897?

Quote from: Walter Schulz on October 03, 2017, 07:35:37 AM
Audio markers not moving in LV after 2nd recording for both builds. Always 0.

Both of my builds?

The important thing is if you can verify that it is working properly in the unified branch. I just found a missing stub but I think we'll need to keep it commented out.