Magic Lantern (RAW) Video format v2.0 (mlv_rec.mo)

Started by g3gg0, July 15, 2013, 10:58:23 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

tjaja

QuoteCard spanning is working just fine, i can confirm on that, as i always shoot with it ON! Trying out the latest nightly all day and it works all right...

That makes it even weirder. Can you post your settings if its not too much of a hassle? Card spanning used to work here too but now its constant idle, even with the the highest resolution.

My build is of 7-2-2014. Record func + card/folder sel. is on standard in the canon menu( useless info?)  The two cards are now in fat32 and the SD has EOS_develop and Bootdisk flashed on it.
5DFree, 550D, canon 50mm 1.4

gravitatemediagroup

the last several nightly builds i've tested all freeze up after I press record, with mlv_rec and the original raw.  I haven't made any changes to settings other than frame skipping.
the little camera icon pops up in the top right corner, but just stays 0:00.  with a MK3

1%

Turn off the card full save file and it starts instantly.

tjaja

Now im pretty sure card spanning is resisting:

When I turn off CF-only buffers and Buffer Method on 0 it wont record at all.
Also with a 5d3
5DFree, 550D, canon 50mm 1.4

escho

I´m trying to make the cold-pixel-fix from raw2dng working with mlv_dump: https://bitbucket.org/escho/escho-magiclantern/branch/cold-pix-fix

Doing this, I went into something, I never realized before  in this way:

MLV-file 2.2MB recorded with my 600D (camera on my teleskope for recording jupiter, 5801 frames, 640 x 360 px, mlv_dump from today)
Decoding times:

./mlv_dump -r -o test.RAW *.MLV:      11s
./raw2dng test.RAW:                             44s

./mlv_dump --dng  *.MLV:                    5min 59s

Why this very big difference of decoding times between the detour over legacy raw and direct converting to dng with mlv_dump?

Edgar
https://sternenkarten.com/
600D, 6D, openSUSE Tumbleweed

ouuzi

Quote from: 1% on February 08, 2014, 06:22:35 PM
Turn off the card full save file and it starts instantly.
where is that setting 1%?

tjaja

Quotewhere is that setting 1%?
Beneath Card Spanning:
Reserve card space ON/OFF
5DFree, 550D, canon 50mm 1.4

tonybeccar

Sorry to bother here again, still trying to understand the metadata. What is the Audio Frame Count for? An amount of frames for the audio and video to be in sync? If so, how does it work exactly? Thanks!

escho

Quote from: escho on February 08, 2014, 08:21:32 PM

Why this very big difference of decoding times between the detour over legacy raw and direct converting to dng with mlv_dump?

Edgar

Oh, I understand. Disabling croma-smooth by using the --no-cs option makes the stuff fast. Didn´t know, that chrama-smooth is enabled by default. Is this wanted?

Edgar
https://sternenkarten.com/
600D, 6D, openSUSE Tumbleweed

tin2tin

I've noticed that ffmpeg has a GSOC suggestion which includes better DNG handling: http://wiki.multimedia.cx/index.php?title=FFmpeg_Summer_of_Code_2014#Bayer_RGB_colorspaces

How about suggesting the ffmpeg folks a MLV import GSOC implementation, if you guys thinks that MLV is mature enough by now?

tonybeccar

Quote from: tin2tin on February 08, 2014, 09:11:59 PM
I've noticed that ffmpeg has a GSOC suggestion which includes better DNG handling: http://wiki.multimedia.cx/index.php?title=FFmpeg_Summer_of_Code_2014#Bayer_RGB_colorspaces

How about suggesting the ffmpeg folks a MLV import GSOC implementation, if you guys thinks that MLV is mature enough by now?

Excuse me.. but ffmpeg doesn't support DNGs NOW? Am I right?

tjaja

I am seeing there are multiple questions varying from themes being asked on this thread.
Maybe opening a new thread would be better.
Last try here:


See how idle the sd card is? Volcano Kohala saw this picture and complained how idle the sd is.
5DFree, 550D, canon 50mm 1.4

tonybeccar

Quote from: escho on February 08, 2014, 09:08:38 PM
Oh, I understand. Disabling croma-smooth by using the --no-cs option makes the stuff fast. Didn´t know, that chrama-smooth is enabled by default. Is this wanted?

Edgar

Is there a quality difference between chrome-smoothed and non-chroma smoothed? What's the difference?

tonybeccar

Oh one other thing, I think a bug maybe... there seems to be a mismatch in the camera serial number. For example mine is: 2661200228 and inside the MLV it shows: 9E9EB164. Mlv_dump shows the same. Is it a bug or a different way of coding the number?

escho

Quote from: tonybeccar on February 08, 2014, 09:16:06 PM
Is there a quality difference between chrome-smoothed and non-chroma smoothed? What's the difference?

Yes, should be. Enabling chroma-smooth should make the pics a little bit smoother (reducing  colored noise and maybe some hot pixels). But in this case, it does nothing. I can use any chroma-smooth-option, I want, the output-dngs are always the same. No difference between them.

Edgar
https://sternenkarten.com/
600D, 6D, openSUSE Tumbleweed

escho

Quote from: escho on February 08, 2014, 09:40:57 PM
Yes, should be. Enabling chroma-smooth should make the pics a little bit smoother (reducing  colored noise and maybe some hot pixels). But in this case, it does nothing. I can use any chroma-smooth-option, I want, the output-dngs are always the same. No difference between them.

Edgar

That´s a bug in mlv_dump.c

I found it, but cannot create a pull request to fix it at the moment. Maybe later...

Edgar
https://sternenkarten.com/
600D, 6D, openSUSE Tumbleweed

tjaja

Ok, so i left out my CF card trying to do raw on just the SD. Card spanning on. I lowered the resolution so it would be like 19mb/s. I rebooted to make sure card warming increases a lil speed.
After warm up,I hit REC and the module said: failed to create file. Card full?
After rebooting the camera, put in high speed shooting and the card took the shots without hesitating. I also recorded a normal movie.
Card spanning off and it recorded perfectly. So now i put the cf card in again, card spanning on, and upped the resolution to 2k.
SD card idle again. 
5DFree, 550D, canon 50mm 1.4

g3gg0

Quote from: tin2tin on February 08, 2014, 09:11:59 PM
I've noticed that ffmpeg has a GSOC suggestion which includes better DNG handling: http://wiki.multimedia.cx/index.php?title=FFmpeg_Summer_of_Code_2014#Bayer_RGB_colorspaces

How about suggesting the ffmpeg folks a MLV import GSOC implementation, if you guys thinks that MLV is mature enough by now?

thanks, getting in contact with them.
Help us with datasheets - Help us with register dumps
magic lantern: 1Magic9991E1eWbGvrsx186GovYCXFbppY, server expenses: [email protected]
ONLY donate for things we have done, not for things you expect!

duey101

Have I missed this somewhere in the forum, because I just scoured the entire forum for this and got nothing.  Did I just make a breakthrough discovery that PPro CC works native with MLV raw files direct off the card (with a few minor glitches).  I was just mucking around with all these converters and programs and thinking to myself, how great would it be if Adobe just supported MLV native right off the SD/CF card.  Well, it seems that PPro CC does just that... almost 100%. 

I was dragging in some CDNG clips into PPro and then I went to my Media Browser and saw my MLV RAW folder there and decided to click on it just for fun to see what happens.  To my amazement PPro said "processing clips" the MLV raw clips!!!  Then I then dragged those MLV raw clips into the source monitor, set in/out marks, dragged them into my timeline and edited, added effects, and exported!  All without any problems or crashes and glitch free scrubbing in PPro!  The only glitch is there is a weird triangle that progresses down the frame as the clip is played and I saw a few dead/cold pixels in the output file, but that might be something in my settings that caused the cold pixels, not sure.

Has this been posted already on the forum?  I couldn't find it.  Could this be a major breakthrough for ML developers?  I sure hope so!!!  Fingers crossed!   :)  Please chime in with any ideas or fixes for the triangle or cold pixels, because other than that PPro works native with .MLV raw files right off the card!  I can't believe this hasn't been discovered already.

Here is a screen capture of PPro CC showing the MLV clips...



And the mystery arrow that progresses down the screen with the .MLV extension next to it.



Here is the MLV ouput to H.264/Viemo setting...
[vimeo]http://vimeo.com/86220798[/vimeo]
Gear: Canon 5D Mark III, 60D, EF 70-200L, EF 85mm, EF 50mm, EF 10-22mm.  Platform: Dual Boot Win 7 Ultimate x64/Mavericks Hackintosh, PPro CC, LR5.

andy kh

it doesnt work for me. mlv clip is not shown in the media browser
5D Mark III - 70D

g3gg0

We talk about adobe Premiere pro that supports mlv out of the box?
wow...
wish that were true :)
Help us with datasheets - Help us with register dumps
magic lantern: 1Magic9991E1eWbGvrsx186GovYCXFbppY, server expenses: [email protected]
ONLY donate for things we have done, not for things you expect!

duey101

@g3gg0  Please look at the thread I started on this topic, it definitely works, look at the videos I posted.

http://www.magiclantern.fm/forum/index.php?topic=10401.new#new

Maybe delete this post here since I already started another thread?  I wasn't sure where to put it. 
Gear: Canon 5D Mark III, 60D, EF 70-200L, EF 85mm, EF 50mm, EF 10-22mm.  Platform: Dual Boot Win 7 Ultimate x64/Mavericks Hackintosh, PPro CC, LR5.

andy kh

now i found out that its the drastic MediaReader worstation that enable premiere pro import mlv or raw directly. and the triangle is the watermark since you are using trial version. to get rid of the triangle u need to buy drastic media reader.
5D Mark III - 70D

escho

Quote from: escho on February 08, 2014, 10:03:09 PM
That´s a bug in mlv_dump.c


The bug wasn´t a bug. My testings were wrong. Sorry for that...

Edgar
https://sternenkarten.com/
600D, 6D, openSUSE Tumbleweed

tronics

Where to get the latest nightly build of the mlv_rec.mo?
In the OP post there is only one link that did not change over time (as far as I understand).

I have a 128GB 1050x Komputerbay card. Is it worth switching to the current RAW version, or shall I stay with the old version because only the 64GB 1000x is reliable enough?

I have a Canon 5d mkIII and I need to shoot in minimum 1080p25 (located in Europe).

Thank you.