Author Topic: 50D - 14bit raw video builds and test results  (Read 79999 times)

akumiszcza

  • Freshman
  • **
  • Posts: 85
Re: 50D - 14bit raw video builds and test results
« Reply #100 on: June 28, 2013, 08:57:15 PM »
@akumiszcza thank you for your continued detailed bug reports - how did it work with a card format?

This is I who should thank you, and others, for wonderful new builds of ML!

As for formatting, it makes wonders!

Settings: quality jpeg L, small hacks on, global draw off, auto ettr always on, 1920x1080 @ 23.976 at x5

Everywhere below these are numbers of frames before a frame is skipped. Started right after turning on - no video recorded before. Second and third trial done immediately after frame skipped.

No format (card taken out of box and put into camera): 1060 frames, 1123, 1017
In camera format (keep ML): 1497, 1878, 1898!

1000-1100 vs almost 1900 is a hell of a difference. And the format takes seconds, so it's a "quick format", not erasing each byte on the card.

Speed during recording: 81.7 MB/s.


I didn't try formatting the card in card reader yet.

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D - 14bit raw video builds and test results
« Reply #101 on: June 28, 2013, 09:08:32 PM »
Aligned + 64K clusters is giving me the best speeds.. expect a 1-2mb cut from formatting in camera to 32k clusters. At least on 64GB cards.

KENNEDYR21

  • New to the forum
  • *
  • Posts: 7
Re: 50D - 14bit raw video builds and test results
« Reply #102 on: June 28, 2013, 09:50:15 PM »
Question, should i be formatting my card in camera or from the card reader using macboot, to get the best possible speed. I use Komputerbay 64gb 1000x.

I've been formatting in camera and never got speeds higher then 63 ( following the methods advised, GD off etc etc...), untill i used the small hacks. which boosted me up to around 75. I see alot of you getting speeds of 80 to 81. i also tried turning off the the timers, but for some reason that option is not listed in my debug list.
Note: Using very latest build.

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D - 14bit raw video builds and test results
« Reply #103 on: June 28, 2013, 10:01:38 PM »
Its on my builds along with display filters. Main doesn't have it yet.


You have to align partition to 4096 and set cluster size to 64, then you should get to the 80s. no idea on how to do it on mac... maybe virtual machine

akumiszcza

  • Freshman
  • **
  • Posts: 85
Re: 50D - 14bit raw video builds and test results
« Reply #104 on: June 28, 2013, 11:53:03 PM »
Aligned + 64K clusters is giving me the best speeds.. expect a 1-2mb cut from formatting in camera to 32k clusters. At least on 64GB cards.

I reformatted the card:

diskpart
list disk
select disk [...] <- I chose the disk with 29GB, same order as in diskmgmt.msc
clean
create partition primary align=4096


Then format in explorer - fat32, 64kb, quick.

To check:
wmic partition get BlockSize, StartingOffset, Name, Index
StartingOffset divided by BlockSize should be a multiple of 4096 I think? (I got 8192)
Was the procedure alright?

The result with the same options as the previous test:
2186, 2027, 1506

Generally it was about 2000 frames. Much more than 1000 with a genuine format. BTW, reformatting the card in camera removes the alignment.

I forgot to mention - all tests were done with 27 june unified build.

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D - 14bit raw video builds and test results
« Reply #105 on: June 29, 2013, 12:30:50 AM »
It didn't unalign for me, just did the clusters to 32, I'll double check it. It should be a multiple of 4096. I think my starting offset was much higher than 8192.

heh, yea it Fd alignment, had to reformat.

akumiszcza

  • Freshman
  • **
  • Posts: 85
Re: 50D - 14bit raw video builds and test results
« Reply #106 on: June 29, 2013, 09:20:55 PM »
I see some problems with Auto-ETTR for taking photos in unified 27 June and 28 June builds at least. In M mode starting ETTR sets time to 30", although the time shown on the screen is different. If I try to take a photo it really tries to expose it for 30 seconds... In AV mode it works OK.

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D - 14bit raw video builds and test results
« Reply #107 on: June 29, 2013, 10:38:27 PM »
For me its not working right now in photo... it doesn't open the LV for long enough then writes an assert about lv_request count. In LV modes its ok.

aaand a few reboots then its working.. but doing same thing on 6D.. weird.

Think it needs to wait a little longer for lv_request and try again if it fails.

akumiszcza

  • Freshman
  • **
  • Posts: 85
Re: 50D - 14bit raw video builds and test results
« Reply #108 on: June 29, 2013, 11:56:20 PM »
Sorry, I did not mention it. It was LV mode, not  photo mode. That's why I wrote it set 30"on the camera (small lcd at the top), while showing correct time on the screen (global draw). The correct time for the exposure should have been around 1/30 s. The av mode photo was correctly exposed.

dsManning

  • Member
  • ***
  • Posts: 102
Re: 50D - 14bit raw video builds and test results
« Reply #109 on: July 06, 2013, 02:21:03 AM »
Komputerbay 32GB 1000x card is working really well with the most recent build GregoryOfManhattan, thanks!

Getting over a full minute of 1920x1080 with no special exfat formatting, just running it through the card.  I don't intend to shoot 1080 all the time (that crop at 5X on my 24-70 2.8 is heavy & ~4.2mb/CDNG is killing me), regular framing still upscales nicely, but it is so nice to know that we can shoot over a minute of full RAW 1080 goodness.

Below is a shaky video of some fireworks on the 4th.  So windy up there, and my crappy pull focus really shows, but I'm really happy with the colours and lack there of (blacks).  Original video was over 1 minute, but I chopped off the first few seconds because the shake was unbearable.

Watch on YouTube at 1080 for full quality

KahL

  • Freshman
  • **
  • Posts: 64
  • kahleem poole-tejada.CINEMATOGRAPHER
Re: 50D - 14bit raw video builds and test results
« Reply #110 on: July 06, 2013, 08:34:19 AM »
Wanted to share my latest piece using the 50D Raw (off of the June 28th build).
80% shot on raw, and slow mo pieces using 60D video.

It's becoming smoother using Davinci Resolve to start things off. The color matching gets a bit cluttered, but w/ a LOG export setup from the Raw sources (along w/ the video filmed in Vision Log), it streamlines things a bit.


GEAR
Shot on Canon 50D w/ Magic Lantern 14bit DNG Raw.
Secondary shots on Canon 60D Raw (Super 16mm grade resolution) and 720p 60fps video (for slo-mo, using VisionColor picture style)

FILM GRAIN provided by VisionColor

LENS
Nikkor AI-S 28mm f2.8

GregoryOfManhattan

  • Member
  • ***
  • Posts: 170
Re: 50D - 14bit raw video builds and test results
« Reply #111 on: July 12, 2013, 12:34:45 AM »
new unified build
https://bitbucket.org/GregoryOfManhattan/magic-lantern/downloads/magiclantern-2013Jul11.50D.109.go.unified.5db91070a1aa.zip
changes include:
- pic-view incorrect size fix based on an excellent bug report http://www.magiclantern.fm/forum/index.php?topic=6976
- refactoring of dynamic range code in raw.c NOTE: 50D users should consider these changes the DxO values for 50D start at 200 ISO and have 7 total values. i added these from www.dxomark.com but wonder if the value for 100 ISO should be interpolated see src/raw.c get_dxo_dynamic_range
- Fix raw settings refresh after zoom mode change
- new ime input modules are in process

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: 50D - 14bit raw video builds and test results
« Reply #112 on: July 12, 2013, 07:42:41 AM »
Yes, put an interpolated ISO 100 value, because all my other code assummes that.

GregoryOfManhattan

  • Member
  • ***
  • Posts: 170
Re: 50D - 14bit raw video builds and test results
« Reply #113 on: July 12, 2013, 02:17:43 PM »
Yes, put an interpolated ISO 100 value, because all my other code assummes that.
thanks - glad you refactored code and i looked through it - seemed to assume 100. (GiovanniC or someone else had previously warned of this)
submitted pull request after calculating that the 50D goes to 11 (100 ISO Ev dynamic range is 11.00)

so after this update, would the 50D raw video look any different?
seems that in active movie_mode raw_info.dynamic_range will be compute_dynamic_range - so no change for raw video.
photo mode images in liveview will now have a more correct dynamic range applied.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: 50D - 14bit raw video builds and test results
« Reply #114 on: July 12, 2013, 02:46:15 PM »
Nope, this is used for display only (e.g. to compute underexposure thresholds, stuff like that).

D.L. Watson

  • Freshman
  • **
  • Posts: 77
  • Film Artist
Re: 50D - 14bit raw video builds and test results
« Reply #115 on: July 13, 2013, 06:31:40 AM »
I don't know how to thank the developers for this feature. You are further democratizing the tools and technologies of independent filmmaking. I thank you and will continue to do what I can to support Magic Lantern (especially when I get my bonus checks).

I thought I would share my first real attempt at 1080p RAW with the 50D. By the way, I'm using the Komputer Bay 1000x 32gig and I'm experiencing continuous recording in 5X mode, 1080p.


I shot with a 8mm Rokinon and a 200mm Canon FD lens.
See my portfolio of work at www.dlwatson.net

akumiszcza

  • Freshman
  • **
  • Posts: 85
Re: 50D - 14bit raw video builds and test results
« Reply #116 on: July 13, 2013, 01:47:59 PM »
The issue with auto-ETTR still appears in latest July 11 build. I've noticed that it appears almost only on dark or very dark scenes and in M mode, both LV and photo mode.

Here's what it looks like:

As you can see, the exposition was quite OK at 1/50 s, f/2.8, ISO 800. After turning on Auto-ETTR by pressing SET the camer set it to 30 s, f/2.8, ISO 1600 which would overexpose the whole frame.

Here are the settings:
magic.cfg
# Magic Lantern 2013Jul11.50D.109.go.unified.5db91070a1aa (5db91070a1aa (unified) tip)
# Built on 2013-07-11 16:42:39 by go@hack.local
# Configuration saved on 2013/07/13 09:32:23
beta.warn = 13
menu.first = -2
movie.log = 1
fps.preset = 1
fps.override.idx = 32
fps.override = 1
post.deflicker.sidecar = 0
spotmeter.draw = 0
waveform.draw = 0
zebra.draw = 0
disp.mode.x = 133
module.autoload = 1


ettr.cfg
# Config file for module ettr (ETTR.MO)

auto.ettr = 1


raw_rec.cfg
# Config file for module raw_rec (RAW_REC.MO)

raw.video.enabled = 1
raw.res.x = 14
raw.aspect.ratio = 14
raw.write.speed = 7577
raw.small.hacks = 1
raw.warm.up = 4

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: 50D - 14bit raw video builds and test results
« Reply #117 on: July 13, 2013, 02:18:22 PM »
You have reached the exposure limits of LiveView.

The problem is that I don't know exactly how to find them for each camera.

akumiszcza

  • Freshman
  • **
  • Posts: 85
Re: 50D - 14bit raw video builds and test results
« Reply #118 on: July 15, 2013, 07:38:28 AM »
You have reached the exposure limits of LiveView.

The problem is that I don't know exactly how to find them for each camera.

Sorry for noob questions, but does this mean it will never be possible to use auto-ETTR in low light? Or maybe during finding the proper exposure it goes through "impossible settings" for a moment and the whole process breaks? Can it be avoided if these "exposure limits" are found?

I'm a photographer, not a videomaker, and this feature will be much more important than occasional videos.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: 50D - 14bit raw video builds and test results
« Reply #119 on: July 15, 2013, 07:47:47 AM »
Outside LiveView; but this is not yet ported on 50D IIRC

I've used it with 5D3 in a cave. Auto Snap, took first shot at 1 second or so, next shot auto-exposed at around 10-30 seconds ISO 100-6400.

GregoryOfManhattan

  • Member
  • ***
  • Posts: 170
Re: 50D - 14bit raw video builds and test results
« Reply #120 on: July 21, 2013, 05:01:26 PM »
new 50D unified builds posted with more correct Dynamic range information.
previously to July 15, 50D unified has been underestimating available dynamic range at most ISO settings.
have corrected this, albeit with a potentially inaccurate ISO 100 dynamic range value.
see discussion on Topic: Is 100 a native ISO on 50D? Correct Dynamic Range values for 50D http://www.magiclantern.fm/forum/index.php?topic=7102.msg59340#msg59340

Histogram and Zebras should now be more accurate.
if the ISO 100 zebras or Histogram appear to be inaccurate based on your photographs, please weigh in on Topic: Is 100 a native ISO on 50D? Correct Dynamic Range values for 50D.
if underestimating dynamic range is better (safer) - the value could be set lower.





Andy600

  • Contributor
  • Hero Member
  • *****
  • Posts: 1863
  • Have you tried turning it off and on again?
Re: 50D - 14bit raw video builds and test results
« Reply #121 on: July 21, 2013, 05:09:37 PM »
Gregory - Have you tried using ADTG for shutter timers? I've been using it for a few days and haven't had any issues. Not tried it with Unified though.

https://bitbucket.org/andy600/tl50d/commits/216d975da278a5ab5bde1ecb52044bea2711c316
Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com

dlrpgmsvc

  • Senior
  • ****
  • Posts: 398
  • The 7D and 50D Robin Hood
Re: 50D - 14bit raw video builds and test results
« Reply #122 on: July 26, 2013, 02:30:12 PM »
Komputerbay 32GB 1000x card is working really well with the most recent build GregoryOfManhattan, thanks!

Getting over a full minute of 1920x1080 with no special exfat formatting, just running it through the card.

Do you manage to have a realtime preview of the full real field of view on the live view display, or do it's cropped also ? Do it jumps or it's fluid ? And color or b/w ?
If you think it's impossible, you have lost beforehand

dsManning

  • Member
  • ***
  • Posts: 102
Re: 50D - 14bit raw video builds and test results
« Reply #123 on: July 26, 2013, 03:25:04 PM »
If you set snap to 5x in zoom prefs and snap to center before you zoom, what you see on screen is what you get at 1080. Preview is in B&W

Andy600

  • Contributor
  • Hero Member
  • *****
  • Posts: 1863
  • Have you tried turning it off and on again?
Re: 50D - 14bit raw video builds and test results
« Reply #124 on: July 26, 2013, 03:29:22 PM »
If you set snap to 5x in zoom prefs and snap to center before you zoom, what you see on screen is what you get at 1080. Preview is in B&W

Not quite. In grayscale preview you see 5x zoom while the video will be 3x zoomed. You need to use the low-res hacked preview to see the full recordable area.
Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com