Author Topic: The CinemaDNG Discussion (raw2cdng)  (Read 782327 times)

chmee

  • Contributor
  • Hero Member
  • *****
  • Posts: 1031
  • raw2cdng
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1275 on: December 24, 2015, 10:19:24 AM »
thx

@mothaibaphoto
It transcodes (00-10) 11 Pictures on my PC. There were ~360 Frames in this MLV and the 12. is not complete i assume. So the problem you have is the flickering, right?

regards chmee (btw. merry christmas)

mothaibaphoto

  • Senior
  • ****
  • Posts: 385
  • pesky kid
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1276 on: December 24, 2015, 02:06:59 PM »
Any other converter transcodes 12 pictures as this is result of running "mlv_dump.exe -f 1-12 " against a big file.
It seems the last picture is omitted, but this is not always the same with 1.7.4 - with big files it can drop random frames.
I believe flickering has nothing to do with this case - I just tried already uploaded file.

chmee

  • Contributor
  • Hero Member
  • *****
  • Posts: 1031
  • raw2cdng
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1277 on: December 24, 2015, 03:01:09 PM »
thanks for clarification. in this case i think i just left the last frame (generally) and its not under this "lostframe"-symptom. If you say, this bigger MLV has problems in my converter - could you leave me a bigger part, that loses frames somewhere in the middle? maybe about 250 frames? zip'ped?

mothaibaphoto

  • Senior
  • ****
  • Posts: 385
  • pesky kid
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1278 on: December 24, 2015, 04:18:00 PM »
I tried about couple of dozen files - and every time just last frame was dropped :(
But, I remember for sure, there was something in between.
Then, I found more than 2 gig file which loses № 494 out of 501. And, finally, i found video with lost frame № 128 out of 135. It's a 550 mb mlv and 80 mb m00. I can upload these files tomorrow (after my daily traffic limit renew).
Merry Christmas !!!
UPD: video with lost frame № 128 out of 135

ibrahim

  • Member
  • ***
  • Posts: 193
  • Physician & videographer
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1279 on: January 08, 2016, 06:21:37 PM »
Hi

Whwn I open the mlrawviewer and check the number of frames compared to raw2cdng I notice that many frames are missing after export in raw2cdng compared to mlrawviewer. I use both raw2cdng version 1.7.4 and 1.6.5.
Does this mean that I am getting drop frames in raw2cdng?
Canon 5D Mark IIIs & Canon 600d | Ronin-M | Rokinon 35mm T1.5 Cine AS UMC | Samyang 85mm T1.5 UMC AS Cine VDSLR II   | Canon EF 24-105mm f/4L IS USM | Canon EF 50mm f/1.8 II | etc
Dual sound system: Tascam DR-60d MKII | Audio Technica AT899 | Sennheiser MKE 600

chmee

  • Contributor
  • Hero Member
  • *****
  • Posts: 1031
  • raw2cdng
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1280 on: January 08, 2016, 10:26:16 PM »
@mothaibaphoto
thanks. just downloaded. will test now.

@ibrahim
this bug shouldnt occur with 1.6.1 or 1.6.5.

ibrahim

  • Member
  • ***
  • Posts: 193
  • Physician & videographer
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1281 on: January 09, 2016, 01:54:03 AM »
Thanks chmee ;)
Canon 5D Mark IIIs & Canon 600d | Ronin-M | Rokinon 35mm T1.5 Cine AS UMC | Samyang 85mm T1.5 UMC AS Cine VDSLR II   | Canon EF 24-105mm f/4L IS USM | Canon EF 50mm f/1.8 II | etc
Dual sound system: Tascam DR-60d MKII | Audio Technica AT899 | Sennheiser MKE 600

bobberesh

  • New to the forum
  • *
  • Posts: 4
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1282 on: January 15, 2016, 09:06:37 PM »
@chmee raw2cdng v.1.7.4 and 1.6.5 have been crashing.
If I load raw2cdng once after a complete system restart or shutdown, it is fine. I can load RAW files into the batch by dragging and dropping and then convert. Works perfectly... One time.
After the files have converted, if I drag and drop another set of files or a single file, raw2cdng crashes. If I relaunch raw2cdng, same crash activity happens.

The debug report contains only this:
[drop] ------

Any ideas? The program was working fine until I installed DaVinci Resolve 11 Lite.

Running Asus G750 - Windows 8.1 - Intel i7 - 32GB RAM

Thanks!

chmee

  • Contributor
  • Hero Member
  • *****
  • Posts: 1031
  • raw2cdng
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1283 on: January 23, 2016, 09:54:22 AM »
Hi there

@all
good news, missing-frame bug resolved, needs to be tested. but before yelling "new version out" i need to optimize/fix some other things.

(a) audio-glitch - its said, 1.6.1 did good audio-files for resolve, newer ones not, right?
(b) vertical banding. sometimes it was ok sometimes not. give me some more short video-examples to fix it.

@bobberesh
maybe a problem with folder names? try to dragdrop from other place..

regards chmee

andy kh

  • Hero Member
  • *****
  • Posts: 513
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1284 on: January 24, 2016, 10:29:06 AM »
waiting for new version
5D Mark III - 70D

chmee

  • Contributor
  • Hero Member
  • *****
  • Posts: 1031
  • raw2cdng
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1285 on: January 24, 2016, 10:49:00 PM »
Audio Glitch (Resolve Problem) - could someone tell me if its working with raw2cdng 1.6.3?

1.6.1 - working audio under resolve
1.6.3 - audiolength fixed
1.6.5 - adjusted timeRef

(i dont know what to revert, audiolength or timeRef)

regards chmee

davidrf

  • New to the forum
  • *
  • Posts: 7
  • Viva la Vinyl
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1286 on: February 01, 2016, 02:24:49 PM »
Hello there,
 when I convert MLVs shot with my 6D with raw2cdng 1.7.4 I always get one or two red frames flashing towards the beginning of the resulting DNG file. I tried many times with different settings but once I import the DNG in premiere I always find these red frames. I tried converting the MLVs with MLVRawviewer (which I don't like) and I don't get the red frames, but I'd prefer to use raw2cdng. Any help?

Edit: wooops I noticed only now this issue is already being discussed... I thought it wasn't because the search didn't show anything.
Ekam Sat

ibrahim

  • Member
  • ***
  • Posts: 193
  • Physician & videographer
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1287 on: February 02, 2016, 09:13:59 PM »
Hi,

I notice that raw2cdng 1.6.5 and even 1.7.4 is not exporting my entire mlv file to cDNGs only 1180 out of 2875 frames. My MLV file has .M01 and .M02 associated to it.
Canon 5D Mark IIIs & Canon 600d | Ronin-M | Rokinon 35mm T1.5 Cine AS UMC | Samyang 85mm T1.5 UMC AS Cine VDSLR II   | Canon EF 24-105mm f/4L IS USM | Canon EF 50mm f/1.8 II | etc
Dual sound system: Tascam DR-60d MKII | Audio Technica AT899 | Sennheiser MKE 600

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6762
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1288 on: February 02, 2016, 09:16:47 PM »
Missing .M00
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

ibrahim

  • Member
  • ***
  • Posts: 193
  • Physician & videographer
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1289 on: February 02, 2016, 09:30:37 PM »
After my recording there were never any M00. How do I solve this?


I have .wav, M01 M02 MLV and .MRX
Canon 5D Mark IIIs & Canon 600d | Ronin-M | Rokinon 35mm T1.5 Cine AS UMC | Samyang 85mm T1.5 UMC AS Cine VDSLR II   | Canon EF 24-105mm f/4L IS USM | Canon EF 50mm f/1.8 II | etc
Dual sound system: Tascam DR-60d MKII | Audio Technica AT899 | Sennheiser MKE 600

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6762
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1290 on: February 02, 2016, 09:50:23 PM »
Load File_man.mo and browse files.
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

ibrahim

  • Member
  • ***
  • Posts: 193
  • Physician & videographer
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1291 on: February 03, 2016, 12:02:23 AM »
Sorry I don't understand Walter, could you please elaborate what you mean.  :)
Canon 5D Mark IIIs & Canon 600d | Ronin-M | Rokinon 35mm T1.5 Cine AS UMC | Samyang 85mm T1.5 UMC AS Cine VDSLR II   | Canon EF 24-105mm f/4L IS USM | Canon EF 50mm f/1.8 II | etc
Dual sound system: Tascam DR-60d MKII | Audio Technica AT899 | Sennheiser MKE 600

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6762
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1292 on: February 03, 2016, 02:53:56 AM »
Modules tab -> file_man.mo ON, will start
Restart cam
Debug tab -> File Manager -> DCIM -> 100CANON
Is there a file with extension M00?
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

ibrahim

  • Member
  • ***
  • Posts: 193
  • Physician & videographer
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1293 on: February 04, 2016, 08:12:47 AM »
Modules tab -> file_man.mo ON, will start
Restart cam
Debug tab -> File Manager -> DCIM -> 100CANON
Is there a file with extension M00?

After File manager I get > A:/ or B:/
Choosing A:/ does not lead me to any M00 however:
Choosing B:/ > DCIM > 100EOS5D > find several M00 files (52 B file size).

What do I do with this file?

Canon 5D Mark IIIs & Canon 600d | Ronin-M | Rokinon 35mm T1.5 Cine AS UMC | Samyang 85mm T1.5 UMC AS Cine VDSLR II   | Canon EF 24-105mm f/4L IS USM | Canon EF 50mm f/1.8 II | etc
Dual sound system: Tascam DR-60d MKII | Audio Technica AT899 | Sennheiser MKE 600

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6762
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1294 on: February 04, 2016, 08:18:05 AM »
Your conversion tool doesn't convert M01 (and all following chunks) because M00 is missing ... (hinthinthint)
See reply #1288, too.
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

far.in.out

  • New to the forum
  • *
  • Posts: 34
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1295 on: February 08, 2016, 10:33:25 PM »
Hi. I've just recently started using raw2cdng.
Is it currently stable and safe to use? I've seen there were some issues with missing frames. Cuz it's just TL;DR for me for now.  :)
50D (was 600D) Helios 44M-4, Canon 18-55mm IS II

chmee

  • Contributor
  • Hero Member
  • *****
  • Posts: 1031
  • raw2cdng
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1296 on: February 09, 2016, 07:56:58 AM »
The tool will get an update next days. until now 1.6.5 is recommended.

@walterschulz
a pitty :) thats not fair :) kind of "dontlikethat" /thx

FLoR1aN

  • New to the forum
  • *
  • Posts: 4
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1297 on: February 11, 2016, 07:20:22 PM »
Hello,

I have an issue with Raw2cdng. I can open it, import MLV but when I try to convert IT, I have a "stopped working" message.
In the windows LOG, the issue seems to come from KERNELBASE.dll.

I tried several version of Raw2cdng and I still have the same issue.
I'm on Windows 10 64 bits, and it was working correclty when I was on Windows 8.

Any idea?

chmee

  • Contributor
  • Hero Member
  • *****
  • Posts: 1031
  • raw2cdng
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1298 on: February 11, 2016, 07:51:15 PM »
1. what are the last lines inside the debug-file?
2. starting as administrator?

FLoR1aN

  • New to the forum
  • *
  • Posts: 4
Re: The CinemaDNG Discussion (raw2cdng)
« Reply #1299 on: February 11, 2016, 08:51:10 PM »
1. Here is the entire debug file:

Code: [Select]
------------- 1.7.4 started at 16.02.11 20:47:07 --
[init][settings] -- ffmpeg Exists: false
[drop] started
[drop] Files dropped:
[drop] ------
[drop] -- file D:\M17-1410.MLV.
[drop] ------
[drop] -- file D:\M17-1410.MLV will be analyzed now.
[drop] is MLV
[setFileinfoData] set/changed Filedata
[drop] FileinfoData set
[createMLVBlocklist] started
[createMLVBlocklist] splitFiles counted (1)
[createMLVBlocklist] filesize counted (624MB)
[createMLVBlocklist] indexing Blocks in D:\\M17-1410.MLV
[getMLVAttrib] started
[getMLVAttrib] reading RAWI-Block
[getMLVAttrib] reading MLVI-Block
[getMLVAttrib] reading IDNT-Block
[getMLVAttrib] reading WBAL-Block
[getMLVAttrib] reading EXPO-Block
[getMLVAttrib] reading LENS-Block
[getMLVAttrib] reading WAVI-Block
[getMLVAttrib] [!] NO WAVI Block
 ***** [getMLVAttributes] metaData Object:
xResolution=1824
yResolution=764
frames=268
bitsperSample=14
bitsperSampleChanged=0
isLog=False
colorMatrixA=System.Byte[]
colorMatrixB=
forwardMatrixA=
forwardMatrixB=
lostFrames=0
fpsNom=25000
fpsDen=1000
duration=00:10:18
dropFrame=False
fpsString=25.00
stripByteCount=2438688
stripByteCountReal=2438688
modell=Canon EOS 6D
camId=MAGIC3942748
apiVersion=0
splitCount=1
photoRAW=False
photoRAWe=False
RGGBValues=System.Int32[]
RGBfraction=System.Int32[]
wb_R=0.540084388185654
wb_G=1
wb_B=0.547008547008547
whiteBalance=4500
whiteBalanceMode=0
whiteBalanceGM=5200
whiteBalanceBA=5200
blackLevelOld=2047
blackLevelNew=2047
whiteLevelOld=13000
whiteLevelNew=13000
maximize=True
maximizer=5.98338354788642
previewPic=
previewFrame=0
errorString=
isMLV=True
isFRSP=False
DNGHeader=
version=1.7.4
versionString=System.Byte[]
propertiesString=
verticalBandingCoeffs=
verticalBandingNeeded=False
deadSensel=System.Collections.Generic.List`1[raw2cdng_v2.point]
 *****
 ***** [getMLVAttributes] fileData Object:
fileName=D:\M17-1410.MLV
fileNameOnly=M17-1410
fileNameShort=M171410G
fileNameNum=171410
tempPath=D:\TEMP\
sourcePath=D:\
parentSourcePath=
basePath=
destinationPath=
extraPathInfo=
_changedPath=
outputFilename=
creationTime=11/02/2016 20:31:58
modificationTime=17/01/2016 14:10:52
fileSize=624
VIDFBlock=
RAWBlock=
 *****
 ***** [getMLVAttributes] lensData Object:
lens=EF35mm f/2 IS USM2
focalLength=35
aperture=1820
isoValue=110
shutter=1/50s
 *****
[drop] MLV Attributes and Blocklist created and sorted. Blocks: 558
[drop] VIDF-List created. Blocks: 268
[readVIDFBlockData] started
[readVIDFBlockData] done: [0][1][2][3][4][5][6][7][8][9][10][11][12][13][14][15][16][17][18][19][20][21][22][23][24]
[readVIDFBlockData] done: [25][26][27][28][29][30][31][32][33][34][35][36][37][38][39][40][41][42][43][44][45][46][47][48][49]
[readVIDFBlockData] done: [50][51][52][53][54][55][56][57][58][59][60][61][62][63][64][65][66][67][68][69][70][71][72][73][74]
[readVIDFBlockData] done: [75][76][77][78][79][80][81][82][83][84][85][86][87][88][89][90][91][92][93][94][95][96][97][98][99]
[readVIDFBlockData] done: [100][101][102][103][104][105][106][107][108][109][110][111][112][113][114][115][116][117][118][119][120][121][122][123][124]
[readVIDFBlockData] done: [125][126][127][128][129][130][131][132][133][134][135][136][137][138][139][140][141][142][143][144][145][146][147][148][149]
[readVIDFBlockData] done: [150][151][152][153][154][155][156][157][158][159][160][161][162][163][164][165][166][167][168][169][170][171][172][173][174]
[readVIDFBlockData] done: [175][176][177][178][179][180][181][182][183][184][185][186][187][188][189][190][191][192][193][194][195][196][197][198][199]
[readVIDFBlockData] done: [200][201][202][203][204][205][206][207][208][209][210][211][212][213][214][215][216][217][218][219][220][221][222][223][224]
[readVIDFBlockData] done: [225][226][227][228][229][230][231][232][233][234][235][236][237][238][239][240][241][242][243][244][245][246][247][248][249]
[drop] VIDF-Blockdata read and created.
[drop] adding M17-1410 to batchList
[showPicture] started
[drop] calculating verticalBandingCoeefs and searching hot/dead-pixels..
[drop] NO dead sensels found
[drop] verticalBanding enabled. decision: not needed
[drop] verticalBanding CoEffs: 1 1.00430185684813 1.00268723386271 1.00576654109846 1.00111753703342 1.00459834482779 1.00234481080323 1.00587428639912 0 13.0811428649475
[drop] ** Item M17-1410 imported | MLV
[drop] * res 1824x764px | 25.00fps | 268 frames | BL2047 | WL13000
[drop] * modell Canon EOS 6D | vidfblocks 268 | has no audio
[convert_Click] all in all there are 268 frames to convert
[doWork] started
[doWork] 4 Cores used
[doWork] -> converting item M17-1410
[doWork] settings format 4 with BL0 WL4095 with+ maximizingvalue 5
[doWork] prefix - filename generator F:\Vidéos\Projets\2015-05 NYC\1-CDNG
[doWork] destinationPath -> F:\Vidéos\Projets\2015-05 NYC\1-CDNG
[doWork] outputFilename  -> F:\Vidéos\Projets\2015-05 NYC\1-CDNG

2. I don't understand why, but when I open raw2cdng in Administrator mode, I can't insert MLV file in it. I have a "forbidden" mouse pointer...
It's only in adminstrator mode, it works in normal mode.


Edit: Nevermind, I'm such an idiot...
In reading the last line of the debug log, I reminded I have deleted the output foler...
It works perfectly now !

However, I often have missing frames in DNG output, is there a reason for that?