Author Topic: 12-bit (and 10-bit) RAW video development discussion  (Read 799581 times)

reddeercity

  • Contributor
  • Hero Member
  • *****
  • Posts: 2303
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #425 on: November 10, 2016, 08:23:18 AM »
More testing on 5D Mark ii , by playing around with the SRM Job , SmallHacks & Preview I can now get 10bit 16x9 A.R. 1856x1044 29.97(68MB/s) , 23.976p(55MB/s)
continuous without any Frame corruption/pink noise  . I never have Raw Video 30p continuous before at near HD 1044p  :D
My settings:
29.97p(Set in Canon Menu)
Frame over ride - exact
Small Hacks - enabled
SRM Job      - disabled
Preview ML B/W with overlays killed when recording
Any other setting then this produce corrupted frames.

If you enable SRM Job you get the first frame corrupted with pink noise but all the rest are free of corruption.
with SRM Job disabled all frame including the first are free of corruption.

Now with 12bit I almost got it to product corruption free frame , there just a little color noise bar at the top of every other frame about 40 lines
Setting:
23.976p(continuous) (29.97p records for only 20-30 seconds)
Small Hacks - enabled
SRM Job      - enabled
Preview Canon with overlays killed when recording.

Curious that in 10bit Raw Video ,  Liveview needs to be in magic lantern black & white preview with overlays disabled
where 12bit Raw Video needs Liveview to be in Canon preview to be almost corruption free , any other preview cause total pink noise

I'll post some examples later .
 

rbrune

  • Contributor
  • Freshman
  • *****
  • Posts: 64
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #426 on: November 10, 2016, 08:36:15 AM »
With preview set to Canon, do you still get crashes?

When set to Canon the EOSM crashes when stopping the first 10bit recording.
With ML B&W or Hacked it crashes when starting the second 10bit recording but the first records fine.

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3411
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
12-bit (and 10-bit) RAW video development discussion
« Reply #427 on: November 10, 2016, 10:11:52 AM »
When set to Canon the EOSM crashes when stopping the first 10bit recording.
With ML B&W or Hacked it crashes when starting the second 10bit recording but the first records fine.

I couldn't reproduce any of the crashing (unless you guys are referring to the LiveView freezing) but that's not exactly crashing, is it? especially if it's being recorded blindly.

However upon reading @reddeercity post above re: SRM job memory -- decided to try and fiddle with it and now for some reason if I were to record in either 10 or 12 bit on the EOSM with the SRM job memory enabled OFF then mlv_play.mo doesn't load. (notice in this screenshot below that the invalid header error is at the beginning as oppose to the previous issue)



Although it had issues earlier and now if I were to record in either 10 or 12 bit on EOSM with the SRM job memory enabled ON then mlv_play.mo does load as well as playback files like normal.



Really?!? What's even more odd is the fact that now all of sudden I can playback files on EOSM when earlier I couldn't with that particular file (probably due to a crash while recording) but I honestly don't recall any crashes happening on my watch during this time other than the usual LiveView freeze (don't remember if I kept it rolling till dropped frames or if I had stopped recording myself) but then after trying to reproduce this glitch to no avail and now fiddling with this SRM job memory somehow did the trick or no?
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

Teamsleepkid

  • Member
  • ***
  • Posts: 247
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #428 on: November 10, 2016, 11:14:02 AM »
got some (probably) stupid questions... Is 8 bit raw a thing? you know to achieve higher resolutions? how about monochrome black and white mode for the same reason? has anyone tried using an external monitor to see if that is also freezing while live view is freezing on 10 bit? I'd try it myself but i don't have any monitors or cables to do so. I'm talking about eos m. thanks.
EOS M

SiSS

  • Freshman
  • **
  • Posts: 66
  • Eu
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #429 on: November 10, 2016, 01:44:33 PM »
I think the consensus is that 10-bit acquisition helps you for noticeably better end results than just upping resolution.
There's more to maneuver with 10-bit. Every smartphone and cheap action camera has 4K = and that doesn't mean those deliver anything worthwhile.
Also it's been said that difference between 8-bit and 10-bit is "last" to be noticed with your eyes (10-bit 12-bit not so much, tough there's the material to work with).
Real 10-bit and you have think C300 mk II and C500. Arri Alexa didn't have 4K until SXT and even that doesn't come from 4K sensor. SXT been out for month? So 99% of the films in the movie theaters still don't have native 4K. Tough 10-bit doesn't mean everything either.

SiSS

  • Freshman
  • **
  • Posts: 66
  • Eu
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #430 on: November 10, 2016, 01:49:52 PM »
Everything tested with 24fps 10bit on 5d3 113
2880x1226 2.35:1 (2x crop) - continous
Thanks kgv5, did you notice any difference in moire and/or rolling shutter?
Some test videos please!

Levas

  • Contributor
  • Hero Member
  • *****
  • Posts: 1741
  • 6d - Nightly build user
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #431 on: November 10, 2016, 02:32:28 PM »
Little late at the party  :P
I never thought this was gonna happen, that the hardware in the cams simply were fixed for 14 bit.

But :o WOW :o Respect for these findings!!!  8)

So to put things in perspective...
Canon released a full-frame DSLR in 2008!!!  with some sort of full HD video feature in h.264 compression.
And all these time this cam could record 10 bit raw video in full HD continuously direct to the memory card  ;D
Canon could have saved some serious money by leaving out the chip that does the h.264 conversion(unless that is done by the digic  :P)

Tullen

  • Freshman
  • **
  • Posts: 73
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #432 on: November 10, 2016, 05:11:26 PM »
Hi. I admit I havent read through the whole thread, so forgive me if I missed it, but could this work on the 50D? Since I understand it has similarities with the 5D2.

Cheers

justinbacle

  • New to the forum
  • *
  • Posts: 40
  • DP
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #433 on: November 10, 2016, 05:34:42 PM »
Hi. I admit I havent read through the whole thread, so forgive me if I missed it, but could this work on the 50D? Since I understand it has similarities with the 5D2.

Right now 1 out of 2 frames are garbage on the 50D. Same as the 5Dmk2 :)
Preliminary tests gives FullHD crop mode continuous w/ the 50D though

reddeercity

  • Contributor
  • Hero Member
  • *****
  • Posts: 2303
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #434 on: November 10, 2016, 05:56:36 PM »
Right now 1 out of 2 frames are garbage on the 50D. Same as the 5Dmk2 :)
Really !
Did you even Read any Of the post here or just decided to write Wrong & miss leading
Information ? This Is a big problem here on the forum with new users , not willing to use
Searches or read threads & post and expect someone to give them information .
And Yea FYI 5d2 works with 10bit corruption Free
Give your Facts right !

Deadcode

  • Freshman
  • **
  • Posts: 62
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #435 on: November 10, 2016, 05:56:56 PM »
5D2, Crop mode, 1920x1076 25p 10/12 bit continous. First frame broken, others have strong magenta cast (MLVFS, Davinci)

Any ideas?
 
https://drive.google.com/file/d/0B9d46mzo8guUQkN1YTRCRnhsdTA/view?usp=sharing

reddeercity: would you please share the proper 5D2 settings for non crop mode? i tried what you posted days ago (10bit 1856x1044, ML Grey, Clear overlay) but it didnt worked, every 2nd frame corrupted

justinbacle

  • New to the forum
  • *
  • Posts: 40
  • DP
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #436 on: November 10, 2016, 06:06:17 PM »
Really !
Did you even Read any Of the post here or just decided to write Wrong & miss leading
Information ? This Is a big problem here on the forum with new users , not willing to use
Searches or read threads & post and expect someone to give them information .
And Yea FYI 5d2 works with 10bit corruption Free
Give your Facts right !

Sorry but there is no fix yet for the 50D. And post http://www.magiclantern.fm/forum/index.php?topic=5601.msg174548#msg174548 said that the pink frames shouldn't be solved.
However there is a file https://bitbucket.org/daniel_fort/magic-lantern/downloads specific to the 5dmk2, based on your reply, I guess it fixes pink frames on the 5dmk2.
Sorry if I gave wrong information, just trying to help here.

reddeercity

  • Contributor
  • Hero Member
  • *****
  • Posts: 2303
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #437 on: November 10, 2016, 06:07:49 PM »
Check my post at top of this page I gave my setting
That only works with 10bit right now . Try that if it dosn't work I can post more details.


ilia3101

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 990
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #438 on: November 10, 2016, 06:42:03 PM »
@Deadcode to fix magenta cast/black level on crop mode with 5D2 10bit use exiftool:
Code: [Select]
exiftool -BlackLevel=108 *.dngThis command fixes every frame in the directory, and for 12 bit the black level would be 4* that probably

justinbacle

  • New to the forum
  • *
  • Posts: 40
  • DP
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #439 on: November 10, 2016, 07:01:24 PM »
Check my post at top of this page I gave my setting
That only works with 10bit right now . Try that if it dosn't work I can post more details.
Tried your fix, at first it looked like it worked but it actually doesn't on my 50D. The part that used to be "noise" is now a static frame.
On this example, the top part is flickering but is not what should have been recorded. One every two frame is "splitted" like that.

Both your fixes produced similar results (10 & 12 bits).

Deadcode

  • Freshman
  • **
  • Posts: 62
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #440 on: November 10, 2016, 09:04:14 PM »
Check my post at top of this page I gave my setting
That only works with 10bit right now . Try that if it dosn't work I can post more details.



I tried exactly what you wrote on that post and still corrupted frames
29,970 exact, 1856x1044 10bit, Ml Grey, Clear when recording, SRM disabled, Small Hacks enabled.
I tried 12 bit setup too for 23,976p, i get the 40pixel corruption + the bottom half of the image is "wobbing".

Any suggestion?

*i used magiclantern-raw_video_10bit_12bit.2016Nov07.5D2212.zip

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3411
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
12-bit (and 10-bit) RAW video development discussion
« Reply #441 on: November 10, 2016, 09:09:38 PM »
Tried your fix, at first it looked like it worked but it actually doesn't on my 50D. The part that used to be "noise" is now a static frame.
On this example, the top part is flickering but is not what should have been recorded. One every two frame is "splitted" like that.

Both your fixes produced similar results (10 & 12 bits).

I can also confirm this so called 'splitted' or 'slicing' across the frame horizontally occurring on some of my 7D files while shooting 10/12-bit. I'll need to investigate furthermore to determine what is the culprit in here (fps, mv1080/mv720, etc) and will report my findings when I can.

Once I can reproduce short test files then I'll upload them to share.

Quote from: Quote from: kgv5 on Yesterday
@dfort, are you able to compile a module for 5d3 113 with fine resolution changes?

As promised -- I've managed to get it compiled with the latest 10/12-bit raw_rec.mo (includes finer resolution adjustment) similar to what you get in mlv_rec.mo merged together with crop_rec.mo -- special thanks goes to @dfort for making this possible on my system! 

All cameras running ML except for 1100D.105 & 5D3.123 (I plan on figuring out a way to get it compiled for 5D3.123 at some point) and remember to keep all bug reports on this thread if you plan on testing these builds out. Enjoy!

https://bitbucket.org/DeafEyeJedi/magic-lantern/downloads
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

Teamsleepkid

  • Member
  • ***
  • Posts: 247
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #442 on: November 10, 2016, 09:11:34 PM »
this 10 bit raw is the best thing that ever happened. i don't think I've ever seen such a good image coming out of a camera. so excited for live view to be working on eosm. I've got an a7sii sitting in my room. i haven't even used it in a month. much prefer the image on this 100 dollar camera. absolutely hilarious.
EOS M

Teamsleepkid

  • Member
  • ***
  • Posts: 247
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #443 on: November 10, 2016, 09:20:06 PM »
@deafeyejedi can't seem to get your link to work.
EOS M

ddelreal

  • Member
  • ***
  • Posts: 109
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #444 on: November 10, 2016, 09:33:07 PM »
I get "Access Denied."

Teamsleepkid

  • Member
  • ***
  • Posts: 247
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #445 on: November 10, 2016, 09:36:23 PM »
same here access denied.
EOS M

Teamsleepkid

  • Member
  • ***
  • Posts: 247
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #446 on: November 10, 2016, 09:47:21 PM »
i actually never got your mega link to work either lol. we gotta get this guy online. valuable guy :P there's bitbucket settings on the top right do you have "private profile" checked?
EOS M

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3411
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #447 on: November 10, 2016, 10:07:33 PM »
Ah, ha. Thanks for the hints and @dfort was also able to help me out by pointing me to fixing this by going to Admin > Access > Disable Private (I don't recall turning this ON so this must be a default thing, right?).  :o

In any case -- could you guys please let me know if the link works now and Thanks again @Walter Schulz for dealing with yet another one of these moments.  :P
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109

Teamsleepkid

  • Member
  • ***
  • Posts: 247
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #448 on: November 10, 2016, 10:09:58 PM »
Looks good now
EOS M

DeafEyeJedi

  • Hero Member
  • *****
  • Posts: 3411
  • 5D3 | M1 | 7D | 70D | SL1 | M2 | 50D
Re: 12-bit (and 10-bit) RAW video development discussion
« Reply #449 on: November 10, 2016, 10:11:56 PM »
5D3.113 | 5D3.123 | EOSM.203 | 7D.203 | 70D.112 | 100D.101 | EOSM2.* | 50D.109