Author Topic: 50D Raw video  (Read 680487 times)

roopepal

  • New to the forum
  • *
  • Posts: 6
Re: 50D and 40D Raw video
« Reply #3750 on: October 16, 2013, 07:06:39 AM »
So tell me, I just did the benchmark with the latest nightly build on 50D and Sandisk 16GB Extreme Pro 160, which one of these is the relevant number?


johansugarev

  • Freshman
  • **
  • Posts: 77
Re: 50D and 40D Raw video
« Reply #3751 on: October 16, 2013, 09:15:07 AM »
The one you see while recording?

simulacro

  • Freshman
  • **
  • Posts: 96
  • Learning
Re: 50D and 40D Raw video
« Reply #3752 on: October 16, 2013, 11:10:51 AM »

Thanks Simulacro, great catch! Good thing this was a fun side vid and not a paid thing, lol

Nice comic too! I'm curious do you ever incorporate any comic stuff into your filming?

Thanks too :) comic is an influence, but i haven't used it for an specific work. It helps when storyboarding or simply putting everything in order in my mind
simulacrofilms.blogspot.com

rockfallfilms

  • Member
  • ***
  • Posts: 141
Re: 50D and 40D Raw video
« Reply #3753 on: October 16, 2013, 11:49:22 AM »
So tell me, I just did the benchmark with the latest nightly build on 50D and Sandisk 16GB Extreme Pro 160, which one of these is the relevant number?



Just try recording, if you drop frames then the card is too slow.

SleeperNinja

  • New to the forum
  • *
  • Posts: 28
Re: 50D and 40D Raw video
« Reply #3754 on: October 16, 2013, 05:07:11 PM »
Received a new Komputerbay 128 GB 1000X today and I can't get the card to do a firmware update on my 50D. Wondering if anyone has found a way to make the card work...

Long story short... I had bought a 128 GB 1000X back in July and it work with my camera. However, the write speeds were about 2 - 5 mb/s too slow. Started thinking that with the latest builds that that same card might be applicable...

Any help would be greatly appreciated.
Best I can recall, you have to use a card smaller than 64GB to do firmware updates and install ML. The firmware makes it possible to use the 64GB and larger cards.

In addition, you have to prepare 64GB cards a slightly different way, I believe. I suggest starting with step 1 on the ML Install Wiki, so you can see what it suggests, and why.  ::)

FilmPerson

  • New to the forum
  • *
  • Posts: 22
Re: 50D and 40D Raw video
« Reply #3755 on: October 16, 2013, 07:46:27 PM »
Hey does anyone know how to get the raw grayscale preview to stop flashing? It only works properly when I'm recording.

PhilK

  • New to the forum
  • *
  • Posts: 40
Re: 50D and 40D Raw video
« Reply #3756 on: October 16, 2013, 08:23:14 PM »
Is anyone else seeing this error building from source?

../../src/gui-common.c:29:12: warning: 'bottom_bar_hack' defined but not used [-Wunused-variable]
[ CC       ]   chdk-gui_draw.o
[ CC       ]   movtweaks.o
[ CC       ]   menuhelp.o
[ CC       ]   menuindex.o
[ CC       ]   af_patterns.o
[ CC       ]   focus.o
../../src/focus.c: In function 'focus_stack':
../../src/focus.c:260:29: error: 'focus_rack_enable_delay' undeclared (first use in this function)
../../src/focus.c:260:29: note: each undeclared identifier is reported only once for each function it appears in
make: *** [focus.o] Error 1

It's the same compiling for 600D, everything was OK yesterday and I updated just before I saw this.

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D and 40D Raw video
« Reply #3757 on: October 16, 2013, 09:11:07 PM »
Fixed that compile error.

Quote
Hey does anyone know how to get the raw grayscale preview to stop flashing?

Flashing? When?

Molinsky

  • New to the forum
  • *
  • Posts: 26
Re: 50D and 40D Raw video
« Reply #3758 on: October 16, 2013, 10:31:59 PM »
Fixed that compile error.

Flashing? When?

Remember the flickering in the menu? I posted a video showing the issue after load the module. I believe it's a similar problem.

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D and 40D Raw video
« Reply #3759 on: October 16, 2013, 11:14:59 PM »
For that, I guess turn on Kill flicker in advanced menu or disable dialog timer.

FilmPerson

  • New to the forum
  • *
  • Posts: 22
Re: 50D and 40D Raw video
« Reply #3760 on: October 17, 2013, 01:04:29 AM »
For that, I guess turn on Kill flicker in advanced menu or disable dialog timer.

Am I blind or is the advanced menu not on the 50d? Sorry to be a bother but I can't find either of these options. Updated to nightly build a couple days ago.

To be clear, the problem is that when you turn on greyscale preview while shooting raw that the grayscale preview only shows up every other millisecond.  The camera is showing both the canon preview and the greyscale ML preview, making it extremely hard to use crop mode.

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D and 40D Raw video
« Reply #3761 on: October 17, 2013, 01:53:32 AM »
Menu -> Display -> advanced

It does slow down when you're recording by design... but I wouldn't shoot with GD on while recording.

roopepal

  • New to the forum
  • *
  • Posts: 6
Re: 50D and 40D Raw video
« Reply #3762 on: October 17, 2013, 05:41:27 AM »
Is there a build that includes bulb ramping also?

PhilK

  • New to the forum
  • *
  • Posts: 40
Re: 50D and 40D Raw video
« Reply #3763 on: October 17, 2013, 09:29:24 PM »
Fixed that compile error.

Yep confirmed, thanks.  But it took ages for the pull to register the updated file - I first tried when I got in about 3 hours ago and only in the last 30 mins did it register.

Looking at the Bitbucket site you committed the fix yesterday!

georgenious

  • Just arrived
  • *
  • Posts: 1
Re: 50D and 40D Raw video
« Reply #3764 on: October 18, 2013, 01:58:28 AM »
Hello,

I'm a 50D ML newbie.  I am using Komputerbay 1000x CF card and 50D is constantly giving error when I am trying to transfer the movie files to my mac.  Pictures are transferring fine.  I am guessing it is because the camera does not understand the movie file types.  Has anyone had this experience?  When CF is used with a Kingston card reader, I can copy the movie files.  But it would be nice if I don't have to take the card out every time.

I did quite a bit of search on this subject, but I am not finding the answers.  Maybe I am using bad search words.  If this has been discussed earlier, I apologize.

RenatoPhoto

  • Moderators
  • Hero Member
  • *****
  • Posts: 1509
  • 5DM3 / 7D
Re: 50D and 40D Raw video
« Reply #3765 on: October 18, 2013, 02:17:04 AM »
No option yet.  Use a card reader.
http://www.pululahuahostal.com  |  EF 300 f/4, EF 100-400 L, EF 180 L, EF-S 10-22, Samyang 14mm, Sigma 28mm EX DG, Sigma 8mm 1:3.5 EX DG, EF 50mm 1:1.8 II, EF 1.4X II, Kenko C-AF 2X

LEVISDAVIS

  • Member
  • ***
  • Posts: 134
Re: 50D and 40D Raw video
« Reply #3766 on: October 18, 2013, 06:17:25 AM »
Komputerbay will sell 128gb 1050x and 128gb 1000x  CF cards that are firmware compatible for the 50D. Shipped in the 1000x to tech support yesterday, but found out about an upgrade path to the 1050x. ...Upgrading to 1050x given previous recording results of the 1000x. Will post results...
Levi S. Davis

vprocessing

  • New to the forum
  • *
  • Posts: 13
Re: 50D and 40D Raw video
« Reply #3767 on: October 18, 2013, 09:26:08 AM »
Hi to all !
I had one time my 50D block after a skipped frame… 25fps 400 iso 1/50 Manual Olympus lens with adapter 1584/892.
So I decided to benchmark my 1000x UDMA7 Komputerbay.
The buffer benchmark gave me results around 40mb/sec.
I've resent it for exchange and now I'm around 30mb/sec………but it works.
Can someone explain the speed thing 'cause I don't understand how can it works @ 40 or even @ 30…

@ what step the dev of the 40D is ?
THX
.V

joaomoutinho

  • New to the forum
  • *
  • Posts: 41
Re: 50D and 40D Raw video
« Reply #3768 on: October 19, 2013, 12:45:10 AM »
Hi to all !
I had one time my 50D block after a skipped frame… 25fps 400 iso 1/50 Manual Olympus lens with adapter 1584/892.
So I decided to benchmark my 1000x UDMA7 Komputerbay.
The buffer benchmark gave me results around 40mb/sec.
I've resent it for exchange and now I'm around 30mb/sec………but it works.
Can someone explain the speed thing 'cause I don't understand how can it works @ 40 or even @ 30…

@ what step the dev of the 40D is ?
THX
.V

You have the RAW picture turned off in the CANON menu? It only works if its JPEG in the CANON menu.

Hope it helps...

rockfallfilms

  • Member
  • ***
  • Posts: 141
Re: 50D and 40D Raw video
« Reply #3769 on: October 19, 2013, 03:23:01 PM »
You have the RAW picture turned off in the CANON menu? It only works if its JPEG in the CANON menu.

Hope it helps...

I always shoot with RAW picture turned on in the menu and I've never had a dropped frame. Your card is probably a dodgy one, the komputerbay's seem to be a bit hit and miss.

Sniper

  • New to the forum
  • *
  • Posts: 8
Re: 50D and 40D Raw video
« Reply #3770 on: October 20, 2013, 05:50:29 AM »
Received a new Komputerbay 128 GB 1000X today and I can't get the card to do a firmware update on my 50D. Wondering if anyone has found a way to make the card work...

Long story short... I had bought a 128 GB 1000X back in July and it work with my camera. However, the write speeds were about 2 - 5 mb/s too slow. Started thinking that with the latest builds that that same card might be applicable...

Any help would be greatly appreciated.

The 64 GB cards are the best for speed.  And as has been said numerous times you need something like a 32 GB or below card for flashing firmware.  I just bought a sandisk 4 GB card for firmware flashing purposes.

Buy a 64 GB card and benchmark and use it.  See if it hits your speed targets.  If not return it.  Keep in mind you have to "warm up" your card to get maximum speed.

SleeperNinja

  • New to the forum
  • *
  • Posts: 28
Re: 50D and 40D Raw video
« Reply #3771 on: October 20, 2013, 06:56:42 AM »
Is there any way to get the 50D to sync beep?   8)

Nikuya

  • New to the forum
  • *
  • Posts: 2
Re: 50D and 40D Raw video
« Reply #3772 on: October 20, 2013, 12:51:25 PM »
Hi!

I've tried several newer versions of the nightly builds but don't get the modules to work. When I start the modules it says that the will be loaded on the next reboot. I've tried rebooting and to take out the battery but the same text appears the next time I start the camera. What is wrong?

dsManning

  • Member
  • ***
  • Posts: 102
Re: 50D and 40D Raw video
« Reply #3773 on: October 20, 2013, 06:54:30 PM »
Is there any way to get the 50D to sync beep?   8)

Was discussed earlier in this thread somewhere.  Quite a few looked into it, but the 50D is missing the hardware on board to produce a similar beep that newer cameras give off.

jamesonblade

  • New to the forum
  • *
  • Posts: 8
Re: 50D and 40D Raw video
« Reply #3774 on: October 20, 2013, 09:31:29 PM »
Another quick brain-picking-

I'm recording h264. I can't seem to get ML back to tethering it's white balance to Canon Custom WB- It's stuck on the Kelvin adjustment. This forces me to manually determine my white balance to match my other camera rather than just using my grey card with Custom WB and tweaking (if need be) from there on the kelvin scale.

How do I get back to just tethering to Canon Custom WB?

Thanks.