Author Topic: 50D Raw video  (Read 480208 times)

rockfallfilms

  • Member
  • ***
  • Posts: 141
50D and 40D Raw video
« Reply #3700 on: October 11, 2013, 10:29:23 AM »
Resolve 10 Beta 3 is out, but I didn't tried it yet

ML DNG's working fine again in Resolve 10 Beta 3

Andy600

  • Contributor
  • Hero Member
  • *****
  • Posts: 1863
  • Have you tried turning it off and on again?
Re: 50D and 40D Raw video
« Reply #3701 on: October 11, 2013, 03:54:37 PM »
Had an unexpected break for a few days so just catching up.

@1% - what's up with compiling? Modules don't get added to the zip  ???
Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D and 40D Raw video
« Reply #3702 on: October 11, 2013, 04:43:47 PM »
The delete if failed thing. I think i just fixed it correctly.... the make -C works

PhilK

  • New to the forum
  • *
  • Posts: 40
Re: 50D and 40D Raw video
« Reply #3703 on: October 11, 2013, 05:08:10 PM »
ML DNG's working fine again in Resolve 10 Beta 3

Thanks vyskocil & rockfallfilms for both reporting this broken and fixed!

Andy600

  • Contributor
  • Hero Member
  • *****
  • Posts: 1863
  • Have you tried turning it off and on again?
Re: 50D and 40D Raw video
« Reply #3704 on: October 11, 2013, 05:38:58 PM »
The delete if failed thing. I think i just fixed it correctly.... the make -C works

I must be doing something wrong.

I used make -C platform/50D.109 zip which made a zip but still no modules. Do modules need compiling individually now?
Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D and 40D Raw video
« Reply #3705 on: October 11, 2013, 05:47:13 PM »
No, I just ran your command after the commit an hour ago and I have modules in the zip... heheh, I think I'll use this now so I only have to copy modules from 1 place.

Andy600

  • Contributor
  • Hero Member
  • *****
  • Posts: 1863
  • Have you tried turning it off and on again?
Re: 50D and 40D Raw video
« Reply #3706 on: October 11, 2013, 06:30:05 PM »
@1% - Thanks, working now :)


***************************************************************************************************************************************
50D users - NEW TRAGIC LANTERN 50D BUILD UPLOADED https://bitbucket.org/andy600/tl50d/downloads/Tragic_Lantern_50D109-Andy600.2013Oct11.zip
***************************************************************************************************************************************

Sorry, no time ATM to post detailed list of updates but here are some brief highlights:-

Great looking new display bar with new 'Histobar' - select in raw histogram settings. (Tip: in the Display menu>Advanced set to auto 4:3)

New modules - Raw_Bolt (bolt_rec is back) Focus Info module (not tested this myself yet)

MLV_Rec seems faster and less prone to corrupt frames (when Dialog timers are disabled) - Not fully tested it.

plus lots of small tweaks and fixes and new stuff in the menu (Lens info prefs, config startup presets, etc)



Download and try it only if you know what you're doing!




As ever, don't thank me, thank 1% for the 50D branch of Tragic Lantern and the other hard working devs for their hard work!
Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: 50D and 40D Raw video
« Reply #3707 on: October 11, 2013, 06:38:11 PM »

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D and 40D Raw video
« Reply #3708 on: October 11, 2013, 06:58:31 PM »
So MLV rec is working without crashing here?

Andy600

  • Contributor
  • Hero Member
  • *****
  • Posts: 1863
  • Have you tried turning it off and on again?
Re: 50D and 40D Raw video
« Reply #3709 on: October 11, 2013, 07:31:03 PM »
@a1ex - sorry, I'll read it  ::)

@1% mlv is working for me - I renamed it in the menu to 'Raw Video (MLV)'.
Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D and 40D Raw video
« Reply #3710 on: October 11, 2013, 07:39:56 PM »
No crash on 2nd recording? Its doing that on pretty much everything else, whoa.

FilmPerson

  • New to the forum
  • *
  • Posts: 22
Re: 50D and 40D Raw video
« Reply #3711 on: October 11, 2013, 07:46:07 PM »
Ok dumb question here, but every time I shut my 50d down I have to reset the resolution, turn raw on, turn movie mode on, etc.  My camera says there's a directory missing when I start it up, could that be causing it? I just installed this today

Also is there a good crop mode tutorial anywhere? Whenever I follow the ML one my screen shows an extremely pink frame.  Thanks

Naif

  • New to the forum
  • *
  • Posts: 3
Re: 50D and 40D Raw video
« Reply #3712 on: October 11, 2013, 10:55:37 PM »
***************************************************************************************************************************************
50D users - NEW TRAGIC LANTERN 50D BUILD UPLOADED https://bitbucket.org/andy600/tl50d/downloads/Tragic_Lantern_50D109-Andy600.2013Oct11.zip
***************************************************************************************************************************************

The new design looks lovely, but the display bar seems to be reporting a different frame rate to whatever I select in the ML menus (1/51 selected, being displayed as 1/74). Is anybody else having this issue?

bart

  • Senior
  • ****
  • Posts: 387
Re: 50D and 40D Raw video
« Reply #3713 on: October 11, 2013, 11:05:37 PM »
config startup presets

I was thinking of sharing preset files for certain tasks.
Like one just for raw/mlv video and strip everything else from the menu. Just a few relevant items. It's great for newcomers. And another preset for timelapses.

Asiertxu

  • New to the forum
  • *
  • Posts: 29
Re: 50D and 40D Raw video
« Reply #3714 on: October 11, 2013, 11:58:54 PM »
I was thinking of sharing preset files for certain tasks.
Like one just for raw/mlv video and strip everything else from the menu. Just a few relevant items. It's great for newcomers. And another preset for timelapses.

Hi there!
Yes, I´m getting the same issue as you and the display is showing some anoying shutter speed numbers than the ones that are selected! :(
VERY STRANGE thing!
Cheers!
Asier.

johansugarev

  • Freshman
  • **
  • Posts: 77
Re: 50D and 40D Raw video
« Reply #3715 on: October 12, 2013, 01:11:29 AM »
Finally figured out what caused my freeze problem with the last several builds of tragic lantern. I have a canon 50 1.4 and some m42 zeiss lenses, which all share an m42 adapter with a focus chip. With the canon 1.4 it works fine (although I don't see mlv in the latest build, or it has replaced raw_rec?); when I put the adapter on with one of the other lenses, though, every time I try entering live view with the raw module on, the camera freezes to a blank screen and I have to take the batteries out. Weird, huh?

akumiszcza

  • Freshman
  • **
  • Posts: 85
Re: 50D and 40D Raw video
« Reply #3716 on: October 12, 2013, 02:54:28 PM »
(…)
***************************************************************************************************************************************
50D users - NEW TRAGIC LANTERN 50D BUILD UPLOADED https://bitbucket.org/andy600/tl50d/downloads/Tragic_Lantern_50D109-Andy600.2013Oct11.zip
***************************************************************************************************************************************
(…)
Great looking new display bar with new 'Histobar' - select in raw histogram settings. (Tip: in the Display menu>Advanced set to auto 4:3)


Does RAW HistoBar work in image review? I have it only in LV, though the info says:
"Will use RAW histogram in LiveView and after taking a pic."

Maybe some other setting is needed too?

Andy600

  • Contributor
  • Hero Member
  • *****
  • Posts: 1863
  • Have you tried turning it off and on again?
Re: 50D and 40D Raw video
« Reply #3717 on: October 12, 2013, 03:34:59 PM »
No crash on 2nd recording? Its doing that on pretty much everything else, whoa.

Had no crashes with MLV. Have you got the IME modules loaded?. I shot 64GB of MLV footage (over a few hours with reboots inbetween) to test for corrupt frames and they are still happening intermittently even when shooting smaller frame sizes. Sadly, I just can't trust MLV on anything important ATM :( I'm sticking with Raw_rec (never has problems)

Also had an issue where the back wheel stopped working and had to delete configs to get it back. Trying to find what caused it.

@akumiszcza - Histobar is only working in LV for me

@Bart - good idea  :) - I had one user msg me having problems for weeks so i sent him my build + config and it fixed it. ML can be a little too techy (or too much hard work) for some shooters ...but they still wanna use it! ;)

Re: shutter speed issue - I had the same thing happen but only with certain config presets. Also, shutter speed readout appears frozen in the ML menu but actual shutter speed can still be changed  ???
Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D and 40D Raw video
« Reply #3718 on: October 12, 2013, 05:49:51 PM »
When it changes on top screen it doesn't mean your actual LV shutter changes.

FPS is still limiting the blanking... still needs expo override.

No I didn't load IME but it worked without those before. Seems like its working on 5DII/50D/5DIII and thats it.

New MLV is still crashing on me.

Ok, found the commits, works now.

johansugarev

  • Freshman
  • **
  • Posts: 77
Re: 50D and 40D Raw video
« Reply #3719 on: October 12, 2013, 10:56:30 PM »
Got this crash log today:
ASSERT: 0
at Stub.c:29, task LVC_AE
lv:1 mode:3


Magic Lantern version : Andy600.Build.2013Oct11.50D109
Mercurial changeset   : dd08a07137b8+ (unified) tip
Built on 2013-10-11 15:48:27 UTC by magiclantern@magiclantern-VirtualBox.
Free Memory  : 200K + 3716K


also this log:

http://pastebay.net/1321285



1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D and 40D Raw video
« Reply #3720 on: October 12, 2013, 11:03:35 PM »
Are you shooting in M mode?

johansugarev

  • Freshman
  • **
  • Posts: 77
Re: 50D and 40D Raw video
« Reply #3721 on: October 12, 2013, 11:18:24 PM »
Yes. M mode, raw.

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D and 40D Raw video
« Reply #3722 on: October 12, 2013, 11:25:07 PM »
Auto iso?

johansugarev

  • Freshman
  • **
  • Posts: 77
Re: 50D and 40D Raw video
« Reply #3723 on: October 12, 2013, 11:34:16 PM »
Nope. Only White balance is auto.

My settings are the defaults + all the IME modules and raw_rec. Global draw on, small hacks on, exposure override on, fps override off, movie mode on (tried both ways). Could there be something wrong with my card, cause I'm pretty sure I have all other things right, but it still crashes when I go to Lv with raw on or when I turn raw on when in LV?
I have auto power off from canon set to 4 minutes, but turning it off doesn't seem to help.

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: 50D and 40D Raw video
« Reply #3724 on: October 12, 2013, 11:35:37 PM »
Try setting a manual white balance. Does that help.... some part of auto exposure is crashing.