Author Topic: 50D Raw video  (Read 683426 times)

Molinsky

  • New to the forum
  • *
  • Posts: 26
Re: Raw video on 50d and 40d
« Reply #3000 on: August 22, 2013, 01:43:33 PM »
Can you upload your magic.cfg and raw_rec.cfg files?

Oh boy, not now. Just when I get home. :P

Its not doing it to me. I think an extra black bar is drawing with raw_rec + movie mode.

I did find some display filters fight with the grayscale preview, ie defish.

I have no ideas anymore. Having problem with all the previews.

I copied Modules folder under ML directory, however nothing happens. Please let me know what shall be done in order to enable it in my 50D. Do I have to copy the files raw_rec.o, raw_rec.mo & magic.sym in another folder?

Did you loaded the modules after started the camera?

orim

  • New to the forum
  • *
  • Posts: 22
  • 50D / 70D
Re: Raw video on 50d and 40d
« Reply #3001 on: August 22, 2013, 01:55:32 PM »
Hi,

I decided to try dualISO on my 50D,
I put this Tragic.Lantern-2.0-Andy600.Build.2013Aug19.50D109 on my empty CF
and then used this 50D_cr2hdr.zip + Use these for processing Raw video files or Dual ISO photos.zip
but unfortunately I still have only green/white zebras in highlights - without any other details.

What am I missing here, please?

Andy600

  • Contributor
  • Hero Member
  • *****
  • Posts: 1863
  • Have you tried turning it off and on again?
Re: Raw video on 50d and 40d
« Reply #3002 on: August 22, 2013, 02:33:49 PM »
@Batasuna - Copy everything in the zip to your card including the autoexec.bin  ::) DO NOT change the directory structure!

@Orim - You are probably over exposing your shots. Are you using the raw histogram, raw zebras? 'raw' being the important bit ;)
Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com

araucaria

  • Member
  • ***
  • Posts: 132
Re: Raw video on 50d and 40d
« Reply #3003 on: August 22, 2013, 02:54:56 PM »
Hey Andy, is there a way to go above 1/120 shutter speed?

Andy600

  • Contributor
  • Hero Member
  • *****
  • Posts: 1863
  • Have you tried turning it off and on again?
Re: Raw video on 50d and 40d
« Reply #3004 on: August 22, 2013, 03:10:36 PM »
Hey Andy, is there a way to go above 1/120 shutter speed?

Try changing the FPS Override 'optimize for' setting. Hi Jello should let you go a lot higher (maybe1/4000 etc).

I get 1/150 at 24p with 'exact'.

Also, noticed something with FPS under artificial light when shooting last night. The 50D's video mode is NTSC 30p and usually you can trust the shutter speed indicator when it turns green but I had to drop to a slightly lower shutter speed to remove the slow flicker caused by AC in Europe. I don't think this is an issue on cameras that have native 25p PAL so it's worth double checking for that 'out of sync' flickering before hitting record.
Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com

orim

  • New to the forum
  • *
  • Posts: 22
  • 50D / 70D
Re: Raw video on 50d and 40d
« Reply #3005 on: August 22, 2013, 03:14:06 PM »

@Orim - You are probably over exposing your shots. Are you using the raw histogram, raw zebras? 'raw' being the important bit ;)

Andy600,
thank you for your interest.
The best I can have on picture (in lightroom from dng) is a green highlighted window, with green "shadow" on the wall...
It is far away from your results...
I had ETTR on, so I switched it off  and used 100/1600 dualISO.
Any advice, please?

Andy600

  • Contributor
  • Hero Member
  • *****
  • Posts: 1863
  • Have you tried turning it off and on again?
Re: Raw video on 50d and 40d
« Reply #3006 on: August 22, 2013, 03:24:53 PM »
Andy600,
thank you for your interest.
The best I can have on picture (in lightroom from dng) is a green highlighted window, with green "shadow" on the wall...
It is far away from your results...
I had ETTR on, so I switched it off  and used 100/1600 dualISO.
Any advice, please?

Check the Dual ISO thread. I know very little about how to set-up Dual ISO or how to get the best results. Of the shots I have taken using Dual ISO some have worked and others have highlight issues and that (I think) is because I haven't yet read-up on how to shoot with it correctly.
Colorist working with Davinci Resolve, Baselight, Nuke, After Effects & Premier Pro. Occasional Sunday afternoon DOP. Developer of Cinelog-C Colorspace Management and LUTs - www.cinelogdcp.com

araucaria

  • Member
  • ***
  • Posts: 132
Re: Raw video on 50d and 40d
« Reply #3007 on: August 22, 2013, 05:33:09 PM »
Try changing the FPS Override 'optimize for' setting. Hi Jello should let you go a lot higher (maybe1/4000 etc).

I get 1/150 at 24p with 'exact'.

Also, noticed something with FPS under artificial light when shooting last night. The 50D's video mode is NTSC 30p and usually you can trust the shutter speed indicator when it turns green but I had to drop to a slightly lower shutter speed to remove the slow flicker caused by AC in Europe. I don't think this is an issue on cameras that have native 25p PAL so it's worth double checking for that 'out of sync' flickering before hitting record.

Thanks a lot!

Nachelsoul

  • Freshman
  • **
  • Posts: 54
Re: Raw video on 50d and 40d
« Reply #3008 on: August 22, 2013, 08:04:55 PM »
Also, noticed something with FPS under artificial light when shooting last night. The 50D's video mode is NTSC 30p and usually you can trust the shutter speed indicator when it turns green but I had to drop to a slightly lower shutter speed to remove the slow flicker caused by AC in Europe. I don't think this is an issue on cameras that have native 25p PAL so it's worth double checking for that 'out of sync' flickering before hitting record.
Same issue I noticed. As you say the ntsc mode could not monitoring the image in a way you can get rid of it. Maybe Mr1% can give us some "light".....

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: Raw video on 50d and 40d
« Reply #3009 on: August 22, 2013, 08:30:41 PM »
You should be able to get whatever shutter speed you want now since its ADTG not head timers.

Syncing to things like lights and screens doesn't work on this camera. On others you can tweak the speed a little bit and make lights/tvs stop flickering. 50D it doesn't work, just starts flashing the whole image.

dlrpgmsvc

  • Senior
  • ****
  • Posts: 398
  • The 7D and 50D Robin Hood
Re: Raw video on 50d and 40d
« Reply #3010 on: August 22, 2013, 08:50:35 PM »
You should be able to get whatever shutter speed you want now since its ADTG not head timers.

ADTG doesn't solve anything about shutter speed freedom.

g3gg0 wrote to me about this topic when I asked to him if ADTG can solve the shutter speed/jello effect limitations:

"
There are the same technical limitations like before.

Hi shutter speed requires a fast clock. But the timer for fps has a limited range.
So you can only have 1/(adtg_val) 'th of the fps rate as shutter speed iirc.
But thats long ago when i understood that.

Technically nothing new. We access these registers since months, but in a indirect way.
"

Do you all agree ? Or there is something new here ?
If you think it's impossible, you have lost beforehand

fromdecember

  • New to the forum
  • *
  • Posts: 14
Re: Raw video on 50d and 40d
« Reply #3011 on: August 22, 2013, 09:33:16 PM »
How do I change the exposure meter to go a bit the center without affecting ISO and aperture?  Is there a way?

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: Raw video on 50d and 40d
« Reply #3012 on: August 22, 2013, 09:46:02 PM »
Before ADTG you could only select like 1/24 to 1/120, now it lets you select 1/24 - like 1/2000. I'd say that's a bit more freedom, hence no more shutter speed in the FPS menu. Shutters under FPS and ridiculously high shutters are probably not possible.

kichetof

  • Contributor
  • Senior
  • *****
  • Posts: 469
  • Take a beer and enjoy it!
Re: Raw video on 50d and 40d
« Reply #3013 on: August 22, 2013, 10:17:19 PM »
@Andy

There are a bug with yours TL latest update. When you record a raw video, when you finished the video by click on SET, the blue light flashed, the red light too and the display turn off. When you click on live view button you return on photo mode and the display on. When you re click on LV, the display turn off. After turn off the body, click on LV works fine the first time and the second time I've an error 99.

The crashlog:
Code: [Select]
ASSERT: 0
at Stub.c:29, task LVC_AE
lv:1 mode:3


Magic Lantern version : Andy600.Build.2013Aug17.50D109
Mercurial changeset   : 74dac53a5f5e+ (build-bot-2.0) tip
Built on 2013-08-16 22:57:26 UTC by magiclantern@magiclantern-VirtualBox.
Free Memory  : 285K + 3183K

And the log: http://pastebin.com/dbkL5nAi (sorry it's too long to copy here)

I hope it's useful for you!

Thanks a lot !

Edit : don't appear on the previous TL update (august 12th Tragic.Lantern-2.0-Andy600build.2013Aug12.50D109-DUAL-ISO)

Hi guys,

More informations about my previous problem (perhaps similar to Molinsky).

With the latest Tragic Lantern 2.0, when I switch from photo mode to live view, the screen come black and the dslr not responding (only the LCD control panel display av,tv,iso..). The solution is to remove battery for reuse.

So, I disable all module and activate one by one and switch from photo mode to live view to identify which one cause trouble. I've the problem when I activate raw_rec module. When it's disabled, no problem appears.

I also had a problem when I leave the live view to return to camera mode (when raw_rec disabled), I get a vsync error.

Do you have some suggestions ? Could I try something to help you ?

Thanks for your works!

Nachelsoul

  • Freshman
  • **
  • Posts: 54
Re: Raw video on 50d and 40d
« Reply #3014 on: August 22, 2013, 10:39:50 PM »
You should be able to get whatever shutter speed you want now since its ADTG not head timers.

Syncing to things like lights and screens doesn't work on this camera. On others you can tweak the speed a little bit and make lights/tvs stop flickering. 50D it doesn't work, just starts flashing the whole image.
Thanks for the information. Great work man!!!

Molinsky

  • New to the forum
  • *
  • Posts: 26
Re: Raw video on 50d and 40d
« Reply #3015 on: August 23, 2013, 01:55:33 PM »
Hi guys,

More informations about my previous problem (perhaps similar to Molinsky).

With the latest Tragic Lantern 2.0, when I switch from photo mode to live view, the screen come black and the dslr not responding (only the LCD control panel display av,tv,iso..). The solution is to remove battery for reuse.

So, I disable all module and activate one by one and switch from photo mode to live view to identify which one cause trouble. I've the problem when I activate raw_rec module. When it's disabled, no problem appears.

I also had a problem when I leave the live view to return to camera mode (when raw_rec disabled), I get a vsync error.

Do you have some suggestions ? Could I try something to help you ?

Thanks for your works!

[sigh] Yesterday, I had all problems possible and wasn't able to post here other tests or the config file.

But it's hard anyway when no one else has reproduced the bug.

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: Raw video on 50d and 40d
« Reply #3016 on: August 23, 2013, 03:07:37 PM »
The log:

Code: [Select]
2839: 38239.779 [STARTUP] ERROR ASSERT : Stub.c, Task = LVC_AE
2840: 38239.860 [STARTUP] ERROR ASSERT : Line 29
2841: 38239.903 [STARTUP] ERROR ASSERT : 0
2842: 38240.611 [STARTUP] startupErrorRequestChangeCBR : OverWrite (0x1d => 0x1d)
2843: 38268.795 [GUI] DlgLiveView.c UnvisibleLvDialogItemForBlackout
2844: 38304.212 [LV] FD_SetAfState(7) Mode:2
2845: 38304.234 [LV] AF Mode FACE

Do you use face detection AF because raw module disables it. Also get black screen booting LV if face detection is on w/ raw_rec. I guess you found the side effect  :)

kichetof

  • Contributor
  • Senior
  • *****
  • Posts: 469
  • Take a beer and enjoy it!
Re: Raw video on 50d and 40d
« Reply #3017 on: August 23, 2013, 03:16:22 PM »
The log:

Code: [Select]
2839: 38239.779 [STARTUP] ERROR ASSERT : Stub.c, Task = LVC_AE
2840: 38239.860 [STARTUP] ERROR ASSERT : Line 29
2841: 38239.903 [STARTUP] ERROR ASSERT : 0
2842: 38240.611 [STARTUP] startupErrorRequestChangeCBR : OverWrite (0x1d => 0x1d)
2843: 38268.795 [GUI] DlgLiveView.c UnvisibleLvDialogItemForBlackout
2844: 38304.212 [LV] FD_SetAfState(7) Mode:2
2845: 38304.234 [LV] AF Mode FACE

Do you use face detection AF because raw module disables it.

Effectly, AF mode was configured with face detection. I change to Quick Mode and no problem with module raw_rec but I always have vsync err on a black box (corner top left). It seem to doesn't affect anything.

Thanks 1% to find this!

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: Raw video on 50d and 40d
« Reply #3018 on: August 23, 2013, 03:50:52 PM »
Not sure what you turned on to get a vsync error. Would need a way to reproduce it. I tried peaking/spot/histo/zebras all at once and it was ok. AF quick is OK but opens and closes LV every time so I avoid it.


Ok... I think I found vsync err.. its from auto ETTR but that is working here so not sure what is conflicting with it/breaking it.

kichetof

  • Contributor
  • Senior
  • *****
  • Posts: 469
  • Take a beer and enjoy it!
Re: Raw video on 50d and 40d
« Reply #3019 on: August 23, 2013, 04:59:35 PM »
Yes I confirm. I disabled auto ETTR and I don't have this error.

I saw something strange, I have two lines that blinking every second when movie on with raw_rec enable (through the two black bands).



Maybe it's normal ;)

Do you have information about the development of auto-ETTR in photo mode?

I want to do 50D raw histos in photo mode but I need to figure out how to make those state diagrams from a good idc and with things named + current fw version.

9x1 is working on 6D with the naming. I'll try some other cams, esp older like 50D.

*prop browser is there and working. Just not as flexible as mem spy. Maybe needs something that builds a whole list of properties + data and then you can search through it. Would be useful to try to find stuff like focus data on M/50D, etc.

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: Raw video on 50d and 40d
« Reply #3020 on: August 23, 2013, 05:06:24 PM »
Auto ETTR is working here, it opens LV, closes LV and takes an ETTR reading.. so I don't know why its not working for you.

The lines are from ML grayscale preview, I think its bigger under the overlays.

kichetof

  • Contributor
  • Senior
  • *****
  • Posts: 469
  • Take a beer and enjoy it!
Re: Raw video on 50d and 40d
« Reply #3021 on: August 23, 2013, 05:39:19 PM »
Maybe I have misspoken.
Auto-ETTR works great in live view. It works well in photo mode only by pressing SET button, it doesn't works on Always on or other setting.


This is what I do:

Enable all it's necessary for auto-ETTR in Overlay


Enable auto-ETTR and set to Always On


Try with 2s, 4s, 8s and Hold in review time.

So I can not use it to make timelpase

I don't understand what I'm doing wrong...

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: Raw video on 50d and 40d
« Reply #3022 on: August 23, 2013, 06:02:36 PM »
I think I figured it out. If you close LV before auto ETTR finishes up you get the vsync error. Always on and auto snap I think isn't working for photo mode unless LV is on. I won't have raw data for captured photos (for like raw zebras in photo) until I get a new graph of the state objects. Assume this is where the problem is coming from as it works as expected on 6D (most supported after 5DIII).

kichetof

  • Contributor
  • Senior
  • *****
  • Posts: 469
  • Take a beer and enjoy it!
Re: Raw video on 50d and 40d
« Reply #3023 on: August 23, 2013, 06:17:12 PM »
I know what's the problem! I've made some test in dark situation... I try now and I can reproduce the vsync problem when I put the lens cap and switch to photo mode before auto-ettr finish and bingo! Err vsync.. so it's not a real problem :)

Ok, so I understood right. Auto-ETTR works only on live view (in photo mode, you need to go in live view to obtain the value).

Do you have any plan to develop this on 50d? Maybe I'll write a little script to take time-lapse with auto-ettr without keep live view on a long time.

Monti

  • Freshman
  • **
  • Posts: 73
Re: Raw video on 50d and 40d
« Reply #3024 on: August 23, 2013, 08:51:31 PM »
Seems like ETTR exposure to the right
means over exposing shot making it too bright

is good thing to get a good low noise captures

check this picture out


but what about the auto ettr?
what exactly it is auto about?