Author Topic: 5D2 RAW video Builds 14-Bit  (Read 426248 times)

Doyle4

  • Hero Member
  • *****
  • Posts: 690
  • Canon 5DRAWii & 600Dual-Iso
Re: 14-Bit RAW video Builds for 5D2
« Reply #1225 on: August 27, 2013, 09:26:00 PM »
haha, i just realised this when i pressed it on my mkii  :P

ted ramasola

  • Moderators
  • Hero Member
  • *****
  • Posts: 1251
Re: 14-Bit RAW video Builds for 5D2
« Reply #1226 on: August 27, 2013, 09:48:56 PM »
its what you activate while waiting for your dngs to export proxies or master copy. :)
5DmkII  / 7D
www.ramasolaproductions.com
Texas

reddeercity

  • Contributor
  • Hero Member
  • *****
  • Posts: 2303
Re: 14-Bit RAW video Builds for 5D2
« Reply #1227 on: August 28, 2013, 01:23:43 AM »
Hi All  :)
Just test the new Built (2013/08/27-8cf76a551872), And what the Heck happen :(
I See a Big Drop in performance, i can Only record 3800 to 4000 Frames @ 1856x1004 23.976
on Lexar 1000x 32GB card.
Before i install the new built i was on the July 11th built, and
on that one i was getting 8000 Frames plus @ 1856x1004 23.976p
So it looks like a 50% drop in performance speed! >:(
Its the same for my 64 GB Lexar 1000x card.
When back to the The July 11th bulit (5db91070a1aa) from A_D_
And my Speeds are Back up to 14,000 Frames @ 75.0 MB/s on 64 GB Card=42GB
& 8000 Frames on my 32 GB card @1856x1004 23.976p =30GB

So are we putting too Many Features at The Cost of Large Stable Frame Sizes?
Like 1856x1004 ??
I see no point and having all these features if you can not record Raw video at it
Max size! Continuous.

I will Stay on the  July 11th bulit (5db91070a1aa) from A_D_
Until I can see the Same or better performance @ 1856x1004.

Its nice to have lots of Features but for me, i only need Raw video  ;)

Doyle4

  • Hero Member
  • *****
  • Posts: 690
  • Canon 5DRAWii & 600Dual-Iso
Re: 14-Bit RAW video Builds for 5D2
« Reply #1228 on: August 28, 2013, 02:57:53 PM »
im getting continuous at 1880 2:1, try deleting ml config file and try again. i didnt know this trick a.d told me.

Doyle4

  • Hero Member
  • *****
  • Posts: 690
  • Canon 5DRAWii & 600Dual-Iso
Re: 14-Bit RAW video Builds for 5D2
« Reply #1229 on: August 28, 2013, 02:59:15 PM »
wish i had kept my crash logs from few weeks ago, my camera crashed and i did a cf test and i was hitting 91mb... never hit that since, could of been something in the log to see how it happend... i deleted them :( may do a file recovery and see what i can find.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: 14-Bit RAW video Builds for 5D2
« Reply #1230 on: August 28, 2013, 03:10:16 PM »
So it looks like a 50% drop in performance speed! >:(

Read this: http://www.chiark.greenend.org.uk/~sgtatham/bugs.html

and then do the math; the difference in speed is likely 1%, not 50%. Make sure you use the exact same settings.

Doyle4

  • Hero Member
  • *****
  • Posts: 690
  • Canon 5DRAWii & 600Dual-Iso
Re: 14-Bit RAW video Builds for 5D2
« Reply #1231 on: August 28, 2013, 03:34:03 PM »
@A1ex,

Is it best to use 24fps over 23.976 shooting raw? if so is there a post with details please? had a search, found in one they say to use 24p with fps over ride but doesn't really say why, thanks :)

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: 14-Bit RAW video Builds for 5D2
« Reply #1232 on: August 28, 2013, 03:36:35 PM »
You set it like you would do on any other camera, nothing to do with raw.

Doyle4

  • Hero Member
  • *****
  • Posts: 690
  • Canon 5DRAWii & 600Dual-Iso
Re: 14-Bit RAW video Builds for 5D2
« Reply #1233 on: August 28, 2013, 03:42:09 PM »
Ahh ok cheers, iv been using 23.976 but spotted most people over ride to 24p, ill give it ago. Thanks again.

reddeercity

  • Contributor
  • Hero Member
  • *****
  • Posts: 2303
Re: 14-Bit RAW video Builds for 5D2
« Reply #1234 on: August 28, 2013, 05:53:21 PM »
Read this: http://www.chiark.greenend.org.uk/~sgtatham/bugs.html

and then do the math; the difference in speed is likely 1%, not 50%. Make sure you use the exact same settings.
All my setting are the same, i Turn off everything, Dual ISO, Auto Exp. All the Feature were Disabled.
I tested this 5 Times just in case I made a mistake. And the results are the Same.

The Reason i Said 50% Drop, is i no longer maintain the same Captured Frames,
And i have exactly Half The numbers of frames that i had on the July 11 built !
at 1856x1004 23.976p 75.0MB/s

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: 14-Bit RAW video Builds for 5D2
« Reply #1235 on: August 28, 2013, 06:16:31 PM »
You can unload the modules you don't use, see if any of them is slowing it down.

Did you read that link? what settings did you use? (post the config file)

What other modules do you have loaded?

Did you turn off global draw? enabled small hacks?

Doyle4

  • Hero Member
  • *****
  • Posts: 690
  • Canon 5DRAWii & 600Dual-Iso
Re: 14-Bit RAW video Builds for 5D2
« Reply #1236 on: August 28, 2013, 06:45:41 PM »
Seems to be a big problem with this build... most of my images are all corrupt ill post samples now.. going back to last build and see if its the same. Photoshop CC also says that CR2's are not recognised by Photoshop. Update, can open upto 8 files at a time.

Samples:



Dual ISO disabled, Auto Expo disabled


Doyle4

  • Hero Member
  • *****
  • Posts: 690
  • Canon 5DRAWii & 600Dual-Iso
Re: 14-Bit RAW video Builds for 5D2
« Reply #1237 on: August 28, 2013, 07:23:42 PM »
Update: Gone back to Aug 5th Build as that has good read and write speed, good new's is its not my camera that is broke!! Phew, so there seems to be something up with latest build, i thought i had pushed it to far and killed my sensor! good to know the mkii's ok :)

I have kept all CR2's if they are needed Dev's.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: 14-Bit RAW video Builds for 5D2
« Reply #1238 on: August 28, 2013, 07:27:54 PM »
Find the first broken build (or, even better, the first broken changeset).

Also try this one: http://builds.magiclantern.fm/jenkins/job/5D2.212/7/artifact/platform/5D2.212/magiclantern-v2.3.NEXT.2013Aug28.5D2212.zip

(I didn't try it, but will do tomorrow if you can't find it)

Also, I didn't do any speed tweaks lately, so why do you say aug 5 has good read and write speed?! It shouldn't have slowed down.

Doyle4

  • Hero Member
  • *****
  • Posts: 690
  • Canon 5DRAWii & 600Dual-Iso
Re: 14-Bit RAW video Builds for 5D2
« Reply #1239 on: August 28, 2013, 07:36:34 PM »
Cheers A1ex will try that one now.

The 16th Aug is the first one i have ever had problems with.

On the 5th Aug build i was hitting 97mb write on the 5min bench test. Iv just done one now and its the same as usual 68/70mb. think the test i did few weeks back was a lucky go.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: 14-Bit RAW video Builds for 5D2
« Reply #1240 on: August 28, 2013, 07:41:15 PM »

Doyle4

  • Hero Member
  • *****
  • Posts: 690
  • Canon 5DRAWii & 600Dual-Iso
Re: 14-Bit RAW video Builds for 5D2
« Reply #1241 on: August 28, 2013, 07:48:26 PM »
Not one corrupt image on magiclantern-v2.3.NEXT.2013Aug28.5D2212.zip Thanks, took about 45 pics and all clean.

Ill be honest and say I dont have a clue how to compile, thank you for putting it across though and thanks for a working build.

In modules next to the names it says OldAPI wrong version, not sure if you knew or not.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: 14-Bit RAW video Builds for 5D2
« Reply #1242 on: August 28, 2013, 07:55:02 PM »
Next, try the extras from the problematic build (maybe enable them one by one) and see which one breaks. I'm not sure what extras are there (autoexpo, arkanoid?)

Also try to unload the modules that you don't use (or unload all of them, then enable them one by one).

Once you isolate the thing that's causing the problem, we know what to do (reproduce and fix).

Quote
In modules next to the names it says OldAPI wrong version
All of them?!

Then, no modules were loaded, so the problem is caused by one of them.

Doyle4

  • Hero Member
  • *****
  • Posts: 690
  • Canon 5DRAWii & 600Dual-Iso
Re: 14-Bit RAW video Builds for 5D2
« Reply #1243 on: August 28, 2013, 07:58:08 PM »
okie doke, going to do that now.

a.d.

  • Member
  • ***
  • Posts: 126
Re: 14-Bit RAW video Builds for 5D2
« Reply #1244 on: August 28, 2013, 08:12:47 PM »
@reddeercity
you could delete the other modules which you don't use and copy back if you need it.
For RAW Video with minimal setup:
raw_rec + file_man and maybe ettr
@Doyle4
For Photo:
ettr + auto_expo+dual_iso+ file_man

Doyle4

  • Hero Member
  • *****
  • Posts: 690
  • Canon 5DRAWii & 600Dual-Iso
Re: 14-Bit RAW video Builds for 5D2
« Reply #1245 on: August 28, 2013, 08:13:09 PM »
Sorry i was meaning OldApi on the magiclantern-v2.3.NEXT.2013Aug28.5D2212.zip build before swapping with the 27th build.

autoexpo ok, ettr ok, rest are all OldApi (magiclantern-v2.3.NEXT.2013Aug28.5D2212.zip build)

magiclantern-v2.3.NEXT.2013Aug28.5D2212.zip with 27th extras

All ok apart from Pic View,

sounds stupid, but how do i disable a loaded module? cant see the option.


Doyle4

  • Hero Member
  • *****
  • Posts: 690
  • Canon 5DRAWii & 600Dual-Iso
Re: 14-Bit RAW video Builds for 5D2
« Reply #1246 on: August 28, 2013, 08:15:09 PM »
@ a.d

ettr + auto_expo+dual_iso+ file_man modules were loaded but not enabled.

I enabled dual iso later on during the day but my first few images were standard.

@a.d, Sorry i get what you are saying now, dont load all modules, only ones you need for Photo or Video.

Doyle4

  • Hero Member
  • *****
  • Posts: 690
  • Canon 5DRAWii & 600Dual-Iso
Re: 14-Bit RAW video Builds for 5D2
« Reply #1247 on: August 28, 2013, 08:34:57 PM »
No corrupt images with v2.3.NEXT.2013Aug28.5D2212 and a.d's 27th Aug Modules with the game deleted from CF, all modules were enabled also.

Cant be the game can it?
ill do more testing tomorrow for sure though.

Thanks for all the help.

Update: Think its the RAW_rec module, i have corrupt raw frames, if it is the raw_rec module would it do that to the images i were taking? as a.d pointed out, i had all modules loaded.

Doyle4

  • Hero Member
  • *****
  • Posts: 690
  • Canon 5DRAWii & 600Dual-Iso
Re: 14-Bit RAW video Builds for 5D2
« Reply #1248 on: August 28, 2013, 11:42:48 PM »
27th Build whilst recording in RAW the LCD glitches and flickers, im sure its to do witht eh rec module, sorry if im wrong. rest of the modules seem to be fine.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12564
Re: 14-Bit RAW video Builds for 5D2
« Reply #1249 on: August 28, 2013, 11:47:17 PM »
http://www.chiark.greenend.org.uk/~sgtatham/bugs.html

I have no idea what do you mean by "LCD glitches and flickers"...