Author Topic: [UNMAINTAINED] Canon 100D / SL1  (Read 244133 times)

nunobarros

  • New to the forum
  • *
  • Posts: 7
Re: Canon 100D / SL1
« Reply #75 on: January 28, 2014, 12:11:31 PM »
By the way... Is there any form of programming the without risking to brick the camera?

nunobarros

  • New to the forum
  • *
  • Posts: 7
Re: Canon 100D / SL1
« Reply #76 on: January 28, 2014, 12:12:38 PM »
*programming the port... Sorry

nanomad

  • Administrator
  • Hero Member
  • *****
  • Posts: 2918
  • All your websites are belong to us
Re: Canon 100D / SL1
« Reply #77 on: January 28, 2014, 02:24:14 PM »
Not really at this point
EOS 1100D | EOS 650 (No, I didn't forget the D) | Ye Olde Canon EF Lenses ('87): 50 f/1.8 - 28 f/2.8 - 70-210 f/4 | EF-S 18-55 f/3.5-5.6 | Metz 36 AF-5

Silverleapers

  • New to the forum
  • *
  • Posts: 14
  • Why must my long glass be so narrow sighted...
Re: Canon 100D / SL1
« Reply #78 on: January 28, 2014, 02:27:32 PM »
Hi All;

Brand new here (sorry skipped the rules section). Just wanted to know if Nanomod has found someone to start/port the 100D and if work has started on the 100D. Sent a PM but figured best to post it here so he doesn't get 100 PM's asking "what's up and how can I help".

Cheers;
SL
650D/KissX6/T4i (japanese version), 100D/SL1 (Canadian version), many canon and some sigma lenses.

chilimac02

  • New to the forum
  • *
  • Posts: 41
Re: Canon 100D / SL1
« Reply #79 on: January 30, 2014, 01:40:30 AM »
By the way... Is there any form of programming the without risking to brick the camera?

These sorts of things seem scary, yes. I've used custom firmwares with many other devices, even another canon camera. There is always a risk of the brick... but I've actually only had it happen once, and was able to repair it. There is a reason for detailed instructions being posted with the software. If you don't follow the instructions exactly then you may get bad results. Of course, since there are so many people using ML, you would assume that most are happy with the results!
Rebel SL1/100D... 40mm f/2.8 STM, 18-55mm f/3.5 IS STM, Tamron 70-300mm Di VC USD, Sigma 30mm f/1.4 Art

ibruceuk

  • New to the forum
  • *
  • Posts: 1
Re: Canon 100D / SL1
« Reply #80 on: February 03, 2014, 01:03:53 AM »
I just got myself a 100D and can't wait to put ML onto it.  Any sign of the .fir to enable the boot flag yet? Someone must have done it by now!


freemem73

  • New to the forum
  • *
  • Posts: 3
Re: Canon 100D / SL1
« Reply #81 on: February 04, 2014, 07:30:58 PM »
any news about ML for the little canon?

Luigi_xp

  • New to the forum
  • *
  • Posts: 21
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #82 on: February 08, 2014, 12:28:05 AM »
Oh... The port was cancelled, what a shame... hope on the future some other developer get into it, sometimes i regret buying a 100D just because of the ML functions. They're so useful, especially on video.
P.S since the SL1 is an small T5i, is there any way that the t5i developer could help?
100D.100A

chilimac02

  • New to the forum
  • *
  • Posts: 41
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #83 on: February 08, 2014, 04:14:42 AM »
crap i may sell this and get a t5i
Rebel SL1/100D... 40mm f/2.8 STM, 18-55mm f/3.5 IS STM, Tamron 70-300mm Di VC USD, Sigma 30mm f/1.4 Art

Felipe

  • Senior
  • ****
  • Posts: 256
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #84 on: February 08, 2014, 01:42:14 PM »
crap i may sell this and get a t5i

There is not ML for recent T5i cameras they all come with the new firmware 1.1.3 and ML is for 1.1.1, Keep your SL1 at least is smaller.
650D-100D

chilimac02

  • New to the forum
  • *
  • Posts: 41
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #85 on: February 14, 2014, 05:45:42 AM »
well if ML ever arrives on the 70d - I'm going for it.
Rebel SL1/100D... 40mm f/2.8 STM, 18-55mm f/3.5 IS STM, Tamron 70-300mm Di VC USD, Sigma 30mm f/1.4 Art

paolor

  • New to the forum
  • *
  • Posts: 2
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #86 on: February 14, 2014, 12:33:35 PM »
I am very sad!
my 100d will not have ML!


 :'( :'( :'( :'( :'( :'( :'( :'( :'( :'( :'(

nunobarros

  • New to the forum
  • *
  • Posts: 7
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #87 on: February 14, 2014, 07:03:33 PM »
I spent some time thinking in an answer but I'm speachless... :(
WHY???

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12207
  • Maintenance mode
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #88 on: February 14, 2014, 07:11:01 PM »
Quote from CHDK wiki (which applies here too):

Quote
A port of a new camera model happens if and only if there is a developer who has the camera and sufficient time, motivation and skill to complete the port. If this describes you, then you may be able to help.

Luigi_xp

  • New to the forum
  • *
  • Posts: 21
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #89 on: February 16, 2014, 12:16:45 AM »
Quote from CHDK wiki (which applies here too):

I have the camera and alerady messed up with ARM processor on nintendo consoles, using arm-gcc. I've alerady read about starting development, trough it's still no clear to me what i should start doing. If someone guides me how to start, i will help as i can.
100D.100A

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12207
  • Maintenance mode
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #90 on: February 16, 2014, 12:26:56 AM »
The first step is enabling the bootflag, but I'm not sure if this was done.

I'll send you the dumper so you can start looking in the firmware and analyze the boot process.

e^ipi

  • New to the forum
  • *
  • Posts: 1
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #91 on: February 16, 2014, 08:58:48 AM »
Hello!

I purchased an SL1 a few months ago and was hoping for an ML port... It appears that there is no active development on this front.

And I don't see myself selling/exchanging this for something else...

I have the requisite skills... perhaps this is an itch I need to scratch.

I just joined the forum... haven't groked for all the relevant info.

Would someone be kind enough to point me in the right direction?

Cheers!

Luigi_xp

  • New to the forum
  • *
  • Posts: 21
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #92 on: February 16, 2014, 03:12:56 PM »
Request the dumper to a1ex, so your can help me finding the bootflag. I've installed the development system on my machine and learning how the thing works.
Two heads work better than one. I will send you a PM so we can talk.
Hello!

I purchased an SL1 a few months ago and was hoping for an ML port... It appears that there is no active development on this front.

And I don't see myself selling/exchanging this for something else...

I have the requisite skills... perhaps this is an itch I need to scratch.

I just joined the forum... haven't groked for all the relevant info.

Would someone be kind enough to point me in the right direction?

Cheers!
100D.100A

Silverleapers

  • New to the forum
  • *
  • Posts: 14
  • Why must my long glass be so narrow sighted...
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #93 on: February 18, 2014, 06:14:10 PM »
Whooo Hooo! Waiting until the girlfriend finds out something has been started! THANK YOU SOO MUCH! Should we start a crowd funding to help out and speed thing up? Might help you guys buy a few burgers and a few cameras that you can sacrifice. Just a thought.
650D/KissX6/T4i (japanese version), 100D/SL1 (Canadian version), many canon and some sigma lenses.

Luigi_xp

  • New to the forum
  • *
  • Posts: 21
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #94 on: February 18, 2014, 07:21:59 PM »
If you want to donate, do this for the entire project, the people who first make this possible.
 ;)
We're alerady trying to port it, but this thing needs time and patience to do, we're alerady making it as fast as we can without messing around with this, so just wait, and if we can port it, we will.
100D.100A

Dafin

  • New to the forum
  • *
  • Posts: 3
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #95 on: February 23, 2014, 02:12:27 AM »
..., though it's still no clear to me what i should start doing. If someone guides me how to start, i will help as i can.

Have you gone through the sticky topics here :  http://www.magiclantern.fm/forum/index.php?board=25.0

Including http://www.magiclantern.fm/forum/index.php?topic=9517.0

Try, Fail, do it again.
Take breaks.
Take pictures on your breaks.
Look for shortcuts, (I'm sure the innards are 98%+ the same as the 700D- only the buffer size may be slightly less on the 100D, and we have a combined Q/SET button- maybe cross reference with people working on the existing EOS M ports?).
Persevere.
Dont rush
Start Forum threads.
Ask for help.
Give help where you can.
Dont be afraid to get it wrong, post your mistakes, maybe you will find a general ML bug along the way , when you think it your fault. Then you will be helping the whole community!

Most of all do not be afraid to ask questions!
People who contributed/maintain the other ports once knew about as much as ML  Dev. as you do now.

Yes I would love to donate to the whole ML (and I will eventually! ), but I also would like to give a little something to the people making this specific SL1 port happen.  At worst you(and whoever else you team up with) will maybe get some coffee money for your efforts, at most you maybe could get a 5DMK3 from all the donations you receive,  maybe? :p
Well maybe, I don't want to tempt you with money, that is wrong, you should only really do it because you want to- just like a lot of the great people here have done so with the other ports.

Good Luck, Should you wish to accept this challenge, the force shall be with you and whoever you take with you!
SL1/100D, naughty forty, 18-135 stm, pentacon 50mm, and an insatiable appetite to improve my image capturing skills :p

Luigi_xp

  • New to the forum
  • *
  • Posts: 21
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #96 on: February 25, 2014, 02:16:38 AM »
ff143424:    e28f00a4    add   r0, pc, #164   ; ff1434d0: (62616e45)  *"EnableBootDisk"
ff143434:    e28f00a8    add   r0, pc, #168   ; ff1434e4: (61736944)  *"DisableBootDisk"
this is the bootflag?
100D.100A

riic

  • New to the forum
  • *
  • Posts: 1
  • Canon 100D 18-135 STM, 50mm1.8
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #97 on: February 25, 2014, 03:44:14 PM »
I bought my camera almost one year ago and still waiting for ML (especially zebras:) )
I promise to donate 1/10 cost of my 100D for your effort :)

Luigi_xp

  • New to the forum
  • *
  • Posts: 21
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #98 on: February 25, 2014, 06:06:48 PM »
i'm trying to port the ml to 100D... But i'm lost, one say i should find the bootloader, then other say i should analyse the boot process... And I end up in nowhere stuck looking at lines and lines of code.
Me and e^ipi will be glad if someone explain *with details* what should be done.
100D.100A

chilimac02

  • New to the forum
  • *
  • Posts: 41
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #99 on: March 03, 2014, 07:48:37 PM »
I've been watching this like a fat kid in a candy store with no money watches for loose change. For some reason I have an incredible sense of excitement about recording RAW video. Hopefully it will happen.
Rebel SL1/100D... 40mm f/2.8 STM, 18-55mm f/3.5 IS STM, Tamron 70-300mm Di VC USD, Sigma 30mm f/1.4 Art