Author Topic: [UNMAINTAINED] Canon 100D / SL1  (Read 243858 times)

jamespero

  • New to the forum
  • *
  • Posts: 7
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #150 on: July 03, 2014, 04:11:22 AM »
Ok I've got the repo cloned and the tool chain setup and I'm ready to rock and roll. I'm trying to do a build right now, but I'm running into some issues. Here's my console output:

Code: [Select]
make -C  /Users/James/documents/repositories/magic-lantern/platform/100D.100
[ VERSION  ]   ../../platform/100D.100/version.bin
[ VERSION  ]   ../../platform/100D.100/version.c
[ CC       ]   version.o
[ CC       ]   boot-hack.o
../../src/boot-hack.c: In function 'my_task_dispatch_hook':
../../src/boot-hack.c:302:5: error: implicit declaration of function 'qprintf' [-Werror=implicit-function-declaration]
     qprintf("dispatch context->pc=0x%08X entry=0x%08X\n", context->pc, task->entry);
     ^
cc1: some warnings being treated as errors
make[1]: *** [boot-hack.o] Error 1
make: *** [100D] Error 2

I'm not very familiar with C, but I know enough to be dangerous and I can usually figure things out as I go; however, this one is trying me. I can comment out the qprintf line and it moves on just fine but I'm not sure if that specifically actually needs to be there... Any advice??? Is this just print out for visual purposes or is this something more important? Also to note, if I comment it out, the next time qprintf comes up, the same issue happens for that one as well.

plazadelmar

  • New to the forum
  • *
  • Posts: 3
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #151 on: July 03, 2014, 09:55:49 AM »
I just purchased 100D and I find out that I can't have ML  :'(

edwarddebruyn

  • New to the forum
  • *
  • Posts: 5
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #152 on: July 09, 2014, 09:16:21 AM »
Nice to see that someone is working on this. nobody around there who can help jamespero ?
And thanks for the efforts jamespero,  look forward to the final....
8)

StephenD

  • New to the forum
  • *
  • Posts: 1
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #153 on: July 15, 2014, 08:44:07 AM »
Ok I've got the repo cloned and the tool chain setup and I'm ready to rock and roll. I'm trying to do a build right now, but I'm running into some issues. Here's my console output:

Code: [Select]
make -C  /Users/James/documents/repositories/magic-lantern/platform/100D.100
[ VERSION  ]   ../../platform/100D.100/version.bin
[ VERSION  ]   ../../platform/100D.100/version.c
[ CC       ]   version.o
[ CC       ]   boot-hack.o
../../src/boot-hack.c: In function 'my_task_dispatch_hook':
../../src/boot-hack.c:302:5: error: implicit declaration of function 'qprintf' [-Werror=implicit-function-declaration]
     qprintf("dispatch context->pc=0x%08X entry=0x%08X\n", context->pc, task->entry);
     ^
cc1: some warnings being treated as errors
make[1]: *** [boot-hack.o] Error 1
make: *** [100D] Error 2

I'm not very familiar with C, but I know enough to be dangerous and I can usually figure things out as I go; however, this one is trying me. I can comment out the qprintf line and it moves on just fine but I'm not sure if that specifically actually needs to be there... Any advice??? Is this just print out for visual purposes or is this something more important? Also to note, if I comment it out, the next time qprintf comes up, the same issue happens for that one as well.

Hi James,
I am new to the ML project, but do have the 100D, so was interested to see what is going on here.

The line "Implicit declaration of qprintf" is telling us that it met this function call before the function was defined. This explains why all qprintf calls will be a problem.

Being new to things here I have not yet seen what this line is trying to do, but just wanted to give you a bit of feedback to encourage you in your efforts.

Stephen

jamespero

  • New to the forum
  • *
  • Posts: 7
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #154 on: July 17, 2014, 03:50:03 PM »
Thanks guys.

StephenD, I was able to gather that much. I've gotten QEMU installed on my system, but still haven't seemed to figure out the reason the QEMU includes aren't being included when I'm building. I haven't had a lot of time to work on it this past 2 weeks so I'm still in the same place I was when I posted my previous post.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12200
  • Maintenance mode
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #155 on: July 17, 2014, 03:51:34 PM »
To setup QEMU, follow the instructions from contrib/qemu/install.sh.

See also http://www.magiclantern.fm/forum/index.php?topic=2864

Lasserious

  • New to the forum
  • *
  • Posts: 1
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #156 on: July 25, 2014, 05:20:14 AM »
I have a SL1 that I would like to put ML on, if anyone would like to use my camera as a guinea pig let me know. I use the SL1 for all my video, and the perks ML would be very beneficial. Contact me if anyone has some info on getting ML loaded on my camear

count

  • New to the forum
  • *
  • Posts: 15
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #157 on: July 27, 2014, 01:49:33 PM »
Hi,

please contact me (count on freenode IRC, also on #magiclantern) to see whether it's of any use just now. We'd do a blind dump of your firmware image to see whether yours got the same checksum mine has. So far, I've seen two different 1.00 versions, but only one user with the same firmware I'm developing against).

Task management code has changed noticeably compare to other cameras, so it might still take some more time until we even got the ML menu. I can only invest a few evenings a month, so progress is slow.

   count
100D.100B

makski

  • New to the forum
  • *
  • Posts: 1
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #158 on: July 27, 2014, 10:42:19 PM »
@count - looking forward very much to the results of Your hard work!! Many people will be very happy and produce tons of brilliant footage, should You succeed!!

How can we be of any help?

Kind Regards!!

demarco

  • New to the forum
  • *
  • Posts: 1
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #159 on: July 29, 2014, 10:25:04 PM »
I would like to add my support for ML on 100d. I really appreciate Count`s and other developer`s efforts to introduce ML on 100d. It is a great software which brings enormous functions for our canon cameras. Please let us know if you need anything to keep working? Full of hope we are waiting.   

wolfmensch

  • New to the forum
  • *
  • Posts: 1
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #160 on: August 03, 2014, 10:12:28 PM »
Hello, all. 

In the rush to 4K and such great cameras as the GH4 and Sony A7s, it seems to me what has been lost is that implementing stable RAW and Dual ISO in ML on the SL1 could be a new giant killer.  By this I mean: it's as small as these two; would allow everyone's investment in Canon glass to be leveraged to the max; and just might give Canon breathing room to create a real response to these two new industry leaders.  I am not a coder, but I am a blogger who owns a pair of SL1's and am mighty interested in ML on this body.  Any thoughts on how to accelerate this possibility?

GreatSpace

  • New to the forum
  • *
  • Posts: 1
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #161 on: August 06, 2014, 02:27:45 PM »
Hi everyone,

I am another one who really want ML on SL1/100D.
Super looking forward to see ML could happen on my camera. 100D is a lovely small dslr !
I am not a pro coder. But I would like to help. :D


GS

plazadelmar

  • New to the forum
  • *
  • Posts: 3
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #162 on: August 06, 2014, 06:07:20 PM »
+1 to all above. There is huge queue now with 100D users and we are only missing the coding master.

Flori95

  • New to the forum
  • *
  • Posts: 4
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #163 on: August 07, 2014, 05:19:20 PM »
Hi,
I also own a 100D. I would like to help developing ML for this cam. How can I help?
Thanks ;)

Walter Schulz

  • Contributor
  • Hero Member
  • *****
  • Posts: 6701
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #164 on: August 07, 2014, 05:28:47 PM »
Photogs and videographers: Assist in proof reading upcoming in-camera help!. Your input is wanted and needed!

Flori95

  • New to the forum
  • *
  • Posts: 4
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #165 on: August 08, 2014, 02:42:37 PM »
Thanks! I'll try to compile the unmaintained build for the 100D and try to get a dump.

Flori95

  • New to the forum
  • *
  • Posts: 4
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #166 on: August 10, 2014, 07:08:13 PM »
Acutally I'm not able to build a version for me for testing. :(
Code: [Select]
../../src/state-object.c:13:35: fatal error platform/state-object.h: No such file or directory

blakekibo

  • New to the forum
  • *
  • Posts: 2
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #167 on: August 18, 2014, 08:03:52 AM »
I have 3 100Ds. 2 have modified filters. I can't wait for this to come out so I can test it on them. Let me know if there is anything I can do.

Silverleapers

  • New to the forum
  • *
  • Posts: 14
  • Why must my long glass be so narrow sighted...
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #168 on: August 18, 2014, 02:01:50 PM »
I'm here to help and have a 100D to try builds on. Any recent news from Count, Jamesparo, and others?
650D/KissX6/T4i (japanese version), 100D/SL1 (Canadian version), many canon and some sigma lenses.

Flori95

  • New to the forum
  • *
  • Posts: 4
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #169 on: August 19, 2014, 09:56:40 AM »
Actually I was no able to build a version. But atm I don't have the possibility to test it.
Anyone here who wants to try this on his own risk?

smallpotato000

  • New to the forum
  • *
  • Posts: 4
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #170 on: August 21, 2014, 09:49:05 AM »

smallpotato000

  • New to the forum
  • *
  • Posts: 4
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #171 on: August 21, 2014, 01:12:37 PM »
it is clean that stubs.S is the key.
this file describes function calls (aka stubs) in the official firmware
so, we need to do some reverse engineering with 100D's official firmware
however, i do not have the firmware, and i am not very good at reverse engineering of arm codes.
i would try to do it if i can get the firmware. does anyone have this?
thx.

smallpotato000

  • New to the forum
  • *
  • Posts: 4
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #172 on: August 21, 2014, 02:48:56 PM »
i need a way to enable 100D's bootflag. there is no fir for 100D, then how to do this?

Speaking of good news:



:)

   count

P.S: For those interested - the code is at https://bitbucket.org/berlincount/magic-lantern/commits/all

edwarddebruyn

  • New to the forum
  • *
  • Posts: 5
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #173 on: August 25, 2014, 10:43:09 PM »
Wanted: good ML soft for 100D

50 euro for a good result, who helps.
Why,
The 100D is super compact, the most easy to take around with the other more heavy body's.
no need for me to buy a sony 100RX-3.
Would like to use my 5D2 soft on a 100D.
Waiting for it, like ML very much !!
So for me 50 euro is ok !!!!!

How I would control it, Let it ry out by someone from ML, mail the results on ML and make the results public when every one seems agree the results are ok.
Give your bank count and I forward the 50 euro



kyrobb

  • Member
  • ***
  • Posts: 131
Re: [UNMAINTAINED] Canon 100D / SL1
« Reply #174 on: September 01, 2014, 09:39:17 PM »
We should all pitch in some cash to buy 100D's for more developers. This would have to be the cheapest camera in the world capable of shooting 720p Raw video, and I'd love to see it happen!