Author Topic: RAW Video Module raw_rec [Compiling/Installation]  (Read 132827 times)

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12518
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #75 on: May 15, 2013, 08:27:49 AM »
sensor = the thing that gives you the image...

pavelpp

  • Freshman
  • **
  • Posts: 92
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #76 on: May 15, 2013, 08:49:08 AM »
Can someone please compile a test build with raw rec for 550d?

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12518
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #77 on: May 15, 2013, 08:57:50 AM »
Before compiling, one needs to do some reverse engineering and figure it out. It takes time.

a.d.

  • Member
  • ***
  • Posts: 126
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #78 on: May 15, 2013, 10:03:51 AM »
error message?
Sorry, i was tired!
Correction on my previous post: without tinypy it will not compile
Code: [Select]
ARM_ABI=none-eabi
ARM_PATH=~/arm-toolchain
GCC_VERSION=4.7.3
CONFIG_CONSOLE      = y
CONFIG_TCC          = y
CONFIG_MEMCHECK     = y
CONFIG_MODULES      = y
CONFIG_TINYPY       = y
to be clear:
the autoexec.bin and raw_rec.mo are  ok - so far -  but it generate 0 Byte magiclantern.sym

/bin/sh: 1: gawk: not found

Update:
Next Step:
Thanks to a1ex! on the TCC Thread!
I need to install gawk.

Solve! ;D thanks g3gg0 and a1ex!

RenatoPhoto

  • Moderators
  • Hero Member
  • *****
  • Posts: 1509
  • 5DM3 / 7D
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #79 on: May 15, 2013, 07:47:00 PM »
A1ex gr3ggo 1% are there plans in implementing this in an alpha? I remember reading that you guys would rather keep making new features than try and put all nightly's in to an alpha, but that was before this raw feature, do you still feel the same way? How much testing needs to be done before you feel comfortable doing something like this?

As always, thank you for your hard work and dedication

I am also concerned about all these versions of ML that may or may not be compiled correctly.  I am not a programer and have spent many hours making my own compile in windows and Gygwin which I finally got it working.  I prefer to compile myself to make sure I have the latest and dont have to ask anyone to do it for me.

IMHO it is best if that the correct compiled version is build into nightly builds, if there is somebody who can dedicate the time to do it.  The other option is to have an up to date instructive on how to compile it so that all interested and apt people can do it.  I could write an instructive for windows (for the 5D3) compile and Cygwin which would be complementary to what PEL did but I don't think I am qualified to do it so it could be misleading.

http://www.pululahuahostal.com  |  EF 300 f/4, EF 100-400 L, EF 180 L, EF-S 10-22, Samyang 14mm, Sigma 28mm EX DG, Sigma 8mm 1:3.5 EX DG, EF 50mm 1:1.8 II, EF 1.4X II, Kenko C-AF 2X

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #80 on: May 15, 2013, 07:56:59 PM »
This stuff is still being tested. All the info is on here, code is available... Maybe for nightly builds people want picoC or something else. There haven't been any real changes since double buffering was implemented.

aaphotog

  • Senior
  • ****
  • Posts: 356
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #81 on: May 16, 2013, 03:14:43 AM »
I seen it once before, but can't seem to find it. Anyone know a good source to learn how to compile the builds?
I notice there are new additions to ML every few hours and would like to know how I can build them(for installation)


https://bitbucket.org/hudson/magic-lantern/commits/ecc6fd42fb3afbc122849ba929168340574d41aa

I am  on a mac system, if that information helps.



NVM found it(instructions on compiling):
http://www.magiclantern.fm/forum/index.php?topic=991.0

Fergus Kennedy

  • New to the forum
  • *
  • Posts: 10
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #82 on: May 16, 2013, 12:05:53 PM »
I also posted this in another section, then realised this might be a better place- Any help greatly appreciated!

Hi Folks,

First of all- massive thanks to the developers- I'm so excited about this and can't wait to get it running.
Apologies for what may be a stupid newb question, but I'm having trouble getting the RAW capable ML on my 5D Mark III. In the past I've had previous alpha version on it no probs.
This time I've been following all posted instructions to the letter (I think!). Canon firmware 1.1.3, camera on M, etc. When I load the bootflag.fir I get an  error message - could not find ML files, followed by a series of other messages, then some garbage half way up the screen, which stays there. Is this normal behaviour?
Moving onto the next steps, I have deleted the bootflag file and added the ML folder and autoexec file. Plus made the card bootage with EOScard, following the instructions for that. When I load it up, nothing happens when I press the trash button.
I have tried several different SD cards and have cleared all camera settings and have even tried reinstalling the Canon firmware.
HELP- it would be fantastic if someone had any idea where I am going wrong, or anything else to try as it's driving me nuts!
Cheers

Francis

  • Hero Member
  • *****
  • Posts: 818
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #83 on: May 16, 2013, 06:42:27 PM »
I'm having issues compiling on the 5D2. Enabled all the compilation flags in the makefile, getting this exit error.


Code: [Select]
vsscanf.c:(.text+0x5c): warning: warning: the scanf functions add several kilobytes of bloat.
dietlibc.a(sprintf.o): In function `sprintf':
sprintf.c:(.text+0x14): warning: warning: Avoid *sprintf; use *snprintf. It is more secure.
collect2: error: ld returned 1 exit status
make[1]: *** [magiclantern] Error 1
make: *** [5D2] Error 2

Suggestions?

paramon

  • New to the forum
  • *
  • Posts: 9
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #84 on: May 16, 2013, 06:55:18 PM »
I get an  error message - could not find ML files, followed by a series of other messages, then some garbage half way up the screen, which stays there. Is this normal behaviour?
yes, just make sure you let enough time for couple lines of "garbage" to appear, it writes a file at that time
Moving onto the next steps, I have deleted the bootflag file and added the ML folder and autoexec file. Plus made the card bootage with EOScard, following the instructions for that. When I load it up, nothing happens when I press the trash button.
yes looks right, you copy ML  folder and autoexec, then you use EOScard, just don't forget to check EOS_DEVELOP and BOOTDISC check boxes

Fergus Kennedy

  • New to the forum
  • *
  • Posts: 10
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #85 on: May 16, 2013, 07:26:31 PM »
yes, just make sure you let enough time for couple lines of "garbage" to appear, it writes a file at that timeyes looks right, you copy ML  folder and autoexec, then you use EOScard, just don't forget to check EOS_DEVELOP and BOOTDISC check boxes

Thanks so much for the tip, Paramon. I still can't get it working, but at least I know problem is with the second stage, not the first. I've been checking both those boxes in EOScard (or sometimes just BOOTDISC, which some people seem to suggest). After the bootflag process I get a ROM.dat file on the card of 16mb I guess this is right.

Any more things to try greatly appreciated.

Thanks again.

mujart

  • New to the forum
  • *
  • Posts: 3
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #86 on: May 16, 2013, 10:58:46 PM »
i use this files in my 5D MK III,
https://docs.google.com/file/d/0B7QlH_BH2m32dWpOOEpkWktXMXM/edit

the problem there is the line of RAW VIDEO  NOT exist basically

like this photos:




and when press on load modules nothing happend !!

is there any solution??

paramon

  • New to the forum
  • *
  • Posts: 9
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #87 on: May 16, 2013, 11:30:35 PM »
After the bootflag process I get a ROM.dat file on the card of 16mb I guess this is right.
yeah, tat's how i made it work on 5DmkIII,
don't see any missing steps from what you're doing,
i don't know man, try another card, another build, no clue man, i am myself new to this shit :)

premini

  • New to the forum
  • *
  • Posts: 30
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #88 on: May 17, 2013, 01:05:23 AM »
i am not that optimistic that there will be a quick solution :(

Still not optimistic?  :(

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #89 on: May 17, 2013, 01:07:28 AM »
Are we there yet... are we there yet... are we there yet.

platu

  • Member
  • ***
  • Posts: 101
  • 5D3, 60D
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #90 on: May 17, 2013, 01:15:20 AM »
Are we there yet... are we there yet... are we there yet.

So funny... was thinking the same thing.  :)

premini

  • New to the forum
  • *
  • Posts: 30
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #91 on: May 17, 2013, 01:35:52 AM »
Sorry guys...  :-[

Francis

  • Hero Member
  • *****
  • Posts: 818
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #92 on: May 17, 2013, 05:52:12 PM »
Yea, it would be great if not every thread that mentioned RAW turned into the endless repetitive when when when.

This thread is about compiling and installing.

So I'm still having issues getting the current source to compile. enabled  the flags for modules, tcc, tinypy, console, and memtest but exits with an error.

Now it says

Code: [Select]
sprintf.c:(.text+0x14): warning: warning: Avoid *sprintf; use *snprintf. It is more secure.
edmac-memcpy.o: In function `edmac_copy_rectangle_adv_start':
edmac-memcpy.c:(.text+0xbc): undefined reference to `RegisterEDmacCompleteCBR'
edmac-memcpy.c:(.text+0xcc): undefined reference to `RegisterEDmacAbortCBR'
edmac-memcpy.c:(.text+0xe0): undefined reference to `RegisterEDmacPopCBR'
edmac-memcpy.c:(.text+0xf0): undefined reference to `RegisterEDmacCompleteCBR'
edmac-memcpy.c:(.text+0x100): undefined reference to `RegisterEDmacAbortCBR'
edmac-memcpy.c:(.text+0x110): undefined reference to `RegisterEDmacPopCBR'
edmac-memcpy.o: In function `edmac_copy_rectangle_adv_finish':
edmac-memcpy.c:(.text+0x1cc): undefined reference to `UnregisterEDmacCompleteCBR'
edmac-memcpy.c:(.text+0x1d4): undefined reference to `UnregisterEDmacAbortCBR'
edmac-memcpy.c:(.text+0x1dc): undefined reference to `UnregisterEDmacPopCBR'
edmac-memcpy.c:(.text+0x1e4): undefined reference to `UnregisterEDmacCompleteCBR'
edmac-memcpy.c:(.text+0x1ec): undefined reference to `UnregisterEDmacAbortCBR'
edmac-memcpy.c:(.text+0x1f4): undefined reference to `UnregisterEDmacPopCBR'
collect2: error: ld returned 1 exit status
make[1]: *** [magiclantern] Error 1
make: *** [5D2] Error 2

I'm compiling on a Mac using prebuilt tool chain, using 'make 5D2.'

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #93 on: May 17, 2013, 05:56:31 PM »
You need the stubs from Coutts build

Colemar

  • Freshman
  • **
  • Posts: 52
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #94 on: May 17, 2013, 09:56:10 PM »
The latest 5D3 modules build from lourenco does not work for me.  After loading the raw_rec module, its status is "No_Info" instead of the usual "OK" and the "Raw Video" ("Video" being a misnomer if de-bayering is not happening in-camera) option is absent from the ML video menu.  Is anyone else experiencing this?

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12518
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #95 on: May 17, 2013, 10:39:10 PM »
I had this issue at some point; had to run make clean in module dir. No idea what's causing it.

Vegandelight

  • New to the forum
  • *
  • Posts: 27
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #96 on: May 17, 2013, 10:49:55 PM »
Did i miss like the normal compilation guide for ML?

Am I suppose to get that MAGIC.SYM when compiling raw_rec module? I see it in the versions I download, but I haven't seen any when I'm doing it.

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12518
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #97 on: May 17, 2013, 10:58:01 PM »
"make install" will create it; in the work dir it's called "magiclantern.sym" for some reason... don't ask me why :P

1%

  • Developer
  • Hero Member
  • *****
  • Posts: 5936
  • 600D/6D/50D/EOSM/7D
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #98 on: May 17, 2013, 11:00:55 PM »
Should it be renamed to MAGIC.SYM in the makefiles?

a1ex

  • Administrator
  • Hero Member
  • *****
  • Posts: 12518
Re: RAW Video Module raw_rec [Compiling/Installation]
« Reply #99 on: May 17, 2013, 11:07:23 PM »
I would rename it to 550D.sym, 6D.sym and so on. It will help when we'll use the same zip for more cameras.