Author Topic: Noghtly build on 5d mkIII problem  (Read 3724 times)

Simone1971

  • New to the forum
  • *
  • Posts: 11
Noghtly build on 5d mkIII problem
« on: June 04, 2013, 02:12:56 PM »
Hi to every one, i'm new in this forum. I'm trying to install the last nightly build of magic lantern onto my 5d mkIII to use the raw video, but once i've installed following instructions i don't know how to enter in the setup menu. With ml alpha 3 everything is ok, pushing trash button i'm able to use the ml setup normally, but with the last nightly build nothing to do, it seems to be correctly installed, but the setup menu is not present.
Thank you for any answer tha can help me.

Simoen

RenatoPhoto

  • Moderators
  • Hero Member
  • *****
  • Posts: 1509
  • 5DM3 / 7D
Re: Noghtly build on 5d mkIII problem
« Reply #1 on: June 04, 2013, 03:01:49 PM »
READ and UNDERSTAND FIRST

RAW video & ML -- Beginners Guide, FAQ & Useful Links -- READ FIRST
http://www.magiclantern.fm/forum/index.php?topic=5520.0
http://www.pululahuahostal.com  |  EF 300 f/4, EF 100-400 L, EF 180 L, EF-S 10-22, Samyang 14mm, Sigma 28mm EX DG, Sigma 8mm 1:3.5 EX DG, EF 50mm 1:1.8 II, EF 1.4X II, Kenko C-AF 2X

Simone1971

  • New to the forum
  • *
  • Posts: 11
Re: Noghtly build on 5d mkIII problem
« Reply #2 on: June 04, 2013, 04:14:02 PM »
thank you but i've followed the link you posted to install the nightly build and the result is every time the same...  ???

My head is so hard?!?!? :o

RenatoPhoto

  • Moderators
  • Hero Member
  • *****
  • Posts: 1509
  • 5DM3 / 7D
Re: Noghtly build on 5d mkIII problem
« Reply #3 on: June 04, 2013, 04:21:28 PM »
Ok, go to

RAW video & ML -- Beginners Guide, FAQ & Useful Links -- READ FIRST
http://www.magiclantern.fm/forum/index.php?topic=5520.0

Then scroll down to:

FINALLY INSTALLATION OF RAW VIDEO

and read it again.

If you get nothing out of that then provide your step by step procedure and where you are currently
http://www.pululahuahostal.com  |  EF 300 f/4, EF 100-400 L, EF 180 L, EF-S 10-22, Samyang 14mm, Sigma 28mm EX DG, Sigma 8mm 1:3.5 EX DG, EF 50mm 1:1.8 II, EF 1.4X II, Kenko C-AF 2X

Simone1971

  • New to the forum
  • *
  • Posts: 11
Re: Noghtly build on 5d mkIII problem
« Reply #4 on: June 04, 2013, 04:41:35 PM »
oh thank you, but i've done exactly what is written in the paragraph you indicated me. The only file i can't find is "raw_rec.o", i've searched it in every folder found in the last nightly build, but i can't find it.
I'm not a beginner, but now i feel a newbye!!!  :-[

RenatoPhoto

  • Moderators
  • Hero Member
  • *****
  • Posts: 1509
  • 5DM3 / 7D
Re: Noghtly build on 5d mkIII problem
« Reply #5 on: June 04, 2013, 06:03:58 PM »
Sorry raw_rec.o is not needed.  I will update the guide now, I forgot.
http://www.pululahuahostal.com  |  EF 300 f/4, EF 100-400 L, EF 180 L, EF-S 10-22, Samyang 14mm, Sigma 28mm EX DG, Sigma 8mm 1:3.5 EX DG, EF 50mm 1:1.8 II, EF 1.4X II, Kenko C-AF 2X

Simone1971

  • New to the forum
  • *
  • Posts: 11
Re: Noghtly build on 5d mkIII problem
« Reply #6 on: June 04, 2013, 06:43:09 PM »
ok, but for me the problem is always present, i can't activate the setup menu if i try to use the nightly build.

surely i make some mistake, but i don't know what, i follow step by step the guide, but the result is always the same...

RenatoPhoto

  • Moderators
  • Hero Member
  • *****
  • Posts: 1509
  • 5DM3 / 7D
Re: Noghtly build on 5d mkIII problem
« Reply #7 on: June 04, 2013, 06:55:00 PM »
ok, but for me the problem is always present, i can't activate the setup menu if i try to use the nightly build.

surely i make some mistake, but i don't know what, i follow step by step the guide, but the result is always the same...

Try this guide:

How to record: -- RAW VIDEO ON 5D3 --
http://www.magiclantern.fm/forum/index.php?topic=5451.0

first step, put your cam in video mode.

If this does not solve the prob.  please write step by step what you are doing.
http://www.pululahuahostal.com  |  EF 300 f/4, EF 100-400 L, EF 180 L, EF-S 10-22, Samyang 14mm, Sigma 28mm EX DG, Sigma 8mm 1:3.5 EX DG, EF 50mm 1:1.8 II, EF 1.4X II, Kenko C-AF 2X

Simone1971

  • New to the forum
  • *
  • Posts: 11
Re: Noghtly build on 5d mkIII problem
« Reply #8 on: June 04, 2013, 07:50:44 PM »
ok below what i've done step by step:
- downgraded original canon firmware from 1.2.1 to 1.1.3
- formatted sd with low level format flagged
- copied files to install ml alpha 3 to sd
- inserted sd onto 5d mkIII, switched on the 5d and upgraded firmware from setup menu. Now the ml alpha 3 work great, pushing trash button i can enter into ml setup and set everything without problem.
- dowloaded last (june) nightly build
- added autoexec.bin and files listed in your tutorial and reinserted into 5d
- launched firmware upgrade again (auto boot doesn't works on 5d mkIII), but the firmware remain the old alpha 3
- other way i've tried is to delete alpha 3 firmware and copy the bootflag.fir, then relaunch firmware upgrade. After restart the system loads the bootflag (in the canon menu appears "bootflag loaded" and ":)"), but now the ml setup menu is unavaible, i push the trash button but nothing happens.
in every step canon is set in manual mode and video mode

what's wrong in my procedure?

RenatoPhoto

  • Moderators
  • Hero Member
  • *****
  • Posts: 1509
  • 5DM3 / 7D
Re: Noghtly build on 5d mkIII problem
« Reply #9 on: June 05, 2013, 01:51:43 AM »
On the instructions for

Download ML for 5D Mark III - Alpha 3.
http://www.magiclantern.fm/forum/index.php?topic=2602.0

Near the bottom of the page you need to follow the instructions in RED
For DEVELOPERS

FOR DEVELOPERS ONLY

Download the fir file and use it to set the boot flag in your camera.  Important:
We cannot turn this flag off, for now:

How do disable Bootdisk flag on a 5D Mk III
http://www.magiclantern.fm/forum/index.php?topic=6035.msg46124;topicseen#msg46124

Then use EOS card 1.2 to make your card bootable. 

Go to: http://wiki.magiclantern.fm/install

Scroll to:
Installing Magic Lantern on other cards

Download EOScard from the link and make your card bootable.

Now if you have all the required files, your cam will boot with ML installed!
http://www.pululahuahostal.com  |  EF 300 f/4, EF 100-400 L, EF 180 L, EF-S 10-22, Samyang 14mm, Sigma 28mm EX DG, Sigma 8mm 1:3.5 EX DG, EF 50mm 1:1.8 II, EF 1.4X II, Kenko C-AF 2X

Audionut

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 3657
  • Blunt and to the point
Re: Noghtly build on 5d mkIII problem
« Reply #10 on: June 05, 2013, 02:24:15 AM »
As RenatoPhoto has posted.   Make sure you run the developers firmware file to enable the bootflag before trying to use nightly builds.
I'd delete any files in the ML/SETTINGS folder on the card also, just to be on the safe side.

Simone1971

  • New to the forum
  • *
  • Posts: 11
Re: Noghtly build on 5d mkIII problem
« Reply #11 on: June 05, 2013, 10:56:13 AM »
Yessssssssssssss  :D

Now i run to test raw mode!!!
Thank you very much, i'll post my impressions in the right section.

Simone