Author Topic: SD card writing trouble  (Read 5451 times)

ItsMeLenny

  • Hero Member
  • *****
  • Posts: 928
  • 550D
SD card writing trouble
« on: April 21, 2013, 02:19:44 PM »
This bizarre thing has started happening with the write-ability of my SD cards with the new magic lanterns, although I'm unsure as to how this works.

What I do is format a card using my camera, then I put my card into my computer using a usb card reader, and I make the card bootable.
Then I copy magic lantern onto it, the folder and the .bin, and at that moment the card becomes read only in the computer.
Then to be able to put stuff onto the card I have to reformat it in my camera, or reformat it in general, then I do the whole process again.

What this means is I can't delete photos when the card is in my computer, and I can't add new overlays or scripts, or easily update ML as I have to keep starting the process over.

This wasn't always the problem, but it seemed to change with ML as I haven't changed my computer at all.
I've tried accessing the card as root and all other root kind of things, still says not writeable.
Note that I write to the card 2 seconds before this happens.
Running Gnu/Linux Ubuntu 12.04.

Any help is greatly appreciated.

jbuy41

  • Freshman
  • **
  • Posts: 94
Re: SD card writing trouble
« Reply #1 on: April 22, 2013, 07:31:30 PM »
Have you checked the lock on the side of the card.  Sometimes my gets accidentally bumped to lock.

ItsMeLenny

  • Hero Member
  • *****
  • Posts: 928
  • 550D
Re: SD card writing trouble
« Reply #2 on: April 23, 2013, 09:21:37 AM »
I know what you mean about the lock getting bumped, I used to experience that myself.
However, the card is unlocked. And also, I write to the card and then next second while it's still in it becomes unwritable.

Francis

  • Hero Member
  • *****
  • Posts: 818
Re: SD card writing trouble
« Reply #3 on: April 23, 2013, 01:09:58 PM »
I had the write protect switch break on the card reader in my laptop. It would work very intermittently. Try a different reader perhaps.

jbuy41

  • Freshman
  • **
  • Posts: 94
Re: SD card writing trouble
« Reply #4 on: April 23, 2013, 08:49:08 PM »
I have had to disable USB card reader drivers and reload to slove the problem. 

MoiraOBrien

  • New to the forum
  • *
  • Posts: 8
Re: SD card writing trouble
« Reply #5 on: June 10, 2013, 08:54:13 PM »
I have just downloaded the 9th June 5D3 nighly build.  I copied the files onto my SD card, put it in the camera and loaded the firmware.  After loading, the bootflag enable message came up followed by :).  I rebooted the camera but it did not autoboot into ML. I went through the procedure again, and this time I got an oops! message rather than a :) but again it did not reboot into ML. 

I then put back the Alpha 3 version in the camera, with no autoexec.bin file on the card, and lo and behold it autobooted into ML.

I went back to try to change the June9th card and saw that there is now a ROM.DAT file on the card and the card is read only.

Now I would like to get rid of the autoboot, but as I cannot get the newer version loaded, I can't unload it though ML.  Any suggestions?
5D3, 5D2, 7D, FCPX

ItsMeLenny

  • Hero Member
  • *****
  • Posts: 928
  • 550D
Re: SD card writing trouble
« Reply #6 on: June 11, 2013, 06:38:03 AM »
Sounds like a completely different problem.

Do a "dd" write on it to completely blank out the card and start over.

https://en.wikipedia.org/wiki/Dd_%28Unix%29#Disk_wipe

WARNING: Make sure you specify your card and not your hard drive accidentally, as it will wipe anything.

MoiraOBrien

  • New to the forum
  • *
  • Posts: 8
Re: SD card writing trouble
« Reply #7 on: June 11, 2013, 08:12:38 PM »
I am able to format the card using the Mac Disk utility.  However, I have tried again, with the exact same result.

This leaves me with another issue.  When I remove the SD card from the camera, I get a "Firmware update program - loading" on the screen. I put the Alpha 3 card in again, remove and reinsert battery, then "Firmware update" runs something for about 2 seconds then goes off.  I turn on the camera and it autoboots into ML.  This is fine, except I do want the option to be able to remove ML completely so I can use a non ML high capacity SD card for on occasion.

I can't format the later SD card in the camera after reformatting it in the Mac as it does not have a firmware update programme on it.  So, I am unable to kill the bootflag on the camera.
5D3, 5D2, 7D, FCPX

ItsMeLenny

  • Hero Member
  • *****
  • Posts: 928
  • 550D
Re: SD card writing trouble
« Reply #8 on: June 12, 2013, 05:03:40 AM »
That card sounds sketchy. Try a different card.