Auto ETTR based on RAW histogram (

Started by l_d_allan, April 20, 2013, 02:11:30 AM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.


Last night I wanted to film some cactus flowers which only last for one night, and 30 seconds weren't enough in my previous attempt. So, instead of adding extra lights, I modified ETTR to work with very long exposures.

That means:
- you can now set a slowest shutter speed of up to one hour
- if it requires a shutter speed longer than 30 seconds, it will switch to bulb mode, and will configure Bulb Timer with the new exposure time
- once it no longer requires a long exposure, it will switch back to M

The change is not in the nightly yet - I need to do some more tests, since I've modified the ETTR code in quite a few places.


Very useful addition !!!  Many thanks, A1ex.

I've build the ettr-bulb branch for 500D and tested it indoors, in low light, and it works very well.

At first attempt I tried to use the feature in liveview mode with no success, ETTR rises ISO and not exposure.
Then I have tried in photo mode, setting "Autosnap" to trigger ETTR, with bulb timer enabled, and this way it works fine.

I will test it also outdoors, during next days, with a strong ND filter, to capture seashore landscapes like this one (Dual-ISO):

Adjusting exposure in this picture with such a strong ND filter, and sunset's continuously changing light was a pain. I needed to meter the scene with the filter removed, and then calculate the new exposure using the filter coefficient ... Now Auto ETTR will make it much easier, no need to remove and put again the filter every time !


I'm being stupid.

Just tried to compile this but can't work out what to use instead of what I normally use:

hg clone -r unified

The branch says use this:

hg pull && hg update ettr-bulb

But that doesn't work.

Can some expert correct me please.

I'm compiling in the cloud.


Use a different directory to start from and launch:

hg clone -r ettr-bulb



Many thanks, that worked. Like many on the ML forum, once pointed in the right direction I'm OK :-)

Have loaded on to my 5D3 and confirmed the tweaked module is loaded, as I now see the extended time in the slowest shutter.

But I can't see to get it 'to work', ie it just switches to ever higher ISOs.

Have tried it in LV and non-LV modes, using SET and AutoSnap and M and B modes.

Any guess as to what I'm doing wrong?


OK worked a few things out.

'normal' ETTR doesn't require canon review to be on: LE ETTR apparently does.

The LE-ETTR is now going into capture mode, but doesn't stop, ie I have to intervene and the image is totally overexposed.

BTW I'm using a 24-105 Canon F/4L with an ND.

I've also tried exposure sim on and off.

At the moment, I still can't seem to capture an LE image.

I will keep experimenting.


You need to set "bulb timer" active, in ML's menu ( "shoot" section ), set M mode in photo view, adjust desired aperture and ISO, and take the first picture with a half shutter press. If ETTR is set to "autosnap" it will continuously take photos until the correct exposure time is found.



Thanks for those tips.

Still having problems as LE ETTR seems to seek out a high ISO solution.

Am I missing a trick :-)


In live view mode ETTR seeks for high ISO, yes. Do not use live view. Set your desired ISO and simply take the first picture with a half shutter press, and let it run, automatically taking as many pictures as needed, until exposure time settles in the correct value.


I'm not in LV mode.

LE ETTR still goes for high ISO.





Sorry cant do that (at least not to day).

Settings are:
- Auto ETTR = Press SET, Slowest 8m, Highlight Ignore .1%, everything else off
- Expo Override OFF
- Expo Sim OFF
- Bulb Timer 8m (but grey out as not in LV)

Question: should I do a half shutter press in M or B mode, to trigger LE ETTR?


Change the trigger mode to either "Always ON" or "Auto Snap".
Then, do a full shutter press if you are in M, or a long half-shutter press if you are in B.

If you meter with SET, this uses the LiveView image. It's not possible to figure out a 5-minute exposure from a 1/30 test image, so you must meter from an actual long exposure.



OK but what seems to occur in B is that it appears to meter, then it goes into capture mode, ie I get about 5 or 6 beeps and the canon clocks starts counting.

But I stop it after a min or so and everything is totally over exposed.

PS half press doesn't trigger in M mode

PPS I should have said, the exposure should be between 1-2min


Set a shorter time in "bulb timer" (40 seconds) , ETTR in "Auto snap" mode, take the first picture, and let it run, the first picture probably will not be correctly exposed, but ETTR will automatically correct exposure time and it will take also automatically a second picture, and a third one if needed. 


Sorry still not functioning as you.

I'm in B, ML Bulb is set to 40s, Autosnap on, I do a half long press and capture starts. It takes a picture (40s) then does a second at 1/25.


Is the second picture at 1/25 well exposed? If yes, recheck ISO and aperture settings.


No, totally under.

If I switch to canon metering 0Ev is about 3s.


Try starting with bulb timer from 1 second.


Check if the aperture is effectively closing to the desired value when taking the pictures, there have been problems with some lenses in FRSP, I know that was using live view, but who knows... try pressing DOF button and slghtly unlocking the lens from mount ...


Alex's hint at 1s seems to have stabilized things.

I'm using a manual aperture now, ie Canon and ML see F/00.

I seem to be getting solutions now, but ML/Canon gets confused regarding image taking and, out of frustration, I switch on and off to reset things.

Also, can't get LE-ETTR to trigger in M mode.


Quote from: garry23 on June 13, 2015, 05:34:24 PM
Also, can't get LE-ETTR to trigger in M mode.

Quote from: garry23 on June 13, 2015, 04:46:56 PM
PS half press doesn't trigger in M mode

Press the shutter button a bit harder.

Quote from: a1ex on June 13, 2015, 04:40:51 PM
do a full shutter press if you are in M



OK I'll practice a bit more  ;)

Here are some thoughts so far.

Bulb timer doesn't get reset after an LE-ETTR capture. For instance if I originally have the ML Bulb at 1s and LE-ETTR finds the solution at 120s, ML bulb is at 120s when I next use LE-ETTR, unless I manually reset to 1 s. This threw me a few times.

For ML enhanced LE work we have this emergent capability and David M's ND Bulb Module (which is not yet in the nightlies).

The LE-ETTR is great for when you don't really 'care' too much about shutter time.

If you want a 'spot on' shutter time, then the ND Bulb Module is the way to go.

Maybe there is a way to combine to two approaches into an new LE module, ie keep ETTR 'pure' for shutter speeds less than Bulb.


Quote from: garry23 on June 13, 2015, 05:43:03 PM
Bulb timer doesn't get reset after an LE-ETTR capture.

I wanted this to work for timelapse, so it's not meant to be reset - it will fine-tune the solution as the lighting is changing.

To "reset" it, you could start from M mode. After the long exposure image is taken, you will be in B mode, but your mode dial will be still on M. So, flip the dial back and forth to reset the mode (and get back to M), then you can start over.



Have been doing the flipping thing :-)

BTW it still wont trigger, via a long half press, from M, it does from B.